You are on page 1of 3

on STATIC Route

R1

nterface FastEthernet0/0
ip address 203.189.139.202 255.255.255.224
ip nat outside

interface FastEthernet0/1
ip address 192.168.50.1 255.255.255.0
ip nat inside
no shutdown
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip classless
ip route 192.168.50.0 255.255.255.0 192.168.51.2
ip route 0.0.0.0 0.0.0.0 203.189.139.200
!
!
access-list 1 permit any
!

R2
interface FastEthernet0/0
ip address 192.168.50.2 255.255.255.0

!
interface FastEthernet0/1
ip address 192.168.51.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.50.1

EIGRP

R1

interface FastEthernet0/0
ip address 203.189.139.202 255.255.255.224
ip nat outside
interface FastEthernet0/1
ip address 192.168.50.1 255.255.255.0
ip nat inside
no shutdown
!
router eigrp 101
network 192.168.50.0
network 203.189.139.0
no auto-summary
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 203.189.139.200
!
R2
interface FastEthernet0/0
ip address 192.168.50.2 255.255.255.0
interface FastEthernet0/1
ip address 192.168.51.1 255.255.255.0
no shutdown
router eigrp 101
network 192.168.2.0
no auto-summary
!

RIP V2

R1

interface FastEthernet0/0
ip address 203.189.139.202 255.255.255.224
ip nat outside
interface FastEthernet0/1
ip address 192.168.50.1 255.255.255.0
ip nat inside
no shutdown
router rip
version 2
network 192.168.50.0
network 203.189.139.0
no auto-summary
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 203.189.139.200
access-list 1 permit any
!
!
R2

interface FastEthernet0/0
ip address 192.168.50.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.51.1 255.255.255.0

no shutdown
!
router rip
version 2
network 192.168.50.0
network 192.168.51.0
no auto-summary
!

You might also like