You are on page 1of 3

Now we are going to redistribute OSP and EIGRP bidirecrionally.

If we redistribute with the same metric on both R9 and R10 then, EIGRP will
load balance traffic to the core between R53 and R54.

When we check OSPF cost for a destination in the core, such as R8 interface
e0/3 10.254.0.26, we find out that on R9 the cost is 30 and on R10 the cost is
20.

R9#sh ip route 10.254.0.26


Routing entry for 10.254.0.24/30
Known via "ospf 1", distance 110, metric 30, type intra area
[…]
Routing Descriptor Blocks:
* 10.254.0.17, from 10.255.1.8, 00:23:41 ago, via Ethernet0/0
Route metric is 30, traffic share count is 1

R10#sh ip route 10.254.0.26


Routing entry for 10.254.0.24/30
Known via "ospf 1", distance 110, metric 20, type intra area
[…]
Routing Descriptor Blocks:
* 10.254.0.29, from 10.255.1.8, 00:23:09 ago, via Ethernet0/0
Route metric is 20, traffic share count is 1

The best path is via R10 because lower cost is preferred.


So we create a route-map that match cost between 0 and 21 and we set the
bandwidth to 10000 in order to lower the metric in the redistribution.

The other costs (>21) will have a bandwidth of 1000 which set a higher
metric in the redistribution.

47
R9/R10
router ospf 1
redistribute eigrp 1 subnets
route-map METRIC permit 10
match metric 10 +- 11
set metric 10000 100 255 1 1500
route-map METRIC permit 20
set metric 1000 100 255 1 1500
router eigrp JACOBS
address-family ipv4 unicast autonomous-system 1
topology base
redistribute ospf 1 route-map METRIC

The second problem is about R52 loopback52 interface 52.52.52.52. That


subnet is an external EIGRP route. So when EIGRP load balance that route, R9
learns it via OSPF with an AD of 110 and via EIGRP with an AD of 170.
As a result, R9 should the suboptimal route via OSPF because 110<170.

To correct that, we need to deny routes tagged with 172.172.172.172 on R9


and R10.

R9/R10
route-map TAG deny 10
match tag 172.172.172.172
route-map TAG permit 20
!
router ospf 1
distribute-list route-map TAG in

48
Verifications:

R50#traceroute 10.255.1.8
Type escape sequence to abort.
Tracing the route to 10.255.1.8
VRF info: (vrf in name/id, vrf out name/id)
1 172.30.100.5 1 msec 1 msec 0 msec
2 10.254.0.65 0 msec 0 msec 1 msec
3 10.254.0.29 1 msec 1 msec 0 msec
4 10.254.0.26 1 msec 1 msec *

R9#sh ip route eigrp

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 25 subnets, 2 masks


D 10.254.0.64/30 [90/2048000] via 10.254.0.62, 01:03:19, Ethernet0/1
52.0.0.0/32 is subnetted, 1 subnets
D EX 52.52.52.52 [170/1536640] via 10.254.0.62, 01:03:19, Ethernet0/1
172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks
--More—

R10#sh ip route eigrp

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 25 subnets, 2 masks


D 10.254.0.60/30 [90/2048000] via 10.254.0.66, 01:04:06, Ethernet0/1
52.0.0.0/32 is subnetted, 1 subnets
D EX 52.52.52.52 [170/1536640] via 10.254.0.66, 00:39:59, Ethernet0/1
172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks
--More--

49

You might also like