You are on page 1of 5

SEDE LIMA-INDEPEDENCIA

///////////////////////////////////////////////
router hural
///////////////////////////////////////////////
en
conf t
hostname LIM-ROUT_PRIN
ip domain-name cisco.com
username cisco privilege 15 password cisco
crypto key generate rsa
1024
ip ssh version 2
line vty 0 15
password cisco
login local
transport input all
logging synchronous
exit

line console 0
password cisco
login local
logging synchronous
exit

enable password cisco


service password-encryption

configure terminal
int gi0/0/0
no sh

int gi0/0/0.10
encapsulation dot1q 10
description RED-VLAN10
ip add 192.168.10.1 255.255.255.0
no sh

int gi0/0/0.20
encapsulation dot1q 20
description RED-VLAN20
ip add 192.168.20.1 255.255.255.0
no sh

int gi0/0/1
description RED-WAN
ip add 10.10.10.1 255.255.255.252
no sh
exit

router eigrp 10
network 10.10.10.0 0.0.0.3
network 192.168.10.0 0.0.0.255
network 192.168.20.0 0.0.0.255
passive-interface gi0/0/0.10
passive-interface gi0/0/0.20
no auto-summary

ip access-list standard restriccion_red-10


permit 192.168.10.0 0.0.0.255
permit 192.168.30.0 0.0.0.255

ip access-list standard restriccion_red-20


permit 192.168.40.0 0.0.0.255
permit 192.168.20.0 0.0.0.255
exit

int gi0/0/0.10
ip access-group restriccion_red-10 out

int gi0/0/0.20
ip access-group restriccion_red-20 out
exit

ip access-list standard restriccion-ssh


permit host 192.168.10.240
exit

line vty 0 15
access-class restriccion-ssh in

ip dhcp excluded-address 192.168.10.1


ip dhcp excluded-address 192.168.10.240
ip dhcp excluded-address 192.168.20.1

ip dhcp pool LAN_VLAN10


network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 8.8.8.8

ip dhcp pool LAN_VLAN20


network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
dns-server 8.8.8.8
exit
do wr
end

/////////////////////////////////////////
HURAL - SW PRINCIPAL
//////////////////////////////////////////

en
conf t
hostname INDEP-SW_PRINCIPAL
ip domain-name cisco.com
username cisco privilege 15 password cisco
crypto key generate rsa
1024
ip ssh version 2
line vty 0 15
password cisco
login local
transport input all
logging synchronous
exit

line console 0
password cisco
login local
logging synchronous
exit

enable password cisco


service password-encryption

vlan 10
name vlan-10
vlan 20
name vlan_20
exit

int vlan 10
ip add 192.168.10.245 255.255.255.0

ip access-list standard restriccion-ssh


permit host 192.168.10.240
exit

line vty 0 15
access-class restriccion-ssh in
exit

int gi0/1
switchport mode trunk

int range fa0/1-2


switchport mode trunk
ip default-gateway 192.168.10.1
do wr
end

/////////////////////////////////////////
INDEP - SW ACCESO 01
//////////////////////////////////////////

en
conf t
hostname INDEP-SW_ACCESO_01
ip domain-name cisco.com
username cisco privilege 15 password cisco
crypto key generate rsa
1024
ip ssh version 2
line vty 0 15
password cisco
login local
transport input all
logging synchronous
exit

line console 0
password cisco
login local
logging synchronous
exit
enable password cisco
service password-encryption

vlan 10
name vlan-10
vlan 20
name vlan_20
exit

int vlan 10
ip add 192.168.10.246 255.255.255.0

ip access-list standard restriccion-ssh


permit host 192.168.10.240
exit

line vty 0 15
access-class restriccion-ssh in
exit

int gi0/1
switchport mode trunk

int range fa0/1-12


switchport mode access
switchport access vlan 10

int range fa0/13-24


switchport mode access
switchport access vlan 20
exit
ip default-gateway 192.168.10.1
do wr
end

/////////////////////////////////////////
INDEP - SW ACCESO 02
//////////////////////////////////////////

en
conf t
hostname INDEP-SW_ACCESO_02
ip domain-name cisco.com
username cisco privilege 15 password cisco
crypto key generate rsa
1024
ip ssh version 2
line vty 0 15
password cisco
login local
transport input all
logging synchronous
exit

line console 0
password cisco
login local
logging synchronous
exit
enable password cisco
service password-encryption

vlan 10
name vlan-10
vlan 20
name vlan_20
exit

int vlan 10
ip add 192.168.10.247 255.255.255.0

ip access-list standard restriccion-ssh


permit host 192.168.10.240
exit

line vty 0 15
access-class restriccion-ssh in
exit

int gi0/1
switchport mode trunk

int range fa0/1-12


switchport mode access
switchport access vlan 10

int range fa0/13-24


switchport mode access
switchport access vlan 20
exit
ip default-gateway 192.168.10.1
do wr
end

You might also like