You are on page 1of 5

SEDE HURAL

////////////////////////////////////
router hural
/////////////////////////////////////

en
conf t
hostname HUAR-ROUT_PRIN
ip domain-name cisco.com
username cisco privilege 15 password cisco
crypto key generate rsa
1024
ip ssh version 2
line vty 0 15
password cisco
login local
transport input ssh
logging synchronous
exit

line console 0
password cisco
login local
logging synchronous
exit
enable password cisco
service password-encryption

configure terminal
int gi0/0/0
no sh

int gi0/0/0.30
encapsulation dot1q 30
description RED-VLAN30
ip add 192.168.30.1 255.255.255.0
no sh

int gi0/0/0.40
encapsulation dot1q 40
description RED-VLAN40
ip add 192.168.40.1 255.255.255.0
no sh

int gi0/0/1
description RED-WAN
ip add 10.10.10.2 255.255.255.252
no sh
exit

router eigrp 10
network 10.10.10.0 0.0.0.3
network 192.168.30.0 0.0.0.255
network 192.168.40.0 0.0.0.255
passive-interface gi0/0/0.30
passive-interface gi0/0/0.40
no auto-summary
ip access-list standard restriccion_red-30
permit 192.168.10.0 0.0.0.255
permit 192.168.30.0 0.0.0.255

ip access-list standard restriccion_red-40


permit 192.168.40.0 0.0.0.255
permit 192.168.20.0 0.0.0.255
exit

int gi0/0/0.30
ip access-group restriccion_red-30 out

int gi0/0/0.40
ip access-group restriccion_red-40 out
exit

ip access-list standard restriccion-ssh


permit host 192.168.30.240
permit host 192.168.10.240
exit

line vty 0 15
access-class restriccion-ssh in
exit
do wr

ip dhcp excluded-address 192.168.30.1


ip dhcp excluded-address 192.168.30.240
ip dhcp excluded-address 192.168.40.1

ip dhcp pool LAN_VLAN30


network 192.168.30.0 255.255.255.0
default-router 192.168.30.1
dns-server 8.8.8.8

ip dhcp pool LAN_VLAN40


network 192.168.40.0 255.255.255.0
default-router 192.168.40.1
dns-server 8.8.8.8
exit
do wr

/////////////////////////////////////////
HURAL - SW PRINCIPAL
//////////////////////////////////////////

en
conf t
hostname HUAR-SW_PRINCIPAL
ip domain-name cisco.com
username cisco privilege 15 password cisco
crypto key generate rsa
1024
ip ssh version 2
line vty 0 15
password cisco
login local
transport input ssh
logging synchronous
exit

line console 0
password cisco
login local
logging synchronous
exit
service password-encryption

vlan 30
name vlan-30
vlan 40
name vlan_40
exit

int vlan 30
ip add 192.168.30.245 255.255.255.0

ip access-list standard restriccion-ssh


permit host 192.168.30.240
permit host 192.168.10.240
exit

line vty 0 15
access-class restriccion-ssh in
exit

int gi0/1
switchport mode trunk

int range fa0/1-2


switchport mode trunk
exit
ip default-gateway 192.168.30.1
do wr

/////////////////////////////////////////
HURAL - SW ACCESO 01
//////////////////////////////////////////

en
conf t
hostname HUAR-SW_ACCESO_01
ip domain-name cisco.com
username cisco privilege 15 password cisco
crypto key generate rsa
1024
ip ssh version 2
line vty 0 15
password cisco
login local
transport input ssh
logging synchronous
exit

line console 0
password cisco
login local
logging synchronous
exit

enable password cisco


service password-encryption

vlan 30
name vlan-30
vlan 40
name vlan_40
exit

int vlan 30
ip add 192.168.30.246 255.255.255.0

ip access-list standard restriccion-ssh


permit host 192.168.30.240
permit host 192.168.10.240
exit

line vty 0 15
access-class restriccion-ssh in
exit

int gi0/1
switchport mode trunk

int range fa0/1-12


switchport mode access
switchport access vlan 30

int range fa0/13-24


switchport mode access
switchport access vlan 40
exit
ip default-gateway 192.168.30.1
do wr

/////////////////////////////////////////
HURAL - SW ACCESO 02
//////////////////////////////////////////

en
conf t
hostname HUAR-SW_ACCESO_02
ip domain-name cisco.com
username cisco privilege 15 password cisco
crypto key generate rsa
1024
ip ssh version 2
line vty 0 15
password cisco
login local
transport input ssh
logging synchronous
exit

line console 0
password cisco
login local
logging synchronous
exit

enable password cisco


service password-encryption

vlan 30
name vlan-30
vlan 40
name vlan_40
exit

int vlan 30
ip add 192.168.30.247 255.255.255.0

ip access-list standard restriccion-ssh


permit host 192.168.30.240
permit host 192.168.10.240
exit

line vty 0 15
access-class restriccion-ssh in
exit

int gi0/1
switchport mode trunk

int range fa0/1-12


switchport mode access
switchport access vlan 30

int range fa0/13-24


switchport mode access
switchport access vlan 40
exit
ip default-gateway 192.168.30.1
do wr

You might also like