You are on page 1of 2

:local user "syafiranet86"

:local pass "syafiranet86"


:local gwid "WAG-D5-KBL"
:local ether "wlan1"
:local wlan "PMPME00213-N/TLK-CI-104427"
:local wms "@wms.1262639631.000"
:local redirect "https//www.google.com"

:log info "Menjalankan Auto Login ..."


:local ip [/ip address get [/ip address find interface="$ether"] address];
:local ip [put [:pick $ip 0 [:find $ip "/"]]];
:if ([:len $ip] = 0) do={
:log error ("Interface $ether tidak mendapatkan alamat ip --- mencoba
mendapatkan...");
/ip dhcp-client release [find interface="$ether"];
};
delay 1s

:local mac [/interface get [find name="$ether"] mac-address];


:local gateway [/ip dhcp-client get [find interface="$ether"] gateway];
:log warning "IP Address : $ip"
:log warning "MAC Address : $mac"
:log warning "IP Gateway : $gateway"

:log info "Menghubungkan ..."

:local num1 [:pick [/system clock get time] 0]


:local num2 [:pick [/system clock get time] 1]
:local num3 [:pick [/system clock get time] 3]
:local num4 [:pick [/system clock get time] 6]
:local char1 [:pick "abcdefghijklmnopqrstuvwxyz" "$num1$num2"]
:local char2 [:pick "abcdefghijklmnopqrstuvwxyz" "2$num2"]
:local char3 [:pick "abcdefghijklmnopqrstuvwxyz" "1$num4"]
:local user "$user.$char3$char1$char2$wms"

:do {
:tool fetch mode=https http-header-field="Content-Type: application/x-www-
form-urlencoded; charset=UTF-8,User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64;
x64) AppleWebKit/537.36,Referer: https://welcome2.wifi.id/login/?
gw_id=$gwid&client_mac=$mac&wlan=$wlan&sessionid=02202122200000a8923a158623&redirec
t=$redirect" http-method=post http-data="username=$user&password=$pass"
url="https://welcome2.wifi.id/wms/auth/authnew/autologin/quarantine.php\?
ipc=$ip&gw_id=$gwid&mac=$mac&redirect=$redirect&wlan=$wlan" dst-path=wms.txt;
:if ([/ping address=$gateway interface="$ether" count=2] = 0) do={
:log error "Login gagal... ";
/ip dhcp-client release [find interface="$ether"];
}
:if ([/ping address=$gateway interface="$ether" count=2] != 0) do={
:log info "Login sukes..."
:local iRes [/file get wms.txt contents];
:log warning $iRes
delay 1s
:file remove wms.txt
}
}
#:log warning "$user.$char3$char1$char2$wms"
https://welcome2.wifi.id/login/?gw_id=WAG-D5-
KBL&client_mac=70:3A:51:9A:AC:2B&wlan=PBKRZ00019-N/TLK-CI-
59043:@wifi.id&sessionid=WAG-D5-01203120200000d71452067276

You might also like