You are on page 1of 4

GRE Tunnel

****************GRE tunnel******************

ON router1

en

config t

hostname R1

int s0/0/0

ip add 132.132.25.1 255.255.255.252

no shut

int fa0/0

ip add 192.168.10.1 255.255.255.0

no shut

On router2

 Step1

en

config t

hostname R2

int s0/0/0

ip add 132.132.25.2 255.255.255.252

no shut

exit

int s0/0/1

ip add 132.132.25.5 255.255.255.252

no shut
exit

On router3

en

config t

hostname R3

int s0/0/0

ip add 132.132.25.9 255.255.255.252

no shut

exit

int s0/0/1

ip add 132.132.25.6 255.255.255.252

no shut

exit

ON router4

en

config t

hostname R4

int s0/0/0

ip add 132.132.25.10 255.255.255.252

no shut

exit

int fa0/0

ip add 192.168.20.1 255.255.255.0

no shut
exit

 Step 2

Enable eigrp on R1 R2 R3 & R4 (do not advertise pc network)

config t

router eigrp 100

network 132.132.0.0

no auto-summary

exit

 Step 3

Enable tunnel on R1

int tunnel 0

tunnel mode gre ip

ip address 10.0.0.1 255.0.0.0

tunnel source s0/0/0

tunnel destination 132.132.25.10

exit

on R4

int tunnel 0

tunnel mode gre ip

ip address 10.0.0.2 255.0.0.0

tunnel source s0/0/0

tunnel destination 132.132.25.1

exit
 Step 4

Assign ip address to pc1 and pc2

ping from pc1 to pc2 (it will fail)

 Step 5

On router R1

config t

router ospf 1

network 192.168.10.0 0.0.0.255 area 0

network 10.0.0.0 0.255.255.255 area 0

On router R4

config t

router ospf 1

network 192.168.20.0 0.0.0.255 area 0

network 10.0.0.0 0.255.255.255 area 0

 step 6

ping from pc1 and pc2 (it will success)

#sh interface tunnel 0

You might also like