You are on page 1of 2

Mode & prompt Command Results

ping 192.168.2.1 Pings a specific address


? Help – displays a list of available commands
Tab key after letter(s) Tab completion-finishes a partial command
Up arrow key Allows user to scroll forward through former commands
These commands work in any Down arrow key Allows user to scroll backward through former commands
mode Spacebar Displays the next screen
traceroute 192.168.2.1 Traces the path to an IP address
Ctrl-C break
enable Goes to privilege exec mode
show ip interface Displays IPv4 stats for all interfaces on a router
User exec> show version Displays info about the currently loaded software version,
hardware info, device info
show clock shows device time & date
Disable Goes back to user exec mode
clock set 19:45:00 23 April 2012 Sets the date & time
configure terminal switches to global configuration level
show running-config Displays the running configuration located in RAM
show startup-config Displays saved configuration located in NVRAM
show arp Displays the ARP table of the device
show version Displays currently loaded IOS version
show interfaces display stats for all interfaces
show ip interface display IP stats for all interfaces
Privileged exec# configure terminal Goes to global configuration mode
copy running-config startup-config Saves the running configuration to the startup configuration
copy startup-config running-config copies the configuration in NVRAM to RAM
write memory Saves the running configuration to the startup configuration
(on newer devices)
reload restarts the device
erase startup-config removes the startup configuration
ping 192.168.108.125 ping to that address
traceroute 192.168.108.254 trace each hop to that address
banner motd #NO ACCESS# sets the banner to NO ACCESS
end Ends configuration mode and returns to privileged EXEC
mode
interface fastethernet 0/0 Goes to configure an individual interface
interface serial 0/0/0 Goes to configure an individual interface
hostname OTC SuperRouter changes the name of the device
no hostname negates the name change
Global configuration (config)# enable password superhero set an unencrypted enable password to superhero
enable secret superhero set an encrypted enable (priv. exec) password to superhero
line vty 0 15 Enter virtual terminal (Telnet) line configuration mode
line console 0 goes to the console line
service password-encryption encrypt display of all passwords except secret
no ip domain lookup to stop the router from “translating”
Description OTC Graff Hall 108 Assigns a description to the interface
Exit Goes back to global configuration mode
line console 0 goes to console configuration
password Cisco sets a password
login configures the router to require authentication upon login
Interface (config-if)# no login removes the need for authentication
ip address 192.168.2.1 255.255.255.0 set interface IP address and mask
clock rate 56000 set clock rate for DCE device
no shutdown enables the interface
shutdown set interface to down
password superhero enable password checking at login
Interface (config-line)# login enable password checking at login
Logging synchronous Keeps update messages from interrupting your typing
(config)# no ip domain lookup
Stops the router from “translating” or trying to resolve from DNS

(config-line)# logging synchronous


Keeps update messages from interrupting your typing of commands (vty 0 15 AND console line)

Run the above commands on EACH router, in the appropriate modes.

Configuring static routes:


ip route 192.168.209.xxx 255.255.255.xxx se0/1/0

*destination network address & mask, and serial interface will differ

*this command will have to be entered on BOTH routers to tell them how to get to the
remote LAN

>>>To be able to ping a PC, TURN OFF WINDOWS FIREWALL ON THAT PC!!!

Password-related commands:

Service password-encryption – encrypts the display of all passwords except secret

Security passwords min-length 8 – sets the password minimum length requirement to 8 characters

Login block-for 120 attempts 3 within 60 – locks out in case of brute-force attack

Exec-timeout 10 – configures the device to disconnect idle users after 10 minutes

Switching commands:

VLAN configuration (IP addresses below are random)


Switch> enable
Switch# configure terminal
Switch(config)# interface vlan 1
Switch(config-if)# ip address 192.168.217.253 255.255.255.0
Switch(config-if)# no shut
Switch(config)# ip default-gateway 192.168.217.254
To delete the vlan.dat file: Switch# delete vlan.dat

Configure the console and/or VTY lines to log out after X minutes of inactivity:
Switch(config-line)# exec-timeout X
Router(config-line)# exec-timeout X

IPv6 commands:

IPv6 unicast address


Router(config-if)# ipv6 address 2001:db8:acad:3::1/64
IPv6 link-local address
Router(config-if)# ipv6 address FE80::1 link-local
Enable a router as an IPv6 router
Router(config)# ipv6 unicast-routing

You might also like