You are on page 1of 6

BMIT3094 ADVANCED COMPUTER NETWORKS

Tutorial 6

1. R1 acts as Cisco IOS DHCPv4 server assigns and manages IPv4 addresses from specified
address pools within the router to DHCPv4 clients. You are required to exclude first 5 IP
addresses from both of the LANs. Write down the commands for R1.

172.16.45.6/24

172.16.55.6/26

172.16.55.5/26

Figure 1-1: A network topology

R1 – ip dhcp excluded-address 172.16.45.1 172.16.45.5


ip dhcp excluded-address 172.16.55.1 172.16.55.5

ip dhcp pool LAN45


network 172.16.45.0 255.255.255.0
default-router 172.16.45.1

ip dhcp pool LAN55


network 172.16.55.0 255.255.255.192
default-router 172.16.55.1
dns-server 172.16.55.5

2. A network administrator has setup a network topology as shown in Figure2-1 and configures
DHCP, Syslog and NTP services as shown in Figure 2-2.

202201 1
BMIT3094 ADVANCED COMPUTER NETWORKS

Figure 2-1: A network topology

service timestamps log datetime msec

hostname R1

ip dhcp excluded-address 10.0.1.254 ip dhcp excluded-


address 10.0.3.1 10.0.3.3 ip dhcp excluded-address
10.0.1.1 10.0.1.2

ip dhcp pool 10.0.1.X


network 10.0.1.0 255.255.255.0 default-router 10.0.1.1
interface GigabitEthernet0/1 ip address
10.0.1.1 255.255.255.0

interface GigabitEthernet0/2 ip
address 10.0.3.1 255.255.255.0

interface Serial0/0/0
ip address 209.165.14.2 255.255.255.0

ip route 0.0.0.0 0.0.0.0 Serial0/0/0

ntp server 64.103.224.2 key 0

Figure 2-2: Partial output of “show running-config”

(i) DHCP is not functioning for PC2 and L2 when the network administrator tried to release and
renew IP addresses as shown in Figure 2-3. Based on Figure 2-1 and Figure 2-2, identify and
rectify the problem.

202201 2
BMIT3094 ADVANCED COMPUTER NETWORKS

Figure2-3: Sample output of “ipconfig /release” and “ipconfig /renew”

Problem Solution
Missing DHCP Ip dhcp pool LAN3.X
Configuration for network 10.0.3.0 Network 10.0.3.0 255.255.255.0
Default-router 10.0.3.1

3. PC1 is attempting to acquire an IPv4 address from a DHCPv4 server using a broadcast message.
In this scenario, R1 is not configured as a DHCPv4 server and does not forward the broadcast.

(i) Can PC1 obtain a DHCP IPv4 address from the DHCPv4 Server? Justify your answer.
PC1 cannot receive an IP address using DHCP. Because the DHCPv4 server is located on a
different network. PC1 is in network 192.168.20.0/24 but DHCPv4 server is located on
192.168.30.0/24

(ii) How to allow PC1 to obtain a DHCP IPv4 address from the DHCPv4 Server. Propose a
solution and write the commands.
- R1 must be configured to relay DHCPv4 messages to the DHCPv4 server.
- Configure R1 with the ip helper-address address interface configuration command.
interface GigabitEthernet0/0/0
ip address 192.168.20.1 255.255.255.0
ip helper-address 192.168.30.5
- This will cause R1 to relay DHCPv4 broadcasts to the DHCPv4 server.

202201 3
BMIT3094 ADVANCED COMPUTER NETWORKS

- When R1 has been configured as a DHCPv4 relay agent, it accepts broadcast requests for the
DHCPv4 service and then forwards those requests as a unicast to the IPv4 address
192.168.30.5.

4. Given the following network physical topology and partial configurations shown in Figure 4-1,
all the hosts attached to the Internal LAN are not able to acquire TCP/IP configuration
information from the DHCPv4 Server. As a network associate, you are required to troubleshoot
and correct the configuration errors. Document the problem discovered, explanations and a
detailed solution.

Figure 4-1 A network with a DHCPv4 server

Problem Discovered Explanations & A Detailed Solution


DHCPv4 relay is not configure on R1 Explanation (Any 2, 2 marks each, total 4m)

- In the attempt of acquiring TCP/IP configuration


parameters from a DHCPv4 server, a DHCPv4
client will send out a broadcast message to reach the
DHCPv4 server

- In this scenario, router R1 does not forward the


broadcast message as this is a default function of a
router and the DHCPv4 relay service has not been
configured on its G0/1 interface.

- Therefore, the DHCPv4 broadcast messages


cannot reach the DHCPv4 server and the host will
not have the IP address.

Solution: (4m)
Configure an IP helper address will enable a router
to forward DHCPv4 broadcasts to the DHCPv4
server, acting as a relay. (2m)

202201 4
BMIT3094 ADVANCED COMPUTER NETWORKS

interface g0/1 (1m)


ip helper-address 192.168.0.254 (lm)

5. CEO of ARMY Sdn. Bhd. has employed you to ensure all the PCs in the company are able to
communicate with each other. Assume all the IPv4 addressing, static routing and OSPF
configurations are configured in the respective routers. With reference to a network topology
shown in Figure 5-1, answer the following questions.

Figure 5-1: A network topology

a) DHCP (Dynamic Host Configuration Protocol) configurations are to be configured in BEDHCP


router. PC-V, PC-JK, PC-HOPE and PC-JM should obtain the IP addresses and other DHCP
configurations automatically from BE-DHCP router as shown in Figure 5-1. Use
Table 5-1 to document the DHCP configurations with justifications. (16 marks)

Table 5-1: Documentation Table


Router name Configurations Justifications
BE-DHCP ip dhcp excluded-address DHCP excluded ip addresses are from 1
192.168.44.1 (0.5m) to 9 because ip addresses for PC-JK(.11)
192.168.44.9 (0.5m) and PCV(.10) respectively. (1m)
Default gateway is 192.168.44.1 to
ip dhcp pool route to remote site. (lm) dns-server
DHCP_LAN2(0.5m) 192.168.44.2 (1m)

network 192.168.44.0
255.255.255.0 (0.5m)

default-router 192.168.44.1
(0.5m)

202201 5
BMIT3094 ADVANCED COMPUTER NETWORKS

dns-server
192.168.44.2(0.5m)
ip dhcp excluded-address DHCP excluded ip addresses are from 1
172.16.33.1 (0.5m) to .19 because ip addresses for PC-
172.16.33.19 (0.5m) HOPE(20) and PCJM.21) respectively.
(lm) Default gateway is 172.16.33.1 to
ip dhcp pool route to remote site (1m) dns-server
DHCP_LAN1(0.5m) 192.168.44.2 (1m)

network 172.16.33.0
255.255.255.0 (0.5m)

default-router 172.16.33.1
(0.5m)

dns-server
192.168.44.2(0.5m)
BE-NAT int g0/0 (1m) PC-HOPE and PC-JM are attempting to
ip helper-address acquire an IPv4 address from a
172.16.1.1 DHCPv4 server using a broadcast
message.

BE-NAT is not configured as a


DHCPv4 server and does not forward
the broadcast.

DHCPv4 server (BE-DHCP) is located


on a different network, PCI cannot
receive an IP address using DHCP. BE-
NAT must be configured with ip helper-
address command to relay DHCPv4
messages to the DHCPv4 server.

Any 1 noint x 2m=2m

202201 6

You might also like