You are on page 1of 32

CCNA PROJECT

SUBMITTED BY:
NAME : HARIKRISHNAN A S
STUDENT ID: NSKCD0918014
COURSE CODE: NSND035

TOPIC
IMPLIMENTING SWITCHING
ABSTRACT

• A business firm with switching network has to be created with 7


switches
• Entire network consisting of three groups
• Individual switches need to be configured in a secure manner
with protection from any person with restricted access.

CHAPTER 1
AIM

• A Switching network with 7 switches need to be created


• Entire topology should be in 3 different group
• VLAN should be implemented
• Each switch should configured in a secure manner with
enable secret password
• Each should be protected with Port-Security
CHAPTER 2
PROCEDURES

• Start a new project


• Design the requirements
• Insert the components
• Network devices
• Configure password
• Implement VLAN
• Implement Port-Security
• Check whether the communication is established
CHAPTER 3
NETWORK REQUIREMENTS

• Identify the hardware components required to setup the network


for the network systems.
• The application server should be setup in a secure manner with
network
• IP addressing range for users and hardware components.
• The users at same group should be able to access each other.
• Network topology diagram

CHAPTER 4
THEORY

.TRUNK

. A SWITCH TO SWITCH CONNECTIONS ARE TRUNK


ACCESS
PC - SWITCH CONNECTION ARE ACCESS
.ACCESS AND TRUNK configuration cammond

for access port


switch(config)#interface fastethernet 0/1
switch(config-if)#switchport mode access

for trunk port


switch(config)#interface fastethernet 0/2
switch(config-if)#switchport mode trunk

. VTP DOMAIN
.vtp updates will not be recivedin switch which is having
different domain name
.It receives when domain name is same

.configuration command

. TO CREATE DOMAIN

switch(config)#vtp domain nsk

.TO CHANGE THE VTP MODE

.
switch(config)#vtp mode server/client
VLAN
. SWITCH IS A SINGLE BROADCAST DOMAIN
.CONVERTING A SINGLE BROADCAST DOMAIN TO
MULTIPLE BROADCAST DOMAIN IS CALLED VLAN
.IT IS A VIRTUAL LAN CREATE IN A SWITCH

CHAPTER 5
TOPOLOGY

CHAPTER 6
CONFIGURATION

SWITCH 1 server

HEAD#SHOW RUNning-config
Building configuration...

Current configuration : 1517 bytes


!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
enable secret 5 $1$mERr$Bok4KDfVutXOJolNq009M/
enable password ccna
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 3
switchport mode access
switchport port-security
switchport port-security mac-address 0050.0F92.E641
!
interface FastEthernet0/3
switchport access vlan 6
switchport mode access
switchport port-security
switchport port-security mac-address 0001.436D.D98A
!
interface FastEthernet0/4
switchport access vlan 9
switchport mode access
switchport port-security
switchport port-security mac-address 000B.BE8C.D021
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

ii. Enable password

Sl no Type Password
1 Secret ccna

switch 2 - client
Current configuration : 1517 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
enable secret 5 $1$mERr$Bok4KDfVutXOJolNq009M/
enable password ccna
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 3
switchport mode access
switchport port-security
switchport port-security mac-address 0050.0F92.E641
!
interface FastEthernet0/3
switchport access vlan 6
switchport mode access
switchport port-security
switchport port-security mac-address 0001.436D.D98A
!
interface FastEthernet0/4
switchport access vlan 9
switchport mode access
switchport port-security
switchport port-security mac-address 000B.BE8C.D021
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

ii. . Enable password

Sl no Type Password
1 Secret ccna
switch 3 - client

Switch#sh run
Building configuration...

Current configuration : 1517 bytes


!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
enable secret 5 $1$mERr$Bok4KDfVutXOJolNq009M/
enable password ccna
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport mode trunk
!
interface FastEthernet0/3
switchport access vlan 3
switchport mode access
switchport port-security
switchport port-security mac-address 00D0.5849.BD4B
!
interface FastEthernet0/4
switchport access vlan 6
switchport mode access
switchport port-security
switchport port-security mac-address 0005.5E9D.C8EA
!
interface FastEthernet0/5
switchport access vlan 9
switchport mode access
switchport port-security
switchport port-security mac-address 0002.1742.2315
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

ii. Enable password

Sl no Type Password
1 Secret ccna

SWITCH 4 - client

Switch#sh run
Building configuration...

Current configuration : 1517 bytes


!
version 12.2
no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

hostname Switch

!
enable secret 5 $1$mERr$Bok4KDfVutXOJolNq009M/

enable password ccna

spanning-tree mode pvst

interface FastEthernet0/1

interface FastEthernet0/2

switchport mode trunk

interface FastEthernet0/3

switchport access vlan 3

switchport mode access

switchport port-security

switchport port-security mac-address 0001.64D1.1872

interface FastEthernet0/4

switchport access vlan 6

switchport mode access

switchport port-security

switchport port-security mac-address 0002.4A67.5560

interface FastEthernet0/5

switchport access vlan 9


switchport mode access

switchport port-security

switchport port-security mac-address 0001.6416.BB9E

interface FastEthernet0/6

interface FastEthernet0/7

interface FastEthernet0/8

interface FastEthernet0/9

interface FastEthernet0/10

interface FastEthernet0/11

interface FastEthernet0/12

interface FastEthernet0/13

interface FastEthernet0/14

interface FastEthernet0/15

interface FastEthernet0/16

interface FastEthernet0/17
!

interface FastEthernet0/18

interface FastEthernet0/19

interface FastEthernet0/20

interface FastEthernet0/21

interface FastEthernet0/22

interface FastEthernet0/23

interface FastEthernet0/24

interface GigabitEthernet1/1

interface GigabitEthernet1/2

interface Vlan1

no ip address

shutdown

line con 0

line vty 0 4
login

line vty 5 15

login

!
end

iii. Enable password

Sl no Type Password
1 Secret ccna

SWITCH 5 - client
Switch#sh run
Building configuration...

Current configuration : 1517 bytes


!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
enable secret 5 $1$mERr$Bok4KDfVutXOJolNq009M/
enable password ccna
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport mode trunk
!
interface FastEthernet0/3
switchport access vlan 3
switchport mode access
switchport port-security
switchport port-security mac-address 0090.0C6E.0B6C
!
interface FastEthernet0/4
switchport access vlan 6
switchport mode access
switchport port-security
switchport port-security mac-address 0000.0C04.100B
!
interface FastEthernet0/5
switchport access vlan 9
switchport mode access
switchport port-security
switchport port-security mac-address 0060.5C9E.79B2
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

ii. Enable password

Sl no Type Password
1 Secret ccna

SWITCH 6 - client

Switch#sh run
Building configuration...

Current configuration : 1517 bytes


!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
enable secret 5 $1$mERr$Bok4KDfVutXOJolNq009M/
enable password ccna
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport mode trunk
!
interface FastEthernet0/3
switchport access vlan 3
switchport mode access
switchport port-security
switchport port-security mac-address 00D0.FFAA.D33C
!
interface FastEthernet0/4
switchport access vlan 6
switchport mode access
switchport port-security
switchport port-security mac-address 00E0.F9C5.EE75
!
interface FastEthernet0/5
switchport access vlan 9
switchport mode access
switchport port-security
switchport port-security mac-address 0090.2144.593A
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

iii. Enable password

Sl no Type Password
1 Secret ccna

SWITCH 7 - client

Switch#sh run
Building configuration...

Current configuration : 1494 bytes


!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
enable secret 5 $1$mERr$Bok4KDfVutXOJolNq009M/
enable password ccna
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport access vlan 3
switchport mode access
switchport port-security
switchport port-security mac-address 0005.5EA0.C6D9
!
interface FastEthernet0/3
switchport access vlan 6
switchport mode access
switchport port-security
switchport port-security mac-address 0090.2144.593A
!
interface FastEthernet0/4
switchport access vlan 9
switchport mode access
switchport port-security
switchport port-security mac-address 0050.0FE6.4805
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

iii. Enable password

Sl no Type Password
1 Secret ccna

CHAPTER 7
RESULTS

• A Switching network with 7 switches is created successfully


• VLAN is implemented for logical grouping of entire switching
network
• Enable secret password is configured in all seven switches
• Port-Security is enabled on all ports

You might also like