You are on page 1of 2

#### Top 10 process using highest memory

/usr/bin/prstat -s rss -n 10
/usr/bin/prstat -a -s size

### RAM in Solaris


/usr/sbin/prtconf | grep Memory

### Free physical memory on Solaris


/usr/bin/vmstat 1 2
Note: used to check swap and free memory. Check the second line for Solaris.
Also, check if OS is paging by values in "pi" and "p0"

### check swap (Ref: https://docs.oracle.com/cd/E23824_01/html/821-1459/fsswap-


52195.html#scrolltoc)
/usr/sbin/swap -s (in bytes)
Note: total swap space used shown in this command includes portion of
physical memory and swap device/files
/usr/sbin/swap -l (info about swapfile in blocks)
Note: If, "blocks" & "free" values are same then that swapfile is not busy

### CPU info in Solaris


CPU count:
/usr/sbin/psrinfo

Each processor info:


/usr/sbin/psrinfo -v

Processor stats:
mpstat #report per-processor statistics

###displays I/O of all disks


/usr/bin/iostat -xtc

### To check disk usage in Solaris


$ iostat -xn 1 3
$ /usr/sbin/zpool list
$ /usr/sbin/zpool status <zonepool_name_from_above_command>

### network
# netstat -rn (shows IP)

#### to Check Public & Interconnect details


$GRID_HOME/bin/oifcfg getif
$GRID_HOME/bin/oifcfg iflist -p -n
/usr/sbin/ifconfig -a

#### Verify public IP / interconnect settings


SQL> SELECT * FROM gV$CONFIGURED_INTERCONNECTS;
where,
IS_PUBLIC = Yes means its a public interface

#### The VIP details can be checked using a srvctl command as in the following
example:
srvctl config nodeapps

### Check interconnect/publicIP by Traceroute from Node-a


/usr/sbin/traceroute -r -F <priv_or_public>
/usr/sbin/ping -s <priv_or_public>

### OSWatcher commnds on Solaris


IOSTAT=> iostat -xn 1 3
VMSTAT=> vmstat 1 3
TOP=> top -d2 -s1
PRSTAT=> prstat 1 2
PSELF=> ps -elf
MPSTAT=> mpstat 1 2

You might also like