You are on page 1of 5

**************DHCP SERVER************

Configure R1 as a DHCP server.

R1#config t

R1(config)#int fa0/0

R1(config-if)#ip add 192.168.10.1 255.255.255.0

R1(config-if)#no sh

R1(config-if)#exit

R1(config)#int s1/0

R1(config-if)#ip add 192.168.20.1 255.255.255.0

R1(config-if)#no sh
R1(config)#ip dhcp pool surat

R1(dhcp-config)#network 192.168.10.0 255.255.255.0

R1(dhcp-config)#default-router 192.168.10.1

R1(dhcp-config)#domain-name cisco.com

R1(dhcp-config)#dns-server 8.8.8.8

R1(dhcp-config)#import all

R1(dhcp-config)#lease 0 12 0

R1(dhcp-config)#exit

R1(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.10

R1(config)#ip dhcp pool baroda

R1(dhcp-config)#network 192.168.30.0 255.255.255.0

R1(dhcp-config)#default-router 192.168.30.1

R1(dhcp-config)#domain-name mcsa.com

R1(dhcp-config)#dns-server 8.8.8.8

R1(dhcp-config)#import all

R1(dhcp-config)#lease 0 12 0

R1(dhcp-config)#exit

R1(config)#ip dhcp excluded-address 192.168.30.1 192.168.30.10

R1(config)#

To list all DHCP pool


R1#sh ip dhcp pool

To list address lease information....


R1#sh ip dhcp binding
************DHCP RELAY AGENT******************
Configure R2 as a DHCP Relay Agent.

R2#config t

R2(config)#int s1/0

R2(config-if)#ip add 192.168.20.2 255.255.255.0

R2(config-if)#no sh

R2(config-if)#int fa0/0

R2(config-if)#ip add 192.168.30.1 255.255.255.0

R2(config-if)#no sh

R2(config-if)#int fa0/0

R2(config-if)#ip helper-address 192.168.20.1

R1#SH IP ROUTE

R2#SH IP ROUTE

R1(config)#router rip

R1(config-router)#network 192.168.10.0

R1(config-router)#network 192.168.20.0

R1(config-router)#exit

R2(config)#router rip

R2(config-router)#network 192.168.30.0

R2(config-router)#network 192.168.20.0

R2(config-router)#exit
__________________________________________________________________

************************CDP********************
CDP = CISCO DISCOVERY PROTOCOL

CDP Is cisco prop. protocol

CDP Is on by default on cisco device.

CDP Packet send every 60sec by default

CDP holdtime is 180 second.

To list CDP

R1#sh cdp

To change timer

R1(config)#cdp timer 90 [value is 5-254 second]

R1(config)#cdp holdtime 210 [ value is 10-255 second]

To list neighbour

R1#sh cdp neigbour

To list full detail about neighbour

R1#sh cdp neigbour detail


To disable cdp on router.

R1(config)#no cdp run

To disable cdp on specific interface

R1(config)#int fa0/0

R1(config-if)#no cdp enable

You might also like