You are on page 1of 3

SEM VI Computer Networks Laboratory

Experiment No.: Date:

Title: To configure static routing

Learning Objectives: At the end of this experiment, students will be able to:
1. Configure topology with Static Routing
2. Test and verify the configuration
Pre-requisite: Basic concepts of routing protocols
Apparatus: Cisco Packet Tracer

Topology:

Theory:
A router can learn about remote networks in one of two ways:
1. Manually, from configured static routes
2. Automatically, from a dynamic routing protocol

Static Routing: Static routing is a type of network routing technique. Static routing is
not a routing protocol; instead, it is the manual configuration and selection of a network
route, usually managed by the network administrator. It is employed in scenarios where

Page No.:
SEM VI Computer Networks Laboratory

the network parameters and environment are expected to remain constant. The command
for configuring a static route is ip route. The complete syntax for configuring a static
route is:
Router(config)#ip route network-address subnet-mask {ip-address | exit-interface }
The following parameters are used:
network-address - Destination network address of the remote network to be added to the
routing table
subnet-mask - Subnet mask of the remote network to be added to the routing table. The
subnet mask can be modified to summarize a group of networks.
One or both of the following parameters must also be used:
 ip-address - Commonly referred to as the next-hop router's IP address
 Exit-interface - Outgoing interface that would be used in forwarding packets to the

Router1 Configuration Commands:


Router1>en
Router1#config t
Router1(config)#interface f0/0
Router1(config-if)#ip address 10.0.0.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1#interface f0/1
Router1(config-if)#ip address 20.0.0.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2
Router1(config)#ip route 40.0.0.0 255.0.0.0 20.0.0.2
Router1(config)#ip route 50.0.0.0 255.0.0.0 20.0.0.2
Procedure:

Page No.:
SEM VI Computer Networks Laboratory

1. Connect all of the devices in the network according to the given topology
2. Configure the ip addressing of all of the devices.

3. Configure static routes so all devices can communicate over the network.

4. Verify that all PCs can communicate with each other over the network.

5. After configuring the given network, a packet should be ping from any one
machine to another.Enter commands in CLI window of routers to verify
connectivity.

Commands:-
1. Router#show ip route
2. Router#ping destination ip address
3. Router#Clear ip route *
This allows the routing table to switch to the new updates by clearing the old
entries.

Conclusions:

Page No.:

You might also like