You are on page 1of 20

ABDULLAH GOHAR

02-134202-013
LAB#
08

BAHRIA UNIVERSITY KARACHI CAMPUS


Department of Computer Science

DATA COMMUNICATION AND NETWORKS

LAB EXPERIMENT # 8

Dynamic Routing RIP and EIGRP


OBJECTIVE:-

 This lab assignment helps in understanding how dynamic route using Routing Information
Protocol (RIP) can be configured on routers.

EQUIPMENT:-

1. Ethernet Cable
2. Two Router
3. Four PCs
4. Two Switches

THEORY:-

Routing Information Protocol (RIP) is a true distance-vector routing protocol. RIP sends the
complete routing table out to all active interfaces every 30 seconds. RIP only uses hop count to
determine the best way to a remote network, but it has a maximum allowable hop count of 15 by
default, meaning that 16 is deemed unreachable. RIP works well in small networks, but it’s
inefficient on large networks with slow WAN links or on networks with a large number of routers
installed. It cannot distinguish between high bandwidth link and a lower bandwidth link because
delay or bandwidth is not taken under consideration as a metric.

29
ABDULLAH GOHAR
02-134202-013
LAB#
08

NETWORK TOPOLOGY:-

10.0.0.3 20.0.0.3
15.0.0.1 15.0.0.2
`

Router 1 Router 2

PC-1 PC-2 PC-3 PC-4

10.0.0.0 20.0.0.0

PROCEDURE AND OBSERVATION:-

Step01: Configuring RIP routing on router 1


Router1(config)#interface serial 0/0/0 (Configuring serial 0 port)
Router1(config-if)#ip address 15.0.0.1 255.0.0.0
Router1(config-if)#Clock rate 64000
Router1(config-if)#no shut
Router1(config-if)#exit

Router1(config)#interface fa 0/0 (Configuring fastethernet 0 port)


Router1(config-if)#ip address 10.0.0.3 255.0.0.0
Router1(config-if)#no shut
Router1(config-if)#exit

Router1(config)#router rip (Configuring RIP on router 1)


Router1(config)#network 10.0.0.0
Router1(config)#network 15.0.0.0

Router1# show ip route

30
ABDULLAH GOHAR
02-134202-013
LAB#
08

Step 02: Configuring static routing on router 2


Router2(config)#interface serial 0/0/0 (Configuring serial 0 port)
Router2(config-if)#ip address 15.0.0.2 255.0.0.0
Router2(config-if)#Clock rate 64000
Router2(config-if)#no shut
Router2(config-if)#exit

Router2(config)#interface fa 0/0 (Configuring fastethernet 0 port)


Router2(config-if)#ip address 20.0.0.3 255.0.0.0
Router2(config-if)#no shut
Router2(config-if)#exit

Router1(config)#router rip (Configuring RIP on router 2)


Router1(config)#network 20.0.0.0
Router1(config)#network 15.0.0.0

Router2# show ip route

Step03: Verify the route by pinging from Router 1 to Router 2


Router2# ping 20.0.0.2 or
Router1# ping 10.0.0.2

Step04: Verify the route by pinging from PC 1 to PC3


C:\> ping 10.0.0.1 (from PC 1) or
C:\> ping 20.0.0.2 (from PC 3)

EIGRP Properties

The Enhanced Interior Gateway Routing Protocol (EIGRP) is an advanced distance-vector


routing protocol that is used on a computer network to help automate routing decisions and
configuration. EIGRP allows a router to share information it knows about the network with
neighboring routers within the same logical area known as an autonomous system. Contrary to other
well known routing protocols, such as routing information protocol, EIGRP only shares information
that a neighboring router would not have, rather than sending all of its information. EIGRP is
optimized to help reduce the workload of the router and the amount of data that needs to be
transmitted between routers. EIGRP supports Classless Inter-Domain Routing (CIDR) and variable
length subnet masking.

31
ABDULLAH GOHAR
02-134202-013
LAB#
08

NETWORK TOPOLOGY:-

10.0.0.3 20.0.0.3
15.0.0.1 15.0.0.2
`
Router 1 Router 2

PC-1 PC-2 PC-3 PC-4

10.0.0.0 20.0.0.0

PROCEDURE AND OBSERVATION:-

Step01: Configuring EIGRP routing on router 1


Router1(config)#interface serial 0/0/0 (Configuring serial 0 port)
Router1(config-if)#ip address 15.0.0.1 255.0.0.0
Router1(config-if)#Clock rate 64000
Router1(config-if)#no shut
Router1(config-if)#exit

Router1(config)#interface fa 0/0 (Configuring fastethernet 0 port)


Router1(config-if)#ip address 10.0.0.3 255.0.0.0
Router1(config-if)#no shut
Router1(config-if)#exit

Router1(config)#router eigrp 1 (Configuring EIGRP on router 1)


Router1(config)#network 10.0.0.0
Router1(config)#network 15.0.0.0

Router1# show ip route

32
ABDULLAH GOHAR
02-134202-013
LAB#
08

The above given command inserts a static route into the routing table of
router saying, if a packet having destination address of network
20.0.0.0/8 is received on any of the router interfaces then it should be
routed to 15.0.0.2

Step 02: Configuring static routing on router 2


Router2(config)#interface serial 0/0/0 (Configuring serial 0 port)
Router2(config-if)#ip address 15.0.0.2 255.0.0.0
Router2(config-if)#no shut
Router2(config-if)#exit

Router2(config)#interface fa 0/0 (Configuring fastethernet 0 port)


Router2(config-if)#ip address 20.0.0.3 255.0.0.0
Router2(config-if)#no shut
Router2(config-if)#exit

Router1(config)#router eigrp 1 (Configuring EIGRP on router 2)


Router1(config)#network 20.0.0.0
Router1(config)#network 15.0.0.0

Router2# show ip route

Step03: Verify the route by pinging from Router 1 to Router 2


Router2# ping 20.0.0.2 or
Router1# ping 10.0.0.2

Step04: Verify the route by pinging from PC 1 to PC3


C:\> ping 10.0.0.1 (from PC 1) or
C:\> ping 20.0.0.2 (from PC 3)

QUESTIONS:-

33
ABDULLAH GOHAR
02-134202-013
LAB#
08
1. Configure RIP and EIGRP on the following network and show all necessary configuration
steps for each router.

192.168.1.5 172.16.0.5
100.0.0.1 100.0.0.2
`

Router 1 Router 2

192.168.1.0 172.16.0.0

34
ABDULLAH GOHAR
02-134202-013
LAB#
08

35
ABDULLAH GOHAR
02-134202-013
LAB#
08

36
ABDULLAH GOHAR
02-134202-013
LAB#
08

2. Configure RIP and EIGRP on the following network and show all necessary configuration
steps for each router.

Router 2

15.0.0.2 16.0.0.2

16.0.0.1
15.0.0.1

Router 1 Router 3

10.0.0.3 20.0.0.3

10.0.0.0 20.0.0.0

37
ABDULLAH GOHAR
02-134202-013
LAB#
08

38
ABDULLAH GOHAR
02-134202-013
LAB#
08

39
ABDULLAH GOHAR
02-134202-013
LAB#
08

40
ABDULLAH GOHAR
02-134202-013
LAB#
08

41
ABDULLAH GOHAR
02-134202-013
LAB#
08

42
ABDULLAH GOHAR
02-134202-013
LAB#
08

43
ABDULLAH GOHAR
02-134202-013
LAB#
08

44
ABDULLAH GOHAR
02-134202-013
LAB#
08

45
ABDULLAH GOHAR
02-134202-013
LAB#
08

46
ABDULLAH GOHAR
02-134202-013
LAB#
08

47
ABDULLAH GOHAR
02-134202-013
LAB#
08

Teacher Signature: ________________________

Student Registration No: _02-134202-013___________

48

You might also like