You are on page 1of 3

Assigning IP address into Router Ports

Commands Function
Step 1 enable Enables privileged EXEC
mode
In CLI:
Router> enable
Step 2 configure terminal Enters global configuration
mode
In CLI:
Router# configure terminal
Step 3 hostname Sets the hostname to ABR-2

In CLI:
Router# hostname ABR-2
Step 4 interface fastethernet/number Enters interface configuration
mode for the specified fast
In CLI: ethernet interface
ABR-2 (config)# interface
Fastethernet0/0
Step 5 ip address ip-address mask Assigns an IP address and a
subnet mask
In CLI:
ABR-2 (config-if)# ip address
172.16.1.3 255.255.255.0
Step 6 no shutdown Used in interface configuration
mode. “no shutdown” brings
In CLI: up the interface.
Router(config-if)# no shutdown
Step 7 interface fastethernet/number Enters interface configuration
mode for the specified serial
In CLI: interface
ABR-2(config-if)# interface
Serial0/1/0
Step 8 ip address ip-address mask Assigns an IP address and a
subnet mask
In CLI:
ABR-2(config-if)# ip address
172.16.10.5 255.255.255.252
Step 9 no shutdown Enables the interface,
changing its state from
In CLI: administratively down to
ABR-2(config-if)# no shutdown administratively up
Step 10 clock rate bps(bits/sec) To configure the clock rate for
the hardware connections on
In CLI: serial interfaces
ABR-2(config-if) # clock rate
64000
Step 10 interface fastethernet/number Enters interface configuration
mode for the specified
In CLI: loopback interface
ABR-2(config-if)# interface
loopback 30
Step 11 ip address ip-address mask Assigns an IP address and a
subnet mask
In CLI:
ABR-2(config-if)# ip address
192.168.3.1 255.255.255.255
Step 12 no shutdown Enables the interface,
changing its state from
In CLI: administratively down to
ABR-2(config-if)# no shutdown administratively up
Step 13 exit Returns to global configuration
mode
In CLI:
ABR-2(config-if)# exit
Implementing OSPF Protocol in ABR-2

Command or Action Purpose


Step 1 router ospf process-id Enables OSPF routing, and
enter router configuration
In CLI: mode
ABR-2(config)# router ospf 10
Step 2 network ip-address wildcard- Define an interface on which
mask area area-id OSPF runs and the area ID
for that interface
In CLI:
ABR-2(config-router)#
network 172.16.1.0 0.0.0.255
area 0
Step 3 network ip-address wildcard- Define an interface on which
mask area area-id OSPF runs and the area ID
for that interface
In CLI:
ABR-2(config-router)#
network 172.16.10.4 0.0.0.3
area 1
Step 4 network ip-address wildcard- Define an interface on which
mask area area-id OSPF runs and the area ID
for that interface
In CLI:
ABR-2(config-router)#
network 192.168.3.0 0.0.0.0
area 1
Step 5 passive-interface loopback- Used to suppress OSPF hello
id packets on a specified
interface.
In CLI:
ABR-2(config-router)#
passive-interface loopback30

You might also like