You are on page 1of 23

1. How do I know if my volume group is normal, big, or scalable?

Run the lsvg command on the volume group and look at the value for MAX PVs. The value is 32 for
normal, 128 for big and 1,024 for scalable volume group.

2. How do I create a volume group?


Use the following command, where s partition_size sets the number of megabytes (MB) in each
physical partition where the partition_size is expressed in units of MB from one through 1,024. (It’s
one through 131,072 for AIX 5.3.)

mkvg -y name_of_volume_group -s partition_size list_of_hard_disks


The partition_size variable must be equal to a power of two (for example: one, two, four or eight).
The default value for standard and big volume groups is the lowest value to remain within the
limitation of 1,016 physical partitions per physical volume. The default value for scalable volume
groups is the lowest value to accommodate 2,040 physical partitions per physical volume.

3. How can I change the characteristics of a volume group?


You use the chvg command to change the characteristics of a volume group.

4.How do I create a logical volume?

#mklv -y name_of_logical_volume name_of_volume_group number_of_partition

5.How do I increase the size of a logical volume?


To increase the size of the logical volume represented by the lv05 directory by three logical partitions,
for example, type extendlv lv05 3.

6.How do I display all logical volumes that are part of a volume group (e,g, rootvg)?

You can display all logical volumes that are part of rootvg by typing the following command: #lsvg -l
rootvg/

7.How do I list information about logical volumes?

Run the following command to display information about the logical volume #lv1: lslv lv1.

8.How can I clone the rootvg?


You can run the alt_disk_copy command to copy the current rootvg to an alternate disk. The
following example shows how to clone the rootvg to hdisk1: alt_disk_copy -d hdisk1.]

9.How do I replace a disk?

extendvg VolumeGroupName hdisk_new

migratepv hdisk_bad hdisk_newreducevg -d VolumeGroupName hdisk_bad

10.How do I mirror a logical volume?


mklvcopy LogicalVolumeName Numberofcopies
syncvg VolumeGroupName
11.How can I display or set values for network parameters?
The no command sets or displays current or next boot values for network tuning parameters

12.How do I get the IP address of my machine?

Type one of the following: ifconfig -a or host Fully_Qualified_Host_Name. For example, host
cyclop.austin.ibm.com.

13.How do I identify the network interfaces on my server?

Either of the following two commands will display the network interfaces: lsdev -Cc if or ifconfig -a.
To get information about one specific network interface, for eaxample tr0, run the command ifconfig
tr0.

14.How do I activate a network interface?


To activate the network interface tr0, run the command ifconfig tr0 up.

15.How do I display routing table, interface and protocol information?

To display routing table information for an Internet interface, type netstat -r -f inet. To display
interface information for an Internet interface, type netstat -i -f inet. To display statistics for each
protocol, type netstat -s -f inet.

16.How will you create a file if a disk is given to you?

#mkvg –y datavg –s 128 hdisk1 (pv name)

#mklv -y datalv –t jfs2 datavg 1

#crfs –v jfs2 –d datalv –g datavg –a size=10M –m /fs1

17.Difference between JFS & JFS2?

JFS:

JFS is normal filesystem. We cannot create large files in JFS.

Files can be access dynamically.

Max file system size=1TB

Max file size=64GB

Inode size=128b

JFS2:-
Can create a large size filesystems.

Files can be access accordingly as required. (not randomly or sequentially)

Max files system size=4PB

Max file size=4PB


Inode size=512

18.How will you find the inode number?

# ls –li

# istat /etc/passwd

21.How will you find whether a quorum is up or not?

# lsvg vg name

22.How to copy a LV from one VG to another?

# cplv -v <new vg name> <sourcelvname>

23.Mirroring concept?
Check disk size belong to vg , take two same size disk to mirror
# bootinfo –s hdisk2
#lsvg –p rootvg
Add one more disk of same size of already have disk having rootvg.
# extendvg rootvg hdisk2
# lsvg –p rootvg
Now mirror vg with background sync LV. It sync LVs in background with new LVs
# mirrorvg –s rootvg
Create a boot image
# bosboot –ad /dev/hdisk2
#bosboot –ad /dev/hdisk1
Add a blv
record of newly added disk, first check and then add.
# bootlist –m normal -o

#bootlist –m normal hdisk2 hdisk1

24.How will you unmirror a VG if a PV gets failed?


First check the blv record using,
# bootlist –m normal –o
Remove the old blv record, using
# chpv –c hdisk2
# bootlist –m normal hdisk1
# bootlist –m normal hdisk2
Now unmirrorvg
# unmirrorvg rootvg hdisk2
# reducevg rootvg hdisk2
#lsvg –p rootvg
# lspv
# bootlist –m normal –o

25.How will you change a PP size?


PP size can be changed using a T-factor. If not then add a partitions in VG by adding one disk.
# chvg –t3 rootvg

26.T – Factor?
T – factor means that it will change the pp size to increase the efficiency of vg

#chvg –t16 datavg


Cal-if suppose that datavg pp size is 1016 we can take t factor is 16 then it comes to 2048 and pv
contains in vg is 2.

27. What is the default PP Size in AIX?

128MB

28.How will you rename a VG?


Unmount all filesystems in VG.

# umount /test (mount point name)

#varyoffvg datavg

#exportvg datavg0
Importvg with new name

# importvg –y newvg hdisk4

30.What will you do if a disk gets failed?

diag command

31. How to enable & disable quorum?

# chvg –vy pv_name

# chvg –vn pv_name

#chvg –Qn vgname

#chvg –Qs vgname

32.What are the types of error?


1.H/W error
2. S/W error
3. Operator error
4. Unknown error.

33.What are the error levels severity?


1. permanent
2. Temporary
3. Informational
4. Unknown.
34.What is the command to see the error log?

# errpt –a
# errpt -aj errorcode

35.What is the command to clear the errorlog?

# errclear

36.What is the command to increase the size of error log when it is ful?

#usr/lib/errdemon –s ____ [ size ]

37.What is the command to start , stop, restart and list a demon?

# startsrc –g [ Demon name ]

# stopsrc [Demon name ]

# refresh [Demon name ]

# lssrc –al

39.Which file that error daemon stay?

/usr/lib/errdemon

40.Two states of device availability and explain them?


Available state and defined state. When device is in defined state it means it cannot use. Not in ready
state. Run cfgmgr try to make available known in the system that device. Available state means that
device is ready to use

# lsdev –Cc disk


It displays which disks are available

41.How will you check whether a device is installed or not?

# lsdev –Cc disk

44. How many VGs can be created in a LVM?


255 any no. of vg can create.

45.Types of VG & explain about them?


Normal vg -32 pv, 256 lv

# mkvg –y normvg –s 128 hdisk4


Big vg :- 128pv,512lv

# mkvg -B –y bigvg –s 128 hdisk9


Scalable vg: -1024pv, 4096 lv
# mkvg –S –y scalvg –s 512 hdisk1

46. How to convert a normal VG to big & scalable VG and also Big to Scalable VG?

#chvg –B vgname /big vg

# chvg –S/-G vgname /scale vg

48.Default dump device?


hd6

49.Default secondary dump device?


/dev/sysdumpdevnull

50.How find a system dump?

#sysdumpdev -L

51.Where the file does the paging space stay?


/etc/swapspaces

52.How will check whether a fix is installed or not?

# instfix –ik ptfname

53.What are the two states of installation?


Applied and commit state

In applied state if want to do any changes on installed software then we can do

But in commit the changes are not allowed to do. Once did installation.

A committed fileset update cannot be rejected.

Output from the installp -s command, which is used to get a list of applied software
fileset updates and updates that are available to be either committed or rejected.

55.How will you check whether service pack is installed or not?

# oslevel –s

57.How will you check whether software is installed or not?

# lslpp -L |grep -i (software_name)

58.How do you find history of a file set?

#lslpp –h

59.How to remove a failed package installation?

#installp -C
60.How do remove the entries of the device in the odm?

#rmdev -dl

61.What are the types of ODM Database ?

ODM - Object data manager


Pre-defined database PdDv, PdAt
Customised database CuDv, CuAt

62.ODM Commands.

odmcreate: To customize Odm

To remove ODM: odmdrop

odmdelete: To remove object from ODM

To see info in ODM odmget

To change the fields in object class odmchange

To add object to ODM odmadd

63. Types of Installation?


New and complete overwrite

Migration

Preservation

64.Where does log files resides?

AIX logs messages as specified in /etc/syslog.conf file.

65.How to unlock user account?


Smitty user

67.How do u take backup of file systems?

#backup -f /dev/rmt0

69.How will u append a file to a previous archive take by Tar?

#tar -rvf /dev/rmt0

70.What command to take backup other vg’s?

# savevg –if /dev/rmt0 /vgname

71.What command to restore backup of non – rootvg?

# restvg –x –d –f /dev/rmt0
72.How do I know if I am running a uniprocessor kernel or a multiprocessor kernel, or a
32-bit kernel or a 64-bit kernel?

/unix is a symbolic link to the booted kernel. To find out what kernel mode is running, enter ls -l
/unix and see what file /unix it links to. The following are the three possible outputs from the ls -l
/unix command and their corresponding kernels:

1 /unix -> /usr/lib/boot/unix_up # 32 bit uniprocessor kernel

2 /unix -> /usr/lib/boot/unix_mp # 32 bit multiprocessor kernel

3 /unix -> /usr/lib/boot/unix_64 # 64 bit multiprocessor kernel

Note:
AIX 5L Version 5.3 does not support a uniprocessor kernel.

73.How can I change from one kernel mode to another?

During the installation process, one of the kernels, appropriate for the AIX version and the hardware
in operation, is enabled by default. Use the method from the previous question and assume that the
32-bit kernel is enabled. Also assume that you want to boot it up in the 64-bit kernel mode. This can
be done by running the following commands in sequence:

1
ln -sf /usr/lib/boot/unix_64 /unix
2
ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix
3
bosboot -ad /dev/hdiskxx
4
shutdown -r
5

The /dev/hdiskxx directory is where the boot logical volume /dev/hd5 is located. To find out what xx
is in hdiskxx, run the following command:

1 lslv -m hd5

74.How do I know if my Power Systems machine (hardware) is 32-bit or 64-bit?

Run the prtconf command.

75.Can my machine run the 64-bit kernel?

64-bit hardware is required to run the 64-bit kernel.

76.How many processors does my system have?

To display the number of processors on your system, type:

1 lscfg | grep proc

77.How many hard disks does my system have and which ones are in use?
To display the number of hard disks on your system, type:

1 lspv

78.How do I list information about a specific physical volume?

To find details about hdisk1, for example, run the following command:

1 lspv hdisk1

79.How do I get a detailed configuration of my system?

Type the following:

1 lscfg

How do I find out the chip type, system name, node name, model number, and so forth?

The uname command provides details about your system.

Command Description

uname -p Displays the chip type of the system. For example, IBM PowerPC®.

uname -r Displays the release number of the operating system.

uname -s Displays the system name. For example, AIX.

uname -n Displays the name of the node.

uname -a Displays the system name, nodename, version, machine ID.

uname -M Displays the system model name. For example, IBM, 9114-275.

uname -v Displays the operating system version.

uname -m Displays the machine ID number of the hardware running the system.

name -u Displays the system ID number.

AIX

80.What is the technology level of my system?

To determine the highest technology level reached for the current version of AIX on the system, type:

1 oslevel -r
2 lslpp -h bos.rte

81.How do I mount a CD?

Type the following:

1 mount -V cdrfs -o ro /dev/cd0 /cdrom

82.How do I mount a file system?

The following command will mount file system /dev/fslv02 on the /test directory:

1 mount /dev/fslv02 /test

83.How do I mount all default file systems (all standard file systems in the
/etc/filesystems file marked by the mount=true attribute)?

The following command will mount all such file systems:

1 mount {-a|all}

84.How do I display mounted file systems?

Type the following command to display information about all currently mounted file systems:

1 mount

85.How do I remove a file system?

Type the following command to remove the /test file system:

1 rmfs /test

This removes the /test file system, its entry in the /etc/filesystems file, and the underlying logical
volume.

86.How can I defragment a file system?

The defragfs command can be used to improve or report the status of contiguous space within a file
system. For example, to defragment the file system /home, use the following command:

1 defragfs /home

To generate a report on the /data1 file system that indicates its current status as well as its status
after being defragmented, enter:

1 defragfs -r /data1

To generate a report on the fragmentation in the /data1 file system, enter:


1 defragfs -s /data1

How do I display information about the installed file sets on my system?

Type the following command:

1 lslpp -l

To list the installation state for the most recent level of installed file sets for all of the bos.rte file sets,
type:

1 lslpp -l "bos.rte.*"

87.How do I verify if file sets have required prerequisites and are completely installed?

To show the file sets that need to be installed or corrected, type:

1 lppchk -v

88.How do I determine the amount of paging space allocated and in use?

Type the following:

1 lsps -a

89.How do I reduce a paging space?

You can use the chps-d command to dynamically reduce the size of a paging space. For example, if
you want to decrease the size of hd6 with four logical partitions, you issue the following command:

1 chps -d 4 hd6

90.How would I know if my system is capable of using simultaneous multithreading


(SMT)?

Your system is capable of SMT if it is an IBM POWER5 processor-based system or later running AIX
5L Version 5.3 or later.

How would I know if SMT is enabled for my system?

If you run the smtctl command without any options, it tells you if it is enabled or not.

Is SMT supported for the 32-bit kernel?

Yes, SMT is supported for both 32-bit and 64-bit kernel.

Note:

AIX V5.3 32-bit kernel only supports SMT 2. For SMT 4 exploitation, you would need to run AIX V5.3
in a versioned workload partition (WPAR) on top of AIX V7.1 (described in the Workload partitions
section). The 32-bit kernel was removed in AIX V6.1.
How do I enable or disable SMT?

You can enable or disable SMT by running the smtctl command. The following is the syntax:

1 smtctl [ -m off | on [ -w boot | now]]

91.How do I get partition-specific information and statistics?

The lparstat command provides a report of partition information and utilization statistics. This
command also provides a display of hypervisor information.

92.How do I replace a disk?

extendvg VolumeGroupName hdisk_new

migratepv hdisk_bad hdisk_new

reducevg -d VolumeGroupName hdisk_bad

The command migratepv moves allocated physical partitions from one physical volume to one or
more other physical volumes.

The reducevg command removes physical volumes from a volume group. When all the physical
volumes are removed from the volume group, the volume group is deleted.

93.How can I clone (make a copy of) the rootvg?

You can run the alt_disk_copy command to copy the current rootvg to an alternate disk. The
following example shows how to clone the rootvg to hdisk1.

1 alt_disk_copy -d hdisk1

94.How can I display or set values for network parameters?

The no command sets or displays current or next boot values for network tuning parameters.

To display the maximum size of the mbuf pool, type:

How do I identify the network interfaces on my server?

Either of the following two commands will display the network interfaces:

1.lsdev -Cc if

2.ifconfig -a

To get information about one specific network interface, for example, tr0, run the command:

1.ifconfig tr0

95.How do I report system unit activity?

Type the following command:


1 Sar

To report current TTY activity for each 2 seconds for the next 40 seconds, enter the following
command:

1 sar -y -r 2 20

To report the processor use statistics in a WPAR from the global environment, enter the following
command:

1 sar -@ wparname

96.TL and SP Update procedure

1.TL and SP update 2.Down the database 3.down the filesystems

Stop the lisner (su - oracle --> lsnrctl stop)

lsvg -p roovg --> To check boot disks

lspv ---> Confirm rootvg disks

bootinfo -b ---> To check current boot disk

bootlist -om normal ---> to check all boot disks

sysdumpdev -l ---> To view sysdump

lspv -l hdisk0 (Free disk) ----> To check which dump is there in free disk

Ex - in freedisk primary dump is there

sysdumpdev -Pp /dev/sysdumpnull (-Pp ---> Primary dump, -Ps --> secondary dump)

unmirrorvg rootvg hdisk0

lspv -l hdisk0 ----> To view dumplv

rmlv lv_dump1lv --> To remove dump lv

lsvg -p rootvg ----. Confirm the free PP's count (Total and free will be same)

reducevg rootvg hdisk0

bootlist -om normal ---> Now here it will show only one disk

lspv ----> here now free disk will show None status

Now u can go for alt_clone or altclone with update or update through nim server

Once alt_clone is completed change updated disk as primary


bootlist -m normal hdisk0 hdisk1 (hdisk0 --> alt_clone with updated disk, hdisk1 --> old disk)

97. What does Logical Volume Manager(LVM) mean?


The set of operating system commands, library subroutines and other tools that allow
you to establish and control logical volume storage is called the Logical Volume
Manager (LVM).
98. How will you find LTG size?
#lsvg vgname
#lquerypv –M hdiskname
99. How will you change LTG size?
#rmdev -l hdiskx
#chdev -l hdiskx -a max_transfer=0*80000
#mkdev -l hdiskx
100. What is major number?
A major number refers to a type of device. A device number is a major number, and a
minor number specifies a particular device of that type or sometimes the operation mode
of that device type.
101. Explain the ODM concepts?
ODM generally used for Maintain the System information, whenever we install and
reconfigure the hardware device and software, that information’s added in ODM,
Mainly ODM used to store the following information’s
Hardware vital product data information
Software information
Smit menu
Nim
TCPIP
Error log
Device configuration information
Display information for SMIT (menus, selectors, and dialogs)
Vital product data for installation and update procedures
Communications configuration information

System resource information.


But we cannot see any ODM information in file format, but this ODM information
available in many files and different path,
/etc/objrepos
/usr/lib/objrepos
/usr/share/lib/objrepos
102. What is the difference between alt_disk_install and alt_disk_copy?
alt_disk_copy command is just a subset of alt_disk_install. When we run the
alt_disk_install it actually runs the alt_disk_copy as well under cover.
103. What all are the basic file sets needed for the alt_clone operation to perform?
Before proceeding with the alt_clone operation we have to verify the below mentioned
file sets available on the server for the alt_clone operation:

#lslpp -l|grep -I alt_disk

bos.alt_disk_install.boot_images
bos.alt_disk_install.rte 7.2.3.0 COMMITTED Alternate Disk Installation

104. How can we replace a failed disk in rootvg?


For this we need to get a new luns from the Storage team of equal the size of the good
copy existing the rootvg disk or greater than that in size. Then we can follow the below
procedure if we have 2 rootvg disks and one disk failed:
#cfgmgr
#lspv
#extendvg rootvg <new_disk_name>
#migratepv <failed_disk> <new_disk>
#reducevg -d rootvg <failed_disk>
#mirrorvg -S <hdisk_old> <hdisk_new>

105. There’s a vulnerability reported for a package installed on the server. What
action do we need to take?
We need to check for the APAR released by IBM for the software product. If yes, then
download it and by using the “emgr” command install it on the server.

106. How to recover the root password?


We need to boot the server from a bootable media either cd-rom. From there we can go
to the option Installation & Maintenance Menu and can choose to start it in a system
recovery mode. From there we can reset the root password.
#shutdown -r
#Option 3
#passwd <Enter new password>

107. For a mirrored volume group the administrator would like to ensure if one
disk fails the vg stays online What’s the command to check that?
chvg -Qn <vgname>
108. How to check the HMC version?
After login into the HMC on the top we can see the <HMC version>.
109. How can we restore a single file from the mksysb image file?
From the mksysb image file we can restore file by using the below command:
#restore -xvf <mksysb filename> ./<Path of the file to need to restore>/<file_name>
110. How can we check the maximum resources consumed processes?
In AIX we have below procedures to find out the maximum resources consumed
processes details:
#top: command which provides the live update of the processes and their utilization of
resources
From the “nmon analyzer” we can find out the detailed details of the processes.
#ps -ef
#svmon -Put 5

111. How a client server can be able to communicate with the NIM server?
With the help of “niminfo” file the client server can communicate with the Master NIM
server.
In the client server generate the NIMINFO file:
#niminit -a master=<nim_servername> -a name=`uname -n`

112. How to find out the MAC address of a server?


In the “netstat -ia” command from the “Address” column you can find the MAC address.

113. When an IBM engineer asks about to collect the logs what command do we
use?
To collect the system log “snap -gc” command.

114. How can we do OS Upgradation?


By using the “nimadm” command we can do the OS Upgradation.
#nimadm -j nimadmvg -c <lpar_name> -s <spot_name> -l <lpp_source_name> -d
<hdisk*> -Y
It has 12 steps post which the OS get successfully upgradaed.

115. What is the procedure to change the Network card speed on AIX?
We can change the network card speed by using the following steps:
#chdev -l en0 -a state=detach –> Detach the interface
#chdev -l ent0 -a media_speed=1000_Full_Duplex –> Make appropriate changes
#chdev -l en0 -a state=up –> Change the step to UP
[NOTE: Don’t do ifconfig enX up – this will put an IP address of 0.0.0.0] #mkdev -l inet0
–> to activate all routes
116. Command to find the real memory of a server?
Here is the command to find the real memory of a server:
#lsattr -EL sys0 -a realmem

117. How can we get the detailed information of my server?


We can find the detailed information of a server using the below commands:
#prtconf
#lscfg -vpl <devicename>
Whereas,
-v : Displays the vital product data (VPD) found in the customized VPD object class
-p : Displays platform-specific device information.

118. How to find out the maximum supported logical track group (LTG) size of my
hard disk?
You can use the “lquerypv” command with the -M flag. The output gives the LTG size in
KB.
#/usr/sbin/lquerypv -M hdisk*

119. How can I check whether my file system is corrupted or not?


If yes how to recover it to it’s previous most recent state?
Here is the procedure to recover a currupted file system:
#fsck -y <lv_name>
#fsck -p <lv_name>

120. What is DLPAR operation?


By using DLPAR operation we can online allocate additional CPU/Memory/IO and
adapters of a server.
Go to HMC-> Frame-> LPAR-> Right click-> DLPAR operation-> (Choose your
respective operation).
If the Maximum resources limit set for a LPAR is reached then DLPAR operation won’t
work in that case and a downtime is needed of the server.

121. How to map a LPARS FC adapter to the physical adapter of VIO?


Here is the procedure of mapping:
$vfcmap –vadpater vfchost* –fcp fcs* -> Perform the operation on both the VIOs.
Run the “lsmap -all -npiv” command to verify if the mapping for the corresponding client
lapar is correct or not.
Run “cfgmgr” on the LPAR
Then to verify the status -> “lsdev -Cc adapter”

122. What is Quorum?


Quorum is a validation technique done by LVM to resolve data corruption. Quorum
checking is done on the basis of VGDA information available in VG. Greater than 51%
votes are needed to allow valid quorum checking.
#we can check the quorum details using the command “lsvg <vg_name>

123. How can we set the file size limit to unlimited?


Here is the process to set the file size limit to unlimited:
#unlimit -f -> To check the current file size limit
#vi /etc/security/limits : set the “fsize=-1” in the default option

How to activate the paging space?


Here is the procedure to activate the paging space:
#lsps -a -> Current paging space size
#smitty mkps -> To add paging space
#swapon /dev/<paging space_name>

124. What is the diference b/w TL and ML?


TL: technology level
Ml: Maintance level

125. Could you please explain the complete scenario of NFS configuration?
NFS means network filesystem, we can asses the filestem from one server to another
server through NFS
We need to configure NFS using below
Lssrc –g nfs it will list nfs subsystems are in active or not, if it is not active we have to
activate with below command
Startsrc –g nfs
If you want to activate particular subsystem you can activate using below command
Startsrc –s nfs
Need to check NFS port no. 2049

126. How do you replace rootvg faulty disk?


We need to find the failed disk using below commands
Lsdev –Cc disk
Lsvg –p rootvg
Errpt –a
If the failed disk is mirrored with disk, we need to unmirror and reduce
that vg from rootvg
And raise a PMR with site engineer and he wil replace the disk and we will extend that
new disk to existing rootvg and we will mirror the rootvg

127. When I am trying to add new disk to existing volumge group, it showing as
conflicts what may be the reason.?
That new disk PVID is conflicts with other disk

128. What are the types of volume groups in aix?


Normal vg, bigvg , scalable vg

129. What is diff b/w normal , big and scalable vg?


Normal vg : 32 disks 256lvs max pps per vg 32512
Bigvg :128 disks 512 lvs 130048
Scalablevg : 1024 disks 4096lvs 2097152

130. How do you check the complete information of filesystem?


Lsfs -q

131. One of Data base server got rebooted unexpectedly, oracle team is asking
ROOT CAUSE for this?
You need to check the logs in /etc/syslog.conf, ususally all aix logs are stored in this file
, otherwise you can check in errpt | more
Still if you want more info you can raise a PMR with IBM team
132. When Iam trying to increase the filesytem, but iam unable incrase what may
be the reason?
There is no free pp’s in volume group and we need to extend the lp’s per lv

133. What is paging space?


When ever ram memory is not enough to load new programs , that time is there any
waiting process , those are moving to paging space

134. How do you perform TL upgradation in your environement and explain the
process?
TL upgaradation performing in 3 ways
Direct method
Multibos method
Alt disk method
For altdisk method we need to one extra disk which is equal or higher than rootvg disk
Some filesets also need to install
Bos. Alt_disk_install.rte
Bos. Alt_diks_install,images

135. How do you configure NIM server?


We need to install below filesets of nim server, once we install those filesets then only
NIM Server configured
Bos.sysmgt.nim.clinet
Bos.sysmgt.nim.maste
Bos.sysmgt.nim.spot

136. How to recreate /etc/niminfo file or server side and client side?
in nim server we can recreate using below.
Niminfo –r
On client side we can create like below
Niminit –v –a master=server –a client=hostname –a nimsh

137. what are the subsystems for nim server


nimesis and nimd
we can verify using lssrc –g nim
138. how to configure the client machine from nim server using below we can
configure client machine in nim server
goto the path smitty nim perform nim administration tasks

139. what are the TL version in your current environment?


aix 7.1 tl05 sp01
aix 7.2 tl02 sp02

140. user unable to login server, what may be the issue


account got expired, or need to account is locked or not,need to check unsuccessful
login account in lsuser –f username

141. How do you add ip aliasing and del alias?


chdev –l eno –a alias4=ip,subnetbask

142. How do you configure ASM disks for ORACLE?


Once we got the disk from storage we need to run cfgmgr from server end
After that we need to find major and minor number for the disk in /dev
Mknoc –C majorno. Minor no. /dev/disk

143. Have you ever done OS migration in your environment?


I have aix migration from 6.1 to 7.1 using nimadm method
We need one free disk to perform migration using nimadm
Aix migration is happeing in 12 steps

144. When iam trying to login server, it showing as fork error or system got hung
what may be the reason?
We need to login to console, check the paging space of the server using lsps –s
And we need to increase the paging to avoid houg or fork error

145. What is the syntax for oslevel –s?


Os version, tl version, sp version , week and year of release

146. What is DL par operation, how do you know that server is supporing DLPAR
operations or not?
By using DLPAR we can add remove move the resource from one server to another
Using below command to we wil get to know the server having dlpar capability or not
Lspartition –dlpar
147. What are the port no. for ftp, ssh, telnet, smtp, nfs, pop3?
ftp-21,ssh-22,telnet-23,smtp-25,ns-2049,pop3-110,

148. How do you convert from normal vg to bigvg?


Its an online activity to convert normal vg to bigvg using below ommand
Chvg –B vgname

149. How to install the missing filesets manuaaly?


Installp –acgxy fileset name filesetpath name

150. What is difference b/w applied and commited?


Applied means it will maintain moth old verion and new version
Commited means it will maintain only new version

151. How to commited filesets from applied?


Install –C all

152. How do you check the cluster version in power ha?


Lssrc –ls clstrmgrES

153. What are the cluster states in power HA?


Stable, init,
154. What is difference b/w power ha 6.1 and 7.1?
In 6.1 capacity upgrade on demand is there
In 7.1 IBM aware of aix future is there

155. How to move the resource group from one node to another node?
/usr/es/sbin/cluster/bin/clRGmove –G rgname –n node –m

156. How to list the RG info in cluster?


/usr/es/sbin/cluster/bin/clRGinfo

157. What is init tab stanza?


identifier : runlevel: action: command

158. What is the default run level in aix?


2

159. How to check the run level in aix?


cat /etc/init.state

160. How to check the user utilization of cpu, paging?


topas, svmon -G

161. How do you check the hmc ipaddress in server?


lsrsrc “IBM.Management server”

162. How can I display or set values for network parameters?


The no command sets or displays current or next boot values for network tuning
parameters

163. How do I get the IP address of my machine?


Type one of the following: ifconfig -a or host Fully_Qualified_Host_Name. For example,
host cyclop.austin.ibm.com.

164. How do I identify the network interfaces on my server?


Either of the following two commands will display the network interfaces: lsdev -Cc if or
ifconfig -a. To get information about one specific network interface, for eaxample tr0, run
the command ifconfig tr0.

165. How do I activate a network interface?


To activate the network interface tr0, run the command ifconfig tr0 up.
166. How do I display routing table, interface and protocol information?
To display routing table information for an Internet interface, type netstat -r -f inet. To
display interface information for an Internet interface, type netstat -i -f inet. To display
statistics for each protocol, type netstat -s -f inet.

167. How will you create a file if a disk is given to you?


#mkvg –y datavg –s 128 hdisk1 (pv name)
#mklv -y datalv –t jfs2 datavg 1
#crfs –v jfs2 –d datalv –g datavg –a size=10M –m /fs1

You might also like