You are on page 1of 6

In switch in th right side

enable
conf t
vlan 11
name Cus11
vlan 12
name Cus12
vlan 13
name Cusc13
end
show vlan brief

In switch in th lift side

enable
conf t
vlan 21
name Cus21
vlan 22
name Cus22
vlan 23
name Cusc23
end
show vlan brief

In switch 11 ND 5 MOST be the root bridg


switch11
conf t
spanning-tree vlan 11 root primary
spanning-tree vlan 12 root primary
spanning-tree vlan 13 root primary
spanning-tree vlan 1 root primary
end
show spanning-tree

switch5
conf t
spanning-tree vlan 21 root primary
spanning-tree vlan 22 root primary
spanning-tree vlan 23 root primary
spanning-tree vlan 1 root primary
end
show spanning-tree

to mack the path with 200MG between multy-layerswitch0 and switch11


Lacp
switch11
enable
conf t
interface range f0/1-2
channel-group 1 mode active
end
show etherchannel summary

multy-layerswitch0
enable
conf t
interface range f0/1-2
channel-group 1 mode active
end
show etherchannel summary

and the same thing in left side between multy-layerswitch1 and switch5
to dont lose the serves when use channel group mack the group
then add another port in group
switch5

enable
conf t
interface range f0/1-2
channel-group 1 mode active
end
show etherchannel summary

in multy-layerswitch0 there is a vlan but there is not layer 3 vlan


interface vlan
multy-layerswitch0

en
conf t
ip routing
int vlan 11
description GW-VL-11
ip address 10.10.11.1 255.255.255.0
exit
int vlan 12
description GW-VL-12
ip address 10.10.12.1 255.255.255.128
exit
int vlan 13
description GW-VL-13
ip address 10.10.13.1 255.255.255.192
end
show ip int brief

Now create the DHCP pool/

en
conf t
hostname MLS-Ring1
ip dhcp pool Ring1-VL11
network 10.10.11.0 255.255.255.0
default-router 10.10.11.1
dns-server 1.1.1.1
exit
ip dhcp pool Ring1-VL12
network 10.10.12.0 255.255.255.128
default-router 10.10.12.1
dns-server 1.1.1.1
exit
ip dhcp pool Ring1-VL13
network 10.10.13.0 255.255.255.192
default-router 10.10.13.1
dns-server 1.1.1.1
exit
the port with end user most be access

en
conf t
int r f0/
switchport mode access
switchport access vlan
end

and the port between switch most be trunk to data translite

en
conf t
int r f0/1-2
switchport mode trunk
ex

ip dhcp excluded-address 10.10.11.1


ip dhcp excluded-address 10.10.12.1
ip dhcp excluded-address 10.10.13.1
end

the link between maulty layer switch and router is layer 2


most change to layer 3 then give it IP address

en
conf t
int gig 0/1
no switchport
ip add 172.16.1.1 255.255.255.252
ex

the switch need routing OSPF


ip routing
router ospf 1
network 10.10.11.0 0.0.0.255 area 1
network 10.10.12.0 0.0.0.127 area 1
network 10.10.11.0 0.0.0.63 area 1
network 172.16.1.0 0.0.0.3 area 1
show ip ospf neighbor

now in router2 we add ip add in all sads for router and do the ospf

en
conf t
int gig 0/1
ip add 172.16.1.2 255.255.255.252
no shutdown
ex
int gig 0/0
ip add 192.168.1.2 255.255.255.252
no shutdown
ex
router ospf 1
network 172.16.1.0 0.0.0.3 area 1
network 192.168.1.0 0.0.0.3 area 0
end

*
show ip ospf neighbor
show ip ospf database
show ip ospf border-routers

now we do core router router1


en
conf t
int gig 0/0
ip add 192.168.1.1 255.255.255.252
no shutdown
ex
int gig 0/2
ip add 192.168.2.1 255.255.255.252
no shutdown
ex
router ospf 1
network 192.168.1.0 0.0.0.3 area 0
network 192.168.2.0 0.0.0.3 area 0
end

no the comfigure for router0

en
conf t
int gig 0/2
ip add 192.168.2.2 255.255.255.252
no shutdown
ex
int gig 0/1
ip add 172.16.2.2 255.255.255.252
no shutdown
router ospf 1
network 192.168.2.0 0.0.0.3 area 0
network 172.16.2.0 0.0.0.3 area 2
end

in multy-layerswitch1 there is a vlan but there is not layer 3 vlan


interface vlan
multy-layerswitch1

en
conf t
int gig 0/1
no switchport
ip add 172.16.2.1 255.255.255.252
ex

the switch need routing OSPF


ip routing
router ospf 1
network 172.16.2.0 0.0.0.3 area 2
end

in multy-layerswitch1 there is a vlan but there is not layer 3 vlan


interface vlan
multy-layerswitch0

en
conf t
int vlan 21
description GW-VL-21
ip address 10.10.21.1 255.255.255.224
exit
int vlan 22
description GW-VL-22
ip address 10.10.22.1 255.255.255.240
exit
int vlan 23
description GW-VL-23
ip address 10.10.23.1 255.255.255.248
end
show ip int brief

conf t
hostname MLS-Ring2

exit

the port with end user most be access

en
conf t
int r f0/5-6
switchport mode access
switchport access vlan
end

and the port between switch most be trunk to data translite

en
conf t
int r f0/1-2
switchport mode trunk
ex

no do no shutdown int vlan

int vlan 21
no shutdown
exit
int vlan 22
nos shutdown
exit
int vlan 23
no shutdown
ex

router ospf 1
network 10.10.21.0 0.0.0.31 area 2
network 10.10.22.0 0.0.0.15 area 2
network 10.10.21.0 0.0.0.7 area 2
show ip ospf neighbor
in multylayer0 creat dhcp for ring2

en
conf t
ip dhcp pool Ring2-VL21
network 10.10.21.0 255.255.255.224
default-router 10.10.21.1
dns-server 1.1.1.1
exit
ip dhcp pool Ring2-VL22
network 10.10.22.0 255.255.255.240
default-router 10.10.22.1
dns-server 1.1.1.1
exit
ip dhcp pool Ring2-VL23
network 10.10.23.0 255.255.255.248
default-router 10.10.23.1
dns-server 1.1.1.1
exit
ip dhcp excluded-address 10.10.21.1
ip dhcp excluded-address 10.10.22.1
ip dhcp excluded-address 10.10.23.1

in multylayer switch 1 create ip helper in all vlan


en
conf t
int vlan 21
ip helper-address 172.16.1.1
ex
int vlan 22
ip helper-address 172.16.1.1
ex
int vlan 23
ip helper-address 172.16.1.1
end

*
show ip dhcp pool

en
copy running-config startup-config

You might also like