You are on page 1of 2

RSVP-TE CLI configurations:

=========================
1. Enable MPLS on L2 port
-------------------------
tejas# conf t
tejas(config)# interface gig 1/12/5
tejas(config-if)# set mpls enable
tejas(config-if)#

2. L3 interface
---------------
tejas(config)# interface gig 1/12/5
tejas(config-if)# no switchport
tejas(config-if)# ip address 99.0.0.1 255.255.255.0
tejas(config-if)# no shut
tejas(config-if)# set mpls enable
% could not find mib object to edit

NOTE: Currently , command to enable MPLS on L3 interface is not working

3. Configure loopback interface


---------------------------------
tejas(config)# interface loopback 1
tejas(config-if)# ip address 1.1.1.1 255.255.255.255

4.Enable TE in OSPF global configuration


----------------------------------------
tejas(config)# router ospf
tejas(config-router)# mpls traffic-eng
tejas(config-router)# router-id 1.1.1.1
tejas(config-router)# network 99.0.0.1 area 0.0.0.0
tejas(config-router)# network 1.1.1.1 area 0.0.0.0

5. OSPF network type as P2P:


-------------------------
tejas(config)# int gig 1/12/5
tejas(config-if)# ip ospf network point-to-point
tejas(config-if)#

6. MPLS TE-link and component links:


-------------------------------
tejas(config)# mpls traffic-eng
tejas(config-mpls-te)# te-link link_204_219
tejas(config-mpls-te)# address-type ipv4
tejas(config-mpls-te)# remote router-id 5.5.5.5
tejas(config-mpls-te)# local te-link ipv4 99.0.0.1 remote te-link ipv4 99.0.0.2

tejas(config-mpls-te)# int gig 1/12/5


tejas(config-mpls-comp-link)# max reservable bandwidth 100000
tejas(config-mpls-comp-link)# min lsp bandwidth 1000
tejas(config-mpls-comp-link)# no shut
tejas(config-mpls-comp-link)# exit
tejas(config-mpls-te)# no shut

7. RSVP global configurations and interface level configurations:


-----------------------------------------------------------
tejas# conf t
tejas(config)# rsvp
tejas(config-rsvp)# router-id 1.1.1.1
tejas(config-rsvp)# signalling hello supported
tejas(config-rsvp)# set rsvp enable
tejas(config-rsvp)# interface gigabitethernet 1/12/5
tejas(config-rsvp-if)# signalling hello supported
tejas(config-rsvp-if)#
tejas(config-rsvp-if)# no shut
tejas(config-rsvp-if)# exit

9. Tunnel path configs:


----------------------
tejas(config)# ip explicit-path identifier link_ERO
tejas(cfg-ip-expl-path)# index 1 next-address strict 10.1.1.2
tejas(cfg-ip-expl-path)# index 2 next-address strict 11.1.1.2
tejas(cfg-ip-expl-path)# index 2 next-address loose 12.1.1.3
tejas(cfg-ip-expl-path)#

10. MPLS Tunnel configurations:


-----------------------------
interface mplstunnel 1
tunnel mpls destination 102.102.102.102 source 103.103.103.103
tunnel mpls traffic-eng tunnelname tn100-219
tunnel signalling protocol rsvp
tunnel mpls traffic-eng path-option number 1 dynamic
no shutdown

You might also like