You are on page 1of 11

Task: Implementing OSPFv3 on IOS-XE and IOS-XR

All routers have been pre-configured with IPv6 addressing. As a network engineer for INE, you have been
assigned the following tasks to complete:

1. Configure OSPFv3 adjacency between R1 and R5 and between R2 and R5. All interfaces on R5 must be
in Area 1. R1 must only have G1 interface in Area 1. R2 must only have G1 interface in Area 1. Configure
OSPFv3 Area 0 adjacency between R1 and R2. Configure OSPFv3 Area 0 adjacency between R1 and R3.
Configure OSPFv3 Area 0 adjacency between R2 and R4. Configure OSPFv3 Area 0 adjacency between
R3 and R4. Configure OSPFv3 Area 0 adjacency between R3 and XR11. Configure OSPFv3 Area 0
adjacency between R4 and XR12. Configure OSPFv3 Area 0 adjacency between XR11 and XR12. All
Loopbacks must be a part of Area 0 on R1, R2, R3, R4, XR11, and XR12. Configure OSPFv3 Area 2
adjacency between R6 and XR11. Configure OSPFv3 Area 2 adjacency between R6 and XR12. All
interfaces on R6 must be in Area 2 except Loopback0. R6 must advertise interface Loopback0 as a type
5 LSA which accounts for OSPF cost plus redistribution cost. All routers must be configured with the
router-id set as X.X.X.X, where X is the router number.

2. Configure Point-to-Multipoint OSPF network type on the link between R1 and R5 and the link between
R2 and R5. All links (including loopbacks) within Area 0 must be configured with the OSPF network
type as point-to-point. R6 must be configured as the DR and XR11 must be the DROTHER and use the
default network type for the LAN segment. R6 must be configured as the DR and XR12 must not
participate in DR election and use the NBMA network type for the LAN segment.

3. Ensure Traffic from R5 to 2001:150:6:6::6/128 and reverse traffic from R6 to 2001:150:5:5::5/128


takes the path as per the diagram below:
4. OSPFv3 neighbor-ship needs to be authenticated using IPSEC. Configure IPSEC authentication between
R1 and R5 using SPI ID 256 and use MD5 for encryption. Configure IPSEC authentication between R2
and R5 using SPI ID 257 and use SHA1 for encryption.

5. Configure BFD for OSPFv3 between R1 and R5 so that if there is a failure of the link between them, they
begin reconvergence in less than one second.

1.
Solutions:

To allow IPv6 routing protocol to run, we must enable IPv6 Unicast-Routing.

o R1:
2.
3. ipv6 unicast-routing

4. interface Loopback0

5. ipv6 ospf 1 area 0

6. interface GigabitEthernet0/0

7. ipv6 ospf 1 area 0

8. interface GigabitEthernet0/1

9. ipv6 ospf 1 area 1

10. interface GigabitEthernet0/3

11. ipv6 ospf 1 area 0

12. ipv6 router ospf 1

router-id 1.1.1.1
o R2:

ipv6 unicast-routing

interface Loopback0

ipv6 ospf 1 area 0

interface GigabitEthernet0/0

ipv6 ospf 1 area 0

interface GigabitEthernet0/2

ipv6 ospf 1 area 1

interface GigabitEthernet0/3

ipv6 ospf 1 area 0

ipv6 router ospf 1

router-id 2.2.2.2

o R3:

ipv6 unicast-routing

interface Loopback0

ipv6 ospf 1 area 0

interface GigabitEthernet0/0

ipv6 ospf 1 area 0

interface GigabitEthernet0/1

ipv6 ospf 1 area 0

interface GigabitEthernet0/2

ipv6 ospf 1 area 0

ipv6 router ospf 1

router-id 3.3.3.3
o R4:

ipv6 unicast-routing

interface Loopback0

ipv6 ospf 1 area 0

interface GigabitEthernet0/0

ipv6 ospf 1 area 0

interface GigabitEthernet0/1

ipv6 ospf 1 area 0

interface GigabitEthernet0/2

ipv6 ospf 1 area 0

ipv6 router ospf 1

router-id 4.4.4.4

o R5:

ipv6 unicast-routing

interface Loopback0

ipv6 ospf 1 area 1

interface GigabitEthernet0/1

ipv6 ospf 1 area 1

interface GigabitEthernet0/2

ipv6 ospf 1 area 1

ipv6 router ospf 1

router-id 5.5.5.5

o R6:

ipv6 unicast-routing

interface GigabitEthernet0/2
ipv6 ospf 1 area 2

interface GigabitEthernet0/3

ipv6 ospf 1 area 2

ipv6 router ospf 1

router-id 6.6.6.6

redistribute connected route-map LO0->OSPF

route-map LO0->OSPF permit 10

match interface Loopback0

set metric-type type-1

o XR11:

router ospfv3 1

router-id 11.11.11.11

area 0

interface Loopback0

interface GigabitEthernet0/0/0/0

interface GigabitEthernet0/0/0/1

area 2

interface GigabitEthernet0/0/0/2

commit

o XR12:

router ospfv3 1

router-id 12.12.12.12

area 0

interface Loopback0

interface GigabitEthernet0/0/0/0
interface GigabitEthernet0/0/0/1

area 2

interface GigabitEthernet0/0/0/3

commit

13. Key point to remember here is that the R6 must configure neighbor statement towards XR12 as the
network type is NBMA and the neighbor address must be the link local address of XR12.

o R1:
14.
15. interface GigabitEthernet0/1

16. ipv6 ospf network point-to-multipoint

17. interface GigabitEthernet0/0

18. ipv6 ospf network point-to-point

19. interface GigabitEthernet0/3

20. ipv6 ospf network point-to-point

21. interface Loopback0

ipv6 ospf network point-to-point

o R2:

interface GigabitEthernet0/2

ipv6 ospf network point-to-multipoint

interface GigabitEthernet0/0

ipv6 ospf network point-to-point

interface GigabitEthernet0/3

ipv6 ospf network point-to-point

interface Loopback0

ipv6 ospf network point-to-point

o R3:
interface GigabitEthernet0/0

ipv6 ospf network point-to-point

interface GigabitEthernet0/1

ipv6 ospf network point-to-point

interface GigabitEthernet0/2

ipv6 ospf network point-to-point

interface Loopback0

ipv6 ospf network point-to-point

o R4:

interface GigabitEthernet0/0

ipv6 ospf network point-to-point

interface GigabitEthernet0/1

ipv6 ospf network point-to-point

interface GigabitEthernet0/2

ipv6 ospf network point-to-point

interface Loopback0

ipv6 ospf network point-to-point

o R5:

interface GigabitEthernet0/1

ipv6 ospf network point-to-multipoint

interface GigabitEthernet0/2

ipv6 ospf network point-to-multipoint

o XR11:

router ospfv3 1
area 0

interface Loopback0

network point-to-point

interface GigabitEthernet0/0/0/0

network point-to-point

interface GigabitEthernet0/0/0/1

network point-to-point

area 2

interface GigabitEthernet0/0/0/2

priority 0

commit

o XR12:

router ospfv3 1

area 0

interface Loopback0

network point-to-point

interface GigabitEthernet0/0/0/0

network point-to-point

interface GigabitEthernet0/0/0/1

network point-to-point

area 2

interface GigabitEthernet0/0/0/3

priority 0

network non-broadcast

commit

o R6:
interface GigabitEthernet0/3

ipv6 ospf network non-broadcast

ipv6 ospf neighbor FE80::12

22. Traffic Path manipulation in OSPF can be done by changing the interface OSPF cost.

o R1:
23.
24. interface GigabitEthernet0/0

ipv6 ospf cost 1000

o R3:

interface GigabitEthernet0/0

ipv6 ospf cost 1000

o R4:

interface GigabitEthernet0/1

ipv6 ospf cost 1000

o R5:

interface GigabitEthernet0/2

ipv6 ospf cost 1000

o R6:

interface GigabitEthernet0/2

ipv6 ospf cost 1000

o XR12:
router ospfv3 1

area 0

interface GigabitEthernet0/0/0/1

cost 1000

25. OSPFv3 uses IPSEC for authentication and encryption.

o R1:
26.
27. interface GigabitEthernet0/1

ipv6 ospf authentication ipsec spi 256 md5 ABCDEF1234567890ABCDEF1234567890

o R2:

interface GigabitEthernet0/2

ipv6 ospf authentication ipsec spi 257 sha1


ABCDEF1234567890ABCDEF1234567890ABCDEF12

o R5:

interface GigabitEthernet0/1

ipv6 ospf authentication ipsec spi 256 md5 ABCDEF1234567890ABCDEF1234567890

interface GigabitEthernet0/2

ipv6 ospf authentication ipsec spi 257 sha1


ABCDEF1234567890ABCDEF1234567890ABCDEF12

28. When R1 and R5 are configured as BFD adjacent neighbors, any link failure between them would be
detected in less than 1 second and OSPFv3 adjacency would be torn down so that they can re-converge
using an alternate path.

o R1:
29.
30. interface GigabitEthernet0/1

31. ipv6 ospf bfd

bfd interval 250 min_rx 250 multiplier 3


o R5:

interface GigabitEthernet0/1

ipv6 ospf bfd

bfd interval 250 min_rx 250 multiplier 3

You might also like