A Tutorial of Pro/MECHANICA Motion

Pro/MECHANICA MOTION is a motion analysis package that provides mechanism modeling and mechanism design optimization capabilities. This product enables you to analyze your mechanism’s motion and forces. Objectives

• Enhancing the Lecture on An Introduction to Pro/MECHANICA Motion • Familiarizing Pro/MECHANICA Motion Menus • Learning the Process of Motion Analysis Using Pro/MECHANICA
This tutorial, prepared by Dr. D Xue, is used to show how to use Pro/MECHANICA MOTION. The mechanism to be designed and analyzed is shown in Figure 1. This mechanism is an assembly composed of four components: LINK1, LINK2, SLIDER, and SLOT. The SLOT is fixed with the ground. The LINK1 is in motion with a constant rotational speed. When LINK1 is at a certain position, the positions of the LINK2 and SLIDER can be calculated automatically.

Fig. 1 The Mechanism with Four Components I. Starting Pro/ENGINEER In MS Windows, execute Start->Programs->pore II. Modeling the Four Components The four components, LINK1.PRT, LINK2.PRT, SLIDER.PRT, and SLOT.PRT, are created as four parts in Pro/ENGINEER. The dimensions of the four parts are shown in Figure 2. This is the mechanism that we have used in Laboratory 2b.

select name LINK1. select the front surface of SLOT and back surface of LINK1. Modeling the Assembly 1. uncheck Datum Planes and Coordinate Systems. Click Add button of the Component Placement dialog box. 2. Click Add button of the Component Placement ... click Ok button.Fig. Choose COMPONENT->Assemble. Creating the assembly LINKAGE Choose File->New. click OK button. click Open button.PRT. Assembling the components SLOT and LINK1 Choose ASSEMBLY->Component. COMPONENT->Assemble... Components of the Four-bar Linkage Mechanism III.. select the cylindrical surface of SLOT and lower cylindrical surface of LINK1. select name SLOT. select Constraint Type=Mate. Choose View->Model Tree to turn it off. select Assembly button for Type. click OK button. click Open button.PRT..2 Four Pro/ENGINEER Parts Figure 2.ASM. enter assembly name LINKAGE to create an assembly called LINKAGE. select Constraint Type=Mate. 8. set Display Style=Hidden Line. Choose Utilities->Environment. Click Add button of the Component Placement dialog box.

PRT. click Open button. select Constraint Type=Mate. The created assembly is shown in Figure 8. Assembling the component LINK2 Choose COMPONENT->Assemble. select the working directory (such as H:\PC\Motion).3 (a). Click Add button of the Component Placement dialog box.. select the right cylindrical surface of LINK2 and cylindrical surface of SLIDER. select Constraint Type=Mate. 4. select the right cylindrical surface of LINK1 and left cylindrical surface of LINK2. . enter a name LINKAGE. Click Add button of the Component Placement dialog box. Assembling the component SLIDER Choose COMPONENT->Assemble. select the lower internal surface of SLOT and bottom surface of LINK2. select Constraint Type=Mate. Click Add button of the Component Placement dialog box. Fig. select the lower internal surface of SLOT and bottom surface of SLIDER. click Open button.3 (c). The created assembly is shown in Figure 8. Click OK button. select Constraint Type=Mate.PRT.3 (b). Click OK button. select the front surface of LINK1 and back surface of LINK2. click OK button. Click Add button of the Component Placement dialog box. The created assembly is shown in Figure 8.ASM to create a file LINKAGE. select name LINK2. Click Add button of the Component Placement dialog box.dialog box.. select the back surface of LINK2 and front surface of SLIDER.ASM to preserve the created data. 8. 5. select Constraint Type=Mate. Click OK button.3 The Steps to Create the Assembly 3.. Saving the created assembly Choose File->Working Directory. select Constraint Type=Mate. select the lower internal surface of SLOT and right surface of LINK1. select name SLIDER. select Constraint Type=Mate. Choose File->Save. Click Add button of the Component Placement dialog box.

Select Ground. define the Name as joint_2. select PNT1 of SLOT and PNT1 of LINK1. Click Yes button of the copy confirmation dialog box. click OK button.. V. PROPERTY->Material. click Accept button. Four bodies are created at this stage. Choose Assign->Part. select the SLOT part.ASM for motion analysis Choose File->Save As. to clear the window. select Type=Pin. Choose PROPERTY->Done/Return. Analyzing the Mechanism Using Pro/MECHANICA MOTION 1. select LINKAGE2.. set Constant=0. Building the motion model The materials. GET SELECT->Query Sel. click OK button. In the Create Joint Driver window. Select PNT0 of LINK1 and PNT0 of LINK2. select SLOT_. GET SELECT->Query Sel. (4) Defining a driver Choose MOTN MODEL->Drivers. select the joint_1. select Type=Pin. LINK2. In the Joint Create window. Click Delete button.ASM. Current. click Open button. In the Joint Create window. close the Pro/TABLE window by selecting File->Exit. MOT CONNEC->Joints. select Position radio button. choose MECHANICA->Motion. 2. button.. click Done button. select Type=slider. Slope=0. click Accept button. The LINK1 rotates 360o (2π) every 10 seconds. select Assembly.. choose File->Open. Select STEEL and click Add button (the one with 3 right-direction arrows). Click Accept button. click Part. Copying the LINKAGE. click Accept button.. select Ramp check-box. connections.IV. Starting Pro/MECHANICA 1. and driver are defined at this stage. (2) Defining bodies Choose MOTN MODEL->Bodies. POINTS->Select. enter the new name as LINKAGE2. MEC ACTION->Create. The SLOT is associated with Ground body. Click OK button of this window. (3) Creating connections Choose MOTN MODEL->Connections. define the Driver Name as driver_1.ASM to a new file called LINKAGE2. click Accept button. Select PNT1 of LINK2 and PNT0 of SLIDER. 2. Running the assembly analysis Choose MEC MOTION->Analyses. Changing to Pro/MECHANICA environment Choose Applications->Mechanica. Click OK button. bodies. Choose MEC MOTION- . Click Close button.. GET SELECT->Query Sel. In the Joint Create window.6283 to define the angle function θ = 2π/10. define the Name as joint_3. select Type=Pin.. assign STEEL material to LINK1. Choose File->Erase. click Continue button of the unit confirmation window. The assembly tolerance value is displayed. and SLIDER. In the same way. In the Joint Create window. select the SLOT.. MEC ACTION->Create.ASM.. click Edit button. Select include all sub-components check-box. define the Name as joint_1. define the Name as joint_4. click Accept button. Select PNT0 of SLOT and PNT1 of SLIDER. MOTN MODEL->Property.. (1) Specifying the materials Choose MEC MOTION->Model.

click OK button. Output Format=Microsoft Print Manager (Vector). Evaluation Method=Each Time Step.4 shows the analysis result. uncheck To File check-box. click OK button.>Run. The mechanism analysis solver will generate 100 frames of the different mechanism configurations. Offset X=−2. click Graph button. Components=X.. click Accept button. click Close button. (4) Plotting the graphs of the measures Choose MEC MOTION->Results.6 shows the analysis result. MEASURES->Point. button. Evaluation Method=Each Time Step. Output Format=Microsoft Print Manager (Vector). set Start Time=0. select Assembly (Standard/Assembly). Offset X=−2. Point Measure Types=Point Position.ASM to create a file LINKAGE2. (3) Animating the mechanism motion Choose MEC MOTION->Results. A total of 100 frames will be created within 10 seconds. In the Motion Analysis Definition window. Components=X. MOT RESULTS->Graph. click OK button. select Motion (Standard/Motion).75.ASM to preserve the created data. select Motion. Click Yes button of this window. 3. Figure 8. Output Format=Microsoft Print Manager (Vector). Offset X=−2. uncheck To File check-box. Point Measure Types=Point Velocity. select acc_x (Point Acceleration X Each Time Step). Click OK button. (2) Defining motion analysis Choose MEC MOTION->Analyses. In the window. Printer=\\SAMBA\325. set MEASURE NAME=acc_x. Zoom factor=0. click Graph button. Point Measure Types=Point Acceleration. Evaluation Method=Each Time Step.75. click OK button.. set MEASURE NAME=vel_x. Running the motion analysis (1) Creating measures Choose MEC MOTION->Model. a message window will be displayed. Choose File->Close Window. click OK button. Printer=\\SAMBA\325. Duration=10 (seconds). select PNT1 of SLIDER. MOTION GRAPH->Measure. Figure 8. click Start. Figure 8. Components=X. Choose File->Print. In the Create Point Measure window. Choose MEC MOTION->Run. Choose File->Close Window. Printer=\\SAMBA\325. Saving the Motion Model and Quitting Pro/MECHANICA 1. In the Create Point Measure window. MOT RESULTS->Animate. Saving the created assembly Choose File->Save. choose Window->Close Window. click Graph button. In the window.. click Accept button.. click Edit.75.1... VI. If the analysis is a success. Select PNT1 of SLIDER. enter a name LINKAGE2. select pos_x (Point Position X Each Time Step). Click Close button of the Animate window. Use the video control buttons to see the different frames of the mechanism configurations. button. select vel_x (Point Velocity X Each Time Step). In the Create Point Measure window. Click Done button. . ANIMATE->Start.5 shows the analysis result. Zoom factor=0. Choose File->Close Window. Choose File->Print. set MEASURE NAME=pos_x. In the Run window. button. uncheck To File check-box. MEC ACTION->Create. Select PNT1 of SLIDER. Choose File>Print. click OK button. In the window. Zoom factor=0. click Start. MOTN MODEL->Measures. click Accept button. Increment=0.

4 Position Graph Fig. Fig. click Yes button. 8. Quitting Pro/MECHANICA Choose File->Exit.5 Velocity Graph .2. 8.

3. and driver. Following the instructions provided in this tutorial. An Example Four Bar a Linkage .6 Acceleration Graph Optional Laboratory: Building Motion Model & Performing Motion Analysis Instructions: 1. Use LINK1 as the driving component and define the motion function of θ. • Animation to simulate mechanism motion. Review of the introduced Pro/MECHANICA MOTION commands. 4. Build a motion model with 4 components as shown in Fig. bodies. • Analysis modeling to create measures. Use different output measures and observe the analysis results. Define other measures and obtain the values of these measures for different angle θ. define motion analysis model. 8. Test different driver’s motion functions and observe the analysis results. 8.7 Motion Analysis to Linkage Fig. connections. 7. and create frames of mechanism motion simulation.Fig. 5. 2. carry out • Motion modeling to define materials. LINK2 LINK1 θ LINK3 Fig 7.

. • Five parts of the tutorial is located in \\designsv1\courses\mech410\demo folder.Mechanism Design Tutorials How to get this page: • Pro/Help -> Contents -> Using Additional Modules -> Mechanism Design Extension >Mechanism Design Tutorials.

Sign up to vote on this title
UsefulNot useful