You are on page 1of 4

hostname R1

interface Loopback1
ip address 10.1.1.1 255.255.255.0
interface FastEthernet0/0
ip address 192.168.14.1 255.255.255.252
no shutdown
interface Serial0/0
ip address 10.1.102.1 255.255.255.248
clock rate 64000
bandwidth 64
no shutdown
interface Serial0/1
ip address 10.1.103.1 255.255.255.248
bandwidth 64
no shutdown
router eigrp 65001
network 10.0.0.0
network 192.168.14.0
no auto-summary
router bgp 65001
no synchronization
network 10.1.1.0 mask 255.255.255.0
neighbor 10.1.103.3 remote-as 65001
neighbor 10.2.2.2 remote-as 65001
neighbor 10.2.2.2 update-source Loopback1
neighbor 192.168.14.2 remote-as 65002
neighbor 192.168.14.2 route-map IN-FROM-TDP in
neighbor 192.168.14.2 route-map OUT-TO-TDP out
no auto-summary
route-map OUT-TO-TDP permit 10
set metric 10
route-map IN-FROM-TDP permit 10
set local-preference 200
end

hostname R2
interface Loopback2
ip address 10.2.2.2 255.255.255.0
interface Loopback200
ip address 10.20.0.1 255.255.255.0
interface Loopback201
ip address 10.20.1.1 255.255.255.0
interface Loopback202
ip address 10.20.2.1 255.255.255.0
interface Loopback203
ip address 10.20.3.1 255.255.255.0

interface Serial0/0
ip address 10.1.102.2 255.255.255.248
bandwidth 64
no shutdown
interface Serial0/1
ip address 10.1.203.2 255.255.255.248
clock rate 64000
bandwidth 64
no shutdown
router eigrp 65001
network 10.0.0.0
no auto-summary
router bgp 65001
no synchronization
network 10.2.2.0 mask 255.255.255.0
network 10.20.0.0 mask 255.255.252.0
neighbor 10.1.1.1 remote-as 65001
neighbor 10.1.1.1 update-source Loopback2
neighbor 10.1.203.3 remote-as 65001
no auto-summary
ip route 10.20.0.0 255.255.252.0 Null0

hostname R3
interface Loopback3
ip address 10.3.3.3 255.255.255.0
interface Serial0/1
ip address 10.1.103.3 255.255.255.248
clock rate 64000
bandwidth 64
no shutdown
interface Serial0/0
ip address 10.1.203.3 255.255.255.248
bandwidth 64
no shutdown
interface Serial0/2
ip address 192.168.34.1 255.255.255.252
clock rate 64000
bandwidth 64
no shutdown
router eigrp 65001
network 10.0.0.0
network 192.168.34.0
no auto-summary

router bgp 65001


no synchronization
network 10.3.3.0 mask 255.255.255.0
neighbor 10.1.103.1 remote-as 65001
neighbor 10.1.203.2 remote-as 65001
neighbor 192.168.34.2 remote-as 65002
neighbor 192.168.34.2 route-map IN-FROM-TDP in
neighbor 192.168.34.2 route-map OUT-TO-TDP out
no auto-summary
route-map OUT-TO-TDP permit 10
set metric 20
route-map IN-FROM-TDP permit 10
set local-preference 100
end

hostname R4
interface Loopback0
ip address 172.16.0.1 255.255.252.0
interface Loopback4
ip address 172.16.4.1 255.255.252.0
interface Loopback8
ip address 172.16.8.1 255.255.252.0
interface Loopback12
ip address 172.16.12.1 255.255.252.0
interface FastEthernet0/0
ip address 192.168.14.2 255.255.255.252
no shutdown
interface Serial0/0
ip address 192.168.34.2 255.255.255.252
bandwidth 64
no shutdown
router eigrp 65002
network 172.16.0.0
network 192.168.14.0
network 192.168.34.0
passive-interface FastEthernet0/0
passive-interface Serial0/0/0
no auto-summary
router bgp 65002
no synchronization
network 172.16.0.0 mask 255.255.252.0
network 172.16.4.0 mask 255.255.252.0
network 172.16.8.0 mask 255.255.252.0
network 172.16.12.0 mask 255.255.252.0
aggregate-address 172.16.0.0 255.255.240.0 summary-only

neighbor 192.168.14.1 remote-as 65001


neighbor 192.168.34.1 remote-as 65001
no auto-summary
end

ROUTER 1
foreach address {
10.1.1.1
10.2.2.2
10.20.0.1
10.20.1.1
10.20.2.1
10.20.3.1
10.3.3.3
172.16.0.1
172.16.4.1
172.16.8.1
172.16.12.1
10.1.102.1
10.1.102.2
10.1.103.1
10.1.103.3
10.1.203.2
10.1.203.3
192.168.14.1
192.168.14.2
192.168.34.1
192.168.34.2
} {
ping $address source Loopback1}

You might also like