You are on page 1of 18

IPv6 Lab

Therdtoon Theerasasana - ttheera@cisco.com


Udom Limmeechokchai – ulimmeec@cisco.com
Cisco Systems (Thailand) Ltd.

Version 2
Last Update : 19-May-2005

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 1

Agenda

• Lab1 : IPv6 Addressing


• Lab2 : IPv6 Neighbor Discovery
• Lab3 : IPv6 Static Routing
• Lab5 : IPv6 RIPng
• Lab4 : IPv6 Traffic Filter
• Lab6 : IPv6 OSPFv3
• Lab7 : IPv6 BGP
• Lab8 : IPv6 Tunneling

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 2


Network Diagram – IPv6 Lab

PC1 PC2 PC3 PC4 PC5

Ethernet0/0 Ethernet0/0 Ethernet0/0 Ethernet0/0 Ethernet0/0

R1 R2 R3 R4 R5
Ethernet1/0 Ethernet1/0 Ethernet1/0 Ethernet1/0 Ethernet1/0

Ethernet1/0 Ethernet1/0 Ethernet1/0 Ethernet1/0 Ethernet1/0

R6 R7 R8 R9 R10
Ethernet0/0 Ethernet0/0 Ethernet0/0 Ethernet0/0 Ethernet0/0

PC6 PC7 PC8 PC9 PC10

Admin

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 3

How to access to ALL routers and PCs

• Telnet to a host 64.104.66.147 with TCP port number 100xx,


where xx is a router No.
• For example, to access router R5
Telnet 64.104.66.147 10015
• Telnet to a host 64.104.66.147 with TCP port number 1000x,
where x is a PC No.
• For example, to access PC PC3
Telnet 64.104.66.147 10003
• Note : If there are more then one group, TCP port will be
<group>001x

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 4


ALL routers’ and PCs’ BASIC configuration

hostname Rx (or PCx)


!
no ip domain-lookup
!
line con 0
no login
exec-timeout 0 0
privilege level 15

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 5

Lab 1 : Configuring IPv6 Interfaces (1)


Task : Configuring the IPv6 Ethernet Interface
• On Router, go to configure mode
#configure terminal
• Enable IPv6 Unicast Routing on the router
(config)#ipv6 unicast-routing
• Go to configure the workgroup Ethernet0/0 interface
(config)#interface ethernet0/0
• Enable IPv6 on the interface
(config-if)#ipv6 enable
(config-if)#no shutdown
• Quit the configure mode
(config-if)#end
• Verify that the Ethernet interface is configured
#show ipv6 interface ethernet0/0
• Identify the type of addresses that are configured
IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 6
Lab 1 : Configuring IPv6 Interfaces (2)
Task : Finding the Link-Local Address of a PC
• On PC, go to configure mode
#configure terminal
• Go to configure the PC Ethernet0/0 interface
(config)#interface ethernet0/0
• Enable IPv6 on the interface
(config-if)#ipv6 enable
(config-if)#ipv6 address autoconfig
(config-if)#no shutdown
• Quit the configure mode
(config-if)#end
• Verify that the Ethernet interface is configured
#show ipv6 interface ethernet0/0
IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 7

Lab 1 : Configuring IPv6 Interfaces (3)


Task : Verifying IPv6 Link-Local Connectivity
• On the Router, enable console debugging of ICMP
and Neighbor Discovery (ND) IPv6 packets
#debug ipv6 icmp
#debug ipv6 nd
• On the Router, ping the local Ethernet interface of
PC specifying the link local address in the ping
command destination address
#ping fe80::<link local address of PC>
#ping ipv6 fe80::<link local address of PC>
• On the Router, verify the list of IPv6 neighbors
#show ipv6 neighbors

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 8


Lab 1 : Configuring IPv6 Interfaces (4)
Task : Configuring a Static IPv6 Address with EUI-64
• On the Router, configure a global IPv6 address on
this interface using the /64 prefix of your subnet
and the EUI-64 format (see Table1 for your prefix)
#configure terminal
(config)#interface ethernet0/0
(config-if)#ipv6 address 3ffe:b00:ffff:<group>::/64 eui-64
(config)#end
• Verify the configuration
• On the Router, disable all console debugging
#undebug all

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 9

Lab 1 : Configuring IPv6 Interfaces (5)

Table 1 : Assigned Subnet Prefixes for Global Addresses


Workgroup Setup Number Subnet Prefix
Backbone (0) 3ffe:b00:ffff:0::/64
Workgroup Setup #1 3ffe:b00:ffff:1::/64
Workgroup Setup #2 3ffe:b00:ffff:2::/64
Workgroup Setup #3 3ffe:b00:ffff:3::/64
Workgroup Setup #4 3ffe:b00:ffff:4::/64
Workgroup Setup #5 3ffe:b00:ffff:5::/64
Workgroup Setup #6 3ffe:b00:ffff:6::/64
Workgroup Setup #7 3ffe:b00:ffff:7::/64
Workgroup Setup #8 3ffe:b00:ffff:8::/64
Workgroup Setup #9 3ffe:b00:ffff:9::/64
Workgroup Setup #10 3ffe:b00:ffff:A::/64
IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 10
Lab 2 : Using Neighbor Discovery (1)
Task: Configuring Router Advertisements for Global Addresses
• Look at the configuration of PC and determine if it has received a global address
already ?
#show ipv6 interface ethernet0/0
• Enable the debugging mode for IPv6 Neighbor Discovery (ND)
#debug ipv6 nd
• Go to configuration mode and then to the Ethernet0/0 interface submode
#configure terminal
(config)#interface ethernet0/0
• Enable RAs by using the ND command with the subnet prefix assigned to your LAN
(see Table2). Because infinite lifetime is not desired, use 5 minutes (300 seconds)
for lifetime (both preferred and valid)
(config-if)#ipv6 nd prefix 3ffe:b00:ffff:<group>::/64 300 300
• Verify that your PC now has an IPv6 address that was automatically configured with
this subnet prefix. Note that the previously configured link-local address is still
present and valid.
#show ipv6 interface ethernet0/0
• Verify connectivity using the ping command on the Router to the PC using the new
assigned address of the PC as the ping destination
#ping <global address of PC>

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 11

Lab 2 : Using Neighbor Discovery (2)

Table 2 : Assigned Subnet Prefixes for Global Addresses


Workgroup Setup Number Subnet Prefix
Backbone (0) 3ffe:b00:ffff:0::/64
Workgroup Setup #1 3ffe:b00:ffff:1::/64
Workgroup Setup #2 3ffe:b00:ffff:2::/64
Workgroup Setup #3 3ffe:b00:ffff:3::/64
Workgroup Setup #4 3ffe:b00:ffff:4::/64
Workgroup Setup #5 3ffe:b00:ffff:5::/64
Workgroup Setup #6 3ffe:b00:ffff:6::/64
Workgroup Setup #7 3ffe:b00:ffff:7::/64
Workgroup Setup #8 3ffe:b00:ffff:8::/64
Workgroup Setup #9 3ffe:b00:ffff:9::/64
Workgroup Setup #10 3ffe:b00:ffff:A::/64
IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 12
Lab 2 : Using Neighbor Discovery (3)
Task: Configuring Router Advertisements for Site-Local Addresses
• Configure the site-local address of the workgroup Ethernet0/0
interface by using the subnet prefix assigned to your LAN for site-
local addresses (see Table 3). Use EUI-64 format.
#configure terminal
(config)#interface ethernet0/0
(config-if)#ipv6 address fec0:0:0:<group>::/64 eui-64
• Enable RAs by using the ND command with subnet prefix assigned
to your LAN for site-local addresses (see Table 3). Use 5 minutes
(300 seconds) for the lifetime.
(config-if)# ipv6 nd prefix fec0:0:0:<group>::/64 300 300
• Verify that your PC now has an IPv6 address configured with this
subnet prefix.
#show ipv6 interface ethernet0/0
• Verify connectivity to your PC using the ping command on the
Router to the PC using the new assigned address of the PC as the
ping destination address
IPv6 Lab #ping ©<site-local address of PC>
2004 Cisco Systems, Inc. All rights reserved. 13

Lab 2 : Using Neighbor Discovery (4)

Table 3 : Assigned Subnet Prefixes for Site Local Addresses


Workgroup Setup Number Subnet Prefix
Workgroup Setup #1 fec0:0:0:1::/64
Workgroup Setup #2 fec0:0:0:2::/64
Workgroup Setup #3 fec0:0:0:3::/64
Workgroup Setup #4 fec0:0:0:4::/64
Workgroup Setup #5 fec0:0:0:5::/64
Workgroup Setup #6 fec0:0:0:6::/64
Workgroup Setup #7 fec0:0:0:7::/64
Workgroup Setup #8 fec0:0:0:8::/64
Workgroup Setup #9 fec0:0:0:9::/64
Workgroup Setup #10 fec0:0:0:A::/64

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 14


Lab 2 : Using Neighbor Discovery (5)
Task: Configuring a Site-Local network
• Configure the site-local address of the backbone
Ethernet1/0 interface by using the subnet prefix
assigned to the backbone. Use your setup number
for the host part. (see Table 4 for assignment)
#configure terminal
(config)#interface ethernet1/0
(config-if)#ipv6 address fec0::<group>/64
• Verify the connectivity by a ping to one of the other
workgroup routers
#ping <site-local address of another workgroup router>

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 15

Lab 2 : Using Neighbor Discovery (6)

Table 4 : Assigned Site Local Addresses for Backbone Ethernet1/0


Workgroup Setup Number Site-Local Address for E1/0
Workgroup Setup #1 fec0::1/64
Workgroup Setup #2 fec0::2/64
Workgroup Setup #3 fec0::3/64
Workgroup Setup #4 fec0::4/64
Workgroup Setup #5 fec0::5/64
Workgroup Setup #6 fec0::6/64
Workgroup Setup #7 fec0::7/64
Workgroup Setup #8 fec0::8/64
Workgroup Setup #9 fec0::9/64
Workgroup Setup #10 fec0::A/64

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 16


Lab 2 : Using Neighbor Discovery (7)
Task: Renumbering the Local network
• Configure the new address of workgroup Ethernet0/0 interface
by using the new global subnet prefix assigned to your LAN (see
Table 5). Use EUI-64 format.
#configure terminal
(config)#interface ethernet0/0
(config-if)#ipv6 address 3ffe:b00:ffff:100<group>::/64 eui-64
• Enable RAs by using the ND command with the new subnet
prefix assigned to your LAN (see Table 5). Use 5 minutes (300
seconds) for the lifetime.
(config-if)# ipv6 nd prefix 3ffe:b00:ffff:100<group>::/64 300 300
• Verify that your PC has the new address with the new prefix
#show ipv6 interface ethernet0/0

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 17

Lab 2 : Using Neighbor Discovery (8)

Table 5 : NEW Assigned Subnet Prefixes


Workgroup Setup Number NEW Subnet Prefix
Backbone (0) 3ffe:b00:ffff:1000::/64
Workgroup Setup #1 3ffe:b00:ffff:1001::/64
Workgroup Setup #2 3ffe:b00:ffff:1002::/64
Workgroup Setup #3 3ffe:b00:ffff:1003::/64
Workgroup Setup #4 3ffe:b00:ffff:1004::/64
Workgroup Setup #5 3ffe:b00:ffff:1005::/64
Workgroup Setup #6 3ffe:b00:ffff:1006::/64
Workgroup Setup #7 3ffe:b00:ffff:1007::/64
Workgroup Setup #8 3ffe:b00:ffff:1008::/64
Workgroup Setup #9 3ffe:b00:ffff:1009::/64
Workgroup Setup #10 3ffe:b00:ffff:100A::/64
IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 18
Lab 2 : Using Neighbor Discovery (9)
• Modify the Neighbor Advertisement (NAs) for the
3ffe:b00:ffff:<subnet> (the old one) by making the preferred
lifetime equal to zero.
#configure terminal
(config)#interface ethernet0/0
(config-if)# NO ipv6 nd prefix 3ffe:b00:ffff:<group>::/64 300 300
(config-if)# ipv6 nd prefix 3ffe:b00:ffff:<group>::/64 300 0
• Verify that your PC now deprecates the use of the “old” address
prefix and prefers the “new” one.
#show ipv6 interface ethernet0/0
• Verify the connectivity to the PC by using the ping command on
the router to PC using the new assigned address of PC.
#ping <new global address of PC>

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 19

Lab 3 : Static Routing (1)


Task : Configuring IPv6 Static Routing
• Configure a static default route on the router to R10
(config)#ipv6 route ::/0 <R10 IPv6 Address>

• Configure a static route for 3ffe.c00.fff::/64 to R10


(config)#ipv6 route 3ffe:c00:ffff::/64 <R10 IPv6 Address>

• Verify the routing table


#show ipv6 route

• Verify IPv6 connectivity using the ping command on


Router, ping to R10-Loopback Address
#ping 3ffe:c00:ffff::1
#ping 3ffe:d00:ffff::1
IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 20
Lab 4 : Routing with RIP (1)
Task : Configuring RIP
• Enable the debugging mode for IPv6 Routing and IPv6 RIP
#debug ipv6 routing
#debug ipv6 rip
• Configure a RIP process on the router with table name
(config)#ipv6 router rip lab4
• Enable RIP on each Ethernet interface, using the same table name
(config)#interface ethernet0/0
(config-if)#ipv6 rip lab4 enable
(config-if)#interface ethernet1/0
(config-if)#ipv6 rip lab4 enable
• Verify that the routing table is updated by entries coming from the other
workgroup routers
#show ipv6 route
• Verify IPv6 connectivity using the ping command on PC. Use the global
IPv6 address of a PC in another workgroup as the destination address
of the ping command
IPv6 Lab
#ping ©<global address of PC on another workgroup>
2004 Cisco Systems, Inc. All rights reserved. 21

Lab 5 : IPv6 Traffic Filter


Task : Configuring IPv6 Traffic Filter
• Configure an access-list to block IPv6 Site-local source
addresses
(config)#ipv6 access-list lab5
(config-ipv6-acl)#deny ipv6 FEC0:0:0:<group>::/64 any
(config-ipv6-acl)#permit ipv6 any any
• Apply an IPv6 traffic filter to the outgoing interface Ethernet1/0
(config)#interface ethernet1/0
(config-if)#ipv6 traffic-filter lab5 out
• Verify IPv6 Access-list
#show ipv6 access-list
#show ipv6 interface ethernet1/0
• Verify IPv6 connectivity using the ping command on PC. Use the
Site-local IPv6 address of a PC in another workgroup as the
destination address of the ping command
#ping <site-local address of PC on another workgroup>
IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 22
Lab 6 : Routing with OSPFv3
Task : Configuring OSPFv3
• Enable the debugging mode for IPv6 Routing and IPv6 OSPFv3
#debug ipv6 routing
#debug ipv6 ospf event
• Configure an OSPFv3 process 1 on the router with Router-ID from Table7
(config)#ipv6 router ospf 1
(config-rtr)#router-id 192.168.30.xxx
• Enable OSPFv3 on each Ethernet1/0 - Area 0, Ethernet0/0 - Area = <Group>
(config)#interface ethernet0/0
(config-if)#ipv6 ospf 1 area <group>
(config-if)#interface ethernet1/0
(config-if)#ipv6 ospf 1 area 0
• Verify that the routing table is updated by entries coming from the other workgroup routers,
OSPFv3 Neighbor, OSPFv3 database
#show ipv6 route
#show ipv6 ospf neighbor
#show ipv6 ospf database
• Verify IPv6 connectivity using the ping command on PC. Use the global IPv6 address of a PC
in another workgroup as the destination address of the ping command
#ping <global address of PC on another workgroup>

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 23

Lab 7 : Routing with BGP (1)


Task : Configuring BGP
• Ask your peer, which is another workgroup (Workgroup 10 -
Admin), about its router address and autonomous system (AS)
number. (See Table 6 for your own AS number)
• Enable the debugging of BGP,
#debug bgp ipv6
• Define your router as a BGP router with your AS number
(config)#router bgp <your AS number>
• Because IPv4 has not been configured yet and BGP protocol
uses the IPv4 address as an identifier, a special command to
identify the router-id is needed. The router-id to use is IPv4
address of your router that will be used in the next lab. Use
Table 7 to find your router-id. Then identify router BGP router-id.
(config-router)#bgp router-id <your router-id>
• Deactivate the IPv4 default peering
(config-router)#no bgp default ipv4-unicast

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 24


Lab 7 : Routing with BGP (2)

Table 6 : Assigned AS Numbers


Workgroup Setup Number AS Number
Workgroup Setup #1 65001
Workgroup Setup #2 65002
Workgroup Setup #3 65003
Workgroup Setup #4 65004
Workgroup Setup #5 65005
Workgroup Setup #6 65006
Workgroup Setup #7 65007
Workgroup Setup #8 65008
Workgroup Setup #9 65009
Workgroup Setup #10 65010

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 25

Lab 7 : Routing with BGP (4)

Table 7 : Assigned Router-id


Workgroup Setup Number Router-id
Workgroup Setup #1 192.168.30.101
Workgroup Setup #2 192.168.30.102
Workgroup Setup #3 192.168.30.103
Workgroup Setup #4 192.168.30.104
Workgroup Setup #5 192.168.30.105
Workgroup Setup #6 192.168.30.106
Workgroup Setup #7 192.168.30.107
Workgroup Setup #8 192.168.30.108
Workgroup Setup #9 192.168.30.109
Workgroup Setup #10 192.168.30.110

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 26


Lab 7 : Routing with BGP (5)
• Activate the peering with your neighbor (Workgroup 10 –
Admin), using its IP address and AS number. Use the site-local
address of your neighbor. Announce your global prefix and your
site-local prefix of your LAN to your neighbor.
(config-router)#neighbor <peer site-local> remote-as <AS number>
(config-router)#address-family ipv6
(config-router-af)#neighbor <peer site-local> activate
(config-router-af)#network <your global network prefix>/64
(config-router-af)#network <your site local prefix>/64
(config-router-af)#exit
• Look at the BGP routing table to determine if you received BGP
routes from your neighbor
#show ip bgp ipv6 unicast summary
#show ip bgp ipv6 unicast
#show ipv6 route bgp

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 27

Lab 7 : Routing with BGP (6)


Task : Filtering BGP Routes
• Filter the site-local prefix (fec0::/10) so that you do not receive
them
(config)#ipv6 prefix-list lab7 deny fec0::/10 le 128
(config)#ipv6 prefix-list lab7 permit ::/0 le 64
(config)#router bgp <your AS number>
(config-router)#>address-family ipv6
(config-router-af)#neighbor <peer site-local> prefix-list lab7 in
(config-router-af)#exit
• Verify that you do not receive any site-local routes in BGP. Only
the workgroup IPv6 prefix should be received.
#clear ip bgp ipv6 unicast <AS> in
#show ip bgp ipv6 unicast summary
#show ip bgp ipv6 unicast
IPv6 Lab
#show ipv6 route bgp
© 2004 Cisco Systems, Inc. All rights reserved. 28
Lab 8 : Using Tunnels (1)
Task : Configuring the Tunnel
• First disable both RIPng, OSPFv3, BGP. And remove the site-
local address on your Ethernet1/0 interface
(config)#NO ipv6 router rip lab4
(config)#NO ipv6 router ospf 1
(config)#NO router bgp <your AS>
(config)#interface ethernet1/0
(config-if)#NO ipv6 address fec0::/64
(config-if)#NO ipv6 address 3FFE:B00:FFFF:1000::/64 eui-64
• Using Table 8, configure the IPv4 address of the backbone
Ethernet1/0 interface
(config)#interface ethernet1/0
(config-if)#ip address 192.168.30.<group> 255.255.255.0
• Request the IPv4 address of the tunnel endpoint of your neighbor
(Workgroup 10 – Admin)
IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 29

Lab 8 : Using Tunnels (2)

Table 8 : Assigned IPv4 Addresses


Workgroup Setup Number IPv4 Address IPv4 in Hex
Backbone (0) 192.168.30.100 C0A8:1E64
Workgroup Setup #1 192.168.30.101 C0A8:1E65
Workgroup Setup #2 192.168.30.102 C0A8:1E66
Workgroup Setup #3 192.168.30.103 C0A8:1E67
Workgroup Setup #4 192.168.30.104 C0A8:1E68
Workgroup Setup #5 192.168.30.105 C0A8:1E69
Workgroup Setup #6 192.168.30.106 C0A8:1E6A
Workgroup Setup #7 192.168.30.107 C0A8:1E6B
Workgroup Setup #8 192.168.30.108 C0A8:1E6C
Workgroup Setup #9 192.168.30.109 C0A8:1E6D
Workgroup Setup #10 192.168.30.110 C0A8:1E6E
IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 30
Lab 8 : Using Tunnels (3)
• Configure a tunnel interface using tunnel0
(config)#interface tunnel 0
• Use an IPv6 unnumbered address from the
Ethernet0/0 interface
(config-if)#ipv6 unnumbered ethernet0/0
• Identify the source and destination address of the
tunnel, follow by the tunnel mode
(config-if)#tunnel source ethernet1/0
(config-if)#tunnel destination 192.168.30.110
(config-if)#tunnel mode ipv6ip
• Configure a static route for the global address of the
subnet of the other workgroup LAN (workgroup 10) to
point to the tunnel interface
(config)#ipv6 route 3ffe:b00:ffff:100a::/64 Tunnel0
IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 31

Lab 8 : Using Tunnels (4)


• Verify connectivity using the ping command on the
router to IPv6 address of the tunnel endpoint (which is
the Ethernet0/0 global address)
#ping <global IPv6 address of Ethernet0/0 of your neighbor>
• Verify connectivity by using the ping command form
your PC to the other PC
#ping <global IPv6 address of the other PC>

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 32


Lab 8 : Using Tunnels (5)
Task : Configuring a 6to4 Tunnel
• To clean up, disable the tunnel0 interface and erase the global
and site-local addresses in addition to the prefix advertisements
on the Ethernet0/0 interface
(config)#NO interface tunnel 0
(config)#interface ethernet0/0
(config-if)#NO ipv6 address 3ffe:b00:ffff:100<group>::/64 eui-64
(config-if)#NO ipv6 address fec0:0:0:<group>::/64 eui-64
(config-if)#NO ipv6 nd prefix 3ffe:b00:ffff:100<group>::/64 300 300
(config-if)#NO ipv6 nd prefix fec0:0:0:<group>::/64 300 300
• Configure the 6to4 address on the workgroup Ethernet0/0
interface using subnet id 0 and eui-64
(config-if)#ipv6 address 2002:<ipv4 encoded in hex>::/64 eui-64

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 33

Lab 8 : Using Tunnels (6)


• Configure the 6to4 tunnel on tunnel1 interface using
IPv6 unnumbered command to Ethernet0/0. Add a
router for 2002::/16 pointing to that tunnel interface
(config)#interface tunnel 1
(config-if)#ipv6 unnumbered ethernet0/0
(config-if)#tunnel source ethernet1/0
(config-if)#tunnel mode ipv6ip 6to4
(config)#ipv6 route 2002::/16 tunnel1
• Enable RAs for your LAN by using the ND command
with the 6to4 subnet prefix assigned to your LAN. Use
5 minutes (300 seconds) for the lifetime.
(config-if)#ipv6 nd prefix 2002:<ipv4 encoded in hex>::/64 300
300

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 34


Lab 8 : Using Tunnels (7)
• Verify that your PC now has an IPv6 address that was
automatically configured with the 6to4 subnet prefix
#show ipv6 interface ethernet0/0
• Verify IPv6 connectivity using the ping command on
the PC. Use the 6to4 Ipv6 address of PC in another
workgroupas destination address of the ping
command
#ping <address of the other workgroup PC>

IPv6 Lab © 2004 Cisco Systems, Inc. All rights reserved. 35

Presentation_ID
IPv6 Lab © 1999, Cisco Systems,
© 2004Inc.
Cisco Systems, Inc. All rights reserved. www.cisco.com 36

You might also like