You are on page 1of 12

Lab 6.1.5.

3 Configure and Verify RIP

Objective

Configure routers using basic configurations and RIP routing.

Background / Preparation

A simple routed network has been set up to assist in studying RIP


routing behavior.

Step 1: Configure SVC01 router using RIP Routing

a. Configure FastEthernet 0/0 using the IP address 10.0.0.254/8.


SVC01(config)#int fa0/0
SVC01(config-if)#ip add 10.0.0.254 255.0.0.0
SVC01(config-if)#no shut

SVC01(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

b. Configure Serial 0/0/0

1. Configure Serial 0/0/0 using the first usable IP address in the


network 192.168.1.0/24 to connect to the RTR01 router.

2. Configure the clock rate of 64000.


SVC01(config)#int se0/0/0
SVC01(config-if)#ip add 192.168.1.1 255.255.255.0
SVC01(config-if)#cl ra 64000

SVC01(config)#interface Serial0/0/1
SVC01(config-if)#clock rate 64000

c. Configure Serial 0/0/1 using the first usable IP address in the


network 192.168.2.0/24.
SVC01(config)#int se0/0/1
SVC01(config-if)#ip add 192.168.2.1 255.255.255.0

d. Configure RIP routing to advertise all networks.

SVC01(config)#router rip

SVC01(config-router)#ver 2
SVC01(config-router)#net 10.0.0.0
SVC01(config-router)#net 192.168.1.0
SVC01(config-router)#net 192.168.2.0
e. Enable all interfaces

f. Configure end devices

1. Configure Server0 using the first usable IP address in the


network 10.0.0.0/8.
2. Configure the appropriate default gateway and subnet mask.

3. Configure Printer0 using the second usable IP addresses in the


network 10.0.0.0/8.

4. Configure the appropriate default gateway and subnet mask.


Step 2: Configure RTR01 router using RIP Routing

a. Configure FastEthernet 0/0 using the first usable IP address in the


network 192.168.0.0/24 to connect to the RTR02 router.
RTR01(config)#int fa0/0
RTR01(config-if)#ip add 192.168.0.1 255.255.255.0

b. Configure Serial 0/0/0 using the second usable IP address in the


network 192.168.1.0/24 to connect to the SVC01 router.
RTR01(config-if)#int se0/0/0
RTR01(config-if)#ip add 192.168.1.2 255.255.255.0

c. Configure FastEthernet 0/1 using the IP address


172.16.254.254/16.
RTR01(config)#int fa0/1
RTR01(config-if)#ip add 172.16.254.254 255.255.0.0

d. Configure RIP routing to advertise all networks.


RTR01(config-if)#router rip
RTR01(config-router)#ver 2
RTR01(config-router)#net 192.168.0.0
RTR01(config-router)#net 192.168.1.0
RTR01(config-router)#net 172.16.0.0

e. Enable all interfaces

RTR01(config)#interface Serial0/0/0

RTR01(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

RTR01(config-if)#
RTR01(config-if)#exit

RTR01(config)#interface FastEthernet0/1

RTR01(config-if)#no shutdown

RTR01(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

RTR01(config-if)#exit

RTR01(config)#interface FastEthernet0/0

RTR01(config-if)#no shutdown

RTR01(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

f. Configure end devices

1. Configure PC0 using the first usable IP addresses in the


network 172.16.0.0/16.
2. Configure PC1 using the second usable IP addresses in the
network 172.16.0.0/16.

Step 3: Configure RTR02 router using RIP Routing


a. Configure FastEthernet 0/0 using the second usable IP address in
the network 192.168.0.0/24 to connect to the RTR01 router.
RTR02(config)#int fa0/0

RTR02(config-if)# ip add 192.168.0.2 255.255.255.0

b. Configure Serial 0/0/0 using the second usable IP address in the


network 192.168.1.0/24 to connect to the SVC01 router.
RTR02(config)#int se0/0/0
RTR02(config-if)#ip add 192.168.2.2 255.255.255.0

c. Configure FastEthernet 0/1 using the IP address


172.17.254.254/16.
RTR02(config-if)#int fa0/1
RTR02(config-if)#ip add 172.17.254.254 255.255.0.0

d. Configure RIP routing to advertise all networks.


RTR02(config)#router rip
RTR02(config-router)#ver 2
RTR02(config-router)#net 192.168.0.0
RTR02(config-router)#net 192.168.1.0
RTR02(config-router)#net 172.17.0.0

e. Enable all interfaces

RTR02(config)#interface FastEthernet0/0

RTR02(config-if)#no shutdown

RTR02(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

RTR02(config-if)#exit

RTR02(config)#interface FastEthernet0/1

RTR02(config-if)#no shutdown

RTR02(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

RTR02(config-if)#exit

RTR02(config)#interface Serial0/0/0

RTR02(config-if)#no shutdown

RTR02(config-if)#

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

f. Configure end devices


1. Configure PC2 using the first usable IP addresses in the
network 172.17.0.0/16.

2. Configure PC3 using the second usable IP addresses in the


network 172.17.0.0/16.

Step 4: Verify RIP Configuration each router

At the command prompt for each router, use the IP routing


verification commands show ip protocols and show ip route.
Each router should show routes for remote networks designated with
an R in the routing table output from the show ip routecommand.
SVC01#sh ip pro
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 27 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
Serial0/0/0 2 2
Serial0/0/1 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.1.0
192.168.2.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
192.168.1.2 120 00:00:01
Distance: (default is 120)
SVC01#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet0/0


R 172.16.0.0/16 [120/1] via 192.168.1.2, 00:00:13, Serial0/0/0
R 172.17.0.0/16 [120/2] via 192.168.1.2, 00:00:13, Serial0/0/0
R 192.168.0.0/24 [120/1] via 192.168.1.2, 00:00:13, Serial0/0/0
C 192.168.1.0/24 is directly connected, Serial0/0/0
C 192.168.2.0/24 is directly connected, Serial0/0/1
SVC01#

RTR01#sh ip pro
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 18 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
Serial0/0/0 2 2
FastEthernet0/1 2 2
FastEthernet0/0 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
172.16.0.0
192.168.0.0
192.168.1.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
192.168.1.1 120 00:00:07
192.168.0.2 120 00:00:20
Distance: (default is 120)
RTR01#
RTR01#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

R 10.0.0.0/8 [120/1] via 192.168.1.1, 00:00:15, Serial0/0/0


C 172.16.0.0/16 is directly connected, FastEthernet0/1
R 172.17.0.0/16 [120/1] via 192.168.0.2, 00:00:28, FastEthernet0/0
C 192.168.0.0/24 is directly connected, FastEthernet0/0
C 192.168.1.0/24 is directly connected, Serial0/0/0
R 192.168.2.0/24 [120/1] via 192.168.1.1, 00:00:15, Serial0/0/0
RTR01#

RTR02#sh ip pro
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 22 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
FastEthernet0/1 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
172.17.0.0
192.168.0.0
192.168.1.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
192.168.0.1 120 00:00:02
Distance: (default is 120)
RTR02#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

R 10.0.0.0/8 [120/2] via 192.168.0.1, 00:00:11, FastEthernet0/0


R 172.16.0.0/16 [120/1] via 192.168.0.1, 00:00:11, FastEthernet0/0
C 172.17.0.0/16 is directly connected, FastEthernet0/1
C 192.168.0.0/24 is directly connected, FastEthernet0/0
R 192.168.1.0/24 [120/1] via 192.168.0.1, 00:00:11, FastEthernet0/0
C 192.168.2.0/24 is directly connected, Serial0/0/0
RTR02#

You might also like