You are on page 1of 4

isp / 1:

enable
config t
hostname R1

interface s0/1/0
ip address 192.168.2.34 255.255.255.252
no shutdown
exit

interface g0/0
ip address 192.168.2.37 255.255.255.252
no shutdown
exit

ip route 0.0.0.0 0.0.0.0 192.168.2.33

router 2
enable
config t
hostname R2
interface s0/0/0
ip ospf cost 100
ip nat inside
ip address 192.168.2.1 255.255.255.252
no shutdown
exit
interface s0/0/1
ip ospf cost 100
ip nat inside
ip address 192.168.2.9 255.255.255.252
no shutdown
exit
interface S0/1/0
ip nat outside
ip address 192.168.2.33 255.255.255.252
no shutdown
exit

router ospf 1
router-id 2.2.2.2
auto-cost reference-bandwidth 1000
network 192.168.2.0 0.0.0.3 area 0
network 192.168.2.8 0.0.0.3 area 0
redistribute static
exit
ip route 0.0.0.0 0.0.0.0 192.168.2.34

ip nat inside source list 10 interface s0/1/0 overload


access-list 10 permit any
router 3
enable
config t
hostname R3
interface s0/0/0
ip ospf cost 100
ip address 192.168.2.2 255.255.255.252
no shutdown
exit
interface s0/0/1
ip ospf cost 100
ip address 192.168.2.5 255.255.255.252
no shutdown
exit

router ospf 1
router-id 3.3.3.3
auto-cost reference-bandwidth 1000
network 192.168.2.0 0.0.0.3 area 0
network 192.168.2.4 0.0.0.3 area 0
exit

router 4
enable
config t
hostname R4
interface s0/0/0
ip ospf cost 100
ip address 192.168.2.21 255.255.255.252
no shutdown
exit
interface s0/0/1
ip ospf cost 100
ip address 192.168.2.10 255.255.255.252
no shutdown
exit

interface s0/1/0
ip ospf cost 100
ip address 192.168.2.13 255.255.255.252
no shutdown
exit

router ospf 1
router-id 4.4.4.4
auto-cost reference-bandwidth 1000
network 192.168.2.8 0.0.0.3 area 0
network 192.168.2.12 0.0.0.3 area 0
network 192.168.2.20 0.0.0.3 area 0
exit

router 5
enable
config t
hostname R5
interface s0/0/0
ip ospf cost 100
ip address 192.168.2.17 255.255.255.252
no shutdown
exit
interface s0/0/1
ip ospf cost 100
ip address 192.168.2.6 255.255.255.252
no shutdown
exit

interface s0/1/0
ip ospf cost 100
ip address 192.168.2.14 255.255.255.252
no shutdown
exit

interface s0/1/1
ip ospf cost 100
ip address 192.168.2.29 255.255.255.252
no shutdown
exit

router ospf 1
router-id 5.5.5.5
auto-cost reference-bandwidth 1000
network 192.168.2.4 0.0.0.3 area 0
network 192.168.2.12 0.0.0.3 area 0
network 192.168.2.16 0.0.0.3 area 0
network 192.168.2.28 0.0.0.3 area 0
exit

router 6
enable
config t
hostname R6

interface g0/0
ip ospf cost 100
ip address 192.168.0.1 255.255.255.0
no shutdown
exit
interface s0/0/0
ip ospf cost 100
ip address 192.168.2.22 255.255.255.252
no shutdown
exit
interface s0/0/1
ip ospf cost 100
ip address 192.168.2.25 255.255.255.252
no shutdown
exit
interface s0/1/1
ip ospf cost 100
ip address 192.168.2.30 255.255.255.252
no shutdown
exit
router ospf 1
router-id 6.6.6.6
auto-cost reference-bandwidth 1000
passive-interface g0/0
network 192.168.2.20 0.0.0.3 area 0
network 192.168.2.28 0.0.0.3 area 0
network 192.168.2.24 0.0.0.3 area 0
network 192.168.0.0 0.0.0.255 area 0
exit

router 7
enable
config t
hostname R7

interface g0/0
ip ospf cost 100
ip address 192.168.1.1 255.255.255.0
no shutdown
exit
interface s0/0/0
ip ospf cost 100
ip address 192.168.2.18 255.255.255.252
no shutdown
exit
interface s0/0/1
ip ospf cost 100
ip address 192.168.2.26 255.255.255.252
no shutdown
exit

router ospf 1
router-id 7.7.7.7
auto-cost reference-bandwidth 1000
passive-interface g0/0
network 192.168.2.16 0.0.0.3 area 0
network 192.168.2.24 0.0.0.3 area 0
network 192.168.1.0 0.0.0.255 area 0
exit

You might also like