You are on page 1of 23

COPYRIGHT INFORMATION

This publication, CCNA LAB WORKBOOK, was developed by Mohamed Ouamer. All rights
reserved. No part of this publication may be reproduced or distributed in any form or by any
means without the prior written permission of Mohamed Ouamer.

Cisco®, Cisco Systems®, CCDA®, CCNA®, CCDP®, CCNP®, CCIE®, CCSI®, the Cisco
Systems logo and the CCIE logo are trademarks or registered trademarks of Cisco Systems,
Inc. in the United States and certain other countries. All other trademarks are trademarks of
their respective owners.

If you have questions or concerns about our Copyright information, please email us at
contact@networkexperttraining.com.

DISCLAIMER

The following publication, CCNA LAB WORKBOOK, is developed to assist candidates in the
preparation for Cisco Systems’ CCNA exam.
While every effort has been made to ensure that all material is as complete and accurate as
possible, the enclosed material is presented on an “as is” basis. Neither the authors nor
networkexperttraining.com assume any liability or responsibility to any person or entity with
respect to loss or damages incurred from the information contained in this workbook.

If you have questions or concerns about our disclaimer, please email us at


contact@networkexperttraining.com.

ERRATA

Although we have taken every care to ensure the accuracy of our contents, mistakes do
happen. If you find a mistake in this workbook—maybe a mistake in text or configuration—we
would be grateful if you would report this to us. By doing this you can save other readers from
frustration, and help to improve subsequent versions of this workbook. If you find any errata,
report them by contacting us at support@networkexperttraning.com. Once your errata have
been verified, your submission will be accepted and the errata added to the list of existing
errata. . The existing errata can be requested by by contacting us at
support@networkexperttraning.com.
TABLE OF CONTENTS:

CONNECTING TO A ROUTER…………………..……………………...………………………….. 4
ROUTER BASIC CONFIGURATION………………………..……………...……………………….. 16
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

LAB 1: CONNECTING TO A ROUTER

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/12
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

II. Initial Configuration:

R1:
hostname R1
!
interface fastethernet 0/0
ip address 173.16.12.1 255.255.255.0
no shutdown
!
interface loopback 0
ip address 92.16.0.1 255.0.0.0
!
interface loopback 1
ip address 93.16.1.1 255.0.0.0
!
interface loopback 2
ip address 94.16.2.1 255.0.0.0
!
interface loopback 3
ip address 95.16.3.1 255.0.0.0
!
router eigrp 12
network 173.16.12.1
network 92.16.0.1 0.0.0.0
network 93.16.1.1 0.0.0.0
network 94.16.2.1 0.0.0.0
network 95.16.3.1 0.0.0.0
no auto-summary
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/12
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

III. Tasks:

1. Configure the Hyper Terminal application to connect to a Cisco router. Use the following
settings:
Bits per second : 9600
Data Bits :8
Parity : None
Stop bits :1
Flow Control : None
2. Save R1’s initial configuration on PC1, and then import the file to the router’s flash
memory. Name the file r1-config.txt.
3. Copy R1-config.txt content into the running-config file..

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/12
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

IV. Solutions:

Task 1:

To accomplish this task:


1. Open HyperTerminal by going to Start > Programs > Accessories > Communications >
HyperTerminal. HyperTerminal launches and displays the Connection Description
dialog box.

2. In the Name text box, type a name that describes the connection., and then click OK.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/12
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

3. In the Connect To dialog box, choose which COM port you want to use in the Connect
using drop down box.

4. Enter the COM port Bits per second, Data Bits, Parity, Stop bits, and Flow Control, and
then click OK.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/12
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

5. Once you click OK, the session starts.

Task 2:

Once you save the R1’s initial configuration on PC1, follow these steps to import the file
created on PC 1 to R1’s flash memory:

1. In the EXEC mode, use the copy xmodem: flash: command.


2. Enter the name of the destination file
3. The router will ask you if you want to erase the flash. Press N to skip erasing the flash
memory. If you do not have enough space in the flash memory, try to delete
unnecessary files, or simply upgrade the flash memory.
4. Now, go to the Hyper Terminal window and click on TransferÆ Send File

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/12
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

5. The dialog box Send File appears. Click on Browse button to select the file. In the
Protocol drop down box select Xmodem.

6. Finally, Click on the Send button to start file transfer.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 7/12
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

Verification:

R1:
R1#copy xmodem: flash:
Destination filename []? r1-config.txt
Erase flash: before copying? [confirm]n
Begin the Xmodem or Xmodem-1K transfer now...
CCCCC
Verifying checksum... OK (0xC82F)
768 bytes copied in 11.244 secs (69 bytes/sec)
R1#

R1#copy flash:r1-config.txt running-config


Destination filename [running-config]?
768 bytes copied in 0.132 secs
R1#

To display the file content use the more command.

R1#more flash:r1-config.txt
hostname R1
!
interface fastethernet 0/0
ip address 173.16.12.1 255.255.255.0
no shutdown
!
interface loopback 0
ip address 92.16.0.1 255.0.0.0
!
interface loopback 1
ip address 93.16.1.1 255.0.0.0
!
interface loopback 2
ip address 94.16.2.1 255.0.0.0
!
interface loopback 3
ip address 95.16.3.1 255.0.0.0
!
router eigrp 12
network 173.16.12.1
network 92.16.0.1 0.0.0.0
network 93.16.1.1 0.0.0.0

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 8/12
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

network 94.16.2.1 0.0.0.0


network 95.16.3.1 0.0.0.0
no auto-summary
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
End

Task 3:

Now the file is successfully copied in the flash, use the copy flash:r1-config.txt running-
config command to copy the content of the file r1-config.txt into the running-config file.

Verification:

R1:

R1#copy flash:r1-config.txt running-config


Destination filename [running-config]?
768 bytes copied in 0.132 secs
R1#

R1#show running-config
Building configuration...

Current configuration : 917 bytes


!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 9/12
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

!
hostname R1
!
!
ip subnet-zero
!
!
!
!
interface Loopback0
ip address 92.16.0.1 255.0.0.0
!
interface Loopback1
ip address 93.16.1.1 255.0.0.0
!
interface Loopback2
ip address 94.16.2.1 255.0.0.0
!
interface Loopback3
ip address 95.16.3.1 255.0.0.0
!
interface FastEthernet0/0
ip address 173.16.12.1 255.255.255.0
speed auto
!
router eigrp 12
network 92.16.0.1 0.0.0.0
network 93.16.1.1 0.0.0.0
network 94.16.2.1 0.0.0.0
network 95.16.3.1 0.0.0.0
network 173.16.0.0
no auto-summary
no eigrp log-neighbor-changes
!
ip classless
no ip http server
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 10/12
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

line vty 0 4
exec-timeout 0 0
password cisco
logging synchronous
login
!
end

R1#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 11/12
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

V. Links

For more information about the commands used in this lab, use the following links:
1. copy
http://www.cisco.com/en/US/docs/ios/12_3/configfun/command/reference/cfr_1g02.html
#wp1030138
2. more
http://www.cisco.com/en/US/docs/ios/12_3/configfun/command/reference/cfr_1g05.html
#wp1030898

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 12/12
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

LAB 2: ROUTER BASIC CONFIGURATION

I. Network diagram:

II. Initial Configuration:

R1:
ip route 0.0.0.0 0.0.0.0 10.1.2.254
!
interface FastEthernet0/0
ip address 10.1.2.1 255.255.255.0
no shutdown
!
!
end

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/8
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

III. Tasks:
1. Set the hostname of R1 to Rack_A_R1.
2. Set the enable password to cisco$.
3. Create a user account named “admin” with the password cisco@$. The password
should be stored in the running-config in unencrypted format.
4. Set the VTY line password to telnetcisco, and instruct the router to authenticate users
connected remotely.
5. Encrypt the passwords configured in tasks 2 and 4.
6. Configure the router to display the following message whenever a user is
connected to the router.

7. Configure the router to resolve DNS names using the DNS server 10.1.2.254
8. Configure the router such that logging messages sent to the console will not interrupt
you when you type a command.
9. Configure the router’s console to never log of even there is no activity.
10. Turn off password encryption, and decrypt the line password and the enable password
using a key chain object.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/8
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

IV. Solutions:

Task 1:
R1:
Router# configure terminal
Router(config)#hostname RackA_R1
RackA_R1(config)# end
RackA_R1#

Task 2:
R1:
RackA_R1# configure terminal
RackA_R1(config)#enable password cisco$
RackA_R1(config)#end
RackA_R1#

Verification:
RackA_R1#show running-config | include enable
enable password cisco$

Task 3:
R1:
RackA_R1# configure terminal
RackA_R1(config)#username admin secret cisco@$
RackA_R1(config)#end
RackA_R1#

Verification:

R1:
RackA_R1# show running-config | include username
username admin secret 5 $1$TDJ/$c9eOpvmB8RJo3Zit5Mshn1

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/8
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

Task 4:
R1:
RackA_R1# configure terminal
RackA_R1(config)#line vty 0 4
RackA_R1(config-line)#password telnetcisco
RackA_R1(config-line)#login
RackA_R1(config)#end
RackA_R1#
Task 5:
R1:
RackA_R1# configure terminal
RackA_R1(config)#service password-encryption
RackA_R1(config)#end
RackA_R1#

Verification:

R1:
RackA_R1#show running-config
<omitted output>
!
enable password 7 01100F17580442
!
<omitted output>
!
line vty 0 4
password 7 15060E000A2F3F272120362D
<omitted output>

Task 6:
R1:
RackA_R1# configure terminal
RackA_R1(config)#banner motd $
Enter TEXT message. End with the character '$'.
**********************************************************************
* You are Connected To A Private Network *
* Access is Allowed To Authorized Users *
* Your IP address is Logged *
* If You Are Not Authorized To Access This Device, *
* Then Disconnect Immediately *
**********************************************************************

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/8
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

$
RackA_R1(config)#end
RackA_R1#

Verification:

R1:
RackA_R1#logout

RackA_R1 con0 is now available

Press RETURN to get started.

RackA_R1>

Task 7:
R1:
RackA_R1# configure terminal
RackA_R1(config)#ip domain-lookup
RackA_R1(config)#ip name-server 10.1.2.254
RackA_R1(config)#^Z
RackA_R1#

Verification
R1:
RackA_R1#ping www.google.com

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/8
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

Translating "www.google.com"...domain server (10.1.2.254) [OK]

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 74.125.79.147, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 116/148/200 ms
RackA_R1#

Task 8:
R1:
RackA_R1#conf t
RackA_R1(config)#line con 0
RackA_R1(config-line)#logging synchronous
RackA_R1(config-line)#end
RackA_R1#

Task 9:
RackA_R1#conf t
RackA_R1(config)#line con 0
RackA_R1(config-line)#exec-timeout 0 0
RackA_R1(config-line)#^Z
RackA_R1#

Task 10:
R1:
RackA_R1#conf t
RackA_R1(config)# key chain DecryptPassword
RackA_R1(config-keychain)#key 1
RackA_R1(config-keychain-key)#key-string 7 01100F17580442
RackA_R1(config-keychain-key)#exit
RackA_R1(config-keychain)#key 2
RackA_R1(config-keychain-key)#key-string 7 15060E000A2F3F272120362D
RackA_R1(config-keychain-key)#^Z
RackA_R1#

To display the unencrypted format of the passwords, issue the show key chain command.

RackA_R1#show key chain DecryptPassword


Key-chain DecryptPassword:
key 1 -- text "cisco$"
accept lifetime (always valid) - (always valid) [valid now]
send lifetime (always valid) - (always valid) [valid now]
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/8
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

key 2 -- text "telnetcisco"


accept lifetime (always valid) - (always valid) [valid now]
send lifetime (always valid) - (always valid) [valid now]
RackA_R1#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 7/8
CCNA LAB WORKBOOK  BASIC CONFIGURATION 

V. Links
For more information about the commands used in this lab, use the following links:
1. banner motd
http://www.cisco.com/en/US/docs/ios/12_3/configfun/command/reference/cfr_1g01.html
#wp1029811
2. enable password
http://www.cisco.com/en/US/docs/ios/12_3/security/command/reference/sec_d1g.html#
wp1095597
3. enable secret
http://www.cisco.com/en/US/docs/ios/12_3/security/command/reference/sec_d1g.html#
wp1070932
4. exec-timeout
http://www.cisco.com/en/US/docs/ios/12_3/configfun/command/reference/cfr_1g03.html
#wp1029531
5. hostname
http://www.cisco.com/en/US/docs/ios/12_3/configfun/command/reference/cfr_1g03.html
#wp1031151
6. ip domain name
http://www.cisco.com/en/US/docs/ios/12_3/ipaddr/command/reference/ip1_i1g.html#wp
1081400
7. ip name-server
http://www.cisco.com/en/US/docs/ios/12_3/ipaddr/command/reference/ip1_i2g.html#wp
1078776
8. key chain
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_k1g.html#w
p1036467
9. logging synchronous
http://www.cisco.com/en/US/docs/ios/12_3/configfun/command/reference/cfr_1g04.html
#wp1033117
10. password (line configuration)
http://www.cisco.com/en/US/docs/ios/12_3/security/command/reference/sec_i2g.html#w
p1075206
11. service password-encryption
http://www.cisco.com/en/US/docs/ios/12_3/security/command/reference/sec_r1g.html#
wp1070450
12. username
http://www.cisco.com/en/US/docs/ios/12_3/security/command/reference/sec_s1g.html#
wp1096639

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 8/8

You might also like