You are on page 1of 49

COPYRIGHT INFORMATION

This publication, CCNA LAB WORKBOOK, was developed by Mohamed Ouamer. All rights
reserved. No part of this publication may be reproduced or distributed in any form or by any
means without the prior written permission of Mohamed Ouamer.

Cisco®, Cisco Systems®, CCDA®, CCNA®, CCDP®, CCNP®, CCIE®, CCSI®, the Cisco
Systems logo and the CCIE logo are trademarks or registered trademarks of Cisco Systems,
Inc. in the United States and certain other countries. All other trademarks are trademarks of
their respective owners.

If you have questions or concerns about our Copyright information, please email us at
contact@networkexperttraining.com.

DISCLAIMER

The following publication, CCNA LAB WORKBOOK, is developed to assist candidates in the
preparation for Cisco Systems’ CCNA exam.
While every effort has been made to ensure that all material is as complete and accurate as
possible, the enclosed material is presented on an “as is” basis. Neither the authors nor
networkexperttraining.com assume any liability or responsibility to any person or entity with
respect to loss or damages incurred from the information contained in this workbook.

If you have questions or concerns about our disclaimer, please email us at


contact@networkexperttraining.com.

ERRATA

Although we have taken every care to ensure the accuracy of our contents, mistakes do
happen. If you find a mistake in this workbook—maybe a mistake in text or configuration—we
would be grateful if you would report this to us. By doing this you can save other readers from
frustration, and help to improve subsequent versions of this workbook. If you find any errata,
report them by contacting us at support@networkexperttraning.com. Once your errata have
been verified, your submission will be accepted and the errata added to the list of existing
errata. . The existing errata can be requested by by contacting us at
support@networkexperttraning.com.
TABLE OF CONTENTS:

BASIC CONFIGURATION……………………………………………………………………...…… 4
UNICAST UPDATES ...………….…………………………………………………………………. 10
SPLIT HORIZON ………………………………………………………………………………..…. 17
UNEQUAL LOAD BALANCING ……………………………………………………………………. 28
DEFAULT ROUTE …………………………………………………………………………………. 37
ADVANCED SCENARIO ...…………………………………………………………………………. 44
CCNA LAB WORKBOOK  EIGRP 

LAB 1: BASIC CONFIGURATION

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/6
CCNA LAB WORKBOOK  EIGRP 

II. Initial Configuration:


R1:
hostname R1
!
interface loopback 0
ip address 171.16.1.1 255.255.255.0
!
interface loopback 1
ip address 192.168.1.1 255.255.255.0
!
interface fastethernet0/0
ip address 10.12.12.1 255.255.255.0
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
End

R2:
hostname R2
!
!
interface loopback 0
ip address 171.16.2.2 255.255.255.0
!
interface loopback 1
ip address 193.16.12.2 255.255.255.0
!
interface fastethernet0/0
ip address 10.12.12.2 255.255.255.0
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/6
CCNA LAB WORKBOOK  EIGRP 

logging synchronous
password cisco
login
!
!
end

III. Tasks:
1. Configure EIGRP AS 12 on R1 and R2, and advertise all interfaces in EIGRP. Do not
disable auto-summarization.
2. Configure R1 and R2 such that the maximum bandwidth percent used on the link between
them do not exceed 10%.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/6
CCNA LAB WORKBOOK  EIGRP 

IV. Solutions:
Task 1:
R1:
R1#conf t
R1(config)#router eigrp 12
R1(config-router)#network 10.0.0.0
R1(config-router)#network 171.16.0.0
R1(config-router)#network 192.168.1.0
R1(config-router)#end
R1#

R2:
R2#conf t
R2(config)#router eigrp 12
R2(config-router)#network 10.0.0.0
R2(config-router)#network 171.16.0.0
R2(config-router)#network 193.16.12.0
R2(config-router)#end
R2#

Verification:

R1:
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 12
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.12.12.2 Fa0/0 11 00:00:56 260 2340 0 5
R1#

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
- ODR, P - periodic downloaded static route

Gateway of last resort is not set

171.16.0.0/16 is variably subnetted, 2 subnets, 2 masks


C 171.16.1.0/24 is directly connected, Loopback0

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/6
CCNA LAB WORKBOOK  EIGRP 

D 171.16.0.0/16 is a summary, 00:01:01, Null0


D 193.16.12.0/24 [90/409600] via 10.12.12.2, 00:00:55, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.12.12.0/24 is directly connected, FastEthernet0/0
D 10.0.0.0/8 is a summary, 00:01:31, Null0
C 192.168.1.0/24 is directly connected, Loopback1
R1#

R2:
R2#show ip eigrp 12 neighbors
IP-EIGRP neighbors for process 12
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.12.12.1 Fa0/0 14 00:01:10 204 1224 0 3

R2#show ip route eigrp


171.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 171.16.0.0/16 is a summary, 00:01:16, Null0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 10.0.0.0/8 is a summary, 00:01:17, Null0
D 192.168.1.0/24 [90/409600] via 10.12.12.1, 00:01:16, FastEthernet0/0
R2#

Task 3:
R1:
R1#conf t
R1(config)#interface f0/0
R1(config-if)#ip bandwidth-percent eigrp 12 10
R1(config-if)#end
R1#

R2:
R2#conf t
R2(config)#interface f0/0
R2(config-if)#ip bandwidth-percent eigrp 12 10
R2(config-if)#end
R2#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/6
CCNA LAB WORKBOOK  EIGRP 

V. Links
For more information about the commands used in this lab, use the following links:
1. ip bandwidth-percent eigrp
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig1.html#wp1012
741
2. network
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
165
3. router eigrp
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
489
4. show ip eigrp neighbors
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
982

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/6
CCNA LAB WORKBOOK  EIGRP 

LAB 2: UNICAST UPDATES

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/7 
CCNA LAB WORKBOOK  EIGRP 

II. Initial Configuration


R1:
hostname R1
!
!
interface Loopback0
ip address 1.2.3.1 255.255.255.0
!
interface Loopback1
ip address 10.1.4.1 255.255.252.0
!
interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end
R2:
hostname R2
!
!
interface Loopback0
ip address 2.3.4.2 255.255.255.0
!
interface Loopback1
ip address 10.1.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.12.2 255.255.255.0
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/7 
CCNA LAB WORKBOOK  EIGRP 

line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

III. Tasks:
1. Enable EIGRP AS 20 on the network, and advertise all the subnets. EIGRP updates
between R1 and R2 should be sent as unicast packets.
2. Set the maximum paths to the value of 2 on the routers.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/7 
CCNA LAB WORKBOOK  EIGRP 

IV. Solutions:
Task 1:

R1:
R1#conf t
R1(config)#router eigrp 20
R1(config-router)#network 0.0.0.0
R1(config-router)#neighbor 10.1.12.2 fastEthernet 0/0
R1(config-router)#no auto-summary
R1(config-router)#^Z
R1#
R2:
R2#conf t
R2(config)#router eigrp 20
R2(config-router)#network 0.0.0.0
R2(config-router)#neighbor 10.1.12.1 fastEthernet 0/0
R2(config-router)#no auto-summary
R2(config-router)#^Z
R2#

Verification:

R1:
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 20
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.12.2 Fa0/0 12 00:01:55 192 1152 0 3
R1#

R1#debug eigrp packets hello


EIGRP Packets debugging is on
(HELLO)
R1#
*Mar 1 00:07:33.235: EIGRP: Sending HELLO on Loopback0
*Mar 1 00:07:33.239: AS 20, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

*Mar 1 00:07:35.863: EIGRP: Sending HELLO on FastEthernet0/0 nbr 10.1.12.2


*Mar 1 00:07:35.867: AS 20, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R1#
*Mar 1 00:07:37.423: EIGRP: Sending HELLO on Loopback1
*Mar 1 00:07:37.427: AS 20, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/7 
CCNA LAB WORKBOOK  EIGRP 

R2:
R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 20
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.12.1 Fa0/0 12 00:02:01 143 858 0 4
R2#sh

R2#debug eigrp packets hello


EIGRP Packets debugging is on
(HELLO)
R2#
*Mar 1 00:03:20.111: EIGRP: Sending HELLO on Loopback1
*Mar 1 00:03:20.115: AS 20, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

*Mar 1 00:03:20.859: EIGRP: Sending HELLO on FastEthernet0/0 nbr 10.1.12.1


*Mar 1 00:03:20.863: AS 20, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R2#
*Mar 1 00:03:21.131: EIGRP: Sending HELLO on Loopback0
*Mar 1 00:03:21.135: AS 20, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

Task 2:

R1:
R1#conf t
R1(config)# router eigrp 20
R1(config-router)#maximum-paths 2
R1(config-router)#^Z
R1#
R2:
R2#conf t
R2(config)# router eigrp 20
R2(config-router)#maximum-paths 2
R2(config-router)#^Z
R2#

Verification:

R1:
R1#show ip protocols
Routing Protocol is "eigrp 20"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/7 
CCNA LAB WORKBOOK  EIGRP 

Default networks flagged in outgoing updates


Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 20
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 2
Routing for Networks:
0.0.0.0
Routing Information Sources:
Gateway Distance Last Update
10.1.12.2 90 00:00:21
Distance: internal 90 external 170

R1#

R2:
R2#show ip protocols
Routing Protocol is "eigrp 20"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 20
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 2
Routing for Networks:
0.0.0.0
Routing Information Sources:
Gateway Distance Last Update
10.1.12.1 90 00:00:02
Distance: internal 90 external 170

R2#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/7 
CCNA LAB WORKBOOK  EIGRP 

V. Links:
For more information about the commands used in this lab, use the following links:
1. auto-summary
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig1.html#wp1011
150
2. maximum-paths
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_pi1.html#wp10150
04
3. neighbor
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1011
904
4. network
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
165
5. router eigrp
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
489
6. show ip eigrp neighbors
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
982
7. show ip route
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039689
8. show ip protocols
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039132

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 7/7 
CCNA LAB WORKBOOK  EIGRP 

LAB 3: SPLIT HORIZON

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/11
CCNA LAB WORKBOOK  EIGRP 

II. Initial Configuration:


R1:
hostname R1
!
interface loopback 0
ip address 171.16.1.1 255.255.255.0
!
interface Serial0/0
encapsulation frame-relay
ip address 10.123.123.1 255.255.255.0
frame-relay map ip 10.123.123.2 102 broadcast
frame-relay map ip 10.123.123.3 103 broadcast
no frame-relay inverse-arp
no shutdown
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

R2:
hostname R2
!
interface loopback 0
ip address 171.16.2.2 255.255.255.0
!
interface serial0/0
encapsulation frame-relay
ip address 10.123.123.2 255.255.255.0
frame-relay map ip 10.123.123.1 201 broadcast
frame-relay map ip 10.123.123.3 201 broadcast
no frame-relay inverse-arp
!
line con 0
exec-timeout 0 0
logging synchronous
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/11
CCNA LAB WORKBOOK  EIGRP 

!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

R3:
hostname R3
!
!
!
interface loopback 0
ip address 171.16.3.3 255.255.255.0
!
interface Serial0/0
encapsulation frame-relay
ip address 10.123.123.3 255.255.255.0
frame-relay map ip 10.123.123.1 301 broadcast
frame-relay map ip 10.123.123.2 301 broadcast
no frame-relay inverse-arp
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/11
CCNA LAB WORKBOOK  EIGRP 

III. Tasks:
1. Configure EIGRP AS 123 according to the network diagram. Make sure to disable auto
summarization
2. Configure the routers to send EIGRP updates out of the frame relay interfaces only.
3. Configure the routers to calculate the EIGRP metrics based on the bandwidth value
only.
4. Configure R1 such that R2 can reach R3’s connected networks, and via-versa.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/11
CCNA LAB WORKBOOK  EIGRP 

IV. Solutions:
Task 1:
R1:
R1#configure terminal
R1(config)#router eigrp 123
R1(config-router)#network 0.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#end
R1#
R2:
R2#configure terminal
R2(config)#router eigrp 123
R2(config-router)#network 0.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#end
R2#
R3:
R3#configure terminal
R3(config)#router eigrp 123
R3(config-router)#network 0.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#end
R3#

Verification:

R1:
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 123
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.123.123.3 Se0/0 168 00:00:13 152 912 0 2
0 10.123.123.2 Se0/0 168 00:00:17 658 3948 0 2
R1#show ip route eigrp
171.16.0.0/24 is subnetted, 3 subnets
D 171.16.3.0 [90/2297856] via 10.123.123.3, 00:00:39, Serial0/0
D 171.16.2.0 [90/2297856] via 10.123.123.2, 00:00:44, Serial0/0
R1#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/11
CCNA LAB WORKBOOK  EIGRP 

R2:
R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 123
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.123.123.1 Se0/0 170 00:01:02 148 888 0 6
R2#

R2#show ip route eigrp


171.16.0.0/24 is subnetted, 2 subnets
D 171.16.1.0 [90/2297856] via 10.123.123.1, 00:00:42, Serial0/0
R2#

R3:
R3#show ip eigrp neighbors
IP-EIGRP neighbors for process 123
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.123.123.1 Se0/0 164 00:01:07 132 792 0 6
R3#

R3#show ip route eigrp


171.16.0.0/24 is subnetted, 2 subnets
D 171.16.1.0 [90/2297856] via 10.123.123.1, 00:00:30, Serial0/0
R3#

Task 2:
R1:
R1#configure terminal
R1(config)#router eigrp 123
R1(config-router)#metric weights 0 1 0 0 0 0
R1(config-router)#end
R1#

R2:
R2#configure terminal
R2(config)#router eigrp 123
R2(config-router)#metric weights 0 1 0 0 0 0
R2(config-router)#end
R2#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/11
CCNA LAB WORKBOOK  EIGRP 

R3:
R3#configure terminal
R3(config)#router eigrp 123
R3(config-router)#metric weights 0 1 0 0 0 0
R3(config-router)#end
R3#

Verification:
R1:
R1#show ip protocols
Routing Protocol is "eigrp 123"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=0, K4=0, K5=0
<omitted output>

R2:
R2#show ip protocols
Routing Protocol is "eigrp 123"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=0, K4=0, K5=0
<omitted output>

R3
R3#show ip protocols
Routing Protocol is "eigrp 123"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=0, K4=0, K5=0
<omitted output>

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 7/11
CCNA LAB WORKBOOK  EIGRP 

Task 3:
R1:
R1#configure terminal
R1(config)#router eigrp 123
R1(config-router)#passive-interface loopback 0
R1(config-router)#end
R1#
R2:
R2#configure terminal
R2(config)#router eigrp 123
R2(config-router)#passive-interface loopback 0
R2(config-router)#end
R2#
R3:
R3#configure terminal
R3(config)#router eigrp 123
R3(config-router)#passive-interface loopback 0
R3(config-router)#end
R3#

Verification:
R1:
R1#show ip protocols
Routing Protocol is "eigrp 123"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=0, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 123
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
0.0.0.0
Passive Interface(s):
Loopback0
<omitted output>

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 8/11
CCNA LAB WORKBOOK  EIGRP 

R2:
R2#show ip protocols
Routing Protocol is "eigrp 123"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=0, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 123
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
0.0.0.0
Passive Interface(s):
Loopback0
<omitted output>

R3
R3#show ip protocols
Routing Protocol is "eigrp 123"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=0, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 123
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
0.0.0.0
Passive Interface(s):
Loopback0
<omitted output>

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 9/11
CCNA LAB WORKBOOK  EIGRP 

Task 4:
R1:
R1#configure terminal
R1(config)#interface serial 0/0
R1(config-if)#no ip split-horizon eigrp 123
R1(config-if)#end
R1#

Verification:

R2
R2#show ip route eigrp
171.16.0.0/24 is subnetted, 3 subnets
D 171.16.3.0 [90/1657856] via 10.123.123.1, 00:01:05, Serial0/0
D 171.16.1.0 [90/1657856] via 10.123.123.1, 00:01:05, Serial0/0

R3
R3#show ip route eigrp
171.16.0.0/24 is subnetted, 3 subnets
D 171.16.2.0 [90/1657856] via 10.123.123.1, 00:01:23, Serial0/0
D 171.16.1.0 [90/1657856] via 10.123.123.1, 00:01:23, Serial0/0
R3#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 10/11
CCNA LAB WORKBOOK  EIGRP 

V. Links:
For more information about the commands used in this lab, use the following links:
1. auto-summary
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig1.html#wp1011
150
2. ip split-horizon eigrp
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig1.html#wp1013
091
3. metric weights
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1011
716
4. network
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
165
5. passive-interface
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_o1g.html#w
p1036805
6. router eigrp
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
489
7. show ip eigrp neighbors
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
982
8. show ip route
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039689
9. show ip protocols
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039132

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 11/11
CCNA LAB WORKBOOK  EIGRP 

LAB 4: UNEQUAL LOAD BALANCING

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/9
CCNA LAB WORKBOOK  EIGRP 

II. Initial Configuration:


R1:
hostname R1
!
!
interface loopback 0
ip address 171.16.1.1 255.255.255.0
!
interface loopback 1
ip address 192.168.1.1 255.255.255.0
!
Interface serial 1/0
ip address 10.120.120.1 255.255.255.0
no shutdown
!
interface fastethernet0/0
ip address 10.12.12.1 255.255.255.0
no shutdown
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
End

R2:
hostname R2
!
!
interface loopback 0
ip address 171.16.2.2 255.255.255.0
!
interface loopback 1
ip address 193.16.12.2 255.255.255.0
!
Interface serial 1/0
ip address 10.120.120.2 255.255.255.0
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/9
CCNA LAB WORKBOOK  EIGRP 

no shutdown
!
interface fastethernet0/0
ip address 10.12.12.2 255.255.255.0
no shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/9
CCNA LAB WORKBOOK  EIGRP 

III. Tasks:
1. Enable EIGRP AS120 on R1 and R2. Advertise all the networks connected to R1 and
R2 in EIGRP and disable auto-summarization.
2. Authenticate the Ethernet link between R1 and R2 using key 12 and the string cisco12.
3. Configure R1 to load balance traffic destined to the subnets 171.16.2.0/24 and
193.16.12.0/24 trough the interfaces F0/0 and S1/0.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/9
CCNA LAB WORKBOOK  EIGRP 

IV. Solutions:
Task 1:
R1:
R1#configure terminal
R1(config)# router eigrp 120
R1(config-router)# network 10.12.12.1 0.0.0.0
R1(config-router)# network 10.120.120.1 0.0.0.0
R1(config-router)# network 171.16.1.1 0.0.0.0
R1(config-router)# network 192.168.1.1 0.0.0.0
R1(config-router)# no auto-summary
R1(config-router)# end
R1#

R2:
R2#configure terminal
R2(config)# router eigrp 120
R2(config-router)# network 10.12.12.2 0.0.0.0
R2(config-router)# network 10.120.120.2 0.0.0.0
R2(config-router)# network 171.16.2.2 0.0.0.0
R2(config-router)# network 193.16.12.2 0.0.0.0
R2(config-router)# no auto-summary
R2(config-router)# end
R2#

Verification:

R1:
R1#show ip eigrp 120 neighbors
IP-EIGRP neighbors for process 120
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.120.120.2 Se1/0 11 00:00:45 300 1800 0 22
0 10.12.12.2 Fa0/0 13 00:02:54 801 4806 0 19
R1#

R1#show ip route eigrp


171.16.0.0/24 is subnetted, 2 subnets
D 171.16.2.0 [90/409600] via 10.12.12.2, 00:00:51, FastEthernet0/0
D 193.16.12.0/24 [90/409600] via 10.12.12.2, 00:00:51, FastEthernet0/0
R1#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/9
CCNA LAB WORKBOOK  EIGRP 

R1#show ip eigrp 120 topology


IP-EIGRP Topology Table for AS(120)/ID(192.168.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,


r - reply Status, s - sia Status

P 10.120.120.0/24, 1 successors, FD is 2169856


via Connected, Serial1/0
P 10.12.12.0/24, 1 successors, FD is 281600
via Connected, FastEthernet0/0
P 192.168.1.0/24, 1 successors, FD is 128256
via Connected, Loopback1
P 171.16.2.0/24, 1 successors, FD is 409600
via 10.12.12.2 (409600/128256), FastEthernet0/0
via 10.120.120.2 (2297856/128256), Serial1/0
P 171.16.1.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 193.16.12.0/24, 1 successors, FD is 409600
via 10.12.12.2 (409600/128256), FastEthernet0/0
via 10.120.120.2 (2297856/128256), Serial1/0
R1#

R2:
R2#show ip eigrp 120 neighbors
IP-EIGRP neighbors for process 120
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.120.120.1 Se1/0 11 00:03:03 214 1284 0 20
0 10.12.12.1 Fa0/0 10 00:05:12 200 1200 0 17
R2#

R2#show ip route eigrp


171.16.0.0/24 is subnetted, 2 subnets
D 171.16.1.0 [90/409600] via 10.12.12.1, 00:03:14, FastEthernet0/0
D 192.168.1.0/24 [90/409600] via 10.12.12.1, 00:03:14, FastEthernet0/0
R2#

R2#show ip eigrp 120 topology


IP-EIGRP Topology Table for AS(120)/ID(193.16.12.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,


r - reply Status, s - sia Status

P 10.120.120.0/24, 1 successors, FD is 2169856


via Connected, Serial1/0
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/9
CCNA LAB WORKBOOK  EIGRP 

P 10.12.12.0/24, 1 successors, FD is 281600


via Connected, FastEthernet0/0
P 192.168.1.0/24, 1 successors, FD is 409600
via 10.12.12.1 (409600/128256), FastEthernet0/0
via 10.120.120.1 (2297856/128256), Serial1/0
P 171.16.2.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 171.16.1.0/24, 1 successors, FD is 409600
via 10.12.12.1 (409600/128256), FastEthernet0/0
via 10.120.120.1 (2297856/128256), Serial1/0
P 193.16.12.0/24, 1 successors, FD is 128256
via Connected, Loopback1
R2#

Task 2:
R1:
R1#conf t
R1(config)#key chain EIGRPKey
R1(config-keychain)# key 12
R1(config-keychain-key)# key-string cisco12
R1(config-keychain-key)#
R1(config-keychain-key)#interface FastEthernet0/0
R1(config-if)# ip authentication key-chain eigrp 120 EIGRPKey
R1(config-if)#^Z
R1#

R2:
R2#conf t
R2(config)#key chain EIGRPKey
R2(config-keychain)# key 12
R2(config-keychain-key)# key-string cisco12
R2(config-keychain-key)#
R2(config-keychain-key)#interface FastEthernet0/0
R2(config-if)# ip authentication key-chain eigrp 120 EIGRPKey
R2(config-if)#^Z
R2#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 7/9
CCNA LAB WORKBOOK  EIGRP 

Task 3:
R1:
R1#configure terminal
R1(config)# router eigrp 120
R1(config-router)#variance 6
R1(config-router)# end
R1#

Verification:

R1:
R1#show ip route eigrp
171.16.0.0/24 is subnetted, 2 subnets
D 171.16.2.0 [90/2297856] via 10.120.120.2, 00:00:05, Serial1/0
[90/409600] via 10.12.12.2, 00:00:05, FastEthernet0/0
D 193.16.12.0/24 [90/2297856] via 10.120.120.2, 00:00:05, Serial1/0
[90/409600] via 10.12.12.2, 00:00:05, FastEthernet0/0

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 8/9
CCNA LAB WORKBOOK  EIGRP 

V. Link:
For more information about the commands used in this lab, use the following links:
1. auto-summary
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig1.html#wp1011
150
2. ip authentication key-chain eigrp
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig1.html#wp1012
531
3. ip authentication mode eigrp
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig1.html#wp1012
630
4. network
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
165
5. router eigrp
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
489
6. show ip eigrp neighbors
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
982
7. show ip eigrp topology
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1013
230
8. show ip route
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039689
9. show ip protocols
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039132
10. variance
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1014
686

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 9/9
CCNA LAB WORKBOOK  EIGRP 

LAB 5: DEFAULT ROUTE

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/7 
CCNA LAB WORKBOOK  EIGRP 

II. Initial Configuration


R1:
hostname R1
!
!
interface Loopback0
ip address 1.2.3.1 255.255.255.0
!
interface Loopback1
ip address 10.1.4.1 255.255.252.0
!
interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end
R2:
hostname R2
!
!
!
interface Loopback0
ip address 10.1.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.12.2 255.255.255.0
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/7 
CCNA LAB WORKBOOK  EIGRP 

password cisco
login
!
!
end

III. Tasks:
1. Enable EIGRP AS 20 on the network, and advertise all the subnets in the IP address
space 10.0.0.0/8. Updates should be sent out of necessary interfaces.
2. Configure R1 to send a default route to R2.

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/7 
CCNA LAB WORKBOOK  EIGRP 

IV. Solutions:
Task 1:

R1:
R1#conf t
R1(config)#router eigrp 20
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#passive-interface default
R1(config-router)#no passive-interface fastEthernet 0/0
R1(config-router)#^Z
R1#
R2:
R2#conf t
R2(config)#router eigrp 20
R2(config-router)#network 10.0.0.0
R2(config-router)#passive-interface default
R2(config-router)#no passive-interface fastEthernet 0/0
R2(config-router)#no auto-summary
R2(config-router)#^Z
R2#

Verification:

R1:
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 20
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.12.2 Fa0/0 11 00:00:13 174 1044 0 5
R1#

R1#show ip route eigrp


10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.1.2.0/24 [90/409600] via 10.1.12.2, 00:00:17, FastEthernet0/0
R1#

R1#show ip protocols
Routing Protocol is "eigrp 20"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/7 
CCNA LAB WORKBOOK  EIGRP 

EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0


EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 20
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
Passive Interface(s):
FastEthernet0/1
Loopback0
Loopback1
<omitted output>
R2:

R2#show ip eigrp neighbors


IP-EIGRP neighbors for process 20
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.12.1 Fa0/0 12 00:02:44 231 1386 0 12
R2#

R2#show ip route eigrp


10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.1.4.0/22 [90/409600] via 10.1.12.1, 00:02:47, FastEthernet0/0
R2#

R2#show ip protocols
Routing Protocol is "eigrp 20"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 20
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
Passive Interface(s):
FastEthernet0/1
Loopback0
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/7 
CCNA LAB WORKBOOK  EIGRP 

Task 2:

R1:
R1#configure terminal
R1(config)#ip route 0.0.0.0 0.0.0.0 null 0
R1(config)#router eigrp 20
R1(config-router)#redistribute static
R1(config-router)#^Z
R1#

Verification:

R2:
R2#show ip route eigrp
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.1.4.0/22 [90/409600] via 10.1.12.1, 00:02:46, FastEthernet0/0
D*EX 0.0.0.0/0 [170/281600] via 10.1.12.1, 00:00:10, FastEthernet0/0
R2#

R2#ping 1.2.3.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 1.2.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/75/128 ms

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/7 
CCNA LAB WORKBOOK  EIGRP 

V. Links:
For more information about the commands used in this lab, use the following links:
1. auto-summary
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig1.html#wp1011
150
2. ip route
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_pi1.html#wp10313
06
3. network
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
165
4. passive-interface
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_o1g.html#w
p1036805
5. redistribute
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_pi1.html#wp10153
90
6. router eigrp
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
489
7. show ip eigrp neighbors
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
982
8. show ip route
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039689
9. show ip protocols
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039132

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 7/7 
CCNA LAB WORKBOOK  EIGRP 

LAB 6: ADVANCED SCENARIO

I. Network diagram:

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 1/6 
CCNA LAB WORKBOOK  EIGRP 

II. Initial Configuration


R1:
hostname R1
!
!
interface Loopback0
ip address 1.2.3.1 255.255.255.0
!
interface Loopback1
ip address 10.1.4.1 255.255.252.0
!
interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end
R2:
hostname R2
!
!
interface Loopback0
ip address 2.3.4.2 255.255.255.0
!
interface Loopback1
ip address 10.1.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.12.2 255.255.255.0
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 2/6 
CCNA LAB WORKBOOK  EIGRP 

line vty 0 4
exec-timeout 0 0
logging synchronous
password cisco
login
!
!
end

III. Tasks:
1. Configure EIGRP on the network according to the outputs of the show command below:
R1:
R1#show ip route eigrp
D 2.0.0.0/8 [90/256000] via 10.1.12.2, 00:01:38, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.1.2.0/24 [90/256000] via 10.1.12.2, 00:01:38, FastEthernet0/0
R1#

R1#show ip protocols
Routing Protocol is "eigrp 20"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=0, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 20
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 1
Routing for Networks:
1.0.0.0
10.0.0.0
Passive Interface(s):
Loopback0
Loopback1
Routing Information Sources:
Gateway Distance Last Update
(this router) 90 00:01:47
10.1.12.2 90 00:01:41
Distance: internal 90 external 170

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 3/6 
CCNA LAB WORKBOOK  EIGRP 

R2:
R2#show ip route eigrp
1.0.0.0/24 is subnetted, 1 subnets
D 1.2.3.0 [90/256000] via 10.1.12.1, 00:01:22, FastEthernet0/0
2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 2.0.0.0/8 is a summary, 00:02:13, Null0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.1.4.0/22 [90/256000] via 10.1.12.1, 00:01:22, FastEthernet0/0
R2#

R2#show ip protocols
Routing Protocol is "eigrp 20"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=0, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 20
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is in effect
Automatic address summarization:
2.0.0.0/8 for FastEthernet0/0
Summarizing with metric 256
Maximum path: 3
Routing for Networks:
0.0.0.0
Passive Interface(s):
Loopback0
Loopback1
Routing Information Sources:
Gateway Distance Last Update
(this router) 90 00:02:37
Gateway Distance Last Update
10.1.12.1 90 00:01:44
Distance: internal 90 external 170

R2#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 4/6 
CCNA LAB WORKBOOK  EIGRP 

IV. Solutions:
Task 1:

R1:
R1#conf t
R1(config)#router eigrp 20
R1(config-router)#network 10.0.0.0
R1(config-router)#network 1.0.0.0
R1(config-router)#passive-interface loopback 0
R1(config-router)#passive-interface loopback 1
R1(config-router)#metric weights 0 1 0 0 0 0
R1(config-router)#maximum-paths 1
R1(config-router)#no auto-summary
R1(config-router)#end
R1#
R2:
R2#conf t
R2(config)#router eigrp 20
R2(config-router)#network 0.0.0.0
R2(config-router)#passive-interface loopback 0
R2(config-router)#passive-interface loopback 1
R2(config-router)#metric weights 0 1 0 0 0 0
R2(config-router)#maximum-paths 3
R2(config-router)#^Z
R2#

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 5/6 
CCNA LAB WORKBOOK  EIGRP 

V. Links:
For more information about the commands used in this lab, use the following links:
1. auto-summary
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig1.html#wp1011
150
2. maximum-paths
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_pi1.html#wp10150
04
3. metric weights
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1011
716
4. network
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
165
5. passive-interface
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_o1g.html#w
p1036805
6. router eigrp
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
489
7. show ip eigrp neighbors
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1012
982
8. show ip eigrp topology
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1013
230
9. show ip route
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039689
10. show ip protocols
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_s3g.html#w
p1039132
11. variance
http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig2.html#wp1014
686

COPYRIGHT © 2009 MOHAMED OUAMER. ALL RIGHTS RESERVED 
HTTP://WWW.NETWORKEXPERTTRAINING.COM 
PAGE 6/6 

You might also like