You are on page 1of 27

# "Write erase"and then "Reload".

would you like to save initial configuration dialog [ Y/N]:no


would you like to terminate auto-install [Yes]:
press return to get started :

Router > enable


Router # configure terminal,
Router <configure># hostname delhi,
delhi <configure>#^Z
delhi # show version
delhi # show running-configure
delhi # config t
<config># banner motd #
Enter the text message. End with character #
WARNING !!! DO NOT ENTER !!! #
delhi < config># ^z
delhi # exit
Press return to enter [ENTER]
"Now you will find the banner appearing on the console."
delhi >en
delhi # config t
delhi < config># line console 0
" __ line # login
" #Password cisco
" # exit
<config># enable password cisco
" #line vty 0 4
" __line > # password topgun
delhi<config-line>#exit
delhi<config>#exit
delhi exit
Press return to enter[Enter]
WARNING!!! DO NOT ENTER!!!
User verification
Password: cisco
delhi<en
password: cisco
delhi# show running - config
Now you will find all the passwords clearly visible. Therefore to encrypt them:
delhi# config t
<config> # enable secret topgun
" # service password - encryption
" # ^z
delhi # show run
Now you get all the passwords visible in lthe encrypted formet
delhi # show ip interface brief
# config t
<config> # int ethernet 0
config __ if > # ip address 172.16.2. X 255.255.255
" # no shutdown
# description " CCNA Department"
#^z
delhi # show ip int brief
delhi # config t
delhi < config># line console 0
" ---line> # exec-timeout 3 0
# logging synchronous
# ^z
delhi#
Now open a new command prompt in your PC and telnet into delhi router directly by
knowing the "Vty'' password.

>telnet 172.16.2. X
User verification
password: topgun
delhi> en
password : topgun
delhi #
Now to load the configurations into NVRAM and have a backup into the TFTP server.
delhi # show startup- config
You will not find any config there,
delhi # copy running - config startup - config
# destination filename [ startup-config]: [ENTER]
delhi # sh startup-config
[ You will find the same-configuration as the running - config]
check the ip address of TFTP server. Let it be 172.16.2.3
delhi # ping 172.16.2.32
If it pings, then load config into it. For that
delhi # copy running - config tftp
[ Remote Hostname or IP add] : 172.16.2.32
destination file name [ delhi - config]: [ ENTER]
!!! files copied.
delhi # write erase
erasing nvram filesystem .......................[ confirm]: [ENTER]
[OK]
delhi # reload:
:
:
After it boots, again
Router> en
" # config t
<config> # int e 0
__if > # ip address 172.16.2. X 255.255.255
# no shut
# ^z
Router # 172.16.2.32 [ Tftp server]
of it pings then,
Router # copy tftp running - config
: 172.16.2.32
source filename : delhi-config
destination filename [running-config] :
Press
delhi# ^ < Ctrl+Shift+ 6> X
access # show sessions
" # show users
# disconnect
[ confirm] [ENTER]
# exit
..................................................................
X..........................................................

TOPOLOGY:

OBJECTIVE: To interconnect two different switched and create vlans to check the
flow of data trough it.
CONFIGURATION PARAMETERS:
VLAN-ID NAME PORTS PORTS
on 1900 on 2900
10 CCNA 1,2 1,2
20 CCNP 3,4 3,4
30 CCIE 5,6 10,11

Vtp domain- topgun


Vtp password -- cisco

Task 1 : setup the server switch ( catalyst 1900).

Step 1: Erase the nvramand then reload the switch.

Syntax : delete nvram

LAB:
Cat 1900# delete nvram
After it gers erased, it will ask menu based questions and then select [K] to
go to CLI.

Step 2: Setup the hostname for the catalyst.

Syntax: hostname <name>

LAB:
>enable
# config t
<config># hostname Cat 1900

Step 3: Check out whether some vlans are already existing in the switch.

Syntax : show vlan

LAB :
Cat 1900#show vlan
If some vlan already exist then you need to erase that. For that check
whether your switch is in server mode or not.

Syntax: show vtp

LAB:
Cat 1900#show vtp
If its in server mode then shift to next step else:

Syntax: vtp <mode>

LAB:
Cat1900(xonfig)#vtp server

Step 4: clear the existing vlans

Syntax: no vlan <vlan-id>

LAB:
Cat1900<config>#no vlan<number>
Here number = vlan id of the existing vlan.

Repeat this, till all the vlans get erased other than the factory default vlanl and
default vlans for token ring and fddi.

Step 5: Check whether the vlans have got erased or not.

Syntax: show vlan

LAB:
Cat 1900#show vlan
Step 6: Set up the vtp domain name and password for it.

Syntax: Vtp,domain-domain name>


Vtp password-password>

LAB:
Cat 1900<config>#vtpdomain topgun
Cat1900<config>#vtp password cisco

Step 7: Create the new vlans.

Syntax: vland<vlan-id>name <name>

LAB:
Cat1900<config>#vlan 10 name ccna
Cat1900<config>#vlan 20 name ccnp
Cat1900<config>#vlan 30 name ccie
Cat1900<config>#exit

Step 8: Check the newly created vlans.

Syntax: show vlan

LAB:
Cat1900#show vlan

Step 9: Set up the vlan membership in each of those required ports.

Syntax: interface<type><slot number>/<port number>


vlan-membership static <vlan-id>

LAB:
Cat1900<config>#int e0/1
Cat1900<config-if>#vlan-membership static 10
Cat1900<config>#int e0/2
Cat1900<config-if>#vlan-membership static 10
Cat1900<config>#int e0/3
Cat1900<config-if>#vlan-membership static 20
Cat1900<config># int e0/4
Cat1900<config-if>#vlan-membership static 20
Cat1900<config># int e0/5
Cat1900<config-if>#vlan-membership static 30
Cat1900<config># int e0/6
Cat1900<config-if>vlan-membership static 30

Step 10: Setup the trunk links

Syntax: interface <type><slot number>/<port number>


trunk <on/off>

LAB:
Cat1900<config>#int f0/26
Cat1900<config-if>#trunk on
Cat1900<config-if>#int f0/27
Cat1900<config-if>#trunk on

� TASK 2: Setup the client switch.(Cat 2900)

Step 1 : write erase and reload the client switch

LAB:
CAt2900#write erase
Then confirm the erasing of the nvram and then:
Cat 2900#reload

Step 2: Set up the hostname for the switch.

Syntax: hostname<name>

LAB:
Switch>enable
Switch#config t
Switch<config>#hostname Cat 2900
Cat 2900#

Step 3: Check if some vlans are already existing.

Syntax: show vlan

LAB:
Cat2900#show vlan
If some of them are existing apart from lthe factory default vlans, then erase
them. For that check whether your switch is in the server mode or not.

Cat2900#show vtp status


If not in the server mode then :

Syntax: vlan database

LAB:
Cat2900#vlan database

Syntax: #apply

LAB:
Cat2900<vlan>#vtp server

Syntax : #apply

LAB:
Cat2900<vlan>#apply
Now remove all those vlans
Cat2900<vlan>#no vlan <vlan-id>
Here vlan-id is the number which you see when "show vlan "is done.

Now check again if those vlans are erased or not.

Cat2900#show vlan

Step 4: set up the vtp domain and the vtp password.


Syntax: vtp domain <domain name> password <password>

LAB:
Cat2900#vlan database
Cat2900<vlan>#vtp domain topgun password cisco
Cat2900<vlan>#applys

Step 5: now change the vtp mode to client mode.

Syntax: vtp<mode>

LAB:
Cat2900<vlan>#vtp client
Cat2900<vlan>#exit

Step 6: set up the trunk link for the connection between 2 switches to get the vlan
information form the server switch into the client switch.

Syntax: switchport trunk encapsulation <options>


switchport mode trunk

LAB:
Cat2900<config>#int f0/23
Cat2900<config-if>#switchport trunk encapsulation isl
Cat2900<config-if>#switchport mode trunk
Cat2900<config-if>#int f0/24
Cat2900<config-if>#switchport trunk encapasulation isl
Cat2900<config-if>3switchport mode trunk

Step 7: set ip the trunklink physical connectivity between the 2 switches with a
cross-over cable

Step 8: Check whether the switch got the vlan information from lthe server.

LAB:
Cat2900#show vlan
You must be able to see the entire vlan information in the client switch Cat2900.

Step 9: Assign the ports to the vlans,

Syntax: interface<type><slot number>/<port number>


switchport access vlan <vlan-id>

LAB:
Cat2900<config>#int f0/1
Cat2900<config-if>#switchport access vlan 10
Cat2900<config-if>#int f0/2
Cat2900<config-if>#switchport access vlan 10
Cat2900<config-if>#int f0/3
Cat2900<config-if>#switchport access vlan 20
Cat2900<config-if>#int f0/4
Cat2900<config-if>#switchport access vlan 20
Cat2900<config-if>#int f0/10
Cat2900<config-if>#switchport access vlan 30
Cat2900<config-if>#int f0/11
Cat2900<config-if>#switchport access vlan 30
Step 10: After configuring this connesct pc 1 and pc 2 to port 1 and 3 of Cat1900
and pc 3 to port 1 of Cat2900. Pc1 will ping pc 3 as they belong to same vlan to
but pc 2 will not ping pc 3

LAB: IPX ROUTING AND IMPLEMENTING IPX ACCESS-LIST

TOPOLOGY:

OBJECTIVE:
To set up the network with ipx as the routing protocol and check the
routing table and sap advertisements through out the network.

CONFIGURATION PARAMETERS:

Network addresses:
CALCUTTA Router: int e0/0.1 - 10a
int e0/0.2 - 20b
BOMBAY Router: int e0 - 10a
int s0 - 30c
BBONE Router : int e0 - 20b
int s0 - 30c

Encapsulation type :
Network 10a - arpa
Network 20b - novell-ether
Network 30c - hdlc

Step 1: Enable ipx routing in all the routers of the network.

Syntax : ipx routing


LAB:
Calcutta<config>#ipx routing
Bombay<config>#ipx routing
Bbone<config>#ipx routing

Step 2 : Set up the network and the encapsulation type at each interface of the
routers.

Syntax : ipx network <network> [node][encapsulation][<encapsulation>]

LAB:
Bombay<config>#int e0
Bombay<config-if>#ipx network 10a encapsulation arpa
Bombay<config-if>#no shutdown
Bombay<config-if>#int s0
Bombay<config-if>#ipx network 30c encapsulation hdlc
Bombay<config-if>#no shut

Calcutta<config>#int e0/0.1
Calcutta<config-subif>#ipx network 10a encapsulation arpa
Calcutta<config-subif>#int e0/0.2
Calcutta<config-subif>#ipx network 20b encapsulation novell-ether
Calcutta<config-subif>#exit
Calcutta<config>#int e0/P
Calcutta<config-if>#no shutdown

Bbone<config>#int e0
Bbone<colnfig-if>#ipx network 20b encapsulation novell-ether
Bbone<config-if>no shutdown
Bbone<config-if>#int s0
Bbone<config-if>#ipx network 30c encapsulation hdlc
Bbone<config-if>#no shutdown

Step 1 : Enable ipx routing in all the routers of the network.

Syntax : ipx routing

LAB :
Calcutta<config>#ipx routing
Bombay<config>#ipx routing
Bbone<config>#ipx routing

Step 2 : Set up the network and the encapsulation type ateach interface of the
routers.

Syntax : ipx network <network>[node][encapsulation][<encapsulation>]

LAB:

Bombay<config>#int e0
Bombay<config-if>#ipx network 10a encapsulation arpa
Bombay<config-if>#no shutdown
Bombay<config-if>#int s0
Bombay<config-if>ipx network 30c encapsulation hdlc
Bombay<config-if>#no shut

Calcutta<config>#int e0/0.1
Calcutta<config-subif>#ipx network 10a encapsulation arpa
Calcutta<config-subif>#int e0/0.2
Calcutta<conifg-subif>#ipx network 20b encapsulation novell-ether
Calcutta<config-subif>#exit
Calcutta<config>#int e0
Calcutta<config-if>#no shutdown

Bbone<config>#int e0
Bbone<config-if>#ipx network 20b encapsulation novell-ether
Bbone<config-if>#no shutdown
Bbone<config-if>#ipx network 30c encapsulation hdlc
Bbone<config-if>#no shutdown

Step 3 : Check the interface are up or not and thereby check the routing table.

Syntax : show <options> interface brief


show <options> route
LAB :
Calcutta#show ipx interface brief
Calcutta#show ipx route

Bombay#show ipx interface brief


Bombay#show ipx route

Bbone#show ipx interface brief


Bbone#show ipx route

Step 4 : To generate SAP packets in the network.

Syntax : ipx sap <service type> <server name> <network node><socket number> <hop
count>

LAB:
Bbone<config>#ipx sap 4 File 1 10a 001a.001b.001c 33 4
Bbone<config>#ipx sap 7 Print 1 20b 002a.002b.002c 34 5

Step 5 : To check the sap table .

Syntax : show ipx servers

LAB :
Bbone#show ipx servers

Calcutta#show ipx servers

Bombay #show ipx servers

Step 6 : To block some sap entries in Bombay router with sap filters. For that
create the sap filter in the router by implementing an access-list and then apply
than in the required interface.

Syntax : access-list<1000-1099>{permit/deny} <network address><service type>

int <type><number>
ipx<{input/output}-sap-filter><access-list number>

LAB:
Bombay<config>#access-list 1001 deny - 1 4
[Note : here - 1 implies any network]
Bombay<config>#int e0
Bombay<config>#ipx input-sap-filter 1001
Bombay<config>#int s0
Bombay<config>#ipx input-sap-filter 1001

Step 7 : Check the new sap table in the router Bbone

LAB:
Bbone#show ipx servers ]
[Note: Some times you may see the old sap table so clear the exsisting sap
table and then see the new one which will appear after 60 seconds.

Bbone#clear ipx sap*


Then again check the sap table, You should not find any entry of service type
4.
Bbone#show ipx servers.

ACCESS CONTROL LISTS


TOPOLOGY:
OBJECTIVE:

Implementing standard and extended access-list to secure your network.

EXTRA HARDWARE ATTACHMENTS : 4 PCs.

2 attached to DELHI : 1st PC : Name - A


IP address -- 10.0.0.5 /24
Default gateway -- 10.0.0.1 /24
2nd PC : Name - B
IPaddress -- 10.0.0.10 /24
Default gateway -- 10.0.0.1 /24

2 attached to BOMBAY : 1st PC: Name --C


IP address --20.0.0.5 /24
Default gateway -- 20.0.0.1 /24
2nd PC: Name --D
IP address -- 20.0.0.10 /24
Default gateway -- 20.0.0.1 /24

TASK 1 : Block A from sending any packet out of DELHI.

Step 1 >Create a standard access-list to deny source A

Syntax : access -list <access-list number (1-99)>{permit/deny}<source


address><wildcard mask>

LAB:

Delhi<config>#access-list 1 deny 10.0.0.5 0.0.0.0

Delhi<config>#access-list 1 permit any

Step 2> Apply the access-list to the serial interface in the outbound direction.

Syntax : interface <type> <number>


ip access-group <access-list number><in/out>

LAB:
Delhi<config>#int s0
Delhi<config-if>#ip access-group 1 out

Step 3>Testing and verification by pinging any interface outside Delhi network.

LAB:
Delhi<cinfig>#ping 200.0.0.6
TASK 2 : Block any network other than 20.0.0.0 trying to telnet into Bombay.

Step 1> Create a standard access-list in Bombay to allow only network 20.0.0.0

Syntax : access-list <number> {permit/deny} <source addrss><widcard mask>

LAB:
Bombay<config>#access-list 2 permit 20.0.0.0 0.0.0.255

Step 2> Create a telnet session by opening vty lines and set kup vty password and
enable password to open a valid telnet session.

Syntax: line vty 0<0-4>


login
password< password>
enable password <password>
LAB:
Bombay<config>#line vty 0.4
Bombay<config-line>login
Bombay<config-line>#password cisco
Bombay<config-line>#exit
Bombay<config>#enable password topgun

Step 3> Apply the access list to the vty lines.

Syntax: access-class <access-list number><in/out>

LAB:
Bombay <config>#line vty 0 4
Bombay<config-line> #access class in

Step 4> Test by tring to telnet from any pc of any network other than 20.0.0.0

Syntax: telnet <ip address>

LAB:
From pc A or B do:
telnet 201.0.0.2

TASK 3: Create an extended access-list to block icmp packets from B to D.

Step 1> Create an access-list in the Delhi router to block icmp packets coming from
B and going to D. Permit rest of the ip traffic.

Syntax: access-list<number (100-199)>{permit/deny}<source address><wild card


mask> <destination address> <wildcard mask><kOperator Operand>

LAB:
Delhi<config>#access-list 100 deny icmp 10.0.0.0. 0.0.0.0 20.0.0.0. echo
Delhi<config>#access-list 100 deny icmp 10.0.0.0. 0.0.0.0 20.0.0.0. echo-
reply
Delhi<config>#access-list 100 permit ip any any

Step 2> Apply this access-list to the Ethernet interface of Delhi.

Syntax: ip access-group <access-list number><in/out>s

LAB:
Delhi<config>#int e0
Delhi<config-if>#ip access-group 100 in

Step 3> Test and verify.

Syntax: Ping

LAB:
From pc B,
ping 20.0.0.10

TASK 4: Make D as the FTP server and then block B from doing FTP to D.

Step 1> Create an extended access-list to deny FTP in Delhi router. Permit rest of
the ip traffic.

Syntax : access-list < number (100-199)>{permit/deny}< source address><wildcard


mask><destination address><wildcard mask><Operator operand>

LAB :

Delhi<config>#access-list 101 deny tcp 10.0.0.10.0.0.0.0 20.0.0.10 0.0.0.0


eq
21
Delhi<config>#access-list 101 deny tcp 10.0.0.10.0.0.0.0 20.0.0.10 0.0.0.0
eq
20
Delhi<config>#access-list 101 permit ip any any

Step 2>Repeat step2 of TASk 3.

LAB :

Delhi<config>#int e0
Delhi<config-if>#ip access-group 101 in

Step 3>Test and verify.

LAB :

From the command prompt of PC B:


ftp 20.0.0.10

......................................................................X............
...........................................................

ROUTING --Static, Default, RIP & IGRP

TOPOLOGY :

OBJECTIVE :
To setup the routing in between routers remotely connected to each other by
enabling static or dynamic routing protocols. (Static, default, RIP, IGRP).

CONFIGURATION PARAMETERS:

DELHI Router : Ethernet interface - 10.0.0.1 /24


Serial 0 interface -- 200.0.0.5 /30
BBONE Router : Ethernet interface --30.0.0.1 /24
Serial 1 interface -- 200.0.0.6 /30
Serial 0 interface -- 201.0.0.1 /30
BOMBAY Router : Ethernet interface --20.0.0.1 /24
Serial 0 interface -- 201.0.0.2 /30
BBONE : Serial 0 and Serial 1 are DCE cable ends.

Autonomous system number for IGRP -- 100

TASK 1 : General router setup.

Step 1 > Setting the routers with their hostnames.

Syntax : hostname < name>

LAB :
Router<config>#hostname Delhi
Router<config>#hostname Bombay
Router<config>#hostname Bbone

Step 2 > Giving ip address to all the required interfaces and bring them up.

Syntax : ip address <address> <subnet mask>


Syntax : no shutdown

LAB :

Delhi<config>#interface Ethernet 0
Delhi<config-if>#ip address 10.0.0.1 255.255.255.0
Delhi<config-if>#no shut
Delhi<config-if>#interface s0
Delhi<config-if>#ip address 200.0.0.5 255.255.255.252
Delhi<config-if>#no shut

Bombay<config>#int e0
Bombay<config-if>#ip address 20.0.0.1 255.255.255.0
Bombay<config-if>#no shut
Bombay<config-if>#int s0
Bombay<config-if>#ip address 201.0.0.2 255.255.255.252
Bombay<config-if>#no shut

Bbone<config>#int e0
Bbone<config-if>#ip address 172.16/20 255.255.255.0
Bbone<config-if>#no shut
Bbone<config-if>#int s0
Bbone<config-if>#ip address 201.0.0.1 255.255.255.252
Bbone<config-if>#no shut
Bbone<config-if># int s1
Bbone<config-if>#ip address 200.0.0.6 255.255.255.252
Bbone<config-if>#no shut
Step 3>Assign clock rate to the DCE interfaces.

Syntax : clock rate <options>

LAB :
Bbone<config>#int s0
Bbone<config-if>#clock rate 64000
Bbone<config>#int s1

TASK 2 :Verify all the interfaces of the routers are administratively up or not.

Step 1> Check all the interface status.

Syntax : show ip interface brief.

LAB :

Bbone# show ip interface brief

Bombay#show ip interface brief

Delhi# show ip interface brief

TASK 3 : Enable static routing in all the routers.

Step 1> Check the routing table to see the directly connected networks.

Syntax : show ip route

LAB:
Bbone#show ip route

Bombay# show ip route

Delhi# show ip route

Step 2> Manually enter routers to the unknown networks.

Syntax : ip route <destination network ip address > < subnet mask ><next hop ip
address/ outgoing interface>

LAB:

Bombay<config># ip route 10.0.0.0. 255.255.255.0 201.0.0.1


Bombay<config># ip route 200.0.0.0.255.255.255.252.201.0.0.1
Bombay<config># ip route 30.0.0.0. 255.255.255. 201.0.0.1

Delhi<config># ip route 20.0.0.0 255.255.255. 200.0.0.6


Delhi<config># ip route 201.0.0.0 255.255.255.255 200.0.0.6
Delhi<config># ip route 30.0.0.0 255.255.255. 200.0.0.6

Step 3 > Recheck the new routing table by repeating step 1 of TASK 3.

Step 4> Test thhe Connectivity to the remote interfaces.

Syntax : Ping < host in address >


LAB :

Delhi #ping 172.16.2.0.


Delhi #ping 20.0.0.1

Bbone # ping 10.0.0.1


Bbone # ping 20.0.0.1

Bombay # ping 10.0.0.1


Bombay # ping 172.16.2.0

TASK 4: Enable default routing for the stub networks.

Step1 > Remove the static route entries from the router DELHI and BOMBAY as they
are stubnetworks.

Syntax:
no ip route < destination network ip address > < subnet mask> < next
hop ip address/ outgoing interface>

LAB:

Delhi<config># no ip route 20.0.0.0 255.255.255.0 200.0.0.6


Delhi<config># no ip route 201.0.0.0 255.255.255.252 200.0.0.6
Delhi<config># no ip route 30.0.0.0 255.255.255.0 200.0.0.6

Bombay<config># no ip route 10.0.0.0 255.255.255.0


201.0.0.1
Bombay<config># no ip route 200.0.0.0 255.255.255.252 201.0.0.1
Bombay<config># no ip route 30.0.0.0 255.255.255.0 201.0.0.1

Step 2> Enable default routing in the rounters belonging tgo stub networks (Delhi
and Bombay ),

Syntax: ip route 0.0.0.0.0.0.0.0 < next hop in address>

LAB:

Delhi <config> # ip rounte 0.0.0.0 0.0.0.0 200.0.0.6


Bombay <config> # ip route 0.0.0.0 0.0.0.0 201.0.0.1
Bbone route should not be erased it should have route.

Step 3> Repeat step3 and step4 of TASK 3.

TASK 5: Enable RIP as the dynamic routing.

Step 1 > Remove all the existing static and dyanamic routes from the routers in
Delhi and Bombay.

Syntax : no ip rounte 0.0.0.0.0.0.0.0 <next hopo in address / outgoing


interface>

LAB:

Delhi <config># no ip route 0.0.0.0 0.0.0.0 200.0.0.6

Bombay<config># no ip route 0.0.0.0 0.0.0.0 201.0.0.1


In Bbone:

Syntax : no ip route <destination network in address > < subnet mask > <next hop
in address/ outgoing interface>

LAB:

Bbone <Config>#no ip route 20.0.0.0 255.255.255.0 201.0.0.2


Bbone <Config>#no ip route 10.0.0.0 255.255.255.0 200.0.0.5

Step 2 > Enable rip in all the rounters.

Syntax : rounter rip

LAB:
Delhi<config>#router rip
Bombay <config># router rip
Bbone<config># router rip

Step 3> Advertise the directly connected networks.

Syntax : network < network ip address>

LAB :

Delhi < config-router>#network 10.0.0.0


Delhi <config-router>#network 200.0.0.0

Bombay< config-router>#network 10.0.0.0


Bombay< config-router>#network 201.0.0.0

Bbone < config-router>#network 30.0.0.0


Bbone < config-router>#network 200.0.0.0
Bbone < config-router>#network 201.0.0.0

Note : While enabling IGRP in the system we need not remove the rip commands from
the routers as the rip entries will get automatically replaced by the igrp entries
as igrp has lower administrative distance than that of the rip.

Bbone#<debug ip rip >


Bbone#<no debug all>
Bbone#Sh ip protocal

debug igrp transactions. [ Display IGRP trans table]


debug igrp events
debug ip igrp events.
debug ip igrp trans.

router rip C Rip configuration


events and trans.
flushed after?

LAB: ISDN AND FRAME-RELAY


TOPOLOGY:

OBJECTIVE : To setup your network for isdn connection as well as for the frame-
relay.

CONFIGURATION PARAMETERS:

ISDN switch type - basic dmx 100

DELHI Router : Int e0 - 50.0.0.1 /24


Int s0 - 200.0.0.1 /24
Int bri0 - 100.0.0.1 /24
SPID number 5551000001
For 200.0.0.2 DLCI --100
For 200.0.0.3 DLCI --100
BOMBAY Router: Int e0 - 60.0.0.1 /24
Int s0 - 200.0.0.2 /24
Int bri0 - 100.0.0.2 /24
SPID number: 5552000001
For 200.0.0.1 DLCI --200
For 200.0.0.3F DLCI --201
FRSWITCH Router: Int e0 --70.0.0.1 /24
Int s0 -- 200.0.0.2 /24
For 200.0.0.1 DLCI=300
For 200.0.0.2 DLCI= 301

ISDN LAB:

Step 1 : Set up all the interfaces of all the routers and check whether they are up
or not.

LAB:

Delhi<config>#int e0
Delhi<config-if>#ip address 50.0.0.1.255.255.255.0
Delhi<config-if>#no shut
Delhi<config-if>#int so
Delhi<config-if>#ip address 200.0.0.1.255.255.255.0
Delhi<config-if>#no shut
Delhi<config-if>#int bri 0
Delhi<config-if>#ip address 100.0.0.1.255.255.255.0
Delhi<config-if>#no shut

Bombay<config>#int e0
Bombay<config-if>#ip address 60.0.0.1.255.255.255.0
Bombay<config-if>#no shut
Bombay<config-if>#int s0
Bombay<config-if>#ip address 200.0.0.2.255.255.255.0
Bombay<config-if>#no shut
Bombay<config-if>#int bri 0
Bombay<config-if>#ip address 100.0.0.2.255.255.255.0
Bombay<config-if>#no shut

Frswitch<config>#int e0
Frswitch<config-if>#ip address 70.0.0.1.255.255.255.0
Frswitch<config-if>#no shut
Frswitch<config-if>#int s0
Frswitch<config-if>#ip address 200.0.0.3.255.255.255.0
Frswitch<config-if>#no shut

Step 2 : Setup routing to all the networks.

Syntax : ip route <destination network ip address > < subnet mask> <next Hop ip
address>

LAB:

Delhi<config>#ip route 60.0.0.0 255.255.255.0 100.0.0.2


Delhi<config>#ip route 60.0.0.0 255.255.255.0 200.0.0.2
Delhi<config>#ip route 70.0.0.0 255.255.255.0 200.0.0.3

Bombay<config>#ip route 50.0.0.0 255.255.255.0 100.0.0.1


Bombay<config>#ip route 50.0.0.0 255.255.255.0 200.0.0.1
Bombay<config>#ip route 60.0.0.0 255.255.255.0 100.0.0.3

Frswitch<config>#ip route 50.0.0.0 255.255.255.0 200.0.0.1


Frswitch<config>#ip route 60.0.0.0 255.255.255.0 200.0.0.2

Step 3 : Configure the isdn switch type and enable encapsulation as ppp in the bri
interface and authentication type as chap.

Syntax : isdn switch-type basic-dms100


encapsulation ppp
ppp authentication chap

LAB :

Delhi<config>#isdn switch-type basic-dms 100


Delhi<config>#int bri0
Delhi<config-if>#encapsulation ppp
Delhi<config-if>#ppp authentication chap

Bombay<config>#isdn switch-type basic-dms 100


Bombay<config>#int bri0
Bombay<config-if>#encapsulation ppp
Bombay<config-if>#ppp authentication chap

Step 4 : set up the username and password for chap authentication

Syntax : username <name>password <password>

Note: Username and password is case sensitive Name is the hostname of the router
on the other side.
LAB:
Delhi<config>#username Bombay password cisco

Delhi<config>#username Delhi password cisco

Step 5: Set up a dialer-list to describe the interesting traffic Apply that in the
bri interface.

Syntax : dialer-list <number>protocol<protocol>{permit/deny}[list] [access-list


number]

int bri 0
dialer-group <dialer-list number>

LAB:

Delhi<config>#dialer-list 1 protocol ip permit


Delhi<config>#int bri0
Delhi<config-if>#dialer-group 1

Bombay<config>#dialer-list 1 protocol ip permit


Bombay<config>#int bri0
Bombay<config-if>#dialer-group 1

Step 6: Set up a dialer information by declaring your router's spid number and
setting a dialer map.

Syntax: isdn spid1 <number >


dialer map ip <ip address> name <name><spid number>

LAB:

Delhi<config>#int bri0
Delhi<config-if>#ISDN SPID 1 5551000001
Delhi<config-if>#dialer map ip 100.0.0.2 name Bombay 5552000001
Delhi<config-if>#no shut

Bombay<config>#int bri0
Bombay<config-if>#ISDN SPID 1 5552000001
Bombay<config-if>#dialer map ip 100.0.0.1 name Bombay 5551000001
Bombay<config-if>#no shut

Step 7: Check the isdn connection is trough or not.

Syntax: ping

LAB:

Delhi#ping 100.0.0.2
Bombay#ping 100.0.0.1

FRAME-RELAY LAB:

Step 1 : Enable encapsulation as frame-relay in all the serial interfaces.


Syntax: encapsulation frame-relay

LAB:

Delhi<config>#int s0
Delhi<config-if>#encapsulation frame-relay

Bombay<config>#int s0
Bombay<config-if>#encapsulation frame-relay

Step 2 : Set up the frame-relay maps.

Syntax: frame-relay map ip <ip address.<local-dlci number>[broadcast]

LAB:

Delhi<config>#int s0
Delhi<config-if>#frame-relay map ip 200.0.0.2 100 broadcast
Delhi<config-if>#frame-relay map ip 200.0.0.3 101 broadcast

Bombay<config>#int s0
Bombay<config-if>#frame-relay map ip 200.0.0.1 200 broadcast
Bombay<config-if>#frame-relay map ip 200.0.0.3 201 broadcast

Frswitch<config>#int s0
Frswitch<config-if>#frame-relay map ip 200.0.0.1 300 broadcast
Frswitch<config-if>#frame-relay map ip 200.0.0.2 301 broadcast

Step 3 : Check the connectivity.

Syntax : ping
trace

LAB:

Delhi#ping 60.0.0.1
Delhi#ping 70.0.0.1

Bombay#ping 70.0.0.1
Bombay#ping 50.0.01

Frswitch#ping 50.0.0.1
Frswitch#ping 60.0.0.1

Note : Check the interfaces by giving "show ip int brief" command. If both
the interfaces bri0 and s0 are up then load sharing will occur when you ping
bombay's network from delhi and vice versa. To stop that happenign shut dowb any
one interface while pinging like shut down bri interface and then kping through
serial interface.

You might also like