You are on page 1of 17

26 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ

2.39
Κεφάλαιο 2ο
Ποια είναι η μορφή της σύνθετης επιλογής και που χρησιμοποιείται;
Η συνθέτη επιλογή είναι: Η Συνθήκη είναι
• παράσταση ή
Αν Συνθήκη τότε
•μια λογική μεταβλητή.
Ομάδα Εντολών 1 Και μόνο όταν είναι αληθής μπορούν να
εκτελεστούν
Αλλιώς Ομάδα Εντολών 1 που βρίσκονται στο σώμα
Ομάδα Εντολών 2 της.
Τέλος_αν Διαφορετικά αν δηλ είναι ψευδής η συνθήκη
Θα εκτελεστεί η Ομάδα Εντολών 2

Η σύνθετη επιλογή χρησιμοποιείται όταν έχουμε
να εκτελέσουμε μια διαφορετική ομάδα εντολών
που εξαρτώνται από δύο αντίθετες συνθήκες.
27 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.40
Κεφάλαιο 2ο
Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθεί σαν είσοδος η τιμή
1)7,
2) 0 και Θα μπορούσα να το έγραφα έτσι:
3)-7 Αλγόριθμος Παράδειγμα_V
Εμφάνισε “Δώσε τιμή για το α”
Διάβασε α
τ ο
Διάβασε α
κέ
πα
Αν α>0 τότε
Εμφάνισε “Μεγαλύτερο του 0”
Αλλιώς
Εμφάνισε “Μικρότερο ή ίσο του 0”
Τέλος_αν
Τέλος Παράδειγμα_V
1) Η εντολή Διάβασε α εκχωρεί στη μεταβλητή α την τιμή 7 7
Μεγαλύτερο
Η επόμενη εντολή είναι Σύνθετη επιλογή. του 0

Ελέγχει αν η α έχει τιμή μεγαλύτερη από την τιμή 0.
Η συνθήκη είναι αληθής οπότε οι εντολές που βρίσκονται μεταξύ του
Αν … τότε και Αλλιώς θα εκτελεστούν
Κατόπιν θα συνεχιστεί η εκτέλεση του αλγορίθμου μετά το Τέλος_άν
Που τυγχάνει να είναι και το τέλος του αλγορίθμου
28 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.40
Κεφάλαιο 2ο
Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθεί σαν είσοδος η τιμή
1)7,
2) 0 και
3)-7 Αλγόριθμος Παράδειγμα_V
Διάβασε α
Αν α>0 τότε
Εμφάνισε “Μεγαλύτερο του 0”
Αλλιώς
Εμφάνισε “Μικρότερο ή ίσο του 0”
Τέλος_αν
0
Τέλος Παράδειγμα_V Μικρότερο ή
ίσο του 0
1) Η εντολή Διάβασε α εκχωρεί στη μεταβλητή α την τιμή 0
Η επόμενη εντολή είναι Σύνθετη επιλογή.
Ελέγχει αν η α έχει τιμή μεγαλύτερη από την τιμή 0.
Η συνθήκη είναι ψευδής οπότε οι εντολές που βρίσκονται μεταξύ του
Αν … τότε και Αλλιώς δεν θα εκτελεστούν
Κατόπιν θα συνεχιστεί η εκτέλεση του αλγορίθμου μετά το Αλλιώς μέχρι το Τέλος_αν
Και θα εμφανιστεί το μήνυμα: Μικρότερο ή ίσο του 0
Και τελειώνει ο αλγόριθμος
29 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.40
Κεφάλαιο 2ο
Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθεί σαν είσοδος η τιμή
1)7,
2) 0 και
3)-7 Αλγόριθμος Παράδειγμα_V
Διάβασε α
Αν α>0 τότε
Εμφάνισε “Μεγαλύτερο του 0”
Αλλιώς
Εμφάνισε “Μικρότερο ή ίσο του 0”
Τέλος_αν
-7
Τέλος Παράδειγμα_V Μικρότερο ή
ίσο του 0
1) Η εντολή Διάβασε α εκχωρεί στη μεταβλητή α την τιμή - 7
Η επόμενη εντολή είναι Σύνθετη επιλογή.
Ελέγχει αν η α έχει τιμή μεγαλύτερη από την τιμή 0.
Η συνθήκη είναι ψευδής οπότε οι εντολές που βρίσκονται μεταξύ του
Αν … τότε και Αλλιώς δεν θα εκτελεστούν
Κατόπιν θα συνεχιστεί η εκτέλεση του αλγορίθμου μετά το Αλλιώς μέχρι το Τέλος_αν
Και θα εμφανιστεί το μήνυμα: Μικρότερο ή ίσο του 0
Και τελειώνει ο αλγόριθμος
30 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.41
Κεφάλαιο 2ο
Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθεί σαν είσοδοι οι τιμές
1)15, -15.
Θα μπορούσα να το έγραφα έτσι:
Αλγόριθμος Παράδειγμα_Ψ
Εμφάνισε “Δώσε τιμή για το α,β”
Διάβασε α,β
τ ο
Αν α > 0 και β + 50 – α ≠0 τότε
Διάβασε α,β
κέ
Εμφάνισε “Περίπτωση Α” 15 -15
πα
Περίπτωση Α
Αλλιώς Το α*β ισούται
Εμφάνισε “Περίπτωση Β” με -225

Τέλος_αν
Εμφάνισε “Το α*β ισούται με”, α*β
Τέλος Παράδειγμα_Ψ
1) Η εντολή Διάβασε α,β εκχωρεί στη μεταβλητή α την τιμή 15 και στη β την τιμή -15.
Η επόμενη εντολή είναι Σύνθετη επιλογή.
Ελέγχει αν η α έχει τιμή μεγαλύτερη από την τιμή 0 και αν β+50-10≠0 ισχύει.
Η συνθήκη είναι αληθής οπότε οι εντολές που βρίσκονται μεταξύ του
Αν … τότε και Αλλιώς θα εκτελεστούν.
Κατόπιν θα συνεχιστεί η εκτέλεση του αλγορίθμου μετά το Τέλος_άν
Στο τέλος θα τερματίζεται ο αλγόριθμος.
31 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.42 Κεφάλαιο 2ο
Να γραφεί η ακόλουθη γενική μορφή της σύνθετης επιλογής , κάνοντας χρήση
της δομής απλής επιλογής.
Η γενική μορφή της σύνθετης επιλογής είναι:

Αν Συνθήκη τότε Στη σύνθετη δομή επιλογής για να εκτελεστούν οι εντολές στο Αλλιώς,
Θα πρέπει η Συνθήκη στο Αν…τότε να είναι ψευδής.
Ομάδα εντολών1
Δηλ. στο Αλλιώς οδηγείται η εκτέλεση όταν ισχύει το όχι Συνθήκη,
Αλλιώς Η άρνηση δηλαδή της αρχικής συνθήκης.

Ομάδα εντολών 2
Τέλος_αν
Άρα η ισοδύναμη γενική μορφή της Σύνθετης επιλογής με χρήση της απλής επιλογής είναι:

Αν Συνθήκη τότε
Ομάδα εντολών1 Προσοχή έγραψα Αν όχι Συνθήκη
Για να δηλώσω το Αλλιώς(=2 επιλογές).
Τέλος_αν

Αν όχι Συνθήκη τότε
Ομάδα εντολών 2
Τέλος_αν
32 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.43
Κεφάλαιο 2ο
Να μετατραπεί ο ακόλουθος αλγόριθμος κάνοντας χρήση απλών επιλογών.
Ο ισοδύναμος αλγόριθμος είναι:

Αλγόριθμος Παράδειγμα_8 Αλγόριθμος Παράδειγμα_8
α ← 10 α ← 10
Αν α >2 0 ή α/2>2 τότε Αν α >2 0 ή α/2>2 τότε
α ← α/2 - 10 α ← α/2 - 10
Εμφάνισε “α=”,α Εμφάνισε “α=”,α
Αλλιώς Τέλος_αν
Αν όχι (α>20 ή α/2>2) τότε
α ← -10*α α ← -10*α
Εμφάνισε “α=”,α Εμφάνισε “α=”,α
Τέλος_αν Τέλος_αν
Τέλος Παράδειγμα_8 Τέλος Παράδειγμα_8

Μία σύνθετη επιλογή. Δύο απλές επιλογές.
33 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.44
Κεφάλαιο 2ο
Να γραφεί με διάγραμμα ροής ο ακόλουθος αλγόριθμος.
Αρχή
Αλγόριθμος Παράδειγμα_Ω
Διάβασε α,β
Διάβασε α,β
Αν α >β τότε
Εμφάνισε α
Αλλιώς α>β

Εμφάνισε β Ναι Όχι

Τέλος_αν
α β

Τέλος Παράδειγμα_Ω

Τέλος

Το Αν…τότε αντικαθίσταται με έναν ρόμβο,
Ενώ το Τέλος_αν δεν εμφανίζεται στο διάγραμμα ροής.
Στην σύνθετη επιλογή χρησιμοποιούμε ρόμβο απ΄όπου ξεκινούν δύο βελάκια.
Ναι Όχι
α>β
34 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.45 Κεφάλαιο 2ο
Να μετατραπεί το ακόλουθο διάγραμμα ροής σε ψευδοκώδικα.
Αρχή
Στο διάγραμμα ροής υπάρχουν 2 ρόμβοι.
Άρα ο αλγόριθμος έχει 2 επιλογές.
Διάβασε α,β Η πρώτη επιλογή δεν περιέχει εντολές στο όχι.
Άρα είναι απλή επιλογή.
α≠β
Η δεύτερη επιλογή περιέχει εντολές στο όχι ,άρα υπάρχει μια σύνθετη
επιλογή (2 βελάκια):
Ναι
Ο ψευδοκώδικας είναι: Αλγόριθμος Παράδειγμα_Δ
β ← α-2

Διάβασε α,β
α≥β τότε
Ναι Όχι Αν α≠β

β ← α-2
Εμφάνισε α Εμφάνισε β Τέλος_αν
Αν α≥β τότε
Εμφάνισε α
Τέλος Αλλιώς
Εμφάνισε β

Τέλος_αν

Τέλος Παράδειγμα_Δ
35 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.46
Κεφάλαιο 2ο
Ποιος από τους δύο παρακάτω αλγόριθμους είναι πιο αποτελεσματικός,δηλ
εκτελεί λιγότερες ενέργειες ;
Αλγόριθμος Παράδειγμα_Α Αλγόριθμος Παράδειγμα_Α
Διάβασε α,β Διάβασε α,β
Αν α >β και α+β>20 τότε Αν α >β και α+β>20 τότε
Εμφάνισε α,β Εμφάνισε α,β
Αλλιώς Τέλος_αν
Εμφάνισε β,α Αν όχι α >β και α+β>20 τότε
Τέλος_αν Εμφάνισε β,α
Τέλος_αν
Τέλος Παράδειγμα_Α
Τέλος Παράδειγμα_Α
Στο1ο αλγόριθμο γίνεται έλεγχος μία φορά μόνο. Στο 2ο αλγόριθμο αρχικά θα ελεγχθεί η
Αν ισχύει η συνθήκη θα εκτελεστούν οι εντολές πρώτη συνθήκη. Αν ισχύει θα
μεταξύ του Αν …. τότε και Αλλιώς . εκτελεστούν αλλιώς όχι.
Διαφορετικά θα εκτελεστούν οι εντολές μεταξύ του Σε κάθε περίπτωση η εκτέλεση του
Αλλιώς και Τέλος_αν αλγορίθμου θα συνεχίσει στη
δεύτερη επιλογή και θα γίνει πάλι
έλεγχος.
Αρα θα έχουμε 2 ελέγχους.
Συνεπώς ο 1ος αλγόριθμος θα είναι πιο αποτελεσματικός
36 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.47 Κεφάλαιο 2ο
Να γραφεί ένας αλγόριθμος που θα διαβάζει τρεις αριθμούς, θα τους συγκρίνει και θα εμφανίζει τον
μέγιστο.
Λύση
Η περίπτωση να συγκρίνουμε περισσότερους από
Αλγόριθμος Μέγιστος
2 αριθμούς είναι πιο δύσκολη.
Πρέπει να χωρίσουμε τη διαδικασία σε
βήματα,συγκρίνοντας τους αριθμούς ανά δύο. Εμφάνισε “Δώσε τρεις αριθμούς”
πάνε πακέτο.
Διάβασε α,β,γ
1ο Βήμα: Αρχικά θεωρούμε ότι ο μεγαλύτερος
αριθμός είναι ο πρώτος. max ← α
Τον εκχωρούμε σε μια μεταβλητή την οποία την
ονομάζουμε max.
Αν β > max τότε
2ο Βήμα: Συγκρίνουμε τον δεύτερο αριθμό με τον
max← β ….
μέχρι τώρα μεγαλύτερο, δηλ την τιμή του max.
Και βρίσκουμε τον μεγαλύτερο. Τέλος_αν
Τον μεγαλύτερο των δύο αριθμών τον εκχωρούμε
στη μεταβλητή max.

3ο Βήμα: Συγκρίνουμε τον τρίτο αριθμό με τον Αν γ> max τότε
μέχρι τώρα μεγαλύτερο, δηλ την τιμή του max. max←γ ….
Και βρίσκουμε τον μεγαλύτερο.
Τέλος_αν
Τον μεγαλύτερο των δύο αριθμών τον εκχωρούμε
στη μεταβλητή max.
Εμφάνισε “Ο μεγαλύτερος αριθμός είναι :”, max
Άρα ο αλγόριθμος είναι :
Τέλος Μέγιστος
37 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.48 Κεφάλαιο 2ο Λύση
Πηγαίνεις σε ένα πολυκατάστημα και παρατηρείς τις παρακάτω τιμές για 4 διαφορετικά είδη γάλακτος.

Είδος Τιμή Ποσότητα Αλγόριθμος Φθηνότερο_Γάλα
ΓΑΛΑ_Α 0,5 € 300 ml Τιμή_Α ← 0,5/300
ΓΑΛΑ_Β 0,6 € 400 ml Τιμή_Β ← 0,6/400
ΓΑΛΑ_Γ 0,8 € 500 ml
Τιμή_Γ ← 0,8/500
ΓΑΛΑ_Δ 0,9 € 550 ml
Τιμή_Δ ← 0,9/550
min ← Τιμή_Α
Φθηνότερο_είδος ← “Γάλα_Α”
Να γράψεις αλγόριθμο που
Αν Τιμή_Β < min τότε
•θα υπολογίζει και
•θα εμφανίζει το είδος γάλακτος με την min← Τιμή_Β ….
Φθηνότερο_είδος ← “Γάλα_Β”
πιο συμφέρουσα τιμή.
Τέλος_αν
Αν Τιμή_Γ < min τότε
1ο Βήμα: Αρχικά πρέπει να βρούμε για κάθε είδος
γάλακτος την τιμή ανά ml. min← Τιμή_Γ ….

Αυτό βρίσκεται αν διαιρέσουμε Φθηνότερο_είδος ← “Γάλα_Γ”
•την τιμή δια
•την ποσότητα. Τέλος_αν
2ο Βήμα: Αφού γίνει η μετατροπή συγκρίνουμε Αν Τιμή_Δ < min τότε
κάθε τιμη/ml (όπως στην 2.47 ) min← Τιμή_Δ ….
Θα εκχωρούμε σε μια μεταβλητή min την ελάχιστη
τιμή. Φθηνότερο_είδος ← “Γάλα_Δ”
Τέλος_αν
Άρα ο αλγόριθμος είναι :
Εμφάνισε “Το φθηνότερο είδος είναι :”, Φθηνότερο_είδος

Τέλος Φθηνότερο_Γάλα
38 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.49 Κεφάλαιο 2ο
Να γραφεί αλγόριθμος ο οποίος θα υπολογίζει την συνάρτηση:

x4+1 Λύση
f(x)=
x Αλγόριθμος Συνάρτηση_f
Λογικά θα ισχύει x≠0
Εμφάνισε “Δώσε ένα αριθμό”
Το αποτέλεσμα της συνάρτησης εξαρτάται από τη τιμή του x. πάνε πακέτο.
Διάβασε χ
Ο αλγόριθμος θα διαβάζει μια τυχαία τιμή για το x
και θα υπολογίζει τη συνάρτηση. !Το f(x) δεν είναι αποδεκτό
! όνομα αποδεκτό είναι το fx
Αν όμως η τιμή εισόδου είναι ίση με μηδέν,
η συνάρτηση δεν ορίζεται. Αν χ≠ 0 τότε
Διότι δεν μπορεί να γίνει διαίρεση με το μηδέν. fx← (x^4+1)/χ x≠0

Εμφάνισε “Αποτέλεσμα :”,fx
Αλλιώς ! Δύο περιπτώσεις
….
Άρα πρέπει να εξελέγξουμε την τιμή του x Εμφάνισε “Δεν είναι δυνατό να γίνει υπολογισμός”
και κατόπιν να κάνουμε τους υπολογισμούς
Άρα ο αλγόριθμος είναι : Τέλος_αν

Τέλος Συνάρτηση_f
39 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.50 Κεφάλαιο 2ο
Να γραφεί αλγόριθμος ο οποίος θα δέχεται ως είσοδο ένα αριθμό και
θα εμφανίζει το μήνυμα :”Άρτιος”, αν ο αριθμός είναι άρτιος ή
το μήνυμα :”Περιττός ” , αν ο αριθμός είναι περιττός.

Λύση Αλγόριθμος Άρτιος_Περιττός
Ένας αριθμός είναι άρτιος όταν διαιρείται ακριβώς με
το 2 , Εμφάνισε “Δώσε ένα αριθμό”
όταν το mod του αριθμού με το δύο (2) είναι μηδέν (0) πάνε πακέτο.
X mod 2 =0 Διάβασε χ

Σε οποιαδήποτε άλλη περίπτωση είναι περιττός.
Άρα έχω δύο περιπτώσεις. Αν χmod 2 = 0 τότε
….
modx
Εμφάνισε “Άρτιος ”
Αλλιώς ! Δύο περιπτώσεις
Άρα ο αλγόριθμος είναι :
Εμφάνισε “Περιττός”

Τέλος_αν

Τέλος Άρτιος_Περιττός
40 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.51 Κεφάλαιο 2ο
Να γραφεί αλγόριθμος που θα δέχεται ως είσοδο τρεις τιμές.
Οι δύο πρώτες θα είναι αριθμητικές , ενώ η τρίτη τιμή θα είναι αλφαριθμητική.
Ο αλγόριθμος θα εμφανίζει το άθροισμα των δύο πρώτων τιμών όταν η τρίτη μεταβλητή ισούται με
ΠΡΟΣΘΕΣΗ
και τη διαφορά των δύο πρώτων σε οποιαδήποτε άλλη περίπτωση. ….

Λύση
Ο αλγόριθμος θα διαβάζει 3 τιμές, οι οποίες θα Αλγόριθμος ΑΡΙΘ_ΠΡΑΞΗ
εισάγονται σε 3 μεταβλητές.
Εμφάνισε “Δώσε τρεις τιμές”
…. πάνε πακέτο.
Διάβασε α, β, γ
Ο έλεγχος αφορά την τιμή της τρίτης μεταβλητής.
Αν γ = “ΠΡΟΣΘΕΣΗ” τότε ΠΡΟΣΘΕΣΗ

Η Τρίτη τιμή θα είναι αλφαριθμητική , εφόσον το
περιεχόμενο της είναι μια λέξη. Εμφάνισε α+β
Τις αλφαριθμητικές μεταβλητές τις διαβάζουμε όπως και Αλλιώς ! Δύο περιπτώσεις
τις υπόλοιπες μεταβλητές ,
απλά στον έλεγχο ή στην εντολή εκχώρησης Εμφάνισε α-β
χρησιμοποιούμε διπλά εισαγωγικά.
Τέλος_αν

Τέλος ΑΡΙΘ_ΠΡΑΞΗ
Άρα ο αλγόριθμος είναι :
41 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.52 Κεφάλαιο 2ο
Να γραφεί αλγόριθμος που θα διαβάζει τις ετήσιες αποδοχές ενός υπαλλήλου.
Στη συνέχεια θα υπολογίζει την κράτηση φόρου που παρακρατείται ως εξής:
Αν οι αποδοχές του υπαλλήλου ξεπερνούν ένα συγκεκριμένο όριο χρημάτων τότε θα παρακρατείται ως
φόρος 30% των αποδοχών του, διαφορετικά θα παρακρατείται το 20% .
Να εμφανίζεται η παρακράτηση του φόρου και το καθαρό ποσό που τελικά θα αποδοθεί.

Λύση Υπολογισμός_κρατήσεων
Αρχικά θα πρέπει να διαβάσουμε τις ετήσιες Αλγόριθμος
αποδοχές του υπαλλήλου.
Εμφάνισε “Δώσε αποδοχές υπαλλήλου”
πάνε πακέτο.
Διάβασε αποδοχές
Θα πρέπει να διαβάσουμε και το όριο των
χρημάτων πάνω από το οποίο θα παρακρατείται Εμφάνισε “Δώσε όριο χρημάτων για αλλάγή κλίμακας φόρου:
το 30%. Διάβασε όριο_χρημάτων
Μετά θα κάνουμε την σύγκριση.
> Αν αποδοχές > όριο_χρημάτων τότε >
φόρος← αποδοχές*30/100
Αλλιώς ! Δύο περιπτώσεις
Άρα ο αλγόριθμος είναι :
φόρος← αποδοχές*20/100

Τέλος_αν
Εμφάνισε “Φόρος που παρακρατήθηκε:” ,Φόρος

Εμφάνισε “Ποσό που αποδίδεται :” , αποδοχές-φόρος

Τέλος Υπολογισμός_κρατήσεων
42 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.54 Κεφάλαιο 2ο
Σε ένα διαγωνισμό για την Πυροσβεστική Υπηρεσία οι άντρες υποψήφιοι θα πρέπει να συγκεντρώσουν
τουλάχιστον 80 βαθμούς και να έχουν ύψος τουλάχιστον 175cm. Οι γυναίκες υποψήφιοι θα πρέπει να
συγκεντρώσουν τουλάχιστον 70 βαθμούς και να έχουν ύψος τουλάχιστον 165cm. Να γραφεί αλγόριθμος
που θα ελέγχει αν ένας υποψήφιος πέτυχε στο διαγωνισμό.

Λύση Αλγόριθμος Πυροσβεστική
Αρχικά θα πρέπει να διαβάσουμε
•τη βαθμολογία
•το ύψος και Εμφάνισε “Δώσε βαθμό,ύψος και φύλλο.”
•το φύλλο. πάνε πακέτο.
Διάβασε β,υ,φ

Στη συνέχεια θα ελέγχουμε με
τη μορφή της … Αν (φ=“Άνδρας” και β≥80 και υ ≥175) ή (φ=“Γυναίκα” και β≥70 και υ ≥165) τότε
σύνθετης επιλογής και
με τη βοήθεια λογικών
ΚΑΙ,
τελεστών , Ή Εμφάνισε “Πέτυχες”
,Όχι.
Αλλιώς ! Δύο περιπτώσεις
αν πέτυχε ο / η υποψήφιος/ια Εμφάνισε “Απέτυχες”

Τέλος_αν
Τέλος Πυροσβεστική
Άρα ο αλγόριθμος είναι :