You are on page 1of 5

CISCO IOS MPLS VPN CONFIGURATION

VRF Configuration on R1 & R4


ip vrf CUSTOMER_B
rd 64512:100
route-target export 64512:100
route-target import 64512:100
!
ip vrf CUSTOMER_B
rd 64512:200
route-target export 64512:200
route-target import 64512:200
!
ip vrf SUSAN_SARANDON
rd 64512:300
route-target export 64512:300
route-target import 64512:300

Page | 1
MPLS & Interface Configuration on Provider Routers Router1 & Router4
hostname Router1 hostname Router4
! !
ip cef ip cef
ip mpls ip mpls
! !
interface Loopback0 interface Loopback0
ip address 50.1.1.1 255.255.255.255 ip address 50.1.1.4 255.255.255.255
! !
interface GigabitEthernet2/0 interface GigabitEthernet2/0
ip address 50.1.2.1 255.255.255.252 ip address 50.1.2.10 255.255.255.252
negotiation auto negotiation auto
mpls ip mpls ip
! !
interface FastEthernet5/0 interface FastEthernet5/0
description WAN link to Customer A description WAN link to Customer A
ip address 50.1.3.1 255.255.255.252 ip address 50.1.3.5 255.255.255.252
duplex auto duplex auto
speed auto speed auto
! !
interface FastEthernet5/1 interface FastEthernet5/1
description WAN link to Customer B description WAN Link to Customer B
ip vrf forwarding CUSTOMER_B ip vrf forwarding CUSTOMER_B
ip address 192.168.1.1 255.255.255.252 ip address 192.168.1.5 255.255.255.252
duplex auto duplex auto
speed auto speed auto
! !
interface FastEthernet6/0 interface FastEthernet6/0
description WAN link to Susan Sarandon description WAN link to Susan Sarandon
ip vrf forwarding SUSAN_SARANDON ip vrf forwarding SUSAN_SARANDON
ip address 192.168.1.9 255.255.255.252 ip address 192.168.1.13 255.255.255.252
duplex auto duplex auto
speed auto speed auto
! !

MPLS & Interface Configuration on Provider Routers Router2 & Router3


hostname Router2 hostname Router3
! !
interface Loopback0 interface Loopback0
ip address 50.1.1.2 255.255.255.255 ip address 50.1.1.3 255.255.255.255
! !
interface GigabitEthernet2/0 interface GigabitEthernet2/0
ip address 50.1.2.2 255.255.255.252 ip address 50.1.2.9 255.255.255.252
negotiation auto negotiation auto
mpls ip mpls ip
! !
interface GigabitEthernet3/0 interface GigabitEthernet3/0
ip address 50.1.2.5 255.255.255.252 ip address 50.1.2.6 255.255.255.252
negotiation auto negotiation auto
mpls ip mpls ip

Page | 2
OSPF, BGP and MP-BGP configuration on Provider Routers Router2 & Router3
hostname Router2 hostname Router3
! !
router ospf 1 router ospf 1
log-adjacency-changes log-adjacency-changes
network 50.1.1.0 0.0.0.255 area 0 network 50.1.1.0 0.0.0.255 area 0
network 50.1.2.0 0.0.0.255 area 0 network 50.1.2.0 0.0.0.255 area 0
! !
router bgp 64512 router bgp 64512
no bgp default ipv4-unicast no bgp default ipv4-unicast
bgp cluster-id 100 bgp cluster-id 100
bgp log-neighbor-changes bgp log-neighbor-changes
neighbor 50.1.1.1 remote-as 64512 neighbor 50.1.1.1 remote-as 64512
neighbor 50.1.1.1 update-source Loopback0 neighbor 50.1.1.1 update-source Loopback0
neighbor 50.1.1.2 remote-as 64512 neighbor 50.1.1.2 remote-as 64512
neighbor 50.1.1.2 update-source Loopback0 neighbor 50.1.1.2 update-source Loopback0
neighbor 50.1.1.4 remote-as 64512 neighbor 50.1.1.4 remote-as 64512
neighbor 50.1.1.4 update-source Loopback0 neighbor 50.1.1.4 update-source Loopback0
! !
address-family ipv4 address-family ipv4
neighbor 50.1.1.1 activate neighbor 50.1.1.1 activate
neighbor 50.1.1.1 send-community extended neighbor 50.1.1.1 send-community extended
neighbor 50.1.1.1 route-reflector-client neighbor 50.1.1.1 route-reflector-client
neighbor 50.1.1.2 activate neighbor 50.1.1.2 activate
neighbor 50.1.1.2 send-community extended neighbor 50.1.1.2 send-community extended
neighbor 50.1.1.4 activate neighbor 50.1.1.4 activate
neighbor 50.1.1.4 send-community extended neighbor 50.1.1.4 send-community extended
neighbor 50.1.1.4 route-reflector-client neighbor 50.1.1.4 route-reflector-client
no auto-summary no auto-summary
no synchronization no synchronization
exit-address-family exit-address-family
! !
address-family vpnv4 address-family vpnv4
neighbor 50.1.1.1 activate neighbor 50.1.1.1 activate
neighbor 50.1.1.1 send-community extended neighbor 50.1.1.1 send-community extended
neighbor 50.1.1.1 route-reflector-client neighbor 50.1.1.1 route-reflector-client
neighbor 50.1.1.2 activate neighbor 50.1.1.2 activate
neighbor 50.1.1.2 send-community extended neighbor 50.1.1.2 send-community extended
neighbor 50.1.1.4 activate neighbor 50.1.1.4 activate
neighbor 50.1.1.4 send-community extended neighbor 50.1.1.4 send-community extended
neighbor 50.1.1.4 route-reflector-client neighbor 50.1.1.4 route-reflector-client
exit-address-family exit-address-family
! !

Page | 3
OSPF, BGP and MP-BGP configuration on Provider Routers Router2 & Router3
hostname Router1 hostname Router2
! !
router ospf 1 router ospf 1
log-adjacency-changes log-adjacency-changes
redistribute connected subnets redistribute connected subnets
redistribute static subnets redistribute static subnets
network 50.1.1.0 0.0.0.255 area 0 network 50.1.1.0 0.0.0.255 area 0
network 50.1.2.0 0.0.0.255 area 0 network 50.1.2.0 0.0.0.255 area 0
! !
router bgp 64512 router bgp 64512
no bgp default ipv4-unicast no bgp default ipv4-unicast
bgp log-neighbor-changes bgp log-neighbor-changes
neighbor 50.1.1.2 remote-as 64512 neighbor 50.1.1.2 remote-as 64512
neighbor 50.1.1.2 update-source Loopback0 neighbor 50.1.1.2 update-source Loopback0
neighbor 50.1.1.3 remote-as 64512 neighbor 50.1.1.3 remote-as 64512
neighbor 50.1.1.3 update-source Loopback0 neighbor 50.1.1.3 update-source Loopback0
! !
address-family ipv4 address-family ipv4
redistribute connected redistribute connected
redistribute static redistribute static
redistribute ospf 1 redistribute ospf 1
neighbor 50.1.1.2 activate neighbor 50.1.1.2 activate
neighbor 50.1.1.2 send-community extended neighbor 50.1.1.2 send-community extended
neighbor 50.1.1.3 activate neighbor 50.1.1.3 activate
neighbor 50.1.1.3 send-community extended neighbor 50.1.1.3 send-community extended
no auto-summary no auto-summary
no synchronization no synchronization
exit-address-family exit-address-family
! !
address-family vpnv4 address-family vpnv4
neighbor 50.1.1.2 activate neighbor 50.1.1.2 activate
neighbor 50.1.1.2 send-community extended neighbor 50.1.1.2 send-community extended
neighbor 50.1.1.3 activate neighbor 50.1.1.3 activate
neighbor 50.1.1.3 send-community extended neighbor 50.1.1.3 send-community extended
exit-address-family exit-address-family
! !
address-family ipv4 vrf SUSAN_SARANDON address-family ipv4 vrf SUSAN_SARANDON
redistribute connected redistribute connected
redistribute static redistribute static
no synchronization no synchronization
exit-address-family exit-address-family
! !
address-family ipv4 vrf CUSTOMER_B address-family ipv4 vrf CUSTOMER_B
redistribute connected redistribute connected
redistribute static redistribute static
no synchronization no synchronization
exit-address-family exit-address-family
! !
ip forward-protocol nd ip forward-protocol nd
ip route 50.1.128.0 255.255.255.0 50.1.3.2 ip route 50.1.130.0 255.255.254.0 50.1.3.6
ip route vrf CUSTOMER_B 10.1.1.0 255.255.255.0 ip route vrf CUSTOMER_B 10.1.2.0 255.255.255.0
192.168.1.2 192.168.1.6
ip route vrf SUSAN_SARANDON 10.1.1.0 255.255.255.0 ip route vrf SUSAN_SARANDON 10.1.2.0 255.255.255.0
192.168.1.10 192.168.1.14

Page | 4
Site1 Configurations
hostname CustomerA_Site1 hostname CustomerB_Site1 hostname Susan_Site1
! ! !
interface FastEthernet0/0 interface FastEthernet0/0 interface FastEthernet0/0
description Link to ISP description Link to ISP description Link to ISP
ip address 50.1.3.2 255.255.255.252 ip address 192.168.1.2 255.255.255.252 ip address 192.168.1.10
duplex auto duplex auto 255.255.255.252
speed auto speed auto duplex auto
! ! speed auto
interface FastEthernet1/0 interface FastEthernet1/0 !
description LAN description LAN interface FastEthernet1/0
ip address 50.1.128.1 255.255.255.0 ip address 10.1.1.1 255.255.255.0 description LAN
duplex auto duplex auto ip address 10.1.1.1 255.255.255.0
speed auto speed auto duplex auto
! ! speed auto
ip route 0.0.0.0 0.0.0.0 50.1.3.1 ip route 0.0.0.0 0.0.0.0 192.168.1.1 !
! ! ip route 0.0.0.0 0.0.0.0 192.168.1.9
!

Site1 Configurations
hostname CustomerA_Site2 hostname CustomerB_Site2 hostname Susan_Site2
! ! !
interface FastEthernet0/0 interface FastEthernet0/0 interface FastEthernet0/0
description Link to ISP description Link to ISP description Link to ISP
ip address 50.1.3.6 255.255.255.252 ip address 192.168.1.6 255.255.255.252 ip address 192.168.1.14
duplex auto duplex auto 255.255.255.252
speed auto speed auto duplex auto
! ! speed auto
interface FastEthernet1/0 interface FastEthernet1/0 !
description LAN description LAN interface FastEthernet1/0
ip address 50.1.130.1 255.255.254.0 ip address 10.1.2.1 255.255.255.0 description LAN
duplex auto duplex auto ip address 10.1.2.1 255.255.255.0
speed auto speed auto duplex auto
! ! speed auto
ip route 0.0.0.0 0.0.0.0 50.1.3.5 ip route 0.0.0.0 0.0.0.0 192.168.1.5 !
! ! ip route 0.0.0.0 0.0.0.0 192.168.1.13
!

Page | 5

You might also like