You are on page 1of 7

on STATIC Route

R1

interface FastEthernet0/0
ip address 203.189.139.202 255.255.255.224
ip nat outside

interface FastEthernet0/1
ip address 192.168.50.1 255.255.255.0
ip nat inside
no shutdown
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 203.189.139.206
ip route 192.168.51.0 255.255.255.0 192.168.50.2

access-list 1 permit any

router ospf 100


network 192.168.50.0 0.0.0.255 area 200
network 203.189.139.0 0.0.0.255 area 200

!R2
interface FastEthernet0/0
ip address 192.168.50.2 255.255.255.0
no shutdown
interface FastEthernet0/1
ip address 192.168.51.1 255.255.255.0
no shutdown
ip route 0.0.0.0 0.0.0.0 192.168.50.1
router ospf 100
network 192.168.50.0 0.0.0.255 area 200
network 192.168.51.0 0.0.0.255 area 200
!

=====================================================================
EIGRP
R1
interface FastEthernet0/0
ip address 203.189.139.202 255.255.255.224
ip nat outside
interface FastEthernet0/1
ip address 192.168.50.1 255.255.255.0
ip nat inside
no shutdown
router eigrp 101
network 192.168.50.0
network 203.189.139.0
no auto-summary
ip nat inside source list 1 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 203.189.139.206
!
R2
interface FastEthernet0/0
ip address 192.168.50.2 255.255.255.0
interface FastEthernet0/1
ip address 192.168.51.1 255.255.255.0
no shutdown
router eigrp 101
network 192.168.50.0
network 192.168.51.0
no auto-summary
!
====================================================================================
RIP V2
R1
interface FastEthernet0/0
ip address 203.189.139.202 255.255.255.224
ip nat outside
interface FastEthernet0/1
ip address 192.168.50.1 255.255.255.0
ip nat inside
no shutdown
router rip
version 2
network 192.168.50.0
network 203.189.139.0
no auto-summary
ip nat inside source list 1 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 203.189.139.206
access-list 1 permit any
!
R2
interface FastEthernet0/0
ip address 192.168.50.2 255.255.255.0
InterfaceFastEthernet0/1
ip address 192.168.51.1 255.255.255.0
no shutdown
! router rip
version 2
network 192.168.50.0
network 192.168.51.0
no auto-summary
ip route 0.0.0.0 0.0.0.0 192.168.50.1

router ospf 10
router-id 3.3.3.3
log-adjacency-changes
passive-interface GigabitEthernet0/0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.10.8 0.0.0.3 area 0
network 192.168.10.4 0.0.0.3 area 0
!
On HSRP

On R2 Standby

interface FastEthernet0/0
ip address 192.168.10.4 255.255.255.0
interface FastEthernet0/1
ip address 192.168.30.2 255.255.255.0
standby version 2
standby 10 ip 192.168.30.5
standby 10 priority 106
tandby preempt
no shutdown
router ospf 100
network 192.168.10.0 0.0.0.255 area 100
network 192.168.30.0 0.0.0.255 area 100
!

On R1 Active

interface FastEthernet0/0
ip address 192.168.10.3 255.255.255.0
interface FastEthernet0/1
ip address 192.168.30.1 255.255.255.0
standby version 2
standby 10 ip 192.168.30.5
standby 10 priority 106
standby preempt
shutdown
router ospf 100
network 192.168.10.0 0.0.0.255 area 100
network 192.168.30.0 0.0.0.255 area 100
!

On R0

interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
ip nat inside!
interface FastEthernet0/1
ip address 203.189.139.1 255.255.255.252
ip nat outside
no shutdown
router ospf 100
network 192.168.10.0 0.0.0.255 area 100
network 203.189.139.0 0.0.0.3 area 100
ip nat inside source list 1 interface FastEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 203.189.139.206
On SW

interface FastEthernet0/1
no switchport
ip address 203.189.139.2 255.255.255.252
ip nat outside
!
interface FastEthernet0/2
no switchport
ip address 192.168.10.1 255.255.255.0
ip nat inside
interface FastEthernet0/3
no switchport
ip address 192.168.11.1 255.255.255.0
!router ospf 100
network 192.168.10.0 0.0.0.255 area 100
network 203.189.139.0 0.0.0.3 area 100
network 192.168.11.0 0.0.0.255 area 100
!

R Active

interface FastEthernet0/0
ip address 192.168.10.2 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.30.1 255.255.255.0
standby version 2
standby 10 ip 192.168.30.6
standby 10 priority 150
standby 10 track FastEthernet0/0
standby preempt
shutdown
!
router ospf 100
network 192.168.10.0 0.0.0.255 area 100
network 192.168.30.0 0.0.0.255 area 100
!
On R Standby

interface FastEthernet0/0
ip address 192.168.11.2 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.30.2 255.255.255.0
standby version 2
standby 10 ip 192.168.30.6
standby 10 track FastEthernet0/0
standby preempt
no shutdown
!
router ospf 100
network 192.168.30.0 0.0.0.255 area 100
network 192.168.11.0 0.0.0.255 area 100

SW

!
interface FastEthernet0/3
switchport access vlan 10
switchport mode trunk
switchport port-security maximum 2
switchport port-security mac-address sticky
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode trunk
switchport port-security maximum 2
switchport port-security mac-address sticky

interface FastEthernet0/5
switchport access vlan 30
switchport mode trunk
switchport port-security maximum 2
switchport port-security mac-address sticky
!

You might also like