You are on page 1of 56

CONFIGURING ROUTING

STATIC ROUTING

ip route [destination_network] [mask] [next-


hop_address or exitinterface] [administrative_distance]
[permanent]

2
STATIC ROUTING

192.168.10.0 192.168.30.0 192.168.50.0

192.168.20.0 192.168.40.0

Lab_A(config)#ip route 192.168.30.0 255.255.255.0 192.168.20.2


Lab_A(config)#ip route 192.168.40.0 255.255.255.0 192.168.20.2
Lab_A(config)#ip route 192.168.50.0 255.255.255.0 192.168.20.2
3
STATIC ROUTING
Lab_A#sh ip route
[output cut]
S 192.168.50.0 [1/0] via 192.168.20.2
S 192.168.40.0 [1/0] via 192.168.20.2
S 192.168.30.0 [1/0] via 192.168.20.2
C 192.168.20.0 is directly connected, Serial 0/0
C 192.168.10.0 is directly connected, FastEthernet0/0
Lab_A#
Delete static route:
 Lab_C(config)#no ip route 192.168.10.0 255.255.255.0 192.168.40.1
4
DEFAULT ROUTING
to send packets with a remote destination network not in the routing table to
the next-hop router.
 Lab_C(config)#ip route 0.0.0.0 0.0.0.0 192.168.40.1

Lab_C#sh ip route
[output cut]
Gateway of last resort is 192.168.40.1 to network 0.0.0.0
C 192.168.50.0 is directly connected, FastEthernet0/0
C 192.168.40.0 is directly connected, Serial0/0
S* 0.0.0.0/0 [1/0] via 192.168.40.1

5
GATEWAY OF LAST RESORT

6
GATEWAY OF LAST RESORT
Three solutions for adding a gateway of last resort on the gateway
router to the ISP.
Gateway(config)#ip route 0.0.0.0 0.0.0.0 217.124.6.1
Gateway(config)#ip route 0.0.0.0 0.0.0.0 s0/0
Gateway(config)#ip default-network 217.124.6.0

7
DYNAMIC ROUTING
Describe classful and classless routing protocols
Describe and configure RIPv2
Describe and configure EIGRP
Describe and configure OSPF

8
CLASSFUL AND CLASSLESS ROUTING
PROTOCOLS
How the routing protocols handles subnets masks
information
Classful routing protocols
 RIPv1
 IGRP
 Major network boundaries (Class A, B, or C)
 Don not carry subnet mask information
 Cannot use or work with
 Discontiguous subnets
 VLSM
9
RIP
Lab_C(config)#router rip
Lab_C(config-router)#network 192.168.40.0
Lab_C(config-router)#network 192.168.50.0
Lab_C(config-router)#^Z
Lab_C#

192.168.10.0 192.168.30.0 192.168.50.0

192.168.20.0 192.168.40.0

10
PASSIVE INTERFACE
To stop unwanted RIP updates from propagating across your LANs
and WANs
Prevents RIP update broadcasts from being sent out a defined
interface, but that same interface can still receive RIP updates.
Lab_A(config-router)#passive-interface serial 0/0

11
DISCONTIGUOUS SUBNETS

12
CONFIGURATION

13
ROUTING TABLE

14
DISCONTIGUOUS SUBNETS - FAULTS

15
MISBEHAVIOR EXAMPLE

16
IGRP
Lab_A#config t
Lab_A(config)#router igrp 10
Lab_A(config-router)#network 192.168.10.0
10 = AS number

In Cisco IOS versions 12.3 and greater, IGRP is completely


unsupported, obsolete routing protocol

17
CLASSFUL AND CLASSLESS ROUTING
PROTOCOLS
Classless routing protocols
 RIPv2
 EIGRP
 OSPF
 BGP
 Not restricted to Major network boundaries
 Carry subnet mask information
 Work with
 Discontiguous subnets
 VLSM
18
RIPV2

19
ROUTING TABLE - CORRECT

20
VERIFICATION

21
ROUTING INFORMATION PROTOCOL VERSION
2 (CONTINUED)

22
ROUTING INFORMATION PROTOCOL VERSION
2 (CONTINUED)

23
ROUTING INFORMATION PROTOCOL VERSION
2 (CONTINUED)

24
ROUTING INFORMATION PROTOCOL VERSION
2 (CONTINUED)

25
ROUTING INFORMATION PROTOCOL VERSION
2 (CONTINUED)

26
ENHANCED INTERIOR GATEWAY ROUTING
PROTOCOL
Cisco proprietary protocol
 Hybrid protocol
 Features both distance-vector and link-state protocols
Classless
 Not restricted to Major network boundaries
 Carry subnet mask information
 Work with
 Discontiguous subnets
 VLSM

Route IP, IPX, and AppleTalk


 Protocol Dependent Modules (PDMs) 27
ENHANCED INTERIOR GATEWAY ROUTING
PROTOCOL (CONTINUED)

28
ENHANCED INTERIOR GATEWAY ROUTING
PROTOCOL (CONTINUED)

29
ENHANCED INTERIOR GATEWAY ROUTING
PROTOCOL (CONTINUED)

30
EIGRP CONFIGURATION

31
EIGRP CONFIGURATION (CONTINUED)

32
ENHANCED INTERIOR GATEWAY ROUTING
PROTOCOL (CONTINUED)

33
ENHANCED INTERIOR GATEWAY ROUTING
PROTOCOL (CONTINUED)

34
ENHANCED INTERIOR GATEWAY ROUTING
PROTOCOL (CONTINUED)

35
OPEN SHORTEST PATH FIRST
Suited for large networks
High CPU and memory demands
OSPF Concepts
 Link
 Link-state
 Area
 Cost
 Adjacencies database
 Topological database
 Designated router
 Router election with router ID
 Backup designated router 36
OPEN SHORTEST PATH FIRST (CONTINUED)

37
OPEN SHORTEST PATH FIRST (CONTINUED)

The cost is an indication of the overhead required to send packets across a


certain interface.
The cost of an interface is inversely proportional to the bandwidth of that
interface.
A higher bandwidth indicates a lower cost.
The formula used to calculate the cost is:
cost= 10000 0000/bandwith in bps
10M Ethernet line -> 10 EXP8/10 EXP7 = 10
T1 line -> 10 EXP8/1544000 = 64 38
OPEN SHORTEST PATH FIRST (CONTINUED)

Default hello-interval:
10 seconds (Ethernet)
30 seconds (nonbroadcast)

return to defaults: no ip ospf hello-interval


39
OSPF OPERATION
OPSP operation
 First: Form adjacencies with neighbors
 Second: Election of DR and BDR
 Third: Flood LSAs
 Fourth: Select best routes

Dijkstra’s Shortest Path Algorithm


 Loop-free
 Best cost path
 CPU and Memory demands

40
OSPF OPERATION (CONTINUED)

41
SINGLE-AREA OSFP CONFIGURATION

42
WILDCARD MASKS
Identifies the interface where OSPF will operate
Opposite, reverse to subnet mask
 0 means: must mach exactly
 255 means: I don’t care

Example:
 /28 = 255.255.255.240 -> 0.0.0.15
 /30 = 255.255.255.254 -> 0.0.0.3
 block size -1

43
WILDCARD MASKS

Lab_A(config-router)#network 192.168.10.1 0.0.0.0 area 0


Lab_B(config-router)#network 192.168.0.0 0.0.255.255 area 0
Lab_C(config-router)#network 192.168.40.0 0.0.0.255 area 0

44
SHOW IP OSPF
Routing Process "ospf 132" with ID 192.168.20.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm executed 5 times
Area ranges are
Number of LSA 3. Checksum Sum 0x020E9A
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0 45
OSPF DATABASE
Lab_A#sh ip ospf database
OSPF Router with ID (192.168.20.1) (Process ID 132)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
192.168.20.1 192.168.20.1 648 0x80000003 0x005E2B 3
192.168.40.1 192.168.40.1 351 0x80000003 0x00E32F 5
192.168.40.2 192.168.40.2 192 0x80000003 0x00CD40 3
Lab_A#

46
OSPF INTERFACE
Lab_A#show ip ospf interface
Serial0/0 is up, line protocol is up
Internet Address 192.168.20.1/24, Area 0
Process ID 132, Router ID 192.168.20.1, Network Type
POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:06
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.168.40.1
Suppress hello for 0 neighbor(s)
…………….

47
LOOPBACK INTERFACE
Lab_A#config t
Enter configuration commands, one per line. End with CNTL/Z.
Lab_A(config)#int loopback 0
Lab_A(config-if)#ip address 172.16.10.1 255.255.255.255
Lab_A(config-if)#no shut
Lab_A(config-if)#^Z
Lab_A#

Note: The router must be rebooted or the OSPF process


must be cleared and recreated if we want the logical
interface IP address become RID
48
SINGLE-AREA OSFP CONFIGURATION
(CONTINUED)

49
CONTROLLING ROUTE TRAFFIC

“passive-interface” command
 RouterD(config)# router rip
 RouterD(config-router)# passive-interface s0

EIGRP and OSPF will not send or receive updates

50
CONTROLLING ROUTE TRAFFIC
(CONTINUED)

51
CONTIGUOUS NETWORK DESIGN

52
SUMMARY ROUTES - EIGRP
Core#config t
Core(config)#router eigrp 10
Core(config-router)#network 192.168.10.0
Core(config-router)#network 10.0.0.0
Core(config-router)#no auto-summary
Core(config-router)#interface ethernet 0
Core(config-if)#ip summary-address eigrp 10 192.168.10.64
255.255.255.224

53
SUMMARY ROUTES - OSPF

54
SUMMARY ROUTES - OSPF
Core#config t
Core(config)#router ospf 1
Core(config-router)#network 192.168.10.64 0.0.0.3 area 1
Core(config-router)#network 192.168.10.68 0.0.0.3 area 1
Core(config-router)#network 10.10.10.0 0.0.0.255 area 0
Core(config-router)#area 1 range 192.168.10.64
255.255.255.224

55
SUMMARY
Large, complex internetworks using variable-length subnet masks
require routing protocols that can handle the task
RIPv2 is a classless routing protocol built as an extension to RIPv1
EIGRP is a Cisco proprietary protocol designed to incorporate
some of the features of link-state routing protocols
The open standards protocol OSPF is the link-state protocol of
choice in many networks

56

You might also like