You are on page 1of 26

sho ip int brief

to entre in conf consol set  en (Router Or Switch)

set IP/MASK to VPCS ip 10.0.0.4 255.255.255.0

check in PC1 putty with ipconfig

Routeur conf
Router> en
Router#
Router# show ip int brief
Router#conf t
Router(config)#int GigabitEthernet0/0
Router(config-if)#no shut
Router(config-if)#do wr
Router(config-if)#ip add 10.0.0.2 255.255.255.0
Router(config-if)#do show ip int brief
Router(config-if)#do wr
Router(config-if)#exit
Router(config)#do sh ip int brief | e ass
Router> en
Router#
Router# show ip int brief
Router#conf t
Router(config)#int GigabitEthernet0/0
Router(config-if)#no shut
Router(config-if)#do wr
Router(config-if)#ip add 10.0.0.2 255.255.255.0
Router(config-if)#do show ip int brief
Router(config-if)#do wr
Router(config-if)#exit
Router(config)#do sh ip int brief | e ass

SWITCH conf
Switch>en
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# host Sw
Sw(config)#
Sw(config)#do sh vlan brief
Sw(config)#vlan 10
Sw(config-vlan)#name L2
Sw(config-vlan)#exit
Sw(config)#do sh vlan brief
Sw (config-if)#do wr

Sw(config)#int range GigabitEthernet0/0 , GigabitEthernet0/1


Sw(config-if-range)#
Sw(config-if-range)#switchport access vlan 10
Sw (config-if)#do wr
Sw(config-if-range)#do sh run int GigabitEthernet0/0

Sw (config)#int vlan 10
Sw (config-if)#ip add 10.0.0.3 255.255.255.0
Sw (config-if)#no shut
Sw (config-if)#do wr
Sw(config-if)#do sh ip int brief | e ass

Switch>en
Switch#conf t
Enter configuration commands, one per line.
End with CNTL/Z.
Switch(config)# host Sw
Sw(config)#
Sw(config)#do sh vlan brief
Sw(config)#vlan 10
Sw(config-vlan)#name L2
Sw(config-vlan)#exit
Sw(config)#do sh vlan brief
Sw (config-if)#do wr

Sw(config)#int range GigabitEthernet0/0 ,


GigabitEthernet0/1
Sw(config-if-range)#
Sw(config-if-range)#switchport access vlan 10
Sw (config-if)#do wr
Sw(config-if-range)#do sh run int
GigabitEthernet0/0

Sw (config)#int vlan 10
Sw (config-if)#ip add 10.0.0.3 255.255.255.0
Sw (config-if)#no shut
Sw (config-if)#do wr
Sw(config-if)#do sh ip int brief | e ass

Other Switch and router mode config


Swtch The Other way
Switch
Vlan enter mode /vlan database
ESW1#vlan database
ESW1(vlan)#
ESW1(vlan)#vlan 10 name VLAN10

ESW1(vlan)#vlan 20 name VLAN20


ESW1#vlan database
ESW1(vlan)#show current VLAN ISL Id: 10
Name: VLAN10
…..

VLAN ISL Id: 20


Name: VLAN20
…….

ESW1#conf terminal
ESW1(config)#int f1/2
ESW1(config-if)#switchport mode access Activate the port
ESW1(config-if)#switchport access vlan 10 Set the port in vlan
ESW1(config-if)#no shutdown Do not shut down when we exit

ESW1(config)#interface fastEthernet 1/10


ESW1(config-if)#switchport mode ? access Set trunking mode to ACCESS
unconditionally
trunk Set trunking mode to TRUNK
unconditionally
ESW1(config-if)#switchport mode access
ESW1(config-if)#switchport access vlan 20
ESW1(config-if)#no shutdown
ESW1(config)#int f1/1
ESW1(config-if)#switchport mode trunk
ESW1(config-if)#switchport trunk encapsulation
dot1q
ESW1(config-if)#no shutdown
ESW1(config-if)#exit
ESW1(config)#exit
ESW1#wr To save what we have done

ESW1#conf t
ESW1(config)#int f1/3
ESW1(config-if)#switchport mode access
ESW1(config-if)#switchport access vlan 10
ESW1(config-if)#no shutdown
Sw#show running-config To check configuration running

Router conf another way


Router
The Other Way
R1#conf t
R1(config)#interface fastEthernet 0/0
R1(config-if)#no ip address
R1(config-if)#no shutdown
R1(config)#interface fastEthernet 0/0.1
R1(config-subif)#encapsulation dot1Q ?
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 192.168.10.1 IP addresses of ROUTER for This VLAN 10
255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#exit

R1(config)#int f0/0.2
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 192.168.20.1
255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#exit
R1(config-subif)#exit
R1(config)#exit
R1#wr
PC 1& PC 2 ConfIG
PC1> ip 192.168.10.2/24 192.168.10.1 192.168.10.2/24 is IP adresse and Mask
192.168.10.1 is gateway given in router conf
PC1 : 192.168.10.2 255.255.255.0 gateway
192.168.10.1
PC2> ip 192.168.20.2/24 192.168.20.1 192.168.20.2/24 is IP adresse and Mask
192.168.20.1 is gateway given in router conf
PC2 : 192.168.20.2 255.255.255.0 gateway
192.168.20.1
PC2> sho

NAME IP/MASK GATEWAY MAC


LPORT RHOST:PORT
PC2 192.168.20.2/24 192.168.20.1
00:50:79:66:68:01 20016 127.0.0.1:20017
fe80::250:79ff:fe66:6801/64

192.168.174.148
Floor1(config)#ip dhcp excluded-address 10.10.20.1 10.10.20.50

Floor1(config)#ip dhcp pool Floor1DHCP


Floor1(dhcp-config)#network 192.168.174.0 255.255.255.0

Floor1(dhcp-config)#default-router 192.168.174.148

Floor1(dhcp-config)#dns-server 8.8.8.8

Routeur(dhcp-config)#netbios-name-server 192.168.174.241
Routeur(dhcp-config)#domain-name AZ.corp 
Routeur(dhcp-config)#lease 0 8 0 
Routeur(dhcp-config)#end 

Routeur#configure terminal 
Routeur(config)#ip dhcp  pool NetAd 
Routeur(dhcp-config)#network 192.168.0.0 255.255.255.0 
Routeur(dhcp-config)#default-router 192.168.0.254 
Routeur(dhcp-config)#dns-server 192.168.0.240 
Routeur(dhcp-config)#netbios-name-server 192.168.0.241 
Routeur(dhcp-config)#domain-name domaine.corp 
Routeur(dhcp-config)#lease 0 8 0 
Routeur(dhcp-config)#end 
Improve Your Cisco Network Security
Skills
Cisco Network Security: Core Security Concepts with Lisa Bock
Review the essential terms and concepts you need to know to effectively secure Cisco
networks.
1h 46m • COURSE

Cisco Network Security: Secure Access with Lisa Bock


Learn about Cisco network management, secure device access, and protocols such as
NTP, SCP, and SNMP.
1h 25m • COURSE

Cisco Network Security: VPN with Lisa Bock


Boost your technical skill set by mastering essential VPN concepts, as well as strategies
for using VPNs to secure a network.
1h 27m • COURSE

Cisco Network Security: Secure Routing and Switching with Lisa Bock


Learn how to secure Cisco routers and switches, mitigate Layer 3 and Layer 2 attacks,
and secure a VLAN.
1h 21m • COURSE

Cisco Network Security: Cisco Firewall Technologies with Lisa Bock


Discover how to leverage firewall technologies to secure your organization's
infrastructure. Learn about basic firewall configuration, different types of firewalls, and
more.
1h 34m • COURSE

6
 

Cisco Network Security: Intrusion Detection and Prevention with Lisa Bock


Review the fundamentals of intrusion detection and intrusion prevention systems
(IDS/IPS), how they detect and mitigate common attacks, and the practical applications
of IDS/IPS.
1h 11m • COURSE

Cisco Network Security: Content and Endpoint Security with Lisa Bock


Prepare for the Cisco Certified Network Associate (CCNA) Security exam 210-260.
Review key concepts and confidently tackle the Content and Endpoint Security section of
the exam.
1h 11m • COURSE
Prepare for the Cisco CCNA (200-301)
The Cisco CCNA (200-301) exam focuses on the skills required to install, operate,
configure, and verify IPv4 and IPv6 networks. The exam tests your knowledge of
network components, network devices, and security threats. These courses help you
prepare for this key exam on managing Cisco networks.

Prepare for the Cisco CCNA (200-301) exam.

Learn to manage, secure, and automate Cisco networks.

Learn to install and configure IPv4 and IPv6 networks.

Try for free   Preview the first video

Part of your Lynda.com membership.


5 Hours of expert-created video tutorials
Practice to reinforce what you learned
Certify your achievement
Advance your career

Cisco CCNA (200-301) Cert Prep: Network Fundamentals and Access with Greg
Sowell
Study for the first two domains of the Cisco Certified Network Associate (CCNA) exam: network
fundamentals and network access.
1h 58m • COURSE

Cisco CCNA (200-301) Cert Prep: IP Connectivity and Services with Greg Sowell
Prepare to tackle the third and fourth domains of the Cisco Certified Network Associate (CCNA)
exam: IP Connectivity and IP Services.

1h 20m • COURSE

Cisco CCNA (200-301) Cert Prep: Security, Automation, and


Programmability with Greg Sowell
Study for the final two domains of the Cisco Certified Network Associate (CCNA) exam: security,
and automation and programmability.

1h 12m • COURSE
Prepare for the Implementing Cisco
Enterprise Advanced Routing and Services
(CCNP ENARSI 300-410) Exam
The Cisco CCNP 300-410 ENARSI exam measures your ability to implement and
troubleshoot for advanced Cisco routing technologies and services, including VPN and
infrastructure security. This learning path covers objectives from each domain,
preparing you to perform real-world tasks and pass the exam.

Learn advanced Cisco routing and servicing skills.

Troubleshoot advanced routing technologies.

Prepare for the Cisco CCNP ENARSI 300-410 exam.

Try for free   Preview the first video

Part of your Lynda.com membership.


13 Hours of expert-created video tutorials
Practice to reinforce what you learned
Certify your achievement
Advance your career

 
Cisco CCNP ENARSI (300-410) Cert Prep: 1 Layer 3 Technologies with Kevin
Wallace
Study for the first domain of the Cisco ENARSI certification exam: Layer 3 Technologies. Learn
about route redistribution, policy-based routing, and virtual route forwarding.

1h 34m • COURSE

Cisco CCNP ENARSI (300-410) Cert Prep: 2 VPN Technologies with Kevin Wallace
Study for the second domain of the Cisco ENARSI certification exam: VPN Technologies. Learn
about troubleshooting routing protocols such as EIGRP, OSPF, and BGP.

6h 15m • COURSE

 
Cisco CCNP ENARSI (300-410) Cert Prep: 3 Infrastructure Security with Kevin
Wallace
Study for the third domain of the Cisco ENARSI certification exam: Infrastructure Security. Learn
about troubleshooting secure VPN, IPv4, and IPv6 technologies.

2h 12m • COURSE

Cisco CCNP ENARSI (300-410) Cert Prep: 4 Infrastructure Services with Kevin


Wallace
Study for the fourth domain of the Cisco ENARSI certification exam: Infrastructure Services.
Learn about troubleshooting network services such as remote access, SNMP, DHCP, and
NetFlow.

2h 58m • COURSE
Prepare for the Implementing and Operating
Cisco Enterprise Network Core Technologies
(CCNP ENCOR 350-401) Exam
The Cisco CCNP ENCOR 350-401 exam measures your ability to configure,
troubleshoot, and manage enterprise Cisco technologies, including wired and
wireless networks. This learning path covers objectives from each domain so you're
prepared to perform real-world tasks and pass the ENCOR 350-401 exam.

Learn key enterprise network administration skills.

Implement security principles within an enterprise network.

Prepare for the Cisco CCNP ENCOR 350-401 exam.

Try for free   Preview the first video

Part of your Lynda.com membership.


19 Hours of expert-created video tutorials
Practice to reinforce what you learned
Certify your achievement
Advance your career

 
Cisco CCNP ENCOR (350-401): 1 Architecture, Virtualization, and
Infrastructure with Kevin Wallace
Prepare for the first three domains of the Cisco CCNP ENCOR exam: Architecture, Virtualization,
and Infrastructure.

9h 53m • COURSE

Cisco CCNP ENCOR (350-401): 2 Network Management, Security, and


Automation with Kevin Wallace
Prepare for the last three domains of the Cisco CCNP ENCOR exam: Network Management,
Security, and Automation.

8h 55m • COURSE
Become a Network Administrator
Network administrators play a vital role in managing and maintaining an
organization's computer network. Begin your career in information technology (IT) as
a network administrator, and learn the essential skills you'll need to organize, install,
and support a Cisco network.

Master the networking concepts and skills to support a Cisco network.

Learn to troubleshoot a Cisco network.

Configure routers and switches.

Try for free   Preview the first video

Part of your Lynda.com membership.


31 Hours of expert-created video tutorials
Practice to reinforce what you learned
Certify your achievement
Advance your career

Networking Foundations: Networking Basics (2015) with Timothy Pintello


Introduces the core networking topologies, compares and contrasts the OSI and TCP/IP models,
and introduces common network devices.

1h 48m • COURSE
2

Networking Foundations: IP Addressing with Timothy Pintello


Learn about IP addressing, including logical vs. physical addressing, IPv4 and IPv6, and resolution
techniques such as DHCP and DNS.

2h 35m • COURSE

Networking Foundations: Network Media (LANs) with Greg Sowell


Learn how to set up a LAN (local area network), WAN (wide area network), or wireless area
network in this Foundations of Networking class.

1h 9m • COURSE

4
 

Networking Foundations: Network Media (WANs) with Greg Sowell


Discover how to apply your existing IP knowledge to networking. Learn how to set up WANs
(wide area networks) with switches, routers, and different routing protocols.

2h 2m • COURSE

Networking Foundations: Protocols and CLI Tools with Greg Sowell


Learn how to troubleshoot network connectivity issues using different protocols and command-
line (CLI) tools.

1h 13m • COURSE

6
 

Protecting Your Network with Open-Source Software with Jungwoo Ryoo


Learn how to protect your network for free with open-source tools and these network-security
tutorials from expert Jungwoo Ryoo.

1h 49m • COURSE

Learning IP Addressing with Kevin Wallace


Learn how to configure and verify IP addresses and explore static vs. dynamic addresses and
public vs. private addressing.

36m 32s • COURSE

8
 

Learning Network Troubleshooting with Mark Jacob


Learn how to troubleshoot network performance and security issues.

54m 14s • COURSE

Learning Subnetting with Kevin Wallace


Learn the basics of IPv4 addressing and master the skill of IP subnetting.

1h 31m • COURSE

10
 

Learning the Packet Delivery Process with Mark Jacob


Explore packet delivery topics like understanding port numbers, establishing a TCP session, and
exploring basic IP routing.

1h 29m • COURSE

11

Learning IPv6 with Mark Jacob


Get to know IPv6, the latest version of Internet Protocol, which routes traffic across the web.

56m 24s • COURSE

12
 

Advanced Cisco Routing: RIPv2, EIGRP, and OSPF with Lazaro Diaz


Explore advanced topics and techniques in Cisco routing, from RIPv2 routes for smaller
networks, to EIGRP and OSPF protocols for enterprise networks.

2h 43m • COURSE

13

Wireshark Essential Training with Lisa Bock


Get an overview of packet analysis and using Wireshark, a free network protocol analyzer.
Discover its key features and how it can help with latency issues and network attacks.

2h 25m • COURSE

14
 

Wireshark: Functionality with Lisa Bock


Enhance your Wireshark workflow by becoming better acquainted with its interface and core
features. Discover the different menus and toolbars and how to personalize the interface.

1h 41m • COURSE

15

Learning Cisco CLI Switch Configuration with Denise Allen-Hoyt


Learn how to configure a Cisco switch to connect and control resources on your network.

1h 2m • COURSE

16
 

Learning Cisco CLI Router Configuration with Denise Allen-Hoyt


Learn how to configure a Cisco router to transmit data between local area networks and connect
to the Internet.

1h 38m • COURSE

17

Cisco Networking Foundations with Todd Lammle


Study to pass the Cisco Certified Entry Networking Technician (CCENT) exam, Interconnecting
Cisco Networking Devices Part 1 (100-105), with this comprehensive test prep course.

4h 55m • COURSE

You might also like