You are on page 1of 8

BSCI LAB 10

Configuring Basic Border Gateway Protocol

Lab 10: Configuring Basic Border Gateway Protocol


Objective
Configure P1R1 for basic Exterior Border Gateway Protocol (EBGP). Configure P1R1 and P1R2 for Interior Border
Gateway Protocol (IBGP). Confirm BGP connectivity.

Lab Topology
For this lab, your network design will include two pods of devices. Pod 2 will be configured upon the initial load-
ing of the lab. You will be responsible for configuring Pod 1. The Pod 2 devices will be configured with the same
IP addressing scheme as those in Pod 1. For all labs that require more than one pod, your pod will be represented
as Pod 1, and the remote pod will be Pod 2.

The Topology below represents the NetMap in the Simulator. To access each of the devices from within the Simu-
lator, select the device name from the appropriate menu in the Simulator. For example, to access P1R1, click the
eRouters button and select P1R1 from the drop-down menu.

Boson NetSim for CCNP Lab Manual 61


BSCI LAB 10
Configuring Basic Border Gateway Protocol

BGP Topology

Command Summary
Command Description
router bgp autonomous_system_number enters router config mode for BGP
neighbor ip_address remote-as asn establishes a BGP neighbor relationship
neighbor ip_address next-hop-self defines the neighbor as a Next Hop Self neighbor
network address {mask mask} specifies networks to be advertised by BGP
show ip bgp summary displays summary BGP neighbor status
show ip bgp neighbor displays detailed BGP neighbor status
show ip bgp displays BGP table
clear ip bgp* resets all BGP peer connections

62 Boson NetSim for CCNP Lab Manual


BSCI LAB 10
Configuring Basic Border Gateway Protocol

Lab Tasks
Task 1: Lab Preparation
1. Make sure there is no configuration on P1R1 and P1R2. If any configurations are present, erase them
and reload both routers.
2. Configure P1R1 and P1R2 with the IP addresses shown in the Lab Topology diagram.
3. Assign a clock rate of 64000 to all DCE serial interfaces.
4. On P1R1 and P1R2, enable FastEthernet 0/0, serial 0/0, and Loopback 0.
5. Use ping to verify connectivity.

Task 2: Enable Basic EBGP


1. On P1R1, enable EBGP for your AS. You will need to configure a neighbor statement for each pod. These
examples are for Pod 1. The next-hop-self command is used to force P1R1 to advertise itself as the
next hop on the shared Ethernet backbone.
2. On P1R1, configure a network statement for each directly connected network.
3. Execute the show ip bgp summary command. How many neighbors are listed? How many network
entries are listed?
______________________________________________________________
4. Execute the show ip route command. Do you see any BGP routes? If so, what are the administrative
distances of these routes?
______________________________________________________________
5. Try the show ip bgp neighbors command. What is the BGP state of the first neighbor?
______________________________________________________________

Task 3: Configure IBGP Within Pod 1


Now, configure IBGP between P1R1 and P1R2.
1. On P1R2, enable BGP and configure a network statement for each directly connected network.
2. Configure P1R1 and P1R2 to be BGP neighbors. Use the show ip bgp summary command to verify.
3. Use the show ip route command on P1R2. Does a route exist to the P1R1 loopback network?
______________________________________________________________
4. On P1R2, what is the next hop IP address for the routes to pod 2?
______________________________________________________________
5. On P1R1, configure the neighbor relationship to the P1R2 router with the next-hop-self option.
6. On P1R2, execute the clear ip bgp * command. Wait a minute, and then execute the show ip bgp
command. What is the next hop now?
______________________________________________________________

Boson NetSim for CCNP Lab Manual 63


BSCI LAB 10
Configuring Basic Border Gateway Protocol

Lab Solutions
Task 1: Lab Preparation
Sample base configuration for Pod 1
P1R1 Config
!
hostname P1R1
!
enable password cisco
!
interface Loopback0
ip address 192.168.1.1 255.255.255.240
!
interface FastEthernet0/0
ip address 10.100.100.1 255.255.255.0
!
interface Serial0/0
ip address 192.168.1.33 255.255.255.240
no fair-queue
clock rate 64000
!
interface Serial0/1
no ip address
shutdown
!

P1R2 Config
!
hostname P1R2
!
enable password cisco
!
interface Loopback0
ip address 192.168.1.17 255.255.255.240
!
interface FastEthernet0/0
ip address 192.168.1.49 255.255.255.240
speed auto
!
interface Serial0/0
ip address 192.168.1.34 255.255.255.240
!

64 Boson NetSim for CCNP Lab Manual


BSCI LAB 10
Configuring Basic Border Gateway Protocol

Task 2: Enable Basic EBGP


1. P1R1(config)#router bgp 1
P1R1(config-router)#neighbor 10.100.100.2 remote-as 2
P1R1(config-router)#neighbor 10.100.100.2 next-hop-self

2. P1R1(config-router)#network 10.100.100.0 mask 255.255.255.0


P1R1(config-router)#network 192.168.1.0 mask 255.255.255.240
P1R1(config-router)#network 192.168.1.32 mask 255.255.255.240

3. One neighbor is listed.


One network entry is listed.
P1R1#show ip bgp summary
BGP router identifier 192.168.1.1, local AS number 1
BGP table version is 6, main routing table version 6
5 network entries and 6 paths using 701 bytes of memory
2 BGP path attribute entries using 120 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 5/0 prefixes, 6/0 paths, scan interval 15 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.100.100.2 4 2 8 8 6 0 0 00:04:56 3

4. Yes. The administrative distance of these routes is 20.


P1R1#show ip route

10.0.0.0/24 is subnetted, 1 subnets


C 10.100.100.0 is directly connected, FastEthernet0/0
192.168.1.0/28 is subnetted, 2 subnets
C 192.168.1.32 is directly connected, Serial0/0
C 192.168.1.0 is directly connected, Loopback0
192.168.2.0/28 is subnetted, 2 subnets
B 192.168.2.32 [20/0] via 10.100.100.2, 00:07:18
B 192.168.2.0 [20/0] via 10.100.100.2, 00:07:18

5. Established
P1R1#show ip bgp neighbors
BGP neighbor is 10.100.100.2, remote AS 2, external link
BGP version 4, remote router ID 192.168.2.1
BGP state = Established, up for 00:09:55

Task 3: Configure IBGP Within Pod 1

Boson NetSim for CCNP Lab Manual 65


BSCI LAB 10
Configuring Basic Border Gateway Protocol

1. P1R2(config)#router bgp 1
P1R2(config-router)#network 192.168.1.16 mask 255.255.255.240
P1R2(config-router)#network 192.168.1.32 mask 255.255.255.240
P1R2(config-router)#network 192.168.1.48 mask 255.255.255.240

2. P1R1(config)#router bgp 1
P1R1(config-router)#neighbor 192.168.1.34 remote-as 1

P1R2(config)#router bgp 1
P1R2(config-router)#neighbor 192.168.1.33 remote-as 1

P1R1#show ip bgp summary

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd


10.100.100.2 4 2 36 36 6 0 0 00:32:20 3
192.168.1.34 4 1 6 6 6 0 0 00:01:08 3

3. Yes
P1R2#sh ip route
10.0.0.0/24 is subnetted, 1 subnets
B 10.100.100.0 [200/0] via 192.168.1.33, 00:16:06
192.168.1.0/28 is subnetted, 4 subnets
C 192.168.1.32 is directly connected, Serial0/0
C 192.168.1.48 is directly connected, FastEthernet0/0
B 192.168.1.0 [200/0] via 192.168.1.33, 00:16:06
C 192.168.1.16 is directly connected, Loopback0
192.168.2.0/28 is subnetted, 2 subnets
B 192.168.2.32 [200/0] via 10.100.100.2, 00:15:56
B 192.168.2.0 [200/0] via 10.100.100.2, 00:15:57

4. The next hop is 10.100.100.2.


5. P1R1(config-router)#neighbor 192.168.1.34 next-hop-self
6. The next hop changes to 192.168.1.33.

66 Boson NetSim for CCNP Lab Manual


BSCI LAB 10
Configuring Basic Border Gateway Protocol

Sample BGP Configuration Scripts


Pod 1 Router 1 Pod 1 Router 2
hostname P1R1 hostname P1R2
! !
enable password cisco enable password cisco
! !
interface Loopback0 interface Loopback0
ip address 192.168.1.1 255.255.255.240 ip address 192.168.1.17 255.255.255.240
! !
interface FastEthernet0/0 interface FastEthernet0/0
ip address 10.100.100.1 255.255.255.0 ip address 192.168.1.49 255.255.255.240
! speed auto
interface Serial0/0 !
ip address 192.168.1.33 255.255.255.240 interface Serial0/0
clock rate 64000 ip address 192.168.1.34 255.255.255.240
! !
router bgp 1 router bgp 1
no synchronization no synchronization
bgp log-neighbor-changes bgp log-neighbor-changes
network 10.100.100.0 mask 255.255.255.0 network 192.168.1.16 mask 255.255.255.240
network 192.168.1.0 mask 255.255.255.240 network 192.168.1.32 mask 255.255.255.240
network 192.168.1.32 mask 255.255.255.240 network 192.168.1.48 mask 255.255.255.240
neighbor 10.100.100.2 remote-as 2 neighbor 192.168.1.33 remote-as 1
neighbor 10.100.100.2 next-hop-self !
neighbor 192.168.1.34 remote-as 1
neighbor 192.168.1.34 next-hop-self
!

Boson NetSim for CCNP Lab Manual 67


68 Boson NetSim for CCNP Lab Manual

You might also like