You are on page 1of 43

NIT2222 Networking Technologies

Assignment 1
30/08/2019
Table of Contents
SCENARIO.................................................................................................................................................................3
Topology...................................................................................................................................................................4
Ip configuration and Subnetting...............................................................................................................................5
Configuration............................................................................................................................................................7
For Switch of Building_K......................................................................................................................................7
Assigning Vlans................................................................................................................................................7
Assigning vlans to ports...................................................................................................................................8
Enabling Trunking to the ports linked to the layer 3 switches........................................................................8
For Switch of Building A.......................................................................................................................................9
Assigning Vlans................................................................................................................................................9
Enabling Trunking to the ports linked to the layer 3 switches........................................................................9
For Switch of Building G.....................................................................................................................................10
Assigning Vlans..............................................................................................................................................10
Enabling Trunking to the ports linked to the layer 3 switches......................................................................10
For Switch of Building M....................................................................................................................................11
Assigning Vlans..............................................................................................................................................11
Enabling Trunking to the ports linked to the layer 3 switches......................................................................11
For Switch of Building L......................................................................................................................................12
Assigning Vlans..............................................................................................................................................12
Enabling Trunking to the ports linked to the layer 3 switches......................................................................12
For Layer 3 Switch..............................................................................................................................................13
For Switch 1...................................................................................................................................................13
For Switch 2...................................................................................................................................................15
For Router..........................................................................................................................................................16
Interface config to connect to Switch sw1...................................................................................................16
Interface config to connect to Switch sw2....................................................................................................16
Interface config to connect to isp router 4598355_isprouter.......................................................................16
NAT, default route and access list..................................................................................................................16
For ISP Router……………………………………………………………………………………………………………………………………..……17
IP address of pc…………………………………………………………………………………………………………………………………….….17
Verification......................................................................................................................................................26
Testing the applied HSRP…………………………………………………………………………………………………………………………..26
Script of switches and router configuration......................................................................................................29
SCENARIO

Here, we have to implement a network for a restructured Victoria University. The


physical requirement says that five buildings are present where four of the
buildings house two departments from the five given departments and one
houses all the servers of the departments. The departments include:
a. Sport
b. Health
c. Business
d. Engineering
e. Human Resources

The number of devices used in each department have been mentioned and
subnets have been created accordingly.

As required, a Vlans are to be setup to distinguish the departments. The following


table shows how the vlans have been assigned:

Department Vlan
Sport 10
Health 20
Business 30
Engineering 40
Human Resources 50
Topology

The following is a screenshot of the network design. As shown, five departments


have used five switches. The devices and their corresponding vlans are also
labelled. They are connected to the internet through a router which is then
connected to the isp router. For redundancy purposes (i.e if the device fails), two
layer 3 switches have been used, meaning that even in the absence of a fully
functional layer 3 switch, the network still runs smoothly without any
interruptions.
Subnetting

Then I subnetted IP addresses from given IP range 172.24.0.0/16 .The table with all
details of network design for each network is given below:

Sport
Allocated subnet/Mask 255.255.255.0(24)
Network address 172.24.0.0
Default gateway address 172.24.0.1
Valid host address range 172.24.0.2 - 172.24.0.254
Broadcast address 172.24.0.255

Health
Allocated subnet/Mask 255.255.255.128(25)
Network address 172.24.1.0
Default gateway address 172.24.1.1
Valid host address range 172.24.1.2 - 172.24.1.126
Broadcast address 172.24.1.127

Business
Allocated subnet/Mask 255.255.255.128(25)
Network address 172.24.1.128
Default gateway address 172.24.1.129
Valid host address range 172.24.1.130 - 172.24.1.254
Broadcast address 172.24.1.255

Engineering
Allocated subnet/Mask 255.255.255.192(26)
Network address 172.24.2.0
Default gateway address 172.24.2.1
Valid host address range 172.24.2.2 - 172.24.2.62
Broadcast address 172.24.2.63
Human resources
Allocated subnet/Mask 255.255.255.224(27)
Network address 172.24.2.64
Default gateway address 172.24.2.65
Valid host address range 172.24.2.66 - 172.24.2.94
Broadcast address 172.24.2.95
Configuration

As per the requirements, all the devices in the networks need to be


configured .For a basic guidelines, the step by step procedure include:
a. Configuring vlans
b. Enabling Trunking
c. Assigning IP addresses to all the end devices, the switches and the routers
d. Enabling HSRP for redundancy
e. Enabling NAT

For Switch of Building-k

Switch>enable
Switch#configure terminal
Switch(config)#hostname Building-K

Assigning Vlans
Building-K#config t
Enter configuration commands, one per line. End with CNTL/Z.
Building-K(config)#vlan 10
Building-K(config-vlan)#name sports
Building-K(config-vlan)#exit

Building-K(config)#vlan 20
Building-K(config-vlan)#name health
Building-K(config-vlan)#exit

Building-K(config)#vlan 30
Building-K(config-vlan)#name business
Building-K(config-vlan)#exit

Building-K(config)#vlan 40
Building-K(config-vlan)#name engineering
Building-K(config-vlan)#exit

Building-K(config)#vlan 50
Building-K(config-vlan)#name humanresources
Building-K(config-vlan)#exit
Assigining Vlans to the port
Building-K(config)#int f0/1
Building-K(config-if)#switchport mode access
Building-K(config-if)#switchport access vlan 10
Building-K(config-if)#no shut
Building-K(config-if)#exit

Building-K(config)#int f0/2
Building-K(config-if)#switchport mode access
Building-K(config-if)#switchport access vlan 20
Building-K(config-if)#no shut
Building-K(config-if)#exit

Building-K(config)#int f0/3
Building-K(config-if)#switchport mode access
Building-K(config-if)#switchport access vlan 30
Building-K(config-if)#no shut
Building-K(config-if)#exit

Building-K(config)#int f0/4
Building-K(config-if)#switchport mode access
Building-K(config-if)#switchport access vlan 40
Building-K(config-if)#no shut
Building-K(config-if)#exit

Building-K(config)#int f0/5
Building-K(config-if)#switchport mode access
Building-K(config-if)#switchport access vlan 50
Building-K(config-if)#no shut
Building-K(config-if)#exit

Building-K(config)#int f0/6
Building-K(config-if)#switchport mode access
Building-K(config-if)#switchport access vlan 50
Building-K(config-if)#no shut
Building-K(config-if)#exit

Enabling Trunking to ports

Building-K(config)#int f0/7
Building-K(config-if)#switchport mode trunk
Building-K(config-if)#no shut
Building-K(config-if)#exit

For Switch of Building A


Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname Building-A

Assigning Vlans
Building-A(config)#vlan 30
Building-A(config-vlan)#name business
Building-A(config-vlan)#exit

Building-A(config)#vlan 50
Building-A(config-vlan)#name humanresources
Building-A(config-vlan)#exit

Assigning vlans to port

Building-A(config)#int f0/1
Building-A(config-if)#switchport mode access
Building-A(config-if)#switchport access vlan 30
Building-A(config-if)#no shut
Building-A(config-if)#exit

Building-A(config)#int f0/3
Building-A(config-if)#switchport mode access
Building-A(config-if)#switchport access vlan 50
Building-A(config-if)#no shut
Building-A(config-if)#exit

Enabling trunking ports linked to layer3 switches


Building-A(config)#int f0/5
Building-A(config-if)#switchport mode trunk
Building-A(config-if)#no shut
Building-A(config-if)#exit

Building-A(config)#int f0/6
Building-A(config-if)#switchport mode trunk
Building-A(config-if)#no shut
Building-A(config-if)#exit

For Switch of Building -G


Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname Building-G

Assigning Vlans

Building-G(config)#vlan 30
Building-G(config-vlan)#name business
Building-G(config-vlan)#exit

Building-G(config)#vlan 40
Building-G(config-vlan)#name engineering
Building-G(config-vlan)#exit

Assigning Vlans to ports


Building-G(config)#int f0/1
Building-G(config-if)#switchport mode access
Building-G(config-if)#switchport access vlan 30
Building-G(config-if)#no shut
Building-G(config-if)#exit

Building-G(config)#int f0/4
Building-G(config-if)#switchport mode access
Building-G(config-if)#switchport access vlan 40
Building-G(config-if)#no shut
Building-G(config-if)#exit

Enabling tunking to the ports linked

Building-G(config)#int f0/5
Building-G(config-if)#switchport mode trunk
Building-G(config-if)#exit

Building-G(config)#int f0/6
Building-G(config-if)#switchport mode trunk
Building-G(config-if)#exit
For Switch of Building -M

Switch>enable
Switch#configure terminal
Switch(config)#hostname Building-M

Assigning vlans

Building-M(config)#vlan 10
Building-M(config-vlan)#name sports
Building-M(config-vlan)#exit

Building-M(config)#vlan 20
Building-M(config-vlan)#name health
Building-M(config-vlan)#exit

Assigning vlans to ports


Building-M(config)#int f0/1
Building-M(config-if)#switchport mode acces
Building-M(config-if)#switchport access vlan 10
Building-M(config-if)#no shut
Building-M(config-if)#exit

Building-M(config)#int f0/3
Building-M(config-if)#switchport mode access
Building-M(config-if)#switchport access vlan 20
Building-M(config-if)#no shut
Building-M(config-if)#exit

Enabling trunking to ports linked to layer 3 switch

Building-M(config)#int f0/5
Building-M(config-if)#switchport mode trunk
Building-M(config-if)#no shut
Building-M(config-if)#exit

Building-M(config)#int f0/6
Building-M(config-if)#switchport mode trunk
Building-M(config-if)#no shut
Building-M(config-if)#exit
For switch of Building -L
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname Building-L

Assigining Vlans

Building-L(config)#vlan 10
Building-L(config-vlan)#name sports
Building-L(config-vlan)#exit

Building-L(config)#vlan 20
Building-L(config-vlan)#name health
Building-L(config-vlan)#exit

Assigining vlans to ports

Building-L(config)#int f0/1
Building-L(config-if)#switchport mode access
Building-L(config-if)#switchport access vlan 10
Building-L(config-if)#no shut
Building-L(config-if)#exit

Building-L(config)#int f0/3
Building-L(config-if)#switchport mode access
Building-L(config-if)#switchport access vlan 20
Building-L(config-if)#no shut
Building-L(config-if)#exit

Enabling trunk to ports linked to layer 3 switch


Building-L(config)#int f0/5
Building-L(config-if)#switchport mode trunk
Building-L(config-if)#no shut
Building-L(config-if)#exit

Building-L(config)#int f0/6
Building-L(config-if)#switchport mode trunk
Building-L(config-if)#no shut
Building-L(config-if)#exit
For Multilayer Switch 0

Enabling HSRP

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#
Switch(config)#hostname Mainswitch

For vlan 10
Mainswitch(config)#int vlan 10
Mainswitch(config-if)#ip address 172.29.0.3 255.255.255.0
Mainswitch(config-if)#standby 10 ip 172.29.0.1
Mainswitch(config-if)#standby 10 priority 110
Mainswitch(config-if)#standby 10 preempt
Mainswitch (config-if)#ip routing
Mainswitch(config-if)#exit

For vlan 20
Mainswitch(config)#int vlan 20
Mainswitch(config-if)#ip address 172.29.1.3 255.255.255.128
Mainswitch(config-if)#standby 20 ip 172.29.1.1
Mainswitch (config-if)#ip routing
Mainswitch(config-if)#no shut
Mainswitch(config-if)#exit

For vlan 30
Mainswitch(config)#int vlan 30
Mainswitch(config-if)#ip address 172.29.1.131 255.255.255.128
Mainswitch(config-if)#standby 30 ip 172.29.1.129
Mainswitch (config-if)#ip routing
Mainswitch(config-if)#no shut
Mainswitch(config-if)#exit

For vlan 40
Mainswitch(config)#int vlan 40
Mainswitch(config-if)#ip address 172.29.2.3 255.255.255.192
Mainswitch(config-if)#standby 40 ip 172.29.2.1
Mainswitch (config-if)#ip routing
Mainswitch(config-if)#no shut
Mainswitch(config-if)#exit

Vlan 50
Mainswitch(config)#int vlan 50
Mainswitch(config-if)#ip address 172.29.2.67 255.255.255.224
Mainswitch(config-if)#standby 50 ip 172.29.2.65
Mainswitch(config-if)#standby 50 priority 90
Mainswitch (config-if)#ip routing
Mainswitch(config-if)#no shut
Mainswitch(config-if)#exit

For interface f0/7


Mainswitch(config)#int f0/7
Mainswitch(config-if)#no switchport
Mainswitch(config-if)#ip address 172.29.2.98 255.255.255.252
Mainswitch(config-if)#no shut
Mainswitch(config-if)#exit

For Multilayer Switch1

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname Standbyswitch

Vlan 10
Standbyswitch(config)#int vlan 10
Standbyswitch(config-if)#ip address 172.29.0.2 255.255.255.0
Standbyswitch(config-if)#standby 10 ip 172.29.0.1
Standbyswitch(config-if)#standby 10 preempt
Standbyswitch(config-if)#ip routing
Standbyswitch(config-if)#no shut
Standbyswitch(config-if)#exit

Vlan 20

Standbyswitch(config)#int vlan 20
Standbyswitch(config-if)#ip address 172.29.1.2 255.255.255.128
Standbyswitch(config-if)#standby 20 ip 172.29.1.1
Standbyswitch(config-if)#standby 20 preempt
Standbyswitch(config-if)#ip routing
Standbyswitch(config-if)#exit

Vlan 30
Standbyswitch(config)#int vlan 30
Standbyswitch(config-if)#ip address 172.29.1.130 255.255.255.128
Standbyswitch(config-if)#standby 30 ip 172.29.1.129
Standbyswitch(config-if)#standby 30 priority 120
Standbyswitch(config-if)#standby 30 preempt
Standbyswitch(config-if)#ip routing
Standbyswitch(config-if)#no shut
Standbyswitch(config-if)#exit

Vlan 40
Standbyswitch(config)#int vlan 40
Standbyswitch(config-if)#ip address 172.29.2.2 255.255.255.192
Standbyswitch(config-if)#standby 40 ip 172.29.2.1
Standbyswitch(config-if)#standby 40 priority 110
Standbyswitch(config-if)#ip routing
Standbyswitch(config-if)#no shut
Standbyswitch(config-if)#exit

Vlan 50
Standbyswitch(config)#int vlan 50
Standbyswitch(config-if)#ip addres 172.29.2.66 255.255.255.224
Standbyswitch(config-if)#standby 50 ip 172.29.2.65.
Standbyswitch(config-if)#standby 50 preempt
Standbyswitch(config-if)#ip routing
Standbyswitch(config-if)#no shut
Standbyswitch(config-if)#exit

For interface 0/7


Standbyswitch(config)#int f0/7
Standbyswitch(config-if)#no switchport
Standbyswitch(config-if)#ip address 172.29.2.102 255.255.255.252
Standbyswitch(config-if)#no shut
Standbyswitch(config-if)#exit

For Getaway Router

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname s4627224
s4627229(config)#no ip domain lookup
s4627229(config)#spanning-tree mode pvst

Interface config to connect to Multilayer Switch 1 - FastEthernet0/0


s4627229(config)#int f0/0
s4627229(config-if)#ip address 172.29.2.101 255.255.255.252
s4627229(config-if)#ip nat inside
s4627229(config-if)#no shut
s4627229(config-if)#exit

Interface config to connect to Multilayer Switch 2 - FastEthernet0/1

s4627229(config)#int f0/1
s4627229(config-if)#ip address 172.29.2.97 255.255.255.252
s4627229(config-if)#ip nat inside
s4627229(config-if)#no shut
s4627229(config-if)#exit

interface config to connect ISP router


s4627229(config)#int s0/0/0
s4627224(config-if)#ip address 200.1.4.1 255.255.255.0
s4627224(config-if)#ip nat outside
s4627224(config-if)#no shut
s4627224(config-if)#exit

Nat,default route accesslist


s4627229(config)#int s0/0/0
s4627229(config-if)#ip address 200.1.4.1 255.255.255.0
s4627229(config-if)#ip nat outside
s4627229(config-if)#no shut
s4627224(config-if)#exit

s4627229(config)#ip nat pool lan 200.1.4.5 200.1.4.30 netmask 255.255.255.0


s4627229(config)#ip nat inside source list 1 interface Serial0/0/0 overload
s4627229(config)# ip flow-export version 9
s4627229(config)# access-list 1 permit 172.29.0.0 0.0.0.255
s4627229(config)#end

For ISP router


Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int s0/0/0
Router(config-if)#ip address 200.1.4.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#router-rip
Router(config-router)# version 2
Router(config-router)#etwork 172.29.0.0
Router(config-router)#network 200.1.4.0
Router(config-if)#exit

Spanning tree in each vlan in MultilayerSwitch 0

Mainswitch(config)#spanning-tree vlan 10 root primary


Mainswitch(config)#spanning-tree vlan 20 root primary
Mainswitch(config)#spanning-tree vlan 30 root primary
Mainswitch(config)#spanning-tree vlan 40 root primary
Mainswitch(config)#spanning-tree vlan 50 root primary

Spanning tree in each vlan in stanby switch

Standbyswitch (config)#spanning-tree vlan 20 root Secondary


Standbyswitch (config)#spanning-tree vlan 30 root Secondary
Standbyswitch (config)#spanning-tree vlan 40 root Secondary
Standbyswitch (config)#spanning-tree vlan 50 root Secondary
Verification

Figure 1Pinging vlan 10 from vlan 50

Figure 2Pinging vlan 20 vlan 30


Figure 3Shutting main switch

Figure 4 Pinging vlan with a server down


Figure 5pinging from bulding M to L

Figure 6Pingning 200.1.4.1 from standby witch


Figure 7pinging isp router from a pc

Script of the switches and routers configuration

Building-L
Building-L>
Building-L>enable
Building-L#show run
Building configuration...

Current configuration : 1168 bytes


!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Building-L
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport mode trunk
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
!
end

Building-M
(Building-M>enable
Building-M#show run
Building configuration...

Current configuration : 1168 bytes


!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Building-M
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport mode trunk
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
!
end

Building-G
(Building-G>enable
Building-G#show run
Building configuration...

Current configuration : 1230 bytes


!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Building-G
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport mode trunk
!
interface FastEthernet0/3
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 40
switchport mode access
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
interface Vlan30
mac-address 00d0.583e.1701
no ip address
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
!
end

Building-A
Building-A>
Building-A>
Building-A>enable
Building-A#show run
Building configuration...

Current configuration : 1168 bytes


!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Building-A
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport mode trunk
!
interface FastEthernet0/3
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 50
switchport mode access
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
!
end

Switch-K
(Building-K>
Building-K>
Building-K>enable
Building-K#show run
Building configuration...

Current configuration : 1321 bytes


!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Building-K
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 40
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 50
switchport mode access
!
interface FastEthernet0/6
switchport mode trunk
!
interface FastEthernet0/7
switchport mode trunk
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
!
end

Main switch
Mainswitch#enable
Mainswitch#ping 200.1.4.0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.1.4.0, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

Mainswitch#show run
Building configuration...

Current configuration : 2060 bytes


!
version 12.2(37)SE1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Mainswitch
!
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
no switchport
ip address 172.24.2.162 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0001.4326.0901
ip address 172.24.0.2 255.255.255.0
standby 10 ip 172.24.0.1
standby 10 priority 110
standby 10 preempt
!
interface Vlan20
mac-address 0001.4326.0902
ip address 172.24.1.2 255.255.255.128
standby 10 ip 172.24.1.1
standby 10 priority 110
standby 10 preempt
!
interface Vlan30
mac-address 0001.4326.0903
ip address 172.24.1.130 255.255.255.128
standby 10 ip 172.24.1.129
standby 10 priority 110
standby 10 preempt
!
interface Vlan40
mac-address 0001.4326.0904
ip address 172.24.2.2 255.255.255.192
standby 10 ip 172.24.2.1
standby 10 priority 110
standby 10 preempt
!
interface Vlan50
mac-address 0001.4326.0905
ip address 172.24.2.66 255.255.255.224
standby 10 ip 172.24.2.65
standby 10 priority 110
standby 10 preempt
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.24.2.161
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
!
end

Backup switch

Standbyswitch#show run
Building configuration...

Current configuration : 1958 bytes


!
version 12.2(37)SE1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Standbyswitch
!
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
no switchport
ip address 172.24.2.166 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0090.0ca7.3401
ip address 172.24.0.3 255.255.255.0
standby 10 ip 172.24.0.1
standby 10 priority 90
!
interface Vlan20
mac-address 0090.0ca7.3402
ip address 172.24.1.3 255.255.255.128
standby 10 ip 172.24.1.1
standby 10 priority 90
!
interface Vlan30
mac-address 0090.0ca7.3403
ip address 172.24.1.131 255.255.255.128
standby 10 ip 172.24.1.129
standby 10 priority 90
!
interface Vlan40
mac-address 0090.0ca7.3404
ip address 172.24.2.3 255.255.255.192
standby 10 ip 172.24.2.1
standby 10 priority 90
!
interface Vlan50
mac-address 0090.0ca7.3405
ip address 172.24.2.67 255.255.255.224
standby 10 ip 172.24.2.65
standby 10 priority 90
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.24.2.165
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
!
end

Router s4627224

s4627224#show run
Building configuration...

Current configuration : 1163 bytes


!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname s4627224
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.24.2.161 255.255.255.252
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.24.2.165 255.255.255.252
ip nat inside
duplex auto
speed auto
!
interface Serial0/0/0
ip address 200.1.4.1 255.255.255.0
ip nat outside
clock rate 2000000
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip nat pool lan 200.1.4.3 200.1.4.20 netmask 255.255.255.0
ip nat inside source list 10 pool lan
ip classless
ip route 0.0.0.0 0.0.0.0 172.24.2.162
ip route 0.0.0.0 0.0.0.0 172.24.2.166
!
ip flow-export version 9
!
!
access-list 10 permit 172.24.0.0 0.0.254.255
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Isp router

Router#show run
Building configuration...

Current configuration : 859 bytes


!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 200.1.4.2 255.255.255.0
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 200.1.4.1
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

You might also like