You are on page 1of 4

Download PNETLab Platform

PNETLAB Store
PNETLab.com

BGP EBGP Multihop


Lab Topology:
The lab network topology is illustrated below:

Lab Objective:
The objective of this lab exercise is for you to learn and understand how to configure BGP eBGP
Multihop.
Task:
Above we will try to configure eBGP between R1 and R3. Since R2 is in the middle.

Solution

Basic Configuration:

Router R1 R2
Interface interface Ethernet0/0 interface Ethernet0/0
configuration no shutdown no shutdown
ip address 10.1.12.1 255.255.255.0 ip address 10.1.12.2 255.255.255.0
!
interface Ethernet0/1
no shutdown
ip address 10.1.23.2 255.255.255.0

1
Download PNETLab Platform
PNETLAB Store
PNETLab.com

Router R3
Interface interface Ethernet0/0
configuration no shutdown
ip address 10.1.23.3 255.255.255.0

eBGP (external BGP) by default requires two Cisco IOS routers to be directly connected to each
other in order to establish a neighbor adjacency. This is because eBGP routers use a TTL of one for
their BGP packets. When the BGP neighbor is more than one hop away, the TTL will decrement to
0 and it will be discarded.

First, we need to make R1 reach to R3

R1(config)#ip route 10.1.23.0 255.255.255.0 10.1.12.2

R3(config)#ip route 10.1.12.0 255.255.255.0 10.1.23.2

Let’s configure eBGP

R1(config)#router bgp 1
R1(config-router)#neighbor 10.1.23.3 remote-as 3

R3(config)#router bgp 3
R3(config-router)#neighbor 10.1.12.1 remote-as 1

BGP will not even try to establish a eBGP neighbor adjacency. BGP knows that since these
routers are on different subnets, they are not directly connected.

R1#show ip bgp neighbors | include External


External BGP neighbor not directly connected.

R3#show ip bgp neighbors | include External


External BGP neighbor not directly connected.

Let’s disable this check so that R1 and R3 try to become eBGP neighbors

R1(config-router)#neighbor 10.1.23.3 disable-connected-check

R3(config-router)#neighbor 10.1.12.1 disable-connected-check

Here’s what happens now:

2
Download PNETLab Platform
PNETLAB Store
PNETLab.com

The wireshark capture above shows us that R1 is trying to connect to R3. As you can see the TTL is 1.
Once R2 receives this packet it will decrement the TTL by 1 and drop it

To fix this issue, we’ll tell eBGP to increase the TTL.

R1(config)#router bgp 1
R1(config-router)#no neighbor 10.1.23.3 disable-connected-check
R1(config-router)#neighbor 10.1.23.3 ebgp-multihop 2

R3(config)#router bgp 3
R3(config-router)#no neighbor 10.1.12.1 disable-connected-check

3
Download PNETLab Platform
PNETLAB Store
PNETLab.com

R3(config-router)#neighbor 10.1.12.1 ebgp-multihop 2

After a few seconds, our routers will become eBGP neighbors:

R1(config-router)#
*Aug 17 04:07:46.900: %BGP-5-ADJCHANGE: neighbor 10.1.23.3 Up

R3(config-router)#
*Aug 17 04:07:46.898: %BGP-5-ADJCHANGE: neighbor 10.1.12.1 Up

Let’s verify this change

R1#show ip bgp neighbors | include External


External BGP neighbor may be up to 2 hops away.

R3#show ip bgp neighbors | include External


External BGP neighbor may be up to 2 hops away.

You might also like