You are on page 1of 10

Download PNETLab Platform

PNETLAB Store
PNETLab.com

Troubleshoot EtherChannel

Lab Topology:
Please use the following topology to complete this lab exercise:

https://user.pnetlab.com/store/labs/detail?id=16033395073825

Objectives
Part 1: Examine the Physical Layer and Correct Switch Port Mode Issues
Part 2: Identify and Correct Port Channel Assignment Issues
Part 3: Identify and Correct Port Channel Protocol Issues

1
Download PNETLab Platform
PNETLAB Store
PNETLab.com

Background
A junior technician recently configured four switches. Users are complaining that the network is running
slowly, and they would like you to investigate.
Port Channel Table

Channel Group Ports Protocol

S1: E1/0, E1/1 LACP active


1
S3: E1/0, E1/1
S2: E1/0, E1/1 LACP active
2
S4: E1/0, E1/1
S1: E0/0, E0/1 LACP active
3
S2: E0/0, E0/1
S3: E0/0, E0/1 LACP active
4
S4: E0/0, E0/1
S1: E0/2, E0/3 LACP active
5
S4: E0/2, E0/3
S2: E0/2, E0/3 LACP active
6
S3: E0/2, E0/3

Device Table

Device Group Ports

1 E1/0, E1/1
S1 S1
3 E0/0, E0/1
S1

5 E0/2, E0/3
2 E1/0, E1/1
S2 3 E0/0, E0/1
S2
S2

6 E0/2, E0/3
1 E1/0, E1/1
S3 4 E0/0, E0/1
S3
S3

6 E0/2, E0/3
2 E1/0, E1/1
S4 4 E0/0, E0/1
S4
S4

5 E0/2, E0/3

2
Download PNETLab Platform
PNETLAB Store
PNETLab.com

Instructions

Part 1: Examine the Physical Layer and Correct Switch Port Mode Issues
Step 1: Look for access ports.
Examine the switches. When two or more redundant links connect the same switches, Spanning Tree protocol
will only put one port in forwarding mode to prevent switching loops. When physical ports are assigned to an
EtherChannel port, they behave as one logical port. Each pair will either be operational or down.

S1#show ip interface brief


Interface IP-Address OK? Method Status Protocol
Ethernet0/0 unassigned YES unset up up
Ethernet0/1 unassigned YES unset up up
Ethernet0/2 unassigned YES unset up up
Ethernet0/3 unassigned YES unset up up
Ethernet1/0 unassigned YES unset up up
Ethernet1/1 unassigned YES unset up up
Ethernet1/2 unassigned YES unset up up
Ethernet1/3 unassigned YES unset up up
Port-channel1 unassigned YES unset down down
Port-channel3 unassigned YES unset up up
Port-channel5 unassigned YES unset up up
Vlan1 unassigned YES unset administratively down down

S2#show ip interface brief


Interface IP-Address OK? Method Status Protocol
Ethernet0/0 unassigned YES unset up up
Ethernet0/1 unassigned YES unset up up
Ethernet0/2 unassigned YES unset up up
Ethernet0/3 unassigned YES unset up up
Ethernet1/0 unassigned YES unset up up
Ethernet1/1 unassigned YES unset up up
Ethernet1/2 unassigned YES unset up up
Ethernet1/3 unassigned YES unset up up
Port-channel2 unassigned YES unset up up
Port-channel3 unassigned YES unset down down
Port-channel6 unassigned YES unset up up
Vlan1 unassigned YES unset administratively down down

3
Download PNETLab Platform
PNETLAB Store
PNETLab.com

S3#show ip interface brief


Interface IP-Address OK? Method Status Protocol
Ethernet0/0 unassigned YES unset up up
Ethernet0/1 unassigned YES unset administratively down down
Ethernet0/2 unassigned YES unset up up
Ethernet0/3 unassigned YES unset up up
Ethernet1/0 unassigned YES unset up up
Ethernet1/1 unassigned YES unset up up
Ethernet1/2 unassigned YES unset up up
Ethernet1/3 unassigned YES unset up up
Port-channel1 unassigned YES unset down down
Port-channel4 unassigned YES unset up up
Port-channel6 unassigned YES unset up up
Vlan1 unassigned YES unset administratively down down

S4#show ip interface brief


Interface IP-Address OK? Method Status Protocol
Ethernet0/0 unassigned YES unset up up
Ethernet0/1 unassigned YES unset up up
Ethernet0/2 unassigned YES unset up up
Ethernet0/3 unassigned YES unset up up
Ethernet1/0 unassigned YES unset up up
Ethernet1/1 unassigned YES unset up up
Ethernet1/2 unassigned YES unset up up
Ethernet1/3 unassigned YES unset up up
Port-channel2 unassigned YES unset up up
Port-channel4 unassigned YES unset up up
Port-channel5 unassigned YES unset up up

4
Download PNETLab Platform
PNETLAB Store
PNETLab.com

Step 2: Verify ports are in trunk mode.


a. Verify that all physical ports in the topology are configured as trunks. Correct any ports that are in access
mode.
b. Correct any EtherChannel ports that are not configured as trunks.

S1#show int trunk


Port Mode Encapsulation Status Native vlan
Et1/0 auto 802.1q trunking 1
Et1/1 auto 802.1q trunking 1

S2#show int trunk


Port Mode Encapsulation Status Native vlan
Et0/2 on 802.1q trunking 1
Et0/3 on 802.1q trunking 1
Po2 on 802.1q trunking 1
Po3 on 802.1q trunking 1

S3#show int trunk


Port Mode Encapsulation Status Native vlan
Et0/0 on 802.1q trunking 1
Et0/2 on 802.1q trunking 1
Et0/3 on 802.1q trunking 1
Et1/0 on 802.1q trunking 1
Et1/1 on 802.1q trunking 1

S4#show int trunk


Port Mode Encapsulation Status Native vlan
Et0/0 on 802.1q trunking 1
Et0/1 on 802.1q trunking 1
Po2 on 802.1q trunking 1
Po4 on 802.1q trunking 1

5
Download PNETLab Platform
PNETLAB Store
PNETLab.com

Part 2: Identify and Correct Port Channel Assignment Issues


Step 1: Examine port channel assignments.
The Packet Tracer topology and the Port Channel and Device tables provide details about the physical ports
and their EtherChannel assignments. Use the show etherchannel summary command to learn how the
EtherChannel links are configured. Verify that the switches are configured as shown in the documentation.

Step 2: Correct port channel assignments.


Correct any switch ports that are not assigned to the correct EtherChannel port.

S1#show etherchannel summary


Number of channel-groups in use: 3
Number of aggregators: 3

Group Port-channel Protocol Ports


------+-------------+-----------+-----------------------------------------------
1 Po1(SD) LACP Et1/0(s) Et1/1(s)
3 Po3(SU) LACP Et0/0(P) Et0/1(P)
5 Po5(SU) LACP Et0/2(P) Et0/3(P)

S2#show etherchannel summary


Number of channel-groups in use: 3
Number of aggregators: 3

Group Port-channel Protocol Ports


------+-------------+-----------+-----------------------------------------------
2 Po2(SU) LACP Et1/0(P) Et1/1(P)
3 Po3(SU) LACP Et0/0(P) Et0/1(P)
6 Po6(SD) LACP Et0/2(s) Et0/3(s)

S3#show etherchannel summary


Number of channel-groups in use: 3
Number of aggregators: 3

Group Port-channel Protocol Ports


------+-------------+-----------+-----------------------------------------------
1 Po1(SD) PAgP Et1/0(I)
4 Po4(SD) PAgP Et0/0(I)
6 Po6(SD) PAgP Et0/2(I)

6
Download PNETLab Platform
PNETLAB Store
PNETLab.com

S4#show etherchannel summary


Number of channel-groups in use: 3
Number of aggregators: 3

Group Port-channel Protocol Ports


------+-------------+-----------+-----------------------------------------------
2 Po2(SU) LACP Et1/0(P) Et1/1(P)
4 Po4(SU) LACP Et0/0(s) Et0/1(s) Et0/2(P)
Et0/3(P)
5 Po5(SD) -

Part 3: Identify and Correct Port Channel Protocol Issues

Step 1: Identify protocol issues.


In 2000, the IEEE released 802.3ad (LACP), which is an open standard version of EtherChannel. For
compatibility reasons, the network design team chose to use LACP across the network. The design team has
made it a requirement that all ports that participate in EtherChannel need to actively negotiate the link as
LACP. Verify that the physical ports are configured as indicated in the topology and Port Channel Table.

Step 2: Correct Protocol issues.


a. Correct any switch ports that are not negotiating using LACP.
b. Reissue the show etherchannel summary command to verify that all EtherChannel links are now correctly
configured.
End of Document

Solution:
Step 1: Check interface physical enable in Switch each other
Solution: Enable port e0/1

S3# show run int e0/1


interface Ethernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
no channel-group
channel-group 4 mode active
no shutdown

Step 2: In S1, Channel-Group 1 is suspended and chose to use LACP across the network. In contrast to S3 used
PAgP.Here the problem!!!

Solution: Change mode PAgP to LACP and assign port to Channel-Group.

7
Download PNETLab Platform
PNETLAB Store
PNETLab.com

S3# show run


interface Ethernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
no channel-group
channel-group 4 mode active
!
interface Ethernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
no channel-group
channel-group 4 mode active
!
interface Ethernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
no channel-group
channel-group 6 mode active
!
interface Ethernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
no channel-group
channel-group 6 mode active
!
interface Ethernet1/0
switchport trunk encapsulation dot1q
switchport mode trunk
no channel-group
channel-group 1 mode active
!
interface Ethernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
no channel-group
channel-group 1 mode active

Step 3: In S4, range port e0/2-3 assign to Po4. Admin config assign port to channel-group wrong.
Solution: No channel-group and assign port to channel-group with topology network.

S4(config)#
interface Ethernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 5 mode active
!
interface Ethernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 5 mode active

8
Download PNETLab Platform
PNETLAB Store
PNETLab.com

Verification:
S1#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator

M - not in use, minimum links not met


m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

A - formed by Auto LAG

Number of channel-groups in use: 3


Number of aggregators: 3

Group Port-channel Protocol Ports


------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Et1/0(P) Et1/1(P)
3 Po3(SU) LACP Et0/0(P) Et0/1(P)
5 Po5(SU) LACP Et0/2(P) Et0/3(P)
S2#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator

M - not in use, minimum links not met


m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

A - formed by Auto LAG

Number of channel-groups in use: 3


Number of aggregators: 3

Group Port-channel Protocol Ports


------+-------------+-----------+-----------------------------------------------
2 Po2(SU) LACP Et1/0(P) Et1/1(P)
3 Po3(SU) LACP Et0/0(P) Et0/1(P)
6 Po6(SU) LACP Et0/2(P) Et0/3(P)

9
Download PNETLab Platform
PNETLAB Store
PNETLab.com

S3#show etherchannel summary


Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator

M - not in use, minimum links not met


m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

A - formed by Auto LAG

Number of channel-groups in use: 3


Number of aggregators: 3

Group Port-channel Protocol Ports


------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Et1/0(P) Et1/1(P)
4 Po4(SU) LACP Et0/0(P) Et0/1(P)
6 Po6(SU) LACP Et0/2(P) Et0/3(P)
S4#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator

M - not in use, minimum links not met


m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

A - formed by Auto LAG

Number of channel-groups in use: 3


Number of aggregators: 3

Group Port-channel Protocol Ports


------+-------------+-----------+-----------------------------------------------
2 Po2(SU) LACP Et1/0(P) Et1/1(P)
4 Po4(SU) LACP Et0/0(P) Et0/1(P)
5 Po5(SU) LACP Et0/2(P) Et0/3(P)

10

You might also like