You are on page 1of 165

Connecting Router with 2 PCS

Computer networking professionals getting started with Packet Tracer may find the interface to
be flustered. Being a development program, this is only natural. However, learning how to
configure a router with Packet Tracer will put professionals on the right track to mastering the
program in about half an hour.

By this time, you should already have the Packet Tracer download and have it installed on your
computer. Open the program and select the router from the lower left-hand corner, and drag it
into the center of the sandbox screen as seen below. (Click for larger picture)

We will be setting up a very basic network that allows two computers to communicate, so the
next step is to select end devices from the bottom left-hand corner and drag it to the sandbox
screen. Do this twice to make two computers appear below the router.

Now select connections from the same bottom left-hand corner. When you connect like-
devices(Such as a router and computer) you use a crossover cable, so you should select copper
cross-over cable from the second menu to the immediate right. Click on Router0, and connect
the cable via FastEthernet0/0 as seen below:
Now click the PC0 and select FastEthernet. You will notice that although a link is established, it
is not functional. You can tell by the red dots that are present on both ends of the connection.
Once the router is configured correctly, the red dots will turn green to indicate the devices are
able to communicate.

Do the same operation to PC1, only this time connect the cable to FastEthernet0/1 since
FastEthernet0/0 is already taken by PC0. Your network should be similar to the one below at
this point:

Configuring The Router In Packet Tracer

A router that is turned off doesn’t work very well! Click on your router to bring up the
configuration menu and verify that it is turned on.When on, there will be a small green light
below the switch as seen in the diagram.
Next we have to open the Ethernet ports to allow communication. Although they are physically
connected, they are in a state that is known as being in administrative shut down. Now click on
the CLI tab to access the configuration menu. If you’ve used the Cisco IOS before, you will
notice it looks and acts the same way.

1. Press RETURN to start the session

2. Type enable to get to privileged mode (this gives you more options in configuring the router)

3. Type config terminal (or config t for short) to access the configuration menu.

4. Type interface fastethernet0/0 to access Ethernet0/0

5. Type ip address 192.168.10.1 255.255.255.0 to assign an IP address and subnet mask to the
interface.

6. Type no shutdown to open the interface up for business.

That’s it! You should now see a message similar to the following:

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Now we have to do the same thing for fastethernet0/1. If you don’t, there still won’t be a
connection to PC1! Make sure to enter the IP address carefully as seen below:

1. Press Ctrl + Z to go back to the previous mode.

1. Type interface fastethernet0/1


2. Type ip address 192.168.20.1 255.255.255.0

3. Type no shutdown

At this point our router is configured properly. If you test out a ping, you will notice that the
computers still don’t communicate, however!

Configuring The Gateway In Packet Tracer

Our last step is to configure the gateway on each desktop computer. The gateway is the address
we assigned to the Ethernet port that the desktop is connected to. It will allow the computer to
interface with another network, so our ping won’t work without it!

Click on PC0 to bring up the configuration menu. Under global settings you will find a field for
the gateway. Enter the corresponding IP address of the router’s interface, which is 192.168.10.1.
Then click the FastEthernet tab on the left column to set the actual computer’s IP address to be
on the network. Use 192.168.10.2 for the IP address, and 255.255.255.0 for the subnet mask.

Do the same thing for PC1, only use 192.168.20.1 for the gateway address, 192.168.20.2 for the
IP address, and 255.255.255.0 for the subnet mask. You can confirm that your network works by
sending out a packet of information from PC0 to PC1, and vice versa. Click the packet icon on
the right menu as seen below:
Click on PC0 and then click PC1. On the lower right of the screen you will see a message box
that says “Successful.” If it doesn’t, you may have had a syntax error when putting in an IP
address or router configuration command. Review your work or ask for help among the
community if you are stuck.

How to Configure a Simple Static Routing in Packet Tracer

How to configure a simple static routing in packet tracer using a simple topology with two routers
here we go

Steps:

Step 1:First Create a topology like this


you will get a red light first this is configured topology

Step 2: Configure ip address to routers go to global configuration mode in R1 and R2 configure


connected interfaces

In Router 1

Interface Fastethernet0/0 in global configuration mode

R1(config)#interface fastethernet 0/0


R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
Interface Serial 2/0

R1(config)#interface serial 2/0

R1(config-if)#ip address 20.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#encapsulation ppp

R1(config-if)#no shutdown

R1(config-if)#exit

In Router 2

Interface Fastethernet 0/0

R2(config)#interface fastethernet 0/0

R2(config-if)#ip address 30.0.0.1 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#exit

Interface Serial 2/0

R2(config)#interface serial 2/0

R2(config-if)#ip address 20.0.0.2 255.0.0.0


R2(config-if)#encapsulation ppp

R2(config-if)#no shutdown

R2(config-if)#exit

Step 3 : Assign ip address for both Pc's with appropriate ip and subnetmask and default gateway How ?

Step 4: Now configure both router with static route


By default, Routers Know only directed connected networks here Router 1 know only 10.0.0.0 and
20.0.0.0 it doesn't know the 30.0.0.0 like this R2 doesn't know about 10.0.0.0.So We are going to add
Static route to this both router

R1(config)#ip route Destination Network| Destination N/W SubnetMask |Next Hop Address

In Router R1,Just give this command,In this case Destination is 30.0.0.0 and its subnet mask is 255.0.0.0
next hop address is 20.0.0.2

R1(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2

In Router R2

R2(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1

Thats it!!..Now both routers know all networks,check by ping ip address of host

Step 5:Double click PC move to desktop then command prompt give the command ping 30.0.0.10 in PC 0
you will get reply from 30.0.0.10 like this
From PC1
How to configure static routing using three routers in packet tracer

Steps:

Step 1: Configure ip address to all interfaces with ip address given in this topology
By default Router knows network that is directly connected, So Router R1 knows the network
10.0.0.0,20.0.0.0 it doesn't know about the network 30.0.0.0 and 40.0.0.0.Now check the R1
Routing table

In R1: In privileged mode give this command

R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP


D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet0/0


C 20.0.0.0/8 is directly connected, Serial2/0

Here only two directly connected networks are present.

Step 2 :Now add this two network using static route command

R1(config)#ip route Destination Network| Destination N/W SubnetMask |Next Hop Address

In router R1 go to global configuration mode and enter this command

R1(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2


R1(config)#ip route 40.0.0.0 255.0.0.0 20.0.0.2

Step 3:Now, Check routing table of Router R1 by giving the command in privileged mode

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet0/0


C 20.0.0.0/8 is directly connected, Serial2/0
S 30.0.0.0/8 [1/0] via 20.0.0.2
S 40.0.0.0/8 [1/0] via 20.0.0.2

Now, Router R1 knows the network 30.0.0.0 &40.0.0.0

Step 4:Configure the routers R2 and R3 as we configured in R1

In router R2 go to global Configuration mode add static route to 10.0.0.0 and 40.0.0.0

R2(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1


R2(config)#ip route 40.0.0.0 255.0.0.0 30.0.0.2

In router R3

R3(config)#ip route 10.0.0.0 255.0.0.0 30.0.0.1


R3(config)#ip route 20.0.0.0 255.0.0.0 30.0.0.1

Check routing table of R2 and R3 by using the command

#show ip route

Step 5:Now go to host command prompt and ping ip address of another host you will get reply
like this

PC>
PC>ping 40.0.0.10

Pinging 40.0.0.10 with 32 bytes of data:

Reply from 40.0.0.10: bytes=32 time=125ms TTL=125


Reply from 40.0.0.10: bytes=32 time=125ms TTL=125
Reply from 40.0.0.10: bytes=32 time=125ms TTL=125
Reply from 40.0.0.10: bytes=32 time=125ms TTL=125

Ping statistics for 40.0.0.10:


Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 125ms, Maximum = 125ms, Average = 125ms

Here we are going to see how to configure default route in a routers ,we can configure default
route for stub network. i.e dead end router we can point an ip address or exit interface for all
packets that came to that router.Here we go..

Steps:

Steps 1:Her e, in our topology we have two stub network .


Apply basic configurations ip address to all interfaces and pc's

Step 2:Configure static route on R2 to route packets for 10.0.0.0 and 40.0.0.0 networks like this

R2(config)#ip route Destination Network| Destination N/W SubnetMask |Next Hop Address or
Exit Interface

In Router R2

R2(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1


R2(config)#ip route 40.0.0.0 255.0.0.0 30.0.0.2
Step 3:Now we are going to configure default route on R1 and R3.So the routers forward packets
to assigned ip address next hop address or exit interface

In Router R1

R1(config)#ip route 0.0.0.0 0.0.0.0 20.0.0.2

In Router R3

R3(config)#ip route 0.0.0.0 0.0.0.0 30.0.0.1

Here, 0.0.0.0 0.0.0.0 represents any network any subnetmask. i.e any packet that came to router
R1 will be forwarded to next hop address 20.0.0.2.Now check the routing table of R1

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 20.0.0.2 to network 0.0.0.0

C 10.0.0.0/8 is directly connected, FastEthernet0/0


C 20.0.0.0/8 is directly connected, Serial2/0
S* 0.0.0.0/0 [1/0] via 20.0.0.2
is directly connected, Serial2/0

S* represents Static default route .Now Ping from 10.0.0.10 to 40.0.0.10 you will get reply as

PC>ping 40.0.0.10

Pinging 40.0.0.10 with 32 bytes of data:


Reply from 40.0.0.10: bytes=32 time=141ms TTL=125
Reply from 40.0.0.10: bytes=32 time=187ms TTL=125
Reply from 40.0.0.10: bytes=32 time=172ms TTL=125
Reply from 40.0.0.10: bytes=32 time=125ms TTL=125

Ping statistics for 40.0.0.10:


Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 125ms, Maximum = 187ms, Average = 156ms

we can also configure exit interface instead of next hop address like this

R1(config)#ip route 0.0.0.0 0.0.0.0 serial 2/0

R3(config)#ip route 0.0.0.0 0.0.0.0 serial 3/0

How to configure DHCP in cisco router using packet tracer simulator,

Step 1:Create a topology like this,


Step 2:Configure router interface fastethernet0/0 and fastethernet

1/0 with ip address.

R1#config t
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown

R1(config-if)#exit
R1(config)#interface fastethernet 1/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

Step 3:Configure DHCP pool for the network 10 and 20,

In Router R1,Global Configuration mode,


R1(config)#service dhcp

This command is to enable the dhcp server on a router. Routers in packet tracer won't accept this
command.By default dhcp will be running on router so skip 'service dhcp' command if you are
configuring dhcp in packet tracer,just create a network pool for the network it will work.Use this
in real time or other simulators like gns3.

R1(config)#ip dhcp pool 10network "where '10network' is the pool name we can use what
ever we
want.This command get us into the DHCP Configuration mode."

R1(dhcp-config)#network 10.0.0.0 255.0.0.0 "It defines the network range to be leased"

R1(dhcp-config)#dns-server 10.0.0.2 "Ip address for the dns server."

R1(dhcp-config)#default-router 10.0.0.1 "Default gateway for this network."

R1(dhcp-config)#exit

DHCP pool for 10 Network

R1(config)#ip dhcp pool 10network


R1(dhcp-config)#network 10.0.0.0 255.0.0.0
R1(dhcp-config)#dns-server 10.0.0.2
R1(dhcp-config)#default-router 10.0.0.1
R1(dhcp-config)#exit

DHCP pool for 20 Network

R1(config)#ip dhcp pool 20network


R1(dhcp-config)#network 20.0.0.0 255.0.0.0
R1(dhcp-config)#dns-server 10.0.0.2
R1(dhcp-config)#default-router 20.0.0.1
R1(dhcp-config)#exit

Now, Click on any of the PC->Desktop->ip configuration->Choose DHCP.Now PC will get an


ip from DHCP server.
Few more command We can use, but we can't configure this in packet tracer.Use gns3 simulator
for this.
R1(dhcp-config)#netbios-server x.x.x.x 'where x.x.x.x is ip address of netbios server.

R1(dhcp-config)#lease x 'where X is the number it sets the lease time,by default 1 (i.e. one
day).

R1(dhcp-config)#ip dhcp excluded address x.x.x.x x.x.x.x 'Range of ip address excluded from
the pool it will not be leased to the clients'.

R1(dhcp-config)#ip dhcp excluded address x.x.x.x 'To exclude only one ip address from the
range of ip address'.

Ex.

R1(dhcp-config)#netbios-server 10.0.0.2
R1(dhcp-config)#lease 2
R1(dhcp-config)#ip dhcp excluded address 10.0.0.1 10.0.0.10
R1(dhcp-config)#ip dhcp excluded address 10.0.0.35

Trouble shooting commands,

Router#show ip dhcp binding 'Displays a list of all bindings created.'

Router#show ip dhcp binding w.x.y.z 'Displays the bindings for a specific DHCP client with
an IP address of w.x.y.z.'

Router#clear ip dhcp binding a.b.c.d 'Clears an automatic address binding from the DHCP
server database.'

Router#clear ip dhcp binding * 'Clears all automatic DHCP bindings.'


Router#show ip dhcp conflict 'Displays a list of all address conflicts recorded by the DHCP
server.'

Router#clear ip dhcp conflict a.b.c.d 'Clears address conflict from the database.'

Router#clear ip dhcp conflict * 'Clears conflicts for all addresses.'

Router#show ip dhcp database 'Displays recent activity on the DHCP database.'

Router#show ip dhcp server statistics 'Displays a list of the number of messages sent and
received by the DHCP server.'

Router#clear ip dhcp server statistics

How to configure DHCP within a LAN in a packet Tracer


0 DHCP, LAN, Packet Tracer 00:41

Here,we are going to see how to configure DHCP within a LAN in a packet tracer,

DHCP-Dynamic Host Configuration Protocol

DHCP Proces,(DORA)

=>Discover( Client discovers the DHCP Server for Ip request )


=>Offer ( DHCP servers offers ip to a client and it will wait for the request from cleint
=>Request ( Client reply for requesting offered ip address from dhcp server,sometimes there will
be more dhcp servers.So,client receives offer from multiple servers.client will reply for only
one offer.So, other offers will be canceled and replaced in a pool.)
=>Acknowledgement (Final step from server sending all infromation to client like DNS,Default
Gateway,tftp,domain name,... )

DHCP Server uses Port 67,Client uses port 68


It uses UDP(User Datagram Protocol).

Step 1:Create a LAN like this,


Step 2:Configure router interface with ip 10.0.0.1 and subnet mask 255.0.0.0

Router>enable
Router#config t
Router(config)#interface fastethernet0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#

Step 3:click on server->config,then assign gateway in our example 10.0.0.1

Step 4:Then Click on Fastethernet and assign ip address and subnet mask.I am going to use 10.0.0.2 and
subnet mask 255.0.0.0 for our server.

Step 5:Click on DHCP,there you can see default pool,

step 6:Just give default gate way,here we are using 10.0.0.1.

Step 7:DNS server,Just give our server ip address,10.0.0.2.

Step 8:Then just edit start ip address.I am going to give 10.0.0.10 and subnet mask 255.0.0.0

Step 9:In Maximum Number of Users,Here we are using Class A Network so we can use 1,67,77,216 ip
address.just give how many ip address you want in this pool.I am going to give 500

Step 10:Assign TFTP server ip address,just give our server ip address,10.0.0.2.

Step 11:And click on save.That's it...


Step 12:Now, Click on any of the PC-> then click on Desktop->Ip configuration,and Choose 'DHCP' wait
for some time,if your dhcp request failed then try few more times.This is how you should get.
How to Configure DHCP in Cisco Router Using Packet Tracer and Gns3
9 DHCP, Packet Tracer 02:16
How to configure DHCP in cisco router using packet tracer simulator,

Step 1:Create a topology like this,

Step 2:Configure router interface fastethernet0/0 and fastethernet

1/0 with ip address.

R1#config t
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown

R1(config-if)#exit
R1(config)#interface fastethernet 1/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

Step 3:Configure DHCP pool for the network 10 and 20,

In Router R1,Global Configuration mode,

R1(config)#service dhcp

This command is to enable the dhcp server on a router. Routers in packet tracer won't accept this
command.By default dhcp will be running on router so skip 'service dhcp' command if you are
configuring dhcp in packet tracer,just create a network pool for the network it will work.Use this in real
time or other simulators like gns3.

R1(config)#ip dhcp pool 10network "where '10network' is the pool name we can use what ever we
want.This command get us into the DHCP Configuration mode."

R1(dhcp-config)#network 10.0.0.0 255.0.0.0 "It defines the network range to be leased"

R1(dhcp-config)#dns-server 10.0.0.2 "Ip address for the dns server."

R1(dhcp-config)#default-router 10.0.0.1 "Default gateway for this network."

R1(dhcp-config)#exit

DHCP pool for 10 Network

R1(config)#ip dhcp pool 10network


R1(dhcp-config)#network 10.0.0.0 255.0.0.0
R1(dhcp-config)#dns-server 10.0.0.2
R1(dhcp-config)#default-router 10.0.0.1
R1(dhcp-config)#exit

DHCP pool for 20 Network

R1(config)#ip dhcp pool 20network


R1(dhcp-config)#network 20.0.0.0 255.0.0.0
R1(dhcp-config)#dns-server 10.0.0.2
R1(dhcp-config)#default-router 20.0.0.1
R1(dhcp-config)#exit

Now, Click on any of the PC->Desktop->ip configuration->Choose DHCP.Now PC will get an ip from DHCP
server.
Few more command We can use, but we can't configure this in packet tracer.Use gns3 simulator for this.
R1(dhcp-config)#netbios-server x.x.x.x 'where x.x.x.x is ip address of netbios server.

R1(dhcp-config)#lease x 'where X is the number it sets the lease time,by default 1 (i.e. one day).

R1(dhcp-config)#ip dhcp excluded address x.x.x.x x.x.x.x 'Range of ip address excluded from the pool it
will not be leased to the clients'.

R1(dhcp-config)#ip dhcp excluded address x.x.x.x 'To exclude only one ip address from the range of ip
address'.

Ex.

R1(dhcp-config)#netbios-server 10.0.0.2
R1(dhcp-config)#lease 2
R1(dhcp-config)#ip dhcp excluded address 10.0.0.1 10.0.0.10
R1(dhcp-config)#ip dhcp excluded address 10.0.0.35

Trouble shooting commands,

Router#show ip dhcp binding 'Displays a list of all bindings created.'

Router#show ip dhcp binding w.x.y.z 'Displays the bindings for a specific DHCP client with an IP
address of w.x.y.z.'

Router#clear ip dhcp binding a.b.c.d 'Clears an automatic address binding from the DHCP server
database.'
Router#clear ip dhcp binding * 'Clears all automatic DHCP bindings.'

Router#show ip dhcp conflict 'Displays a list of all address conflicts recorded by the DHCP server.'

Router#clear ip dhcp conflict a.b.c.d 'Clears address conflict from the database.'

Router#clear ip dhcp conflict * 'Clears conflicts for all addresses.'

Router#show ip dhcp database 'Displays recent activity on the DHCP database.'

Router#show ip dhcp server statistics 'Displays a list of the number of messages sent and received by
the DHCP server.'

Router#clear ip dhcp server statistics

How to get ip From DHCP server Present away From Multiple Networks
2 DHCP, Dynamic, Rip 04:50

Here,we are going to see how to get ip from dhcp that is present away from multiple networks.

Step 1:Create topology like this


Step 2:configure router interfaces with approriate ip address like in a topology

Router R1,

In global configuration mode,

R1(config)#interface fastethernet0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 2/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#encapsulation ppp
R1(config-if)#no shutdown
R1(config-if)#exit

Router R2,

In Global configuration mode,

R2(config)#interface serial 2/0


R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastethernet 1/0
R2(config-if)#ip address 40.0.0.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit

Step 3:Now, I am going to use RIP to enable dynamic routing,for that just add directly connected
networks to RIP

In Router R1,

Global config mode,

R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit

In Router R2,
Global config mode,

R2(config)#router rip
R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#network 40.0.0.0
R2(config-router)#exit

Step 4:Configure router interfaces with 'ip helper-address'

We need to configure ip address for the gateway of our network.In this network topology we need
configure Interface fastethernet0/0 in R1 and Interface fastethernet 0/0 in R2 with 'ip helper-
address'.DHCP uses flooded Broadcast (i.e. 255.255.255.255 ) this can be forwarded from one network
to another.we tell the router by giving ip address('ip helper-address') to forward the packet to the DHCP
server if any packet arrived with this broadcast address 255.255.255.255.

In R1,

R1(config)#interface fastethernet0/0
R1(config-if)#ip helper-address 40.0.0.10
R1(config-if)#exit

In R2,

R2(config)#interface fastethernet0/0
R2(config-if)#ip helper-address 40.0.0.10
R2(config-if)#exit

Step 5:Now,Add the network pool to DHCP server,I am going add 10 and 30 network.

Click on Server->Config->DHCP,there you can see default pool for 40 network 'when we configure ip
address to fastethernet of dhcp server, it will add the network automatically to default pool by seeing
the ip address that belongs to.
Now, Add the network pool for 10 and 30 network

Network pool for 10 Network,Just edit

PoolName->10Network
Default Gateway->10.0.0.1
DNS Server->40.0.0.10
Start IP Address->10.0.0.10
Subnetmask->255.0.0.0
Maximum Number of users->100
TFTP Server->40.0.0.10

then click on 'Add' .

Network pool for 30 Network,

PoolName->30Network
Default Gateway->30.0.0.1
DNS Server->40.0.0.10
Start IP Address->30.0.0.10
Subnetmask->255.0.0.0
Maximum Number of users->100
TFTP Server->40.0.0.10

then click on 'Add' and save.


Step 6:Now,From 10 Network click on any PC->Desktop->Ip Configuration->Choose'DHCP'.Now,we will
get ip address from dhcp server.

Step 7:Now,From 30 Network click on any PC->Desktop->Ip Configuration->Choose'DHCP'.Now,we will


get ip address from dhcp server.
How to get IP from DHCP that is Present in Some other Network Using Ip
Helper Address
0 DHCP, LAN 04:37

Here we are going to see, how to configure DHCP for multiple netowrks .Can we get ip address from
DHCP that is prensent in other network? yes we can.Lets see how to do with help of 'ip helper-address'.

Step 1:Create a topology like this,

step 2:Configure the router interface fastethernet0/0 and fastethernet 0/1 with ip address .
Router>enable
Router#config terminal
Router(config)#interface fastethernet0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#interface fastethernet0/1
Router(config-if)#ip address 20.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Step 3:Click on server->config->then just give the gateway ip address .Gateway for this network is
10.0.0.1

Step 4:Then click on fastethernet assign ip address.I am going to give 10.0.0.2 and subnetmask
255.0.0.0.Once we have configured the ip address for the server,DHCP server automatically assign 10
network for default pool.We don't have to create pool for 10 Network again.Just we need to give ip for
DNS,Gateway and TFTP then we may configure starting ip address or leave it and Save.

Step 5:Now,Click on Pc in a LAN with Server and Check whether DHCP working fine in this network.Click
on any PC->Desktop->Ip configuration->Choose DHCP,then you will get ip from dhcp server for this PC.
Step 6:Now,we see how to get ip address for PC that is in a network without Server.For that, first we
have to add network pool in a dhcp server.
So,Click on Server->Config->DHCP.

Step 7:Just edit Pool Name with any other name.I am going to give 20Network.
Default Gateway->20.0.0.1,
DNS Server->10.0.0.2
Start Ip Address->20.0.0.10
Subnet Mask->255.0.0.0
Maximun Number Of Users->100
TFTP Server10.0.0.2

Then,Click on Add and Save.

Setp 8:Now go to router and give ip helper address under fastethernet0/1,that is server address here
our server address is 10.0.0.2.Now we can get ip for this network also

In Router,(Global configuration mode)

Router(config)#interface fastethernet0/1
Router(config-if)#ip helper-address 10.0.0.2
Router(config-if)#exit

Step 9:Now,check whether PC from network without server getting ip from the DHCP server in another
Network.Click on any PC->Desktop->Ip configuration->Choose DHCP.Now i got ip address from dhcp
server.
I am getting ip address from dhcp server..thats it.
How to get ip From DHCP server Present away From Multiple Networks
2 DHCP, Dynamic, Rip 04:50

Here,we are going to see how to get ip from dhcp that is present away from multiple networks.

Step 1:Create topology like this

Step 2:configure router interfaces with approriate ip address like in a topology

Router R1,
In global configuration mode,

R1(config)#interface fastethernet0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 2/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#encapsulation ppp
R1(config-if)#no shutdown
R1(config-if)#exit

Router R2,

In Global configuration mode,

R2(config)#interface serial 2/0


R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastethernet 1/0
R2(config-if)#ip address 40.0.0.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit

Step 3:Now, I am going to use RIP to enable dynamic routing,for that just add directly connected
networks to RIP

In Router R1,

Global config mode,

R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit

In Router R2,

Global config mode,

R2(config)#router rip
R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#network 40.0.0.0
R2(config-router)#exit

Step 4:Configure router interfaces with 'ip helper-address'

We need to configure ip address for the gateway of our network.In this network topology we need
configure Interface fastethernet0/0 in R1 and Interface fastethernet 0/0 in R2 with 'ip helper-
address'.DHCP uses flooded Broadcast (i.e. 255.255.255.255 ) this can be forwarded from one network
to another.we tell the router by giving ip address('ip helper-address') to forward the packet to the DHCP
server if any packet arrived with this broadcast address 255.255.255.255.

In R1,

R1(config)#interface fastethernet0/0
R1(config-if)#ip helper-address 40.0.0.10
R1(config-if)#exit

In R2,

R2(config)#interface fastethernet0/0
R2(config-if)#ip helper-address 40.0.0.10
R2(config-if)#exit
Step 5:Now,Add the network pool to DHCP server,I am going add 10 and 30 network.

Click on Server->Config->DHCP,there you can see default pool for 40 network 'when we configure ip
address to fastethernet of dhcp server, it will add the network automatically to default pool by seeing
the ip address that belongs to.

Now, Add the network pool for 10 and 30 network

Network pool for 10 Network,Just edit

PoolName->10Network
Default Gateway->10.0.0.1
DNS Server->40.0.0.10
Start IP Address->10.0.0.10
Subnetmask->255.0.0.0
Maximum Number of users->100
TFTP Server->40.0.0.10

then click on 'Add' .

Network pool for 30 Network,

PoolName->30Network
Default Gateway->30.0.0.1
DNS Server->40.0.0.10
Start IP Address->30.0.0.10
Subnetmask->255.0.0.0
Maximum Number of users->100
TFTP Server->40.0.0.10

then click on 'Add' and save.


Step 6:Now,From 10 Network click on any PC->Desktop->Ip Configuration->Choose'DHCP'.Now,we will
get ip address from dhcp server.

Step 7:Now,From 30 Network click on any PC->Desktop->Ip Configuration->Choose'DHCP'.Now,we will


get ip address from dhcp server.
How to configure RIP Routing Protocol in Routers
3 Dynamic, Rip, Routing 23:10
RIP-Routing Information Protocol

Routing Information Protocol is distance vector routing protocol.It knows only neighbors,

It doesn't know entire topology,Routing by rumors


It doesn't support classless network(CIDR),But Rip Version 2 supports CIDR and VLSM
It will update routing informations every 30 seconds(Periodic Updates)
It sends entire routing table to its neighbour

RIP- Routing Information Protocol


Administrative Distance-120
Maximum Hop count-15,16 is unreachable network
Metric - Hop count

Here we are going to see how to configure RIP in a simple topology,check connectivity between hosts

Step 1:Create a topology like i have added below


Step 2:Configure ip address for all interfaces and assign ip address,default gateway to hosts

In Router R1,

R1(config)#interface fastethernet 2/0


R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 1/0


R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#encapsulation ppp
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit

In Router R2,

R2(config)#interface serial 1/0


R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface serial 1/1


R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#exit

In Router R3,

R3(config)#
R3(config)#interface serial 1/0
R3(config-if)#ip address 30.0.0.2 255.0.0.0
R3(config-if)#encapsulation ppp
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#
R3(config)#interface fastethernet 2/0
R3(config-if)#ip address 40.0.0.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit

Step 3:Configure RIP to all routers by using command,

In Router R1,

R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit

In Router R2,
R2(config)#router rip
R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#exit

In Router R3,

R3(config)#router rip
R3(config-router)#network 30.0.0.0
R3(config-router)#network 40.0.0.0
R3(config-router)#exit

Step 4: Now check routing table of route R1.Router will have all network information in its routing
table, router learned this route by using rip.

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet2/0


C 20.0.0.0/8 is directly connected, Serial1/0
R 40.0.0.0/8 [120/2] via 20.0.0.2, 00:00:02, Serial1/0
R 30.0.0.0/8 [120/1] via 20.0.0.2, 00:00:02, Serial1/0

Step 5:Now ping from host 10.0.0.10 to 40.0.0.10


RIP Version 2

RIP- Routing Information Protocol


Administrative Distance-120
Maximum Hop count-15,16 is unreachable network
Metric - Hop count

Rip version 2 supports CIDR(Classless Ineternet Domain Routing)

To configure with rip version 2,just give this command,


R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit

How to configure RIP Routing Protocol in Routers


3 Dynamic, Rip, Routing 23:10

RIP-Routing Information Protocol

Routing Information Protocol is distance vector routing protocol.It knows only neighbors,

It doesn't know entire topology,Routing by rumors


It doesn't support classless network(CIDR),But Rip Version 2 supports CIDR and VLSM
It will update routing informations every 30 seconds(Periodic Updates)
It sends entire routing table to its neighbour

RIP- Routing Information Protocol


Administrative Distance-120
Maximum Hop count-15,16 is unreachable network
Metric - Hop count

Here we are going to see how to configure RIP in a simple topology,check connectivity between hosts

Step 1:Create a topology like i have added below


Step 2:Configure ip address for all interfaces and assign ip address,default gateway to hosts

In Router R1,

R1(config)#interface fastethernet 2/0


R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 1/0


R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#encapsulation ppp
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit
In Router R2,

R2(config)#interface serial 1/0


R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface serial 1/1


R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#exit

In Router R3,

R3(config)#
R3(config)#interface serial 1/0
R3(config-if)#ip address 30.0.0.2 255.0.0.0
R3(config-if)#encapsulation ppp
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#
R3(config)#interface fastethernet 2/0
R3(config-if)#ip address 40.0.0.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit

Step 3:Configure RIP to all routers by using command,

In Router R1,

R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit

In Router R2,

R2(config)#router rip
R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#exit

In Router R3,

R3(config)#router rip
R3(config-router)#network 30.0.0.0
R3(config-router)#network 40.0.0.0
R3(config-router)#exit

Step 4: Now check routing table of route R1.Router will have all network information in its routing
table, router learned this route by using rip.

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet2/0


C 20.0.0.0/8 is directly connected, Serial1/0
R 40.0.0.0/8 [120/2] via 20.0.0.2, 00:00:02, Serial1/0
R 30.0.0.0/8 [120/1] via 20.0.0.2, 00:00:02, Serial1/0

Step 5:Now ping from host 10.0.0.10 to 40.0.0.10


RIP Version 2

RIP- Routing Information Protocol


Administrative Distance-120
Maximum Hop count-15,16 is unreachable network
Metric - Hop count

Rip version 2 supports CIDR(Classless Ineternet Domain Routing)

To configure with rip version 2,just give this command,

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit

How to Configure a RiP routing protocol with simple two routers


3 GNS 3, Rip, Routing 21:55

How to configure a rip routing protocol with a simple toplogy in GNS 3 to check the connectivity
between hosts.
Step 1:Create a topology like this and do basic configurations ip address to the router interfaces ,ip
address and default gateway to the host same as in topology.

In Router R1,

R1(config)#interface fastethernet 2/0


R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 1/0


R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#encapsulation ppp
R1(config-if)#no shutdown
R1(config-if)#exit

In Router R2,

R2(config)#interface serial 1/0


R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface fastethernet2/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit

By default routers know directly connected network.

Step 2:Check the routing table of the router R1 and R2 by giving the command show ip route in
privileged mode,

In Router R1,

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet2/0


C 20.0.0.0/8 is directly connected, Serial1/0

In Router R2,

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 30.0.0.0/8 is directly connected, FastEthernet2/0


C 20.0.0.0/8 is directly connected, Serial1/0

Step 3:Now,Run Rip protocols on R1 and R2 .What rip will do is, it will create a routing update by adding
directly connected networks information and it will send to neighbor routers
Just add directly connected networks

In Router R1,

R1(config)#router rip

R1(config-router)#network 10.0.0.0

R1(config-router)#network 20.0.0.0

R1(config-router)#exit

In Router R2,

R2(config)#router rip

R2(config-router)#network 20.0.0.0

R2(config-router)#network 30.0.0.0

R2(config-router)#exit

Now routers learns network information automatically through routing updates


Step 4:Now give show ip route command in R1 and R2 and check the routing table

In Router R1,

R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet0/0

C 20.0.0.0/8 is directly connected, Serial2/0

R 30.0.0.0/8 [120/1] via 20.0.0.2, 00:00:28, Serial2/0

R1#

Here,network 30.0.0.0 learned by the router R1 via Serial 2/0 by routing update from R2,that will be
reachable via 20.0.0.2(next hop).
[120/1]-120 Administrative distance of Rip,1-Reachable on one hop.

In Router R2,

R2#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

R 10.0.0.0/8 [120/1] via 20.0.0.1, 00:00:16, Serial2/0

C 20.0.0.0/8 is directly connected, Serial2/0

C 30.0.0.0/8 is directly connected, FastEthernet0/0

Here,network 30.0.0.0 learned by the router R2 via Serial 2/0 by routing update from R1,that will be
reachable via 20.0.0.1(next hop).
Step 5:Now ping from the Host 10.0.0.10 to Host 30.0.0.10 by giving command

ping 30.0.0.10 you will get,

Rip Timers:

Update Interval-30

Invalid Interval -180


Hold Down Interval -180

Flush After-240

Administrative Distance-120

Configure Igrp in Routers to Enable Routing


3 Dynamic, IGRP, Routing 23:56

Interior Gateway Routing Protocol is distance vector routing protocol.It is a cisco proprietery Routing
Protocol

It knows only neighbors,


It doesn't know entire topology,Routing by rumors
It doesn't support classless network
It will update routing informations every 90 seconds(Periodic Updates)
It sends entire routing table to its neighbour

IGRP-Interior Gateway Routing Protocol


Administrative Distance-100
Maximum Hop count-255
Metric - (Bandwidth +Delay)
Atonomous System(AS),it is using to bring the routers under common adminstration domain.
Routers in different AS won't exchange routing updates

Now ,we see how to configure igrp in a routers,

Step 1:Create topology like this


Step 2:Do basic configurations to all router interfaces and host

In Router R1,

R1(config)#interface fastethernet 2/0


R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 1/0


R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#encapsulation ppp
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit

In Router R2,

R2(config)#interface serial 1/0


R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface serial 1/1


R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#exit

In Router R3,

R3(config)#
R3(config)#interface serial 1/0
R3(config-if)#ip address 30.0.0.2 255.0.0.0
R3(config-if)#encapsulation ppp
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#
R3(config)#interface fastethernet 2/0
R3(config-if)#ip address 40.0.0.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit

Step 3:Configure IGRP Routing Protocol in all routers,

R1(config)#router igrp 100


R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit

Here,100 is atonomous system number

In Router R2,

R2(config)#router igrp 100


R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#exit

In Router R3,

R3(config)#router igrp 100


R3(config-router)#network 30.0.0.0
R3(config-router)#network 40.0.0.0
R3(config-router)#exit
How to configure Ospf Routing Protocol and Connect Areas
4 Dynamic, GNS 3, OSPF, Routing 21:30

OSPF-Open Short Path First,It is a Open Standard Routing Protocol

Link State Routing Protocol


Algorithm -Dijkistra,To find shortest path
Administrativ Distance-110
Metric- 10^8/Bandwidth
Incremental Update
Load Balancing Maximum 6 (Default 4)
It knows Network topology
Router ID-Initializes OSPF Process
Fast convergence

Timers

Hello-10
Dead-40
Wait-40
Retransmit-5

Step 1:Create topology like below i have given


Step 2:Cofigure ip addres to all interfaces

In Router R1,

R1(config)#interface fastethernet 2/0


R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 1/0


R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#encapsulation ppp
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit

In Router R2,

R2(config)#interface serial 1/0


R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface serial 1/1


R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#exit

In Router R3,

R3(config)#
R3(config)#interface serial 1/0
R3(config-if)#ip address 30.0.0.2 255.0.0.0
R3(config-if)#encapsulation ppp
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#
R3(config)#interface fastethernet 2/0
R3(config-if)#ip address 40.0.0.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit

Step 3:Now,Enable ip routing by configuring ospf routing protocol in all routers,


In Router R1,

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 10.0.0.0 0.255.255.255 area 3
R1(config-router)#network 20.0.0.0 0.255.255.255 area 1
R1(config-router)#exit

In Router R2,

R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 20.0.0.0 0.255.255.255 area 1
R2(config-router)#network 30.0.0.0 0.255.255.255 area 0
R2(config-router)#exit

In Router R3,

R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 30.0.0.0 0.255.255.255 area 0
R3(config-router)#network 40.0.0.0 0.255.255.255 area 2
R3(config-router)#exit

You have to configure router id when we configure ospf.It is used to identify the router

Step 4:Now check routing table of R1,

Router#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet2/0


C 20.0.0.0/8 is directly connected, Serial1/0
O IA 40.0.0.0/8 [110/129] via 20.0.0.2, 00:04:23, Serial1/0
O IA 30.0.0.0/8 [110/128] via 20.0.0.2, 00:07:29, Serial1/0

Here,R2 knows Area 0.Network 20.0.0.0 connected to R2 from R1,So R1 learns networks through this
network.

R3(config)#router ospf 1, Here, 1 is Process ID, it can be 1-65535.It initializes ospf process.

There must be one interface up to keep ospf process up.So its better to configure loopback address to
routers.It is a virtual interface never goes down once we configured.

R1(config-if)#interface loopback 0
R1(config-if)#ip add 172.16.1.252 255.255.0.0
R1(config-if)#no shutdown

R2(config-if)#interface loopback 0
R2(config-if)#ip add 172.16.1.253 255.255.0.0
R2(config-if)#no shutdown
R3(config-if)#interface loopback 0
R3(config-if)#ip add 172.16.1.254 255.255.0.0
R3(config-if)#no shutdown

Step 5:Now ,Check Routing table of R3,

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

O IA 20.0.0.0/8 [110/128] via 30.0.0.1, 00:18:58, Serial1/0


C 40.0.0.0/8 is directly connected, FastEthernet2/0
C 30.0.0.0/8 is directly connected, Serial1/0

Here,R3 doesn't know about the area 3 so we have to create virtual link between R1 and R2

Step 6:Create virtual link between R1,R2,by this we create a virtual link to connect area 3 to area 0.
In Router R1,

R1(config)#router ospf 1
R1(config-router)#area 1 virtual-link 2.2.2.2
R1(config-router)#
*Feb 10 10:29:23.767: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on OSPF_VL0 from LOADING to FULL,
Loadi
ng Done

In Rotuer R2,

*Feb 10 10:28:59.543: %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone
area must be virtual-link but not found from 20.0.0.1, Serial1/0a
*Feb 10 10:29:09.535: %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone
area must be virtual-link but not found from 20.0.0.1, Serial1/0.1.1

R2(config-router)#
R2(config-router)#area 1 virtual-link 1.1.1.1
R2(config-router)#exit
R2(config)#

*Feb 10 10:29:19.667: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on OSPF_VL0 from LOADING to FULL,
Loadi
ng Done
Step 7:R2 and R3 get updates about Area 3 .Now,Check routing table of R3,

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

O IA 20.0.0.0/8 [110/128] via 30.0.0.1, 00:01:56, Serial1/0


C 40.0.0.0/8 is directly connected, FastEthernet2/0
O IA 10.0.0.0/8 [110/129] via 30.0.0.1, 00:01:56, Serial1/0
C 30.0.0.0/8 is directly connected, Serial1/0

Step 8:Check connectivity between host 10.0.0.10 to 40.0.0.10


Trouble shooting

R3#show ip protocols
R3#show ip route ospf
R3#show ip ospf neighbors detail
R3#show ip ospf database
R3#show ip ospf interface

How to Configure Ip address to PC and Routers in Packet Tracer


3 Basics, Packet Tracer 00:36
Step 1:Create a simple topology like this,

Step 2:Click on PC 1->Config,assign Gateway in this case,10.0.0.1


Step 3:Click on Fastethernet and assign ip address and subnetmask,
In this case ip 10.0.0.10 and subnet mask 255.0.0.0,Now close PC 1 window.Do like this for PC2 with
appropriate ip and subnet mask.
Step 4:Now Click on Router R1,then click on CLI(Commad Line Interface).

You will see like this,"Continue with configuration dialog? [yes/no]:".Give "no" and Press enter.Now you
will go to user mode,

Step 5:now give "enable" and press enter.Now you get into the Privileged Mode,now type "configure
terminal" and press enter to get into global configuration mode.
Step 6:Now configure router interface with ip address and subnet mask then give no shutdown to make
this interface and line protocol up(i.e. Carefully configure ip address with proper interfaces in this case
f0/0 and f1/0,f is short form of fastethernet.

Router(config)#interface fastEthernet 0/0


Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Interface Line protocol on FastEthernet0/0, changed state to up

Router(config)#interface fastethernet 1/0


Router(config-if)#ip address 20.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Interface Line protocol on FastEthernet1/0, changed state to up


Step 7:Now lights on all ports become green from red.Now click on PC1->Desktop->Command Prompt.

Step 8:Now give this command "ping 20.0.0.10" and press enter.you will get,
connectivity between 10.0.0.10 and 20.0.0.10 is ok.Now PC1 communicates with PC2

Another way of checking connectivity is,select "simple PDU packet" from right side of packet tracer and
select source PC and Destination PC.You will get response at right bottom of the pacter tracer window.

How to Configure EIGRP Routing Protocol With Simple Network


Topology
2 EIGRP, Routing 09:48

EIGRP-Enhanced Interior Gateway Routing Protocol


It is Described as Hybrid Routing Protocol
Administrative Distance(AD)-90
Supports CIDR and VLSM
It uses Diffusion Algorithm to find Best Path
Metric=256x(Bandwidth+Delay)
It uses RTP(Reliable Transport Protocol)
Multiple Protocol Support
Fast Convergence

Now we are going to see EIGRP Routing configurations with simple network topology using packet
tracer,

Step 1:First Create a topology like this,and configure ip address to

all interfaces and PC.


Router R1,Configuration

In Global configuration mode,

R1(config)#interface fastethernet 0/0


R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

Once you have given no shutdown command the port become up

R1(config)#interface serial 2/0


R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#encapsulation ppp
R1(config-if)#no shutdown
R1(config-if)#exit

i.e.Always keep in mind to configure clock rate at DCE(Data Communication Equipment).we can see
clock symbol at the serial interface that is DCE other End is DTE(Data Terminal Equipment).To
avoid confusion just give this command on both side.

Now, "Interface Serial2/0, changed state to down" ,Because other end of the serial interface not
configured.So we have to configure other end of the serial interface in R2,then this interface become up.

Router R2,Config

In Global configuration mode,


R2#config terminal
R2(config)#interface serial 2/0
R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit

Interface Serial2/0 and Line protocol on Interface Serial2/0 changed state to up

R2(config)#
R2(config)#interface serial 3/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#clock rate 64000
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit

Router R3,Config

In Global configuration mode,

R3(config)#interface serial 3/0


R3(config-if)#ip address 30.0.0.2 255.0.0.0
R3(config-if)#encapsulation ppp
R3(config-if)#no shutdown
R3(config-if)#exit

Interface Serial3/0 and Line protocol, changed state to up

R3(config)#interface fastethernet0/0
R3(config-if)#ip address 40.0.0.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit
Interface fastethernet0/0 and line protocol,changed state to up

After all ip address assigned then lights in all interfaces become green.If anything wrong we get red or
amber.

Step 2:Now we see how to configure EIGRP routing protocols in this routers.

R1 Router,In Global Configuration mode,

R1(config)#router eigrp 200


R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit

R2 Router,In Global Configuration mode,

R2(config)#router eigrp 200


R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#exit

R3 Router,In Global Configuration mode,

R3(config)#router eigrp 200


R3(config-router)#network 30.0.0.0
R3(config-router)#network 40.0.0.0
R3(config-router)#exit

i.e.here 200 is Atonomous System Number,it is used to grouping of routers under common
admistration,Routers in different Atonomous Number
will not communicate with each other.So,Atonomous should be same in all routers.

Step 3:Now check the routing table by giving this command,

In Router R1,Privileged mode

R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP


D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet0/0


C 20.0.0.0/8 is directly connected, Serial2/0
D 30.0.0.0/8 [90/21024000] via 20.0.0.2, 00:04:42, Serial2/0
D 40.0.0.0/8 [90/21026560] via 20.0.0.2, 00:02:34, Serial2/0

Router R1 having all networks information in its routing table,Check for R2 and R3 also.

Step 4:Now click on Pc and select Desktop->command prompt,then check connectivity between
10.0.0.10 and 40.0.0.10

PC>Ping 40.0.0.10

Pinging 40.0.0.10 with 32 bytes of data:

Request timed out.


Reply from 40.0.0.10: bytes=32 time=15ms TTL=125
Reply from 40.0.0.10: bytes=32 time=13ms TTL=125
Reply from 40.0.0.10: bytes=32 time=16ms TTL=125

Ping statistics for 40.0.0.10:


Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 13ms, Maximum = 16ms, Average = 14ms

Verifying EIGRP Configurations

In Privileged Mode,

show ip route
show ip protocol
show ip eigrp topology

How to configure DHCP within a LAN in a packet Tracer

Here,we are going to see how to configure DHCP within a LAN in a packet tracer,

DHCP-Dynamic Host Configuration Protocol

DHCP Proces,(DORA)

=>Discover( Client discovers the DHCP Server for Ip request )


=>Offer ( DHCP servers offers ip to a client and it will wait for the request from cleint
=>Request ( Client reply for requesting offered ip address from dhcp server,sometimes there will
be more dhcp servers.So,client receives offer from multiple servers.client will reply for only one
offer.So, other offers will be canceled and replaced in a pool.)
=>Acknowledgement (Final step from server sending all infromation to client like DNS,Default
Gateway,tftp,domain name,... )

DHCP Server uses Port 67,Client uses port 68


It uses UDP(User Datagram Protocol).

Step 1:Create a LAN like this,


Step 2:Configure router interface with ip 10.0.0.1 and subnet mask 255.0.0.0

Router>enable
Router#config t
Router(config)#interface fastethernet0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#
Step 3:click on server->config,then assign gateway in our example 10.0.0.1

Step 4:Then Click on Fastethernet and assign ip address and subnet mask.

I am going to use 10.0.0.2 and subnet mask 255.0.0.0 for our server.

Step 5:Click on DHCP,there you can see default pool,

step 6:Just give default gate way,here we are using 10.0.0.1.

Step 7:DNS server,Just give our server ip address,10.0.0.2.

Step 8:Then just edit start ip address.I am going to give 10.0.0.10

and subnet mask 255.0.0.0

Step 9:In Maximum Number of Users,Here we are using Class A Network

so we can use 1,67,77,216 ip address.just give how many ip

address you want in this pool.I am going to give 500

Step 10:Assign TFTP server ip address,just give our server ip address,10.0.0.2.

Step 11:And click on save.That's it...


Step 12:Now, Click on any of the PC-> then click on Desktop->Ip configuration,and Choose 'DHCP' wait
for some time,if your dhcp request failed then try few more times.This is how you should get.
How to get IP from DHCP that is Present in Some other Network Using Ip
Helper Address
Here we are going to see, how to configure DHCP for multiple netowrks .Can we get ip address from
DHCP that is prensent in other network? yes we can.Lets see how to do with help of 'ip helper-address'.

Step 1:Create a topology like this,

step 2:Configure the router interface fastethernet0/0 and fastethernet 0/1 with ip address .
Router>enable
Router#config terminal
Router(config)#interface fastethernet0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#interface fastethernet0/1
Router(config-if)#ip address 20.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Step 3:Click on server->config->then just give the gateway ip address .Gateway for this network is
10.0.0.1

Step 4:Then click on fastethernet assign ip address.I am going to give 10.0.0.2 and subnetmask
255.0.0.0.Once we have configured the ip address for the server,DHCP server automatically assign 10
network for default pool.We don't have to create pool for 10 Network again.Just we need to give ip for
DNS,Gateway and TFTP then we may configure starting ip address or leave it and Save.

Step 5:Now,Click on Pc in a LAN with Server and Check whether DHCP working fine in this network.Click
on any PC->Desktop->Ip configuration->Choose DHCP,then you will get ip from dhcp server for this PC.
Step 6:Now,we see how to get ip address for PC that is in a network without Server.For that, first we
have to add network pool in a dhcp server.
So,Click on Server->Config->DHCP.

Step 7:Just edit Pool Name with any other name.I am going to give 20Network.
Default Gateway->20.0.0.1,
DNS Server->10.0.0.2
Start Ip Address->20.0.0.10
Subnet Mask->255.0.0.0
Maximun Number Of Users->100
TFTP Server10.0.0.2

Then,Click on Add and Save.

Setp 8:Now go to router and give ip helper address under fastethernet0/1,that is server address here
our server address is 10.0.0.2.Now we can get ip for this network also

In Router,(Global configuration mode)

Router(config)#interface fastethernet0/1
Router(config-if)#ip helper-address 10.0.0.2
Router(config-if)#exit

Step 9:Now,check whether PC from network without server getting ip from the DHCP server in another
Network.Click on any PC->Desktop->Ip configuration->Choose DHCP.Now i got ip address from dhcp
server.
I am getting ip address from dhcp server..thats it.
How to get ip From DHCP server Present away From Multiple Networks
2 DHCP, Dynamic, Rip 04:50

Here,we are going to see how to get ip from dhcp that is present away from multiple networks.

Step 1:Create topology like this

Step 2:configure router interfaces with approriate ip address like in a topology

Router R1,
In global configuration mode,

R1(config)#interface fastethernet0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 2/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#encapsulation ppp
R1(config-if)#no shutdown
R1(config-if)#exit

Router R2,

In Global configuration mode,

R2(config)#interface serial 2/0


R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastethernet 1/0
R2(config-if)#ip address 40.0.0.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit

Step 3:Now, I am going to use RIP to enable dynamic routing,for that just add directly connected
networks to RIP

In Router R1,

Global config mode,

R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit

In Router R2,

Global config mode,

R2(config)#router rip
R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#network 40.0.0.0
R2(config-router)#exit

Step 4:Configure router interfaces with 'ip helper-address'

We need to configure ip address for the gateway of our network.In this network topology we need
configure Interface fastethernet0/0 in R1 and Interface fastethernet 0/0 in R2 with 'ip helper-
address'.DHCP uses flooded Broadcast (i.e. 255.255.255.255 ) this can be forwarded from one network
to another.we tell the router by giving ip address('ip helper-address') to forward the packet to the DHCP
server if any packet arrived with this broadcast address 255.255.255.255.

In R1,

R1(config)#interface fastethernet0/0
R1(config-if)#ip helper-address 40.0.0.10
R1(config-if)#exit

In R2,

R2(config)#interface fastethernet0/0
R2(config-if)#ip helper-address 40.0.0.10
R2(config-if)#exit
Step 5:Now,Add the network pool to DHCP server,I am going add 10 and 30 network.

Click on Server->Config->DHCP,there you can see default pool for 40 network 'when we configure ip
address to fastethernet of dhcp server, it will add the network automatically to default pool by seeing
the ip address that belongs to.

Now, Add the network pool for 10 and 30 network

Network pool for 10 Network,Just edit

PoolName->10Network
Default Gateway->10.0.0.1
DNS Server->40.0.0.10
Start IP Address->10.0.0.10
Subnetmask->255.0.0.0
Maximum Number of users->100
TFTP Server->40.0.0.10

then click on 'Add' .

Network pool for 30 Network,

PoolName->30Network
Default Gateway->30.0.0.1
DNS Server->40.0.0.10
Start IP Address->30.0.0.10
Subnetmask->255.0.0.0
Maximum Number of users->100
TFTP Server->40.0.0.10

then click on 'Add' and save.


Step 6:Now,From 10 Network click on any PC->Desktop->Ip Configuration->Choose'DHCP'.Now,we will
get ip address from dhcp server.

Step 7:Now,From 30 Network click on any PC->Desktop->Ip Configuration->Choose'DHCP'.Now,we will


get ip address from dhcp server.
How the Switch Learns MAC Address Forwards Filters Frames
0 Switching 02:03

In this post we are going to see how the switches learns MAC address and Forwards,Filters the frames in
Layer 2.
Create a topology like this,

Configure ip addresses for all host like i have given in topology,

Click on PC0-->Config-->Fastethernet 0 and Enter IP address and Subnetmask

PC-0
IP-10.0.0.10
Subnetmask-255.0.0.0

PC-1
IP-10.0.0.20
Subnetmask-255.0.0.0

PC-2
IP-10.0.0.30
Subnetmask-255.0.0.0

PC-3
IP-10.0.0.40
Subnetmask-255.0.0.0

we can also see the MAC address of the host's on that window.Now go to Switch Check the MAC
address table in Swith by giving this command,

Switch#show mac-address-table
Mac Address Table
-------------------------------------------

Vlan Mac Address Type Ports


---- ----------- -------- -----

MAC address table is empty,now go to the host 10.0.0.10 and ping host 10.0.0.30

Click on PC0-->Desktop-->Command Prompt ,give this command 'ping 10.0.0.10' and hit enter.

PC>ping 10.0.0.30

Pinging 10.0.0.30 with 32 bytes of data:

Reply from 10.0.0.30: bytes=32 time=1ms TTL=128


Reply from 10.0.0.30: bytes=32 time=0ms TTL=128
Reply from 10.0.0.30: bytes=32 time=0ms TTL=128
Reply from 10.0.0.30: bytes=32 time=0ms TTL=128

Ping statistics for 10.0.0.30:


Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms
Switch#show mac-address-table
Mac Address Table
-------------------------------------------

Vlan Mac Address Type Ports


---- ----------- -------- -----

1 0001.4232.090a DYNAMIC Fa0/3


1 0040.0bb9.a7cc DYNAMIC Fa0/1

Let me explain how switch learned this MAC address,

Once we press enter to ping the ip address, PC will send the packets to switch,switch receives the
packets through the interface fastethernet0/1 and it will read the Source MAC address from the
frame.Now switch will check the MAC address table whether this MAC address already present or not,If
this is MAC address not present in the MAC address table then it will add this physial address to the
table with appropriate port address.Then it will check the Destination MAC address it will be like this
'0000.0000.0000' (because this the first time we ping so PC doesn't know the destination MAC
address,so the address will be zero next time mac address will be added from arp table).Now switch will
send this frame out on all ports because it is unknown unicast address.

Now,all host will receive this packet and every host will check the destination MAC address if it is it's
address it will reply to the host otherwise it will drop it,this is unknown unicast frames right, the MAC
address will be all Zero's.Now, the host will check the destination IP address,if the destination IP address
is matched host's IP address it will reply to the host otherwise it will drop it.

Now,the host 10.0.0.20 and 10.0.0.40 will drop this frames and host 10.0.0.30 will reply to 10.0.0.10
with source MAc address '0001.4232.090a' and the destination address '0040.0bb9.a7cc' of host
10.0.0.10.In the meantime switch waiting for the reply from any host.Now the host 10.0.0.30 sends
packets to the switch,now switch get packets from interface fastethernet0/3 learns the MAC address of
host 10.0.0.30 and it will check the destination address.It was already present in the table so it will not
broadcast the frames out in all ports it will forward the packet through interface fastethernet 0/1 to
host 10.0.0.10.
Now ping from the host 10.0.0.20 to 10.0.0.40 and check the mac address table of switch.

PC>ping 10.0.0.40

Pinging 10.0.0.40 with 32 bytes of data:

Reply from 10.0.0.40: bytes=32 time=2ms TTL=128


Reply from 10.0.0.40: bytes=32 time=0ms TTL=128
Reply from 10.0.0.40: bytes=32 time=1ms TTL=128
Reply from 10.0.0.40: bytes=32 time=0ms TTL=128

Ping statistics for 10.0.0.40:


Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 2ms, Average = 0ms

Switch#show mac-address-table
Mac Address Table
-------------------------------------------

Vlan Mac Address Type Ports


---- ----------- -------- -----

1 0001.4232.090a DYNAMIC Fa0/3


1 0010.1102.3684 DYNAMIC Fa0/2
1 0040.0bb9.a7cc DYNAMIC Fa0/1
1 00e0.f97d.1941 DYNAMIC Fa0/4

That's it!!!....
How to Configure DHCP in Cisco Router Using Packet Tracer and Gns3
9 DHCP, Packet Tracer 02:16

How to configure DHCP in cisco router using packet tracer simulator,

Step 1:Create a topology like this,

Step 2:Configure router interface fastethernet0/0 and fastethernet

1/0 with ip address.

R1#config t
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastethernet 1/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

Step 3:Configure DHCP pool for the network 10 and 20,

In Router R1,Global Configuration mode,

R1(config)#service dhcp

This command is to enable the dhcp server on a router. Routers in packet tracer won't accept this
command.By default dhcp will be running on router so skip 'service dhcp' command if you are
configuring dhcp in packet tracer,just create a network pool for the network it will work.Use this in real
time or other simulators like gns3.

R1(config)#ip dhcp pool 10network "where '10network' is the pool name we can use what ever we
want.This command get us into the DHCP Configuration mode."

R1(dhcp-config)#network 10.0.0.0 255.0.0.0 "It defines the network range to be leased"

R1(dhcp-config)#dns-server 10.0.0.2 "Ip address for the dns server."

R1(dhcp-config)#default-router 10.0.0.1 "Default gateway for this network."

R1(dhcp-config)#exit

DHCP pool for 10 Network

R1(config)#ip dhcp pool 10network


R1(dhcp-config)#network 10.0.0.0 255.0.0.0
R1(dhcp-config)#dns-server 10.0.0.2
R1(dhcp-config)#default-router 10.0.0.1
R1(dhcp-config)#exit

DHCP pool for 20 Network


R1(config)#ip dhcp pool 20network
R1(dhcp-config)#network 20.0.0.0 255.0.0.0
R1(dhcp-config)#dns-server 10.0.0.2
R1(dhcp-config)#default-router 20.0.0.1
R1(dhcp-config)#exit

Now, Click on any of the PC->Desktop->ip configuration->Choose DHCP.Now PC will get an ip from DHCP
server.
Few more command We can use, but we can't configure this in packet tracer.Use gns3 simulator for this.
R1(dhcp-config)#netbios-server x.x.x.x 'where x.x.x.x is ip address of netbios server.

R1(dhcp-config)#lease x 'where X is the number it sets the lease time,by default 1 (i.e. one day).

R1(dhcp-config)#ip dhcp excluded address x.x.x.x x.x.x.x 'Range of ip address excluded from the pool it
will not be leased to the clients'.

R1(dhcp-config)#ip dhcp excluded address x.x.x.x 'To exclude only one ip address from the range of ip
address'.

Ex.

R1(dhcp-config)#netbios-server 10.0.0.2
R1(dhcp-config)#lease 2
R1(dhcp-config)#ip dhcp excluded address 10.0.0.1 10.0.0.10
R1(dhcp-config)#ip dhcp excluded address 10.0.0.35

Trouble shooting commands,

Router#show ip dhcp binding 'Displays a list of all bindings created.'

Router#show ip dhcp binding w.x.y.z 'Displays the bindings for a specific DHCP client with an IP
address of w.x.y.z.'

Router#clear ip dhcp binding a.b.c.d 'Clears an automatic address binding from the DHCP server
database.'
Router#clear ip dhcp binding * 'Clears all automatic DHCP bindings.'

Router#show ip dhcp conflict 'Displays a list of all address conflicts recorded by the DHCP server.'

Router#clear ip dhcp conflict a.b.c.d 'Clears address conflict from the database.'

Router#clear ip dhcp conflict * 'Clears conflicts for all addresses.'

Router#show ip dhcp database 'Displays recent activity on the DHCP database.'

Router#show ip dhcp server statistics 'Displays a list of the number of messages sent and received by
the DHCP server.'

Router#clear ip dhcp server statistics

How to get ip From DHCP server Present away From Multiple Networks
2 DHCP, Dynamic, Rip 04:50

Here,we are going to see how to get ip from dhcp that is present away from multiple networks.

Step 1:Create topology like this


Step 2:configure router interfaces with approriate ip address like in a topology

Router R1,

In global configuration mode,

R1(config)#interface fastethernet0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 2/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#encapsulation ppp
R1(config-if)#no shutdown
R1(config-if)#exit

Router R2,

In Global configuration mode,

R2(config)#interface serial 2/0


R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastethernet 1/0
R2(config-if)#ip address 40.0.0.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit

Step 3:Now, I am going to use RIP to enable dynamic routing,for that just add directly connected
networks to RIP

In Router R1,

Global config mode,

R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit

In Router R2,
Global config mode,

R2(config)#router rip
R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#network 40.0.0.0
R2(config-router)#exit

Step 4:Configure router interfaces with 'ip helper-address'

We need to configure ip address for the gateway of our network.In this network topology we need
configure Interface fastethernet0/0 in R1 and Interface fastethernet 0/0 in R2 with 'ip helper-
address'.DHCP uses flooded Broadcast (i.e. 255.255.255.255 ) this can be forwarded from one network
to another.we tell the router by giving ip address('ip helper-address') to forward the packet to the DHCP
server if any packet arrived with this broadcast address 255.255.255.255.

In R1,

R1(config)#interface fastethernet0/0
R1(config-if)#ip helper-address 40.0.0.10
R1(config-if)#exit

In R2,

R2(config)#interface fastethernet0/0
R2(config-if)#ip helper-address 40.0.0.10
R2(config-if)#exit

Step 5:Now,Add the network pool to DHCP server,I am going add 10 and 30 network.

Click on Server->Config->DHCP,there you can see default pool for 40 network 'when we configure ip
address to fastethernet of dhcp server, it will add the network automatically to default pool by seeing
the ip address that belongs to.
Now, Add the network pool for 10 and 30 network

Network pool for 10 Network,Just edit

PoolName->10Network
Default Gateway->10.0.0.1
DNS Server->40.0.0.10
Start IP Address->10.0.0.10
Subnetmask->255.0.0.0
Maximum Number of users->100
TFTP Server->40.0.0.10

then click on 'Add' .

Network pool for 30 Network,

PoolName->30Network
Default Gateway->30.0.0.1
DNS Server->40.0.0.10
Start IP Address->30.0.0.10
Subnetmask->255.0.0.0
Maximum Number of users->100
TFTP Server->40.0.0.10

then click on 'Add' and save.


Step 6:Now,From 10 Network click on any PC->Desktop->Ip Configuration->Choose'DHCP'.Now,we will
get ip address from dhcp server.

Step 7:Now,From 30 Network click on any PC->Desktop->Ip Configuration->Choose'DHCP'.Now,we will


get ip address from dhcp server.
How to get IP from DHCP that is Present in Some other Network Using Ip
Helper Address
0 DHCP, LAN 04:37
Here we are going to see, how to configure DHCP for multiple netowrks .Can we get ip address from
DHCP that is prensent in other network? yes we can.Lets see how to do with help of 'ip helper-address'.

Step 1:Create a topology like this,

step 2:Configure the router interface fastethernet0/0 and fastethernet 0/1 with ip address .

Router>enable
Router#config terminal
Router(config)#interface fastethernet0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#interface fastethernet0/1
Router(config-if)#ip address 20.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Step 3:Click on server->config->then just give the gateway ip address .Gateway for this network is
10.0.0.1

Step 4:Then click on fastethernet assign ip address.I am going to give 10.0.0.2 and subnetmask
255.0.0.0.Once we have configured the ip address for the server,DHCP server automatically assign 10
network for default pool.We don't have to create pool for 10 Network again.Just we need to give ip for
DNS,Gateway and TFTP then we may configure starting ip address or leave it and Save.

Step 5:Now,Click on Pc in a LAN with Server and Check whether DHCP working fine in this network.Click
on any PC->Desktop->Ip configuration->Choose DHCP,then you will get ip from dhcp server for this PC.
Step 6:Now,we see how to get ip address for PC that is in a network without Server.For that, first we
have to add network pool in a dhcp server.
So,Click on Server->Config->DHCP.

Step 7:Just edit Pool Name with any other name.I am going to give 20Network.
Default Gateway->20.0.0.1,
DNS Server->10.0.0.2
Start Ip Address->20.0.0.10
Subnet Mask->255.0.0.0
Maximun Number Of Users->100
TFTP Server10.0.0.2

Then,Click on Add and Save.

Setp 8:Now go to router and give ip helper address under fastethernet0/1,that is server address here
our server address is 10.0.0.2.Now we can get ip for this network also

In Router,(Global configuration mode)

Router(config)#interface fastethernet0/1
Router(config-if)#ip helper-address 10.0.0.2
Router(config-if)#exit

Step 9:Now,check whether PC from network without server getting ip from the DHCP server in another
Network.Click on any PC->Desktop->Ip configuration->Choose DHCP.Now i got ip address from dhcp
server.
I am getting ip address from dhcp server..thats it.
Packet Tracer 6.1 tutorial - DHCP configuration

DHCP service is a key component of your network infrastructure by allowing centralized ip


address management on a single pool of servers. DHCP configuration is also part of CCNA and
CCNP Switch certification exams curricula. This skill can be tested in lab environnement during
exams ans it's important for students to get used to DHCP configuration before taking the exam.

Packet Tracer 6.0 implements two methods for setting up a DHCP server in your network :

 Configuration of DHCP pools on Cisco routers or multlayer switches.


 Configuration of a standalone DHCP server appliance on the network and usage of the
"ip helper-address" command on network devices for DHCP traffic forwarding outside
each local broadcast domain. This tutorial will describe this method for implementing
DHCP service in your network.

Two VLANs are configured on Switch0 with Router0 as default gateway :

 VLAN 10 - Nework : 192.168.10.0/24 - Gateway : 192.168.10.1 (FA 0/0.10)


 VLAN 20 - Network : 192.168.20.0/24 - Gateway : 192.168.20.1 (FA 0/0.20)

The unique DHCP server is located on a remote subnet with IP 172.16.24.2.


Learning DHCP : recommended books
DHCP configuration

Declare IP address pools on the DHCP management tab of the server like on the picture below.
One pool has to be declared for each VLAN. Don't forget to configure the right network settings
and default gateway (Router0 FA 0/0.10 and FA 0.0.20 IP address) for each VLAN.

Configure router0 for DHCP forwarding

Router(config)# interface FastEthernet0/0.10

Router(config-subif)# encapsulation dot1Q 10

Router(config-subif)# ip address 192.168.10.1 255.255.255.0

Router(config-subif)# ip helper-address 172.16.24.2


Router(config)# interface FastEthernet0/0.20

Router(config-subif)# encapsulation dot1Q 20

Router(config-subif)# ip address 192.168.20.1 255.255.255.0

Router(config-subif)# ip helper-address 172.16.24.2

How to get ip From DHCP server Present away From Multiple Networks

Step 1:Create topology like this


Step 2:configure router interfaces with approriate ip address like in a topology

Router R1,

In global configuration mode,

R1(config)#interface fastethernet0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 2/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#encapsulation ppp
R1(config-if)#no shutdown
R1(config-if)#exit

Router R2,

In Global configuration mode,

R2(config)#interface serial 2/0


R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastethernet 1/0
R2(config-if)#ip address 40.0.0.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit

Step 3:Now, I am going to use RIP to enable dynamic routing,for that just add directly connected
networks to RIP

In Router R1,
Global config mode,

R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit

In Router R2,

Global config mode,

R2(config)#router rip
R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#network 40.0.0.0
R2(config-router)#exit

Step 4:Configure router interfaces with 'ip helper-address'

We need to configure ip address for the gateway of our network.In this network topology we
need configure Interface fastethernet0/0 in R1 and Interface fastethernet 0/0 in R2 with 'ip
helper-address'.DHCP uses flooded Broadcast (i.e. 255.255.255.255 ) this can be forwarded from
one network to another.we tell the router by giving ip address('ip helper-address') to forward the
packet to the DHCP server if any packet arrived with this broadcast address 255.255.255.255.

In R1,

R1(config)#interface fastethernet0/0
R1(config-if)#ip helper-address 40.0.0.10
R1(config-if)#exit

In R2,

R2(config)#interface fastethernet0/0
R2(config-if)#ip helper-address 40.0.0.10
R2(config-if)#exit
Step 5:Now,Add the network pool to DHCP server,I am going add 10 and 30 network.

Click on Server->Config->DHCP,there you can see default pool for 40 network 'when we
configure ip address to fastethernet of dhcp server, it will add the network automatically to
default pool by seeing the ip address that belongs to.

Now, Add the network pool for 10 and 30 network

Network pool for 10 Network,Just edit

PoolName->10Network
Default Gateway->10.0.0.1
DNS Server->40.0.0.10
Start IP Address->10.0.0.10
Subnetmask->255.0.0.0
Maximum Number of users->100
TFTP Server->40.0.0.10

then click on 'Add' .

Network pool for 30 Network,

PoolName->30Network
Default Gateway->30.0.0.1
DNS Server->40.0.0.10
Start IP Address->30.0.0.10
Subnetmask->255.0.0.0
Maximum Number of users->100
TFTP Server->40.0.0.10

then click on 'Add' and save.


Step 6:Now,From 10 Network click on any PC->Desktop->Ip Configuration-
>Choose'DHCP'.Now,we will get ip address from dhcp server.
Step 7:Now,From 30 Network click on any PC->Desktop->Ip Configuration-
>Choose'DHCP'.Now,we will get ip address from dhcp server.
How to get IP from DHCP that is Present in Some other Network Using Ip
Helper Address

Here we are going to see, how to configure DHCP for multiple netowrks .Can we get ip address
from DHCP that is prensent in other network? yes we can.Lets see how to do with help of 'ip
helper-address'.

Step 1:Create a topology like this,

step 2:Configure the router interface fastethernet0/0 and fastethernet 0/1 with ip address .
Router>enable
Router#config terminal
Router(config)#interface fastethernet0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#interface fastethernet0/1
Router(config-if)#ip address 20.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Step 3:Click on server->config->then just give the gateway ip address .Gateway for this network
is 10.0.0.1

Step 4:Then click on fastethernet assign ip address.I am going to give 10.0.0.2 and subnetmask
255.0.0.0.Once we have configured the ip address for the server,DHCP server automatically
assign 10 network for default pool.We don't have to create pool for 10 Network again.Just we
need to give ip for DNS,Gateway and TFTP then we may configure starting ip address or leave it
and Save.

Step 5:Now,Click on Pc in a LAN with Server and Check whether DHCP working fine in this
network.Click on any PC->Desktop->Ip configuration->Choose DHCP,then you will get ip from
dhcp server for this PC.
Step 6:Now,we see how to get ip address for PC that is in a network without Server.For that, first
we have to add network pool in a dhcp server.
So,Click on Server->Config->DHCP.

Step 7:Just edit Pool Name with any other name.I am going to give 20Network.

Default Gateway->20.0.0.1,
DNS Server->10.0.0.2
Start Ip Address->20.0.0.10
Subnet Mask->255.0.0.0
Maximun Number Of Users->100
TFTP Server10.0.0.2

Then,Click on Add and Save.

Setp 8:Now go to router and give ip helper address under fastethernet0/1,that is server address
here our server address is 10.0.0.2.Now we can get ip for this network also

In Router,(Global configuration mode)

Router(config)#interface fastethernet0/1
Router(config-if)#ip helper-address 10.0.0.2
Router(config-if)#exit

Step 9:Now,check whether PC from network without server getting ip from the DHCP server in
another Network.Click on any PC->Desktop->Ip configuration->Choose DHCP.Now i got ip
address from dhcp server.
I am getting ip address from dhcp server..thats it.
How to configure DHCP within a LAN in a packet Tracer

DHCP-Dynamic Host Configuration Protocol

DHCP Proces,(DORA)

=>Discover( Client discovers the DHCP Server for Ip request )


=>Offer ( DHCP servers offers ip to a client and it will wait for the request from cleint
=>Request ( Client reply for requesting offered ip address from dhcp server,sometimes
there will be more dhcp servers.So,client receives offer from multiple servers.client
will reply for only one offer.So, other offers will be canceled and replaced in a
pool.)
=>Acknowledgement (Final step from server sending all infromation to client like
DNS,Default Gateway,tftp,domain name,... )

DHCP Server uses Port 67,Client uses port 68


It uses UDP(User Datagram Protocol).

Step 1:Create a LAN like this,


Step 2:Configure router interface with ip 10.0.0.1 and subnet mask 255.0.0.0

Router>enable
Router#config t
Router(config)#interface fastethernet0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#

Step 3:click on server->config,then assign gateway in our example 10.0.0.1


Step 4:Then Click on Fastethernet and assign ip address and subnet mask.I am going to use
10.0.0.2 and subnet mask 255.0.0.0 for our server.

Step 5:Click on DHCP,there you can see default pool,

step 6:Just give default gate way,here we are using 10.0.0.1.

Step 7:DNS server,Just give our server ip address,10.0.0.2.

Step 8:Then just edit start ip address.I am going to give 10.0.0.10 and subnet mask 255.0.0.0

Step 9:In Maximum Number of Users,Here we are using Class A Network so we can use
1,67,77,216 ip address.just give how many ip address you want in this pool.I am going to give
500

Step 10:Assign TFTP server ip address,just give our server ip address,10.0.0.2.

Step 11:And click on save.That's it...


Step 12:Now, Click on any of the PC-> then click on Desktop->Ip configuration,and Choose
'DHCP' wait for some time,if your dhcp request failed then try few more times.This is how you
should get.
How to Configure EIGRP Routing Protocol With Simple Network
Topology

EIGRP-Enhanced Interior Gateway Routing Protocol

It is Described as Hybrid Routing Protocol


Administrative Distance(AD)-90
Supports CIDR and VLSM
It uses Diffusion Algorithm to find Best Path
Metric=256x(Bandwidth+Delay)
It uses RTP(Reliable Transport Protocol)
Multiple Protocol Support
Fast Convergence

Now we are going to see EIGRP Routing configurations with simple network topology using
packet tracer,

Step 1:First Create a topology like this,and configure ip address to

all interfaces and PC.


Router R1,Configuration

In Global configuration mode,

R1(config)#interface fastethernet 0/0


R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

Once you have given no shutdown command the port become up

R1(config)#interface serial 2/0


R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#encapsulation ppp
R1(config-if)#no shutdown
R1(config-if)#exit

i.e.Always keep in mind to configure clock rate at DCE(Data Communication Equipment).we


can see clock symbol at the serial interface that is DCE other End is DTE(Data Terminal
Equipment).To
avoid confusion just give this command on both side.

Now, "Interface Serial2/0, changed state to down" ,Because other end of the serial interface not
configured.So we have to configure other end of the serial interface in R2,then this interface
become up.

Router R2,Config

In Global configuration mode,

R2#config terminal
R2(config)#interface serial 2/0
R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit

Interface Serial2/0 and Line protocol on Interface Serial2/0 changed state to up

R2(config)#
R2(config)#interface serial 3/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#clock rate 64000
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit

Router R3,Config
In Global configuration mode,

R3(config)#interface serial 3/0


R3(config-if)#ip address 30.0.0.2 255.0.0.0
R3(config-if)#encapsulation ppp
R3(config-if)#no shutdown
R3(config-if)#exit

Interface Serial3/0 and Line protocol, changed state to up

R3(config)#interface fastethernet0/0
R3(config-if)#ip address 40.0.0.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit

Interface fastethernet0/0 and line protocol,changed state to up

After all ip address assigned then lights in all interfaces become green.If anything wrong we get
red or amber.
Step 2:Now we see how to configure EIGRP routing protocols in this routers.

R1 Router,In Global Configuration mode,

R1(config)#router eigrp 200


R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit

R2 Router,In Global Configuration mode,

R2(config)#router eigrp 200


R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#exit

R3 Router,In Global Configuration mode,

R3(config)#router eigrp 200


R3(config-router)#network 30.0.0.0
R3(config-router)#network 40.0.0.0
R3(config-router)#exit

i.e.here 200 is Atonomous System Number,it is used to grouping of routers under common
admistration,Routers in different Atonomous Number
will not communicate with each other.So,Atonomous should be same in all routers.

Step 3:Now check the routing table by giving this command,

In Router R1,Privileged mode

R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP


D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet0/0


C 20.0.0.0/8 is directly connected, Serial2/0
D 30.0.0.0/8 [90/21024000] via 20.0.0.2, 00:04:42, Serial2/0
D 40.0.0.0/8 [90/21026560] via 20.0.0.2, 00:02:34, Serial2/0

Router R1 having all networks information in its routing table,Check for R2 and R3 also.

Step 4:Now click on Pc and select Desktop->command prompt,then check connectivity between
10.0.0.10 and 40.0.0.10

PC>Ping 40.0.0.10

Pinging 40.0.0.10 with 32 bytes of data:

Request timed out.


Reply from 40.0.0.10: bytes=32 time=15ms TTL=125
Reply from 40.0.0.10: bytes=32 time=13ms TTL=125
Reply from 40.0.0.10: bytes=32 time=16ms TTL=125

Ping statistics for 40.0.0.10:


Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 13ms, Maximum = 16ms, Average = 14ms

Verifying EIGRP Configurations

In Privileged Mode,

show ip route
show ip protocol
show ip eigrp topology
http://chennaicisco.blogspot.in/2013/10/how-to-configure-ip-address-to-pc-and.html

You might also like