You are on page 1of 3

Tutorial 5 - Solutions

1) What is an offset-list? Where can it be used? Give an example.

Lets take a lab of 2 routers and do some basic RIPv2 configuration:

Both routers just have the interface serial 1/0 and the interface loopback 0 configured. If you use
the basic RIPv2 configuration and start the routers you can ping the other router.

The routing table of R1:

Two more loopback interfaces are added to R2. The routes have an administrative distance of 120
and a metric of "1", which basically is a hop count. This value has a range of 1 to 15.

R2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface loopback 10
R2(config-if)#ip address 172.17.0.10 255.255.255.255
R2(config-if)#exit
R2(config)#interface loopback 20
R2(config-if)#ip address 172.17.0.20 255.255.255.255
R2(config-if)#end

R1#show ip route
Gateway of last resort is not set

172.17.0.0/32 is subnetted, 4 subnets


R 172.17.0.20 [120/1] via 192.168.100.2, 00:00:05, Serial1/0
R 172.17.0.10 [120/1] via 192.168.100.2, 00:00:05, Serial1/0
C 172.17.0.1 is directly connected, Loopback0
R 172.17.0.2 [120/1] via 192.168.100.2, 00:00:05, Serial1/0
192.168.100.0/30 is subnetted, 1 subnets
C 192.168.100.0 is directly connected, Serial1/0

The two new routes now appear in the routing table of router R1. The metric of RIP routes can be
manipulated with offset lists. For this to work an accesslist has to be configured. The metric of
172.17.0.10 will be increased by 5 on router R1 incoming on the interface S1/0, the metric of
172.17.0.20 will be increased by 7 outgoing on router R2.
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#access-list 10 permit 172.17.0.10 0.0.0.0
R1(config)#router rip
R1(config-router)#offset-list 10 in 5 Serial 1/0
R1(config-router)#end

R2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#access-list 20 permit 172.17.0.20 0.0.0.0
R2(config)#router rip
R2(config-router)#offset-list 20 out 7 Serial 1/0
R2(config-router)#end

R1#show ip route
Gateway of last resort is not set

172.17.0.0/32 is subnetted, 4 subnets


R 172.17.0.20 [120/8] via 192.168.100.2, 00:00:00, Serial1/0
R 172.17.0.10 [120/6] via 192.168.100.2, 00:00:00, Serial1/0
C 172.17.0.1 is directly connected, Loopback0
R 172.17.0.2 [120/1] via 192.168.100.2, 00:00:00, Serial1/0
192.168.100.0/30 is subnetted, 1 subnets
C 192.168.100.0 is directly connected, Serial1/0

2) What does the following SLA achieve?

ROUTER(config)# ip sla 11
ROUTER(config-ip-sla)# icmp-echo 10.1.3.3
ROUTER(config-ip-sla-echo)# frequency 10
ROUTER(config-ip-sla-echo)# exit
ROUTER(config)# ip sla schedule 11 life forever start-time now
ROUTER(config)# track 1 ip sla 11 reachability
ROUTER(config-track)# delay down 10 up 1
ROUTER(config-track)# exit
ROUTER(config)# ip route 0.0.0.0 0.0.0.0 10.1.1.1 2 track 1

The static route is dependent on the tracker 1 which runs a loop function that returns
reachability information. The function runs from now until an infinite time and its checks this
by pinging a foreign node at 10.1.3.3 every 10 secs. If the ping reply has not been received in
10 sec return the reachability as down. If it come back set the reachability back to up in 1
sec.

3) Analyse the following PBR commands-

ROUTER(config)# access-list 1 permit 10.1.0.0 0.0.0.255


ROUTER(config)# access-list 2 permit 10.2.0.0 0.0.0.255
ROUTER(config)# route-map EQUAL-ACCESS permit 10
ROUTER(config-route-map) # match ip address 1
ROUTER(config-route-map)# set ip default next-hop 192.168.6.6
ROUTER(config-route-map)# route-map EQUAL-ACCESS permit 20
ROUTER(config-route-map)# match ip address 2
ROUTER(config-route-map)# set ip default next-hop 172.16.7.7
ROUTER(config-route-map)# route-map EQUAL-ACCESS permit 30
ROUTER(config-route-map)# set default interface null0
ROUTER(config-route-map)# exit
ROUTER(config)# interface FastEthernet 0/0
ROUTER(config-if)# ip address 10.1.1.1 255.255.255.0
ROUTER(config-if)# ip policy route-map EQUAL-ACCESS
ROUTER(config-if)# exit

a. The route map is created to forward defined source traffic out a preferred next hop.
The route map seq 10 looks at source packets from 10.1.0.0/24 and sets the next hop to
forward on to as 192.168.6.6. seq 20 does the same for 10.2.0.0/24 and sets the next hop
as 172.16.7.7 . Any other traffic from other sources are blocked.

4) What is Policy-Based Routing? Explain briefly two use case scenarios.

Routing decisions made based on a policy set by the administrator. Use it for
redistribution, ip sla activities or simply path control.

5) What is meant by path control in IP routing? Give a few reasons why path control is
necessary?

Refer lecture slides.

You might also like