You are on page 1of 2

9/9/22, 3:25 PM AIX for System Administrators: AIX UPDATE - COMMANDS

More

AIX for System Administrators


Practical Guide to AIX (and PowerVM, PowerHA, PowerVC, HMC, DevOps ...)

AIX-HW AIX-OS FS-LVM HA HMC-POWER NETWORKS NIM PERFORMANCE STORAGE POWERVM POWERVC DEVOPS EXTRA

AIX UPDATE - COMMANDS


CLI
COMMANDS:

oslevel                             shows the actual BOS level

oslevel -r                          shows the TL level (or earlier ML)
oslevel -s                          shows what SP level installed

oslevel -sg 5300-09-01-0847         shows which fileset is greater than the given service pack (it is used with bos.rte.install)

oslevel -rl 5300-10                 shows which filesets are below the given TL level (TL level is from instfix -i | grep ML)

oslevel -sl 53-09-020849            shows which filesets are below the given servicepack (used after bos.rte.install has been updated)

------------------------------

bffcreate -ld <dir>                 shows info about the packages in a dir (I:install, U:updatte package)

bffcreate -c -d /bb1                it will change the bff name from U#### to normal fileset name in bb1 !!!overwrites original bff!!!

------------------------------

export INST_DEBUG=yes               setting up debug mode prior install/geninstall/nimadm operation, provides useful info of the failure

------------------------------
SEA

installp                            installs and maintainins LPP packages

        -a (apply)

        -c (commit)

        -p (preview)

        -g (apply prerequisites)

        -X (expand file systems, if needed)

        -Y (accept license agreements)

        -d (device or directory location of software)


FS -
        -q (quiet mode)

installp -apgXYd . bos.rte.install  preview install of given fileset from current (.) location
L

installp -agXYd /home/bb all        installs all fileset from given location
P
installp -aF -d /home/bb all        force install all filesets from given location
V
M
installp -s                         list of applied updates that can be committed or rejected
S
installp -c all                     commit all applied filesets
S

installp -C                         remove all files which were installed in failed state

installp -ld /dev/cd0               list what installable software is available on a device (cd rom)

installp -ld <file.bff>             lists what filesets are in the given bff file

installp -u <fileset>               removes a fileset (installp -ug <fileset> <--it will remove dependencies as well)

installp -upg X11*                  preview remove all X11 related software and prerequisistes

------------------------------

geninstall                          generic installer that installs software of various package formats: LPP, RPM etc.

           -I (use installp flags)

           -p (preview)

           -d (device or directory location of software)

geninstall -I "-acgXY" -p -d /home/bb all   preview install for all files in given location (using installp format)

geninstall -I "-acgXY" -d . bos.rte.install install a fileset from current (.) location (using installp format)

GEN
------------------------------

A
B
install_all_updates -pcYd .          preview of update

C
install_all_updates -cYd .           actually does the update

/var/adm/ras/install_all_updates.log here is the logfile of install_all_updates


C
C
------------------------------
D
D
instfix -i|grep ML (instfix -i|grep TL)    shows whether all filesets are installed
D
instfix -i | grep SP
E
instfix -icqk 5300-05_AIX_ML| grep ":-:"   shows missing software levels
F
instfix -ik IY24043                        shows if a fix (APAR) is installed on the system (instfix -ivk ... <--verbose mode)

I
instfix -k IY73748 -d /dev/cd0             install APAR iY733748 from /dev/cd0

M
O
------------------------------

aix4admins.blogspot.com/2011/06/commands-oslevel-shows-actual-bos-level.html 1/7
9/9/22, 3:25 PM AIX for System Administrators: AIX UPDATE - COMMANDS
S
lslpp -L                            displays info about all installed filesets or fileset updates
S
lslpp -L <fileset>                  displays info about that fileset
S
lslpp -h <fileset>                  shows the history of the fileset
S
lslpp -l | grep <fileset>           shows if it is installed or not

T
lslpp -lc| grep <fileset>           shows the state (Aplp., Comm., Broken..) in /etc/objrepos and in /usr/lib/objrepos of a fileset

lslpp -f <fileset>                  shows all files that are installed with  a particular fileset
U

lslpp -w /usr/local/bin/lsof        shows the fileset which contains the given file (binary) (which command shows full path: which lsof) U
U
lslpp -p <fileset>                  shows requisite information for a specified fileset (-p means possibly prerequisite)
W
lslpp -d <fileset>                  shows filesets that are dependents on the specified fileset

------------------------------

lppchk -v                           verify the installed software is in consistent state

lppchk -v -m3                       if lppchk -v gives an error, with this we can get more info about it

lppchk -c -m3                       makes a checksum on the filesets as well

------------------------------

smitty install                      software installation and maintenance menu

smitty update_all                   update installed software to latest level

smitty remove                       removing installed software

smitty reject                       removes applied filesets

smitty commit                       commits softwares

smitty software_maintain            many functions like reject, commit...

HA
------------------------------

C
restore -Tqvf EMCpower_install      show which files will be changed by the fileset
R
/usr/lpp/PackageName                here are the previous version of the updates which are in applied state (not commited yet)       
P
inutoc <path>                       creates a .toc file in the given path

P
ldd /root/gzip                      lists the path names of all dependencies (lists dynamic dependencies)

P
which_fileset <command>             searches the /usr/lpp/bos/AIX_file_list file for a specified file name or command

P
/usr/lib/instl/lppmgr -d /nim/5304 -rub    the directory will be checked and all duplicate filesets will be removed

                                    (-r: remove, -u:check update filesets, -b: check base level filesets)
P
multibos                             http://www.ibmsystemsmag.com/aix/aprilmay08/tipstechniques/20226p1.aspx
P
---------------------------------------------------------------------
P
P
INSTFIX CORRECTION:
P
P
1. instfix -i | grep ML
P
    All filesets for 5.3.0.0_AIX_ML were found.

S
    All filesets for 5300-01_AIX_ML were found.

G
    All filesets for 5300-04_AIX_ML were found.

    Not all filesets for 5300-05_AIX_ML were found.

    ...

2. instfix -vick 5300-05_AIX_ML | grep :-:

   (instfix -icqk 5300-05_AIX_ML | grep ":-:"                         <--this command was used in the NIM redbook)

5300-05_AIX_ML:X11.adt.motif:5.3.0.50:5.3.0.0:-:AIX 5300-05 Update    <-- shows what is missing

3.lslpp -L X11.adt.motif                                              <-- shows if it is installed and what is the current version

  Fileset                      Level  State  Type  Description (Uninstaller)

  ----------------------------------------------------------------------------

  X11.adt.motif              5.3.0.0    C     F    AIXwindows Application

                                                   Development Toolkit Motif

4. if we have found it in a dir: installp -l -d .

  Fileset Name                Level                     I/U Q Content


HMC
  ====================================================================

  X11.adt.motif               5.3.0.50                   S  N usr     <--shows if reboot needed after install (N= not affected, no H
reboot)
H
                                                                     (Y and B: it affects the currently running programs)
H
                                                                     (B and b: causes bosboot to occur + reboot is needed)
H
H
5. smitty update_all (or smitty install)
H
P
P
6. now it is OK: instfix -i | grep ML

P
    All filesets for 5.3.0.0_AIX_ML were found.

    All filesets for 5300-01_AIX_ML were found.

    All filesets for 5300-04_AIX_ML were found.

    All filesets for 5300-05_AIX_ML were found.

---------------------------------------------------------------------

FIXING FILESETS in ODM:

lppchk -v shows problems with a fileset and you don't want to remove it:

devices.common.IBM.iscsi.rte 5.2.0.0    (not installed; requisite fileset)

1. save ODM

   tar -cvf /tmp/odm.etc.tar /etc/objrepos

   tar -cvf /tmp/odm.usr.lib.tar /usr/lib/objrepos

aix4admins.blogspot.com/2011/06/commands-oslevel-shows-actual-bos-level.html 2/7

You might also like