You are on page 1of 3

110-OSPF

1- static route
0-connected route
90-eigrp
120 - rip

switchport mode access -> end device


switchport mode trunk -> another switch

switchport mode dynamic desirable, dynamic auto, nonegotiate


DTP

STP can help prevent bridge looping on LANs that include redundant links. Without
STP, it would be difficult to implement that redundancy and still avoid network
looping. STP monitors all network links, identifies redundant connections and
disables the ports that can lead to looping.

show vlan -> view vlan database


show interface trunk -> view trunks...

conf t
vlan 10
name manage.....
exit
vlan 20
name employee....

conf t
int f0/1 or int range f0/2-3
switchport mode access
switchport access vlan 10
int f0/2
switchport mode access
switchport access vlan 20

conf t
int f0/2
switchport mode trunk

Vlan 1 is default native vlan

vtp is not a trunking protocol


trunking protocol -> isl , 802.1q

VTP modes
Server - where u can make chngs
client - receives chngs only (u cant make any chng here) -> vtp mode client
transparent - doesn't participate in vtp (not update its own VLAN db but it will
just pass advertisement to its neighbor dvcs)

show vtp status

conf t
vtp version 2
vtp mode server
vtp domain cisco.com
vtp password cisco
vtp pruning
or
interface <#>
switchport mode trunk
switchport trunk allowed vlan <all/none/add/remove/#>

switchport trunk native vlan 10 -> native vlan

conf t
int f0/1
speed 100
duplex full

int f0/1
switchport port-security mac-address ........... or sticky
switchport port-security

sh port security or sh port security interface f0/1

service password-encryption -> not much secure


enable secret cisco

ip route <n/w id> <mask> <next hop/exit int> --> static routing

router rip
ver 2
network 192.168.2.0 (in classfull form)
--> autosumarization issue (no auto-summary)

specific -> network -> default

default route(S*) -> ip route 0.0.0.0 0.0.0.0 next hop

Network route -> ip route 192.168.30.0 255.255.255.0 next hop


host route -> ip route 192.168.30.1 255.255.255.255 next hop

https://www.comparitech.com/net-admin/inter-vlan-routing-configuration/

APIPA(IPV4 Auto configuration) -> 169.254.x.x


If dhcp server fails to assign ip address (IPV4)

auto Link local -> FE80::/64 use eui64 format


IPV6

int g0/0
ipv6 add 2010::/64 eui -> auto ipv6 add

conf t
int g0/0
ipv6 rip netwrk enable
int g0/1
ipv6 rip netwrk enable -> dynamic routing

conf t
ipv6 unicast-routing

ip dhcp pool <name>


network <nw id> <subnet mask>
default-router <gateway-ip>
dns-server <dns ip>

ip dhcp excluded-address 192.168.1.1 192.168.1.10

access-list <ACL_No> <deny/permit> <matching parameters> --> classic

ip access-list standard <ACL_No/name>

ox2142 : Skipping the startup config


ox2102 : normal router, will load the startup config

etherchannel
static - on
pagp - desirable/auto
lacp- active / passive

You might also like