You are on page 1of 15

*********************R_ISP*********************

enable
configure terminal
hostname R_ISP

line console 0
password cisco
login
exit

enable password class

service password-encryption

banner motd #--SOLO PERSONAL AUTORIZADO--#

ip domain-name risp.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

inter g0/0/0
ip add 172.30.100.1 255.255.255.0
no shutdown
ip nat inside

inter s0/1/0
ip add 210.60.60.6 255.255.255.252
clock rate 64000
no shutdown
ip nat outside
exit

ip nat inside source static 172.30.100.1 210.60.60.6

ip route 0.0.0.0 0.0.0.0 210.60.60.5

+++++++++++++++++++++++++++++++++++++++++++++++++

********************R-Borde********************
enable
configure terminal
hostname R_BORDE

line console 0
password cisco
login
exit

enable password class

service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#

ip domain-name rborde.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

ip nat inside source static 10.0.100.1 210.60.60.5


ip nat inside source static 10.0.100.5 210.60.60.5
ip nat inside source static 10.0.100.9 210.60.60.5

interface s0/1/0
ip address 210.60.60.5 255.255.255.252
no shutdown
ip nat outside
exit

interface s0/1/1
ip address 10.0.100.1 255.255.255.252
clock rate 64000
no shutdown
ip nat inside
exit

interface s0/2/0
ip address 10.0.100.5 255.255.255.252
clock rate 64000
no shutdown
ip nat inside
exit

interface s0/2/1
ip address 10.0.100.9 255.255.255.252
clock rate 64000
no shutdown
ip nat inside
exit

ip route 0.0.0.0 0.0.0.0 210.60.60.6

router ospf 1
router-id 1.1.1.1
network 10.0.100.0 0.0.0.3 area 1
network 10.0.100.4 0.0.0.3 area 1
network 10.0.100.8 0.0.0.3 area 1
network 210.60.60.4 0.0.0.3 area 1
default-information originate
exit
++++++++++++++++++++++++++++++++++++++++++++++++

********************R-A***********************
enable
configure terminal
hostname R_A

line console 0
password cisco
login
exit

enable password class

service password-encryption

banner motd #--SOLO PERSONAL AUTORIZADO--#

ip domain-name ra.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

inter s0/1/0
ip add 10.0.100.2 255.255.255.252
no shutdown
exit

inter s0/1/1
ip add 10.0.100.13 255.255.255.252
clock rate 64000
no shutdown
exit

inter g0/0/0
ip add 10.0.100.21 255.255.255.252
no shutdown
exit

inter g0/0/1
ip add 10.0.100.25 255.255.255.252
no shutdown
exit

router ospf 1
router-id 2.2.2.2
network 10.0.100.0 0.0.0.3 area 1
network 10.0.100.12 0.0.0.3 area 1
network 172.168.100.0 0.0.0.3 area 1
network 172.168.100.4 0.0.0.3 area 1
++++++++++++++++++++++++++++++++++++++++++++++++

***********************************R-B*************************************
enable
configure terminal
hostname R_B
line console 0
password cisco
login
exit

enable password class

service password-encryption

banner motd #--SOLO PERSONAL AUTORIZADO--#

ip domain-name rb.com
crypto key generate rsa
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

inter s0/1/0
ip add 10.0.100.6 255.255.255.252
no shutdown
exit

inter s0/1/1
ip add 10.0.100.14 255.255.255.252
no shutdown
exit

inter s0/2/0
ip add 10.0.100.17 255.255.255.252
clock rate 64000
no shutdown
exit

inter g0/0/0
ip add 172.168.100.9 255.255.255.252
no shutdown
exit

inter g0/0/1
ip add 172.168.100.13 255.255.255.252
no shutdown
exit

router ospf 1
router-id 3.3.3.3
network 10.0.100.4 0.0.0.3 area 1
network 10.0.100.12 0.0.0.3 area 1
network 10.0.100.16 0.0.0.3 area 1
network 172.168.100.8 0.0.0.3 area 1
network 172.168.100.12 0.0.0.3 area 1

++++++++++++++++++++++++++++++++++++++++++++++++
*********************R-C*********************
enable
configure terminal
hostname R_C

line console 0
password cisco
login
exit

enable password class

service password-encryption

banner motd #--SOLO PERSONAL AUTORIZADO--#

ip domain-name rc.com
crypto key generate rsa
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

inter s0/1/0
ip add 10.0.100.10 255.255.255.252
no shutdown
exit

inter s0/1/1
ip add 10.0.100.18 255.255.255.252
no shutdown
exit

inter g0/0/0
ip add 172.168.100.17 255.255.255.252
no shutdown
exit

inter g0/0/1
ip add 172.168.100.21 255.255.255.252
no shutdown
exit

router ospf 1
router-id 4.4.4.4
network 10.0.100.8 0.0.0.3 area 1
network 10.0.100.16 0.0.0.3 area 1
network 172.168.100.16 0.0.0.3 area 1
network 172.168.100.20 0.0.0.3 area 1

+++++++++++++++++++++++++++++++++++++++++++++++++

**********************MC-A1***********************
-------------Configuración Básica-----------------
Enable
Configure Terminal
hostname MC-A1
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #SOLO PERSONAL AUTORIZADO#

ip domain-name cisco.local
crypto key generate rsa
1024
ip ssh version 2
username admin secret ccna

line vty 0 15
transport input ssh
login local
exit

---------------Configuración de Vlans-------------
vlan 10
name Ingenieria
exit

vlan 20
name Contabilidad
exit

vlan 30
name TI
exit

vlan 40
name Proveeduria
exit

vlan 80
name AgujeroNegro
exit

Interface range f0/5-24


switchport mode access
switchport access vlan 80
exit

vlan 70
name Nativa
exit

vlan 100
name Administrativa
exit

-----------Configuración de Truncales-------------
interface g0/1
switchport mode access
switchport mode trunk
switchport trunk native vlan 70
switchport trunk allowed vlan all
no shutdown
exit

interface f0/4
switchport mode access
switchport mode trunk
switchport trunk native vlan 70
switchport trunk allowed vlan all
no shutdown
exit

----------Configuración de EtherChanel------------
interface range f0/1-3
shutdown
channel-group 2 mode Desirable
interface range f0/1-3
no shutdown
interface po 2
switchport mode access
switchport mode trunk
switchport trunk native vlan 70
switchport trunk allowed vlan all
no shutdown
exit

-------------Configuración de HSRP----------------
interface vlan 10
ip address 192.168.10.2 255.255.255.240
standby 10 ip 192.168.10.1
standby 10 priority 255
standby 10 preempt
exit

interface vlan 20
ip address 192.168.20.2 255.255.255.240
standby 20 ip 192.168.20.1
standby 20 priority 255
standby 20 preempt
exit

interface vlan 30
ip address 192.168.30.2 255.255.255.240
standby 30 ip 192.168.30.1
standby 30 priority 100
exit

interface vlan 40
ip address 192.168.40.2 255.255.255.240
standby 40 ip 192.168.40.1
standby 40 priority 100
exit

interface vlan 100


Description Administración de Equipos
ip address 172.16.50.2 255.255.255.248
no shutdown
standby 100 ip 172.16.50.1
standby 100 priority 255
standby 100 preempt
ip default-gateway 172.16.50.1

-------------Configuracion Routing---------------
ip routing
interface g0/1
no switchport
ip address 172.168.100.2 255.255.255.252
no shutdown
exit

--------------Configuración OSPF-----------------

router ospf 1
router-id 2.2.0.1
network 172.168.100.0 0.0.0.3 area 1
network 192.168.10.0 0.0.0.15 area 1
network 192.168.20.0 0.0.0.15 area 1
network 192.168.30.0 0.0.0.15 area 1
network 192.168.40.0 0.0.0.15 area 1
network 172.16.50.0 0.0.0.7 area 1
exit

++++++++++++++++++++++++++++++++++++++++++++++++

**********************MC-A2***********************
-------------Configuración Básica-----------------
Enable
Configure Terminal
hostname MC-A2
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #SOLO PERSONAL AUTORIZADO#

ip domain-name cisco.local
crypto key generate rsa
1024
ip ssh version 2
username admin secret ccna

line vty 0 15
transport input ssh
login local
exit
--------------Configuración de Vlans--------------
vlan 10
name Ingenieria
exit

vlan 20
name Contabilidad
exit

vlan 30
name TI
exit

vlan 40
name Proveeduria
exit

vlan 80
name AgujeroNegro
exit

Interface range f0/5-24


switchport mode access
switchport access vlan 80
exit

vlan 70
name Nativa
exit

vlan 100
name Administrativa
exit

-----------Configuración de Truncales-------------
interface g0/1
switchport mode access
switchport mode trunk
switchport trunk native vlan 70
switchport trunk allowed vlan all
no shutdown
exit

interface f0/4
switchport mode access
switchport mode trunk
switchport trunk native vlan 70
switchport trunk allowed vlan all
no shutdown
exit

----------Configuración de EtherChanel------------
interface range f0/1-3
shutdown
channel-group 2 mode Desirable
interface range f0/1-3
no shutdown
interface po 2
switchport mode access
switchport mode trunk
switchport trunk native vlan 70
switchport trunk allowed vlan all
no shutdown
exit
-------------Configuración de HSRP----------------
interface vlan 10
ip address 192.168.10.3 255.255.255.240
standby 10 ip 192.168.10.1
standby 10 priority 100
exit

interface vlan 20
ip address 192.168.20.3 255.255.255.240
standby 20 ip 192.168.20.1
standby 20 priority 100
exit

interface vlan 30
ip address 192.168.30.3 255.255.255.240
standby 30 ip 192.168.30.1
standby 30 priority 255
standby 30 preempt
exit

interface vlan 40
ip address 192.168.40.3 255.255.255.240
standby 40 ip 192.168.40.1
standby 40 priority 255
standby 40 preempt
exit

interface vlan 100


Description Administración de Equipos
ip address 172.16.50.3 255.255.255.248
no shutdown
standby 100 ip 172.16.50.1
standby 100 priority 100
ip default-gateway 172.16.50.1
exit

------------Configuracion Routing-----------------
ip routing
interface g0/1
no switchport
ip address 172.168.100.6 255.255.255.252
no shutdown
exit

--------------Configuración OSPF------------------

router ospf 1
router-id 2.2.0.2
network 172.168.100.4 0.0.0.3 area 1
network 192.168.10.0 0.0.0.15 area 1
network 192.168.20.0 0.0.0.15 area 1
network 192.168.30.0 0.0.0.15 area 1
network 192.168.40.0 0.0.0.15 area 1
network 172.16.50.0 0.0.0.7 area 1
exit

+++++++++++++++++++++++++++++++++++++++++++++++++
**********************SW-A1**********************
--------------Configuración Básica---------------
Enable
Configure Terminal
hostname SW-A1
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #SOLO PERSONAL AUTORIZADO#

ip domain-name cisco.local
crypto key generate rsa
1024
ip ssh version 2
username admin secret ccna

line vty 0 15
transport input ssh
login local
exit
-------------Configuración de Vlans---------------
vlan 10
name Ingenieria
exit
Interface range f0/1-8
switchport mode access
switchport access vlan 10
exit
------------Configurar Vlan de Voz----------------
vlan 150
name voice
exit

interface f0/1
mls qos trust cos
switchport voice vlan 150
exit

-----------------------------------------------
vlan 20
name Contabilidad
exit
Interface range f0/9-16
switchport mode access
switchport access vlan 20
exit
vlan 80
name AgujeroNegro
exit
Interface range f0/17-23
switchport mode access
switchport access vlan 80
exit
Interface g0/2
switchport mode access
switchport access vlan 80
exit

vlan 70
name Nativa
exit

vlan 100
name Administrativa
exit

interface vlan 100


Description Administración de Equipos
ip address 172.16.50.4 255.255.255.248
no shutdown
ip default-gateway 172.16.50.1

-------------Configuración de Truncales-----------
interface g0/1
switchport mode trunk
switchport trunk native vlan 70
switchport trunk allowed vlan all
no shutdown
exit

interface f0/24
switchport mode trunk
switchport trunk native vlan 70
switchport trunk allowed vlan all
no shutdown
exit

------------Configuración de Seguridad------------
Interface range f0/17-23
shutdown

Interface range f0/1-16


switchport port-security
switchport port-security maximum 4
switchport port-security mac-address sticky
switchport port-security violation shutdown
ip dhcp snooping limit rate 6
exit

ip dhcp snooping
ip dhcp snooping vlan 10,20
ip arp inspection vlan 10,20
ip arp inspection validate src-mac
ip arp inspection validate dst-mac
ip arp inspection validate ip

spanning-tree portfast default


spanning-tree portfast bpduguard default

interface f0/24
switchport nonegotiate
ip dhcp snooping trust
ip arp inspection trust
exit

interface g0/1
switchport nonegotiate
ip dhcp snooping trust
ip arp inspection trust
exit

+++++++++++++++++++++++++++++++++++++++++++++++++

**********************SW-A2**********************
--------------Configuración Básica---------------
Enable
Configure Terminal
hostname SW-A2
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #SOLO PERSONAL AUTORIZADO#

ip domain-name cisco.local
crypto key generate rsa
1024
ip ssh version 2
username admin secret ccna

line vty 0 15
transport input ssh
login local
exit
--------------Configuración de Vlans--------------
vlan 30
name TI
exit
Interface range f0/1-8
switchport mode access
switchport access vlan 30
exit
-------------Configurar Vlan de Voz---------------
vlan 150
name voice
exit

interface f0/1
mls qos trust cos
switchport voice vlan 150
exit

--------------------------------------------------
vlan 40
name Proveeduria
exit
Interface range f0/9-16
switchport mode access
switchport access vlan 40
exit
vlan 80
name AgujeroNegro
exit
Interface range f0/17-23
switchport mode access
switchport access vlan 80
exit
Interface g0/2
switchport mode access
switchport access vlan 80
exit

vlan 70
name Nativa
exit

vlan 100
name Administrativa
exit

interface vlan 100


Description Administración de Equipos
ip address 172.16.50.5 255.255.255.248
no shutdown
ip default-gateway 172.16.50.1
exit

------------Configuración de Truncales------------
interface g0/1
switchport mode trunk
switchport trunk native vlan 70
switchport trunk allowed vlan all
no shutdown
exit

interface f0/24
switchport mode trunk
switchport trunk native vlan 70
switchport trunk allowed vlan all
no shutdown
exit

-----------Configuración de Seguridad-------------
Interface range f0/17-23
shutdown

Interface range f0/1-16


switchport port-security
switchport port-security maximum 4
switchport port-security mac-address sticky
switchport port-security violation shutdown
ip dhcp snooping limit rate 6
exit

ip dhcp snooping
ip dhcp snooping vlan 30,40
ip arp inspection vlan 30,40
ip arp inspection validate src-mac
ip arp inspection validate dst-mac
ip arp inspection validate ip

spanning-tree portfast default


spanning-tree portfast bpduguard default

interface f0/24
switchport nonegotiate
ip dhcp snooping trust
ip arp inspection trust
exit

interface g0/1
switchport nonegotiate
ip dhcp snooping trust
ip arp inspection trust
exit

+++++++++++++++++++++++++++++++++++++++++++++++++

+++++++++++++++++++++++++++++++++++++++++++++++++

You might also like