You are on page 1of 34

*************************R_ISP***************************

---------------Configuración Básica--------------------
enable
conf t
hostname R_ISP
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#

ip domain-name risp.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

--------------Configuración Interfaces----------------

inter g0/0/0
ip add 172.30.100.1 255.255.255.0
no shutdown
ip nat inside

inter s0/1/0
ip add 210.60.60.5 255.255.255.252
clock rate 64000
no shutdown
ip nat outside
exit

----------------Configuración NAT--------------------

ip nat inside source static 172.30.100.1 210.60.60.5

-------------Configuración Ruta por defecto--------------

ip route 0.0.0.0 0.0.0.0 210.60.60.6

************************R_BORDE**********************

--------------------Configuración Básica--------------------
enable
configure terminal
hostname R_BORDE
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name rborde.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

----------------Configuración Interfaces------------------

inter s0/1/0
ip add 210.60.60.6 255.255.255.252
ip nat outside
no shutdown
exit

inter s0/1/1
ip add 10.0.100.1 255.255.255.252
clock rate 64000
no shutdown
ip nat inside
exit

inter s0/2/1
ip add 10.0.100.9 255.255.255.252
clock rate 64000
no shutdown
ip nat inside
exit

inter s0/2/0
ip add 10.0.100.5 255.255.255.252
clock rate 64000
no shutdown
ip nat inside
exit

----------Configuración Ruta por defecto--------------

ip route 0.0.0.0 0.0.0.0 210.60.60.5

----------------Configuración OSPF--------------------
router ospf 1
router-ip 1.1.1.1
network 10.0.100.0 0.0.0.3 area 1
network 10.0.100.4 0.0.0.3 area 1
network 10.0.100.8 0.0.0.3 area 1
default-information originate

----------------Configuración NAT--------------------

ip nat inside source static 10.0.100.0 210.60.60.4


ip nat inside source static 10.0.100.4 210.60.60.4
ip nat inside source static 10.0.100.8 210.60.60.4
----------------Configuración DHCP--------------------

ip dhcp excluded-address 10.10.10.1 10.10.10.6


ip dhcp pool DHCP_VLAN_10_A
network 10.10.10.0 255.255.255.240
default-router 10.10.10.3
dns-server 172.30.100.253

ip dhcp excluded-address 20.20.20.1 20.20.20.6


ip dhcp pool DHCP_VLAN_20_A
network 20.20.20.0 255.255.255.240
default-router 20.20.20.3
dns-server 172.30.100.253

ip dhcp excluded-address 30.30.30.1 30.30.30.6


ip dhcp pool DHCP_VLAN_30_A
network 30.30.30.0 255.255.255.240
default-router 30.30.30.3
dns-server 172.30.100.253

ip dhcp excluded-address 40.40.40.1 40.40.40.6


ip dhcp pool DHCP_VLAN_40_A
network 40.40.40.0 255.255.255.240
default-router 40.40.40.3
dns-server 172.30.100.253
exit

ip dhcp excluded-address 10.11.10.1 10.11.10.6


ip dhcp pool DHCP_VLAN_10_B
network 10.11.10.0 255.255.255.240
default-router 10.11.10.3
dns-server 172.30.100.253

ip dhcp excluded-address 20.21.20.1 20.21.20.6


ip dhcp pool DHCP_VLAN_20_B
network 20.21.20.0 255.255.255.240
default-router 20.21.20.3
dns-server 172.30.100.253

ip dhcp excluded-address 30.31.30.1 30.31.30.6


ip dhcp pool DHCP_VLAN_30_B
network 30.31.30.0 255.255.255.240
default-router 30.31.30.3
dns-server 172.30.100.253

ip dhcp excluded-address 40.41.40.1 40.41.40.6


ip dhcp pool DHCP_VLAN_40_B
network 40.41.40.0 255.255.255.240
default-router 40.41.40.3
dns-server 172.30.100.253
exit

ip dhcp excluded-address 10.12.10.1 10.12.10.6


ip dhcp pool DHCP_VLAN_10_C
network 10.12.10.0 255.255.255.240
default-router 10.12.10.3
dns-server 172.30.100.253
ip dhcp excluded-address 20.22.20.1 20.22.20.6
ip dhcp pool DHCP_VLAN_20_C
network 20.22.20.0 255.255.255.240
default-router 20.22.20.3
dns-server 172.30.100.253

ip dhcp excluded-address 30.32.30.1 30.32.30.6


ip dhcp pool DHCP_VLAN_30_C
network 30.32.30.0 255.255.255.240
default-router 30.32.30.3
dns-server 172.30.100.253

ip dhcp excluded-address 40.42.40.1 40.42.40.6


ip dhcp pool DHCP_VLAN_40_C
network 40.42.40.0 255.255.255.240
default-router 40.42.40.3
dns-server 172.30.100.253
exit

**********************R-A*****************************

-----------------Configuración Básica------------------
enable
configure terminal
hostname R_A
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name ra.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

--------------Configuración Interfaces----------------

inter s0/1/0
ip add 10.0.100.2 255.255.255.252
no shutdown
exit

inter s0/1/1
ip add 10.0.100.13 255.255.255.252
clock rate 64000
no shutdown
exit

inter g0/0/0
ip add 192.168.50.1 255.255.255.252
no shutdown
exit
inter g0/0/1
ip add 172.16.16.2 255.255.255.252
no shutdown
exit

----------------Configuración OSPF--------------------

router ospf 1
router-id 2.2.2.2
network 10.0.100.0 0.0.0.3 area 1
network 10.0.100.12 0.0.0.3 area 1
network 192.168.50.0 0.0.0.3 area 1
network 172.16.16.0 0.0.0.3 area 1

**************************R-B***************************
enable
configure terminal
hostname R_B
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name rb.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

--------------Configuración Interfaces----------------

inter s0/1/0
ip add 10.0.100.6 255.255.255.252
no shutdown
exit

inter s0/1/1
ip add 10.0.100.14 255.255.255.252
no shutdown
exit

inter s0/2/0
ip add 10.0.100.17 255.255.255.252
clock rate 64000
no shutdown
exit

inter g0/0/0
ip add 192.168.100.1 255.255.255.252
no shutdown
exit
inter g0/0/1
ip add 172.16.32.1 255.255.255.252
no shutdown
exit

----------------Configuración OSPF--------------------

router ospf 1
router-id 3.3.3.3
network 10.0.100.4 0.0.0.3 area 1
network 10.0.100.12 0.0.0.3 area 1
network 10.0.100.16 0.0.0.3 area 1
network 192.168.100.0 0.0.0.3 area 1
network 172.16.32.0 0.0.0.3 area 1

************************R-C**************************

-----------------Configuración Básica------------------
enable
configure terminal
hostname R_C
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name rc.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

--------------Configuración Interfaces----------------

inter s0/1/0
ip add 10.0.100.10 255.255.255.252
no shutdown
exit

inter s0/1/1
ip add 10.0.100.18 255.255.255.252
no shutdown
exit

inter g0/0/0
ip add 192.168.150.1 255.255.255.252
no shutdown
exit

inter g0/0/1
ip add 172.16.64.1 255.255.255.252
no shutdown
exit

router ospf 1
router-id 4.4.4.4
network 10.0.100.8 0.0.0.3 area 1
network 10.0.100.16 0.0.0.3 area 1
network 192.168.150.0 0.0.0.3 area 1
network 172.16.64.0 0.0.0.3 area 1

/////////////////////////////////////////////////////
////////////////////////RED A////////////////////////
/////////////////////////////////////////////////////
/////////////////////////////////////////////////////

*********************SW-A1***************************

-----------------Configuración Básica------------------
enable
configure terminal
hostname SW_A1
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name swa1.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2
-----------------Configuración VLAN------------------
vlan 10
name Ingenieria
exit
vlan 20
name Contabilidad
exit

vlan 150
name VOICE
exit

vlan 99
name Administracion
exit

vlan 666
name BLACKHOLE
exit
vlan 999
name NATIVE
exit
-------------Configuración Interfaces---------------

Interface range f0/1-8


switchport mode access
switchport access vlan 10
exit

inter f0/1
mls qos trust cos
switchport VOICE vlan 150
exit

Interface range f0/9-16


switchport mode access
switchport access vlan 20
exit

interface vlan 99
Description Administración de Equipos
ip add 172.168.10.3 255.255.255.0
no shutdown
ip default-gateway 172.168.10.5

-------------Configuración de Truncales-----------

inter f0/24
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

inter g0/1
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

------------Configuración de Seguridad------------

Interface range f0/17-23


switchport mode access
switchport access vlan 666
shutdown

int g0/2
switchport mode access
switchport access vlan 666
shutdown

Interface range f0/1-16


switchport port-security
switchport port-security maximum 4
switchport port-security mac-address sticky
switchport port-security violation shutdown
exit

spanning-tree portfast default


spanning-tree portfast bpduguard default

****************************************SW-
A2********************************************
enable
configure terminal
hostname SW_A2
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name swa2.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

-----------------Configuración VLAN------------------

vlan 30
name TI
exit

vlan 40
name Proveeduria
exit

vlan 150
name VOICE
exit

vlan 99
name Administracion
exit

vlan 666
name BLACKHOLE
exit

vlan 999
name NATIVE
exit

-------------Configuración Interfaces---------------

Interface range f0/1-8


switchport mode access
switchport access vlan 30
exit

inter f0/1
mls qos trust cos
switchport voice vlan 150
exit

Interface range f0/9-16


switchport mode access
switchport access vlan 40
exit

interface vlan 99
Description Administración de Equipos
ip add 172.168.10.2 255.255.255.0
ip default-gateway 172.168.10.5

-------------Configuración de Truncales-----------

inter f0/24
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

inter g0/1
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

------------Configuración de Seguridad------------

Interface range f0/17-23


switchport mode access
switchport access vlan 666
shutdown

int g0/2
switchport mode access
switchport access vlan 666
shutdown

Interface range f0/1-16


switchport port-security
switchport port-security maximum 4
switchport port-security mac-address sticky
switchport port-security violation shutdown
exit

spanning-tree portfast default


spanning-tree portfast bpduguard default

***********************MC-A1*********************
-------------Configuración Básica-----------------
enable
configure terminal
hostname MC-A1
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name mca1.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

---------------Configuración de Vlans-------------
vlan 10
name Ingenieria
exit
vlan 20
name Contabilidad
exit
vlan 30
name TI
exit
vlan 40
name Proveeduria
exit
vlan 99
name Administracion
exit
vlan 150
name VOICE
exit
vlan 999
name NATIVE
exit

-----------Configuración de Truncales-------------

inter g0/2
switchport mode access
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

inter f0/4
switchport mode access
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

-------------Configuracion Routing---------------
ip routing

inter g0/1
no switchport
ip add 192.168.50.2 255.255.255.252
no shutdown
exit

-------------Configuración de HSRP----------------
int vlan 10
description default gateway SVI para la ip 10.10.10.1/24
ip add 10.10.10.1 255.255.255.0
ip helper-address 10.0.100.1
Standby 10 ip 10.10.10.3
Standby 10 priority 255
Standby 10 preempt
no shutdown
exit

int vlan 20
description default gateway SVI para la ip 20.20.20.1/24
ip add 20.20.20.1 255.255.255.0
ip helper-address 10.0.100.1
Standby 20 ip 20.20.20.3
Standby 20 priority 255
Standby 20 preempt
no shutdown
exit

int vlan 30
description default gateway SVI para la ip 30.30.30.1/24
ip add 30.30.30.1 255.255.255.0
ip helper-address 10.0.100.1
Standby 30 ip 30.30.30.3
Standby 30 priority 255
Standby 30 preempt
no shutdown
exit

int vlan 40
description default gateway SVI para la ip 40.40.40.1/24
ip add 40.40.40.1 255.255.255.0
ip helper-address 10.0.100.1
Standby 40 ip 40.40.40.3
Standby 40 priority 255
Standby 40 preempt
no shutdown
exit

int vlan 99
description default gateway SVI para la ip 172.168.10.1/24
ip add 172.168.10.1 255.255.255.0
ip helper-address 10.0.100.1
Standby 99 ip 172.168.10.5
Standby 99 priority 255
Standby 99 preempt
no shutdown
exit

--------------Configuración OSPF-----------------

router ospf 1
router-id 2.2.0.1
network 192.168.50.0 0.0.0.3 area 1
network 10.10.10.0 0.0.0.255 area 1
network 20.20.20.0 0.0.0.255 area 1
network 30.30.30.0 0.0.0.255 area 1
network 40.40.40.0 0.0.0.255 area 1
network 172.168.10.0 0.0.0.255 area 1
exit

----------Configuración de EtherChanel------------
interface range f0/1-3
shutdown
channel-group 2 mode Desirable
interface range f0/1-3
no shutdown
interface po 2
switchport mode access
switchport mode trunk
switchport trunk native vlan 999
switchport trunk allowed vlan all
no shutdown
exit

------------Configuración de Seguridad------------

int range f0/5-24


shutdown

**********************MC-A2**********************
-------------Configuración Básica-----------------
enable
configure terminal
hostname MC-A2
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name mca2.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

--------------Configuración de Vlans--------------

vlan 10
name Ingenieria
exit
vlan 20
name Contabilidad
exit
vlan 30
name TI
exit
vlan 40
name Proveeduria
exit
vlan 99
name Administracion
exit
vlan 150
name VOICE
exit
vlan 999
name NATIVE
exit

-----------Configuración de Truncales-------------

inter g0/2
switchport mode access
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

inter f0/4
switchport mode access
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

------------Configuracion Routing-----------------

ip routing
inter g0/1
no switchport
ip add 172.16.16.1 255.255.255.252
no shutdown
exit

----------Configuración de EtherChanel------------
interface range f0/1-3
shutdown
channel-group 2 mode Desirable
interface range f0/1-3
no shutdown
interface po 2
switchport mode access
switchport mode trunk
switchport trunk native vlan 999
switchport trunk allowed vlan all
no shutdown
exit

-------------Configuración de HSRP----------------

int vlan 10
description default gateway SVI para la ip 10.10.10.2/24
ip add 10.10.10.2 255.255.255.0
ip helper-address 10.0.100.1
Standby 10 ip 10.10.10.3
no shutdown
exit

int vlan 20
description default gateway SVI para la ip 20.20.20.2/24
ip add 20.20.20.2 255.255.255.0
ip helper-address 10.0.100.1
Standby 20 ip 20.20.20.3
no shutdown
exit

int vlan 30
description default gateway SVI para la ip 30.30.30.2/24
ip add 30.30.30.2 255.255.255.0
ip helper-address 10.0.100.1
Standby 30 ip 30.30.30.3
no shutdown
exit

int vlan 40
description default gateway SVI para la ip 40.40.40.2/24
ip add 40.40.40.2 255.255.255.0
ip helper-address 10.0.100.1
Standby 40 ip 40.40.40.3
no shutdown
exit

int vlan 99
description default gateway SVI para la ip 172.168.10.1/24
ip add 172.168.10.2 255.255.255.0
Standby 99 ip 172.168.10.5
no shutdown
exit

--------------Configuración OSPF------------------

router ospf 1
router-id 2.2.0.2
network 172.16.16.0 0.0.0.3 area 1
network 10.10.10.0 0.0.0.255 area 1
network 20.20.20.0 0.0.0.255 area 1
network 30.30.30.0 0.0.0.255 area 1
network 40.40.40.0 0.0.0.255 area 1
network 172.168.10.0 0.0.0.255 area 1

------------Configuración de Seguridad------------

int range f0/5-24


shutdown
exit

/////////////////////////////////////////////////////
////////////////////////RED B////////////////////////
/////////////////////////////////////////////////////
/////////////////////////////////////////////////////

**************************SW-B1**********************

--------------Configuración Básica---------------
enable
configure terminal
hostname SW-B1
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name swb1.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

-------------Configuración de Vlans---------------

vlan 10
name Ingenieria
exit

vlan 20
name Contabilidad
exit

vlan 150
name VOICE
exit

vlan 99
name Administracion
exit

vlan 666
name BLACKHOLE
exit

vlan 999
name NATIVE
exit

-------------Configuración Interfaces---------------

Interface range f0/1-8


switchport mode access
switchport access vlan 10
exit

Interface range f0/9-16


switchport mode access
switchport access vlan 20
exit

inter f0/9
mls qos trust cos
switchport voice vlan 150
exit

interface vlan 99
Description Administración de Equipos
ip add 172.168.20.3 255.255.255.0
exit
ip default-gateway 172.168.20.5

-----------Configuración de Truncales-------------

inter f0/24
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

inter g0/1
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

------------Configuración de Seguridad------------

Interface range f0/17-23


switchport mode access
switchport access vlan 666
shutdown
exit
int g0/2
switchport mode access
switchport access vlan 666
shutdown
exit

Interface range f0/1-16


switchport port-security
switchport port-security maximum 4
switchport port-security mac-address sticky
switchport port-security violation shutdown
exit

spanning-tree portfast default


spanning-tree portfast bpduguard default

********************SW-B2**************************

-------------Configuración Básica-----------------
enable
configure terminal
hostname SW-B2
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name swb2.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

---------------Configuración de Vlans-------------

vlan 30
name TI
exit
vlan 40
name Proveeduria
exit
vlan 150
name VOICE
exit
vlan 99
name Administracion
exit
vlan 666
name BLACKHOLE
exit
vlan 999
name NATIVE
exit

-------------Configuración Interfaces---------------

Interface range f0/1-8


switchport mode access
switchport access vlan 30
exit

Interface range f0/9-16


switchport mode access
switchport access vlan 40
exit

inter f0/9
mls qos trust cos
switchport voice vlan 150
exit

interface vlan 99
Description Administración de Equipos
ip add 172.168.20.4 255.255.255.0
exit
ip default-gateway 172.168.20.5

-----------Configuración de Truncales-------------

inter f0/24
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

inter g0/1
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

------------Configuración de Seguridad------------

Interface range f0/17-23


switchport mode access
switchport access vlan 666
shutdown

int g0/2
switchport mode access
switchport access vlan 666
shutdown

Interface range f0/1-16


switchport port-security
switchport port-security maximum 4
switchport port-security mac-address sticky
switchport port-security violation shutdown
exit

spanning-tree portfast default


spanning-tree portfast bpduguard default

************************MC-B1*****************************

-------------Configuración Básica-----------------

enable
configure terminal
hostname MC-B1
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name mcb1.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

--------------Configuración de Vlans--------------

vlan 10
name Ingenieria
exit
vlan 20
name Contabilidad
exit
vlan 30
name TI
exit
vlan 40
name Proveeduria
exit
vlan 150
name VOICE
exit
vlan 99
name Administracion
exit
vlan 999
name NATIVE
exit

-------------Configuración de Truncales-----------

inter g0/2
switchport mode access
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

inter f0/4
switchport mode access
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

----------Configuración de EtherChanel------------
interface range f0/1-3
shutdown
channel-group 2 mode Desirable
interface range f0/1-3
no shutdown
interface po 2
switchport mode access
switchport mode trunk
switchport trunk native vlan 70
switchport trunk allowed vlan all
no shutdown
exit

------------Configuracion Routing-----------------
ip routing
inter g0/1
no switchport
ip add 192.168.100.2 255.255.255.252
no shutdown
exit

-------------Configuración de HSRP----------------

inter vlan 10
description default gateway SVI para la ip 10.11.10.1/24
ip add 10.11.10.1 255.255.255.0
ip helper-address 10.0.100.5
Standby 10 ip 10.11.10.3
Standby 10 priority 255
Standby 10 preempt
no shutdown
exit

inter vlan 20
description default gateway SVI para la ip 20.21.20.1/24
ip add 20.21.20.1 255.255.255.0
ip helper-address 10.0.100.5
Standby 20 ip 20.21.20.3
Standby 20 priority 255
Standby 20 preempt
no shutdown
exit
inter vlan 30
description default gateway SVI para la ip 30.31.30.1/24
ip add 30.31.30.1 255.255.255.0
ip helper-address 10.0.100.5
Standby 30 ip 30.31.30.3
Standby 30 priority 255
Standby 30 preempt
no shutdown
exit

inter vlan 40
description default gateway SVI para la ip 40.41.40.1/24
ip add 40.41.40.1 255.255.255.0
ip helper-address 10.0.100.5
Standby 40 ip 40.41.40.3
Standby 40 priority 255
Standby 40 preempt
no shutdown
exit

int vlan 99
description default gateway SVI para la ip 172.168.20.1/24
ip add 172.168.20.1 255.255.255.0
Standby 99 ip 172.168.20.5
Standby 99 priority 255
Standby 99 preempt
no shutdown
exit

--------------Configuración OSPF------------------

router ospf 1
router-id 3.3.0.1
network 192.168.100.0 0.0.0.3 area 1
network 10.11.10.0 0.0.0.255 area 1
network 20.21.20.0 0.0.0.255 area 1
network 30.31.30.0 0.0.0.255 area 1
network 40.41.40.0 0.0.0.255 area 1
network 172.168.20.0 0.0.0.255 area 1
exit

------------Configuración de Seguridad------------

int range f0/5-24


shutdown
exit

**********************MC-B2************************

-------------Configuración Básica-----------------
enable
configure terminal
hostname MC-B2
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name mcb2.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

--------------Configuración de Vlans--------------

vlan 10
name Ingenieria
exit
vlan 20
name Contabilidad
exit
vlan 30
name TI
exit
vlan 40
name Proveeduria
exit
vlan 150
name VOICE
exit
vlan 99
name Administracion
exit
vlan 999
name NATIVE
exit

-------------Configuración de Truncales-----------

inter g0/2
switchport mode access
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

inter f0/4
switchport mode access
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

----------Configuración de EtherChanel------------
interface range f0/1-3
shutdown
channel-group 2 mode Desirable
interface range f0/1-3
no shutdown
interface po 2
switchport mode access
switchport mode trunk
switchport trunk native vlan 70
switchport trunk allowed vlan all
no shutdown
exit

------------Configuracion Routing-----------------

ip routing
inter g0/1
no switchport
ip add 172.16.32.2 255.255.255.252
no shutdown
exit

-------------Configuración de HSRP----------------

inter vlan 10
description default gateway SVI para la ip 10.11.10.2/24
ip add 10.11.10.2 255.255.255.0
ip helper-address 10.0.100.5
Standby 10 ip 10.11.10.3
no shutdown
exit

inter vlan 20
description default gateway SVI para la ip 20.21.20.2/24
ip add 20.21.20.2 255.255.255.0
ip helper-address 10.0.100.5
Standby 20 ip 20.21.20.3
no shutdown
exit

inter vlan 30
description default gateway SVI para la ip 30.31.30.2/24
ip add 30.31.30.2 255.255.255.0
ip helper-address 10.0.100.5
Standby 30 ip 30.31.30.3
no shutdown
exit

inter vlan 40
description default gateway SVI para la ip 40.41.40.2/24
ip add 40.41.40.2 255.255.255.0
ip helper-address 10.0.100.5
Standby 40 ip 40.41.40.3
no shutdown
exit

int vlan 99
description default gateway SVI para la ip 172.168.10.2/24
ip add 172.168.20.2 255.255.255.0
Standby 99 ip 172.168.20.5
no shutdown
exit

--------------Configuración OSPF------------------

router ospf 1
router-id 3.3.0.2
network 172.16.32.0 0.0.0.3 area 1
network 10.11.10.0 0.0.0.255 area 1
network 20.21.20.0 0.0.0.255 area 1
network 30.31.30.0 0.0.0.255 area 1
network 40.41.40.0 0.0.0.255 area 1
network 172.168.20.0 0.0.0.255 area 1
exit

------------Configuración de Seguridad------------

int range f0/5-24


shutdown
exit

/////////////////////////////////////////////////////
////////////////////////RED C////////////////////////
/////////////////////////////////////////////////////
/////////////////////////////////////////////////////

************************SW-C1************************

-------------Configuración Básica-----------------

enable
configure terminal
hostname SW-C1
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name swc1.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

--------------Configuración de Vlans--------------
vlan 10
name Ingenieria
exit
vlan 20
name Contabilidad
exit
vlan 150
name VOICE
exit
vlan 99
name Administracion
exit
vlan 666
name BLACKHOLE
exit
vlan 999
name NATIVE
exit

-------------Configuración Interfaces---------------

Interface range f0/1-8


switchport mode access
switchport access vlan 10
exit

Interface range f0/9-16


switchport mode access
switchport access vlan 20
exit

inter f0/9
mls qos trust cos
switchport voice vlan 150
exit

interface vlan 99
Description Administración de Equipos
ip add 172.168.30.3 255.255.255.0
exit
ip default-gateway 172.168.30.5

-----------Configuración de Truncales-------------

inter f0/24
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

inter g0/1
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

------------Configuración de Seguridad------------

Interface range f0/17-23


switchport mode access
switchport access vlan 666
shutdown
exit

int g0/2
switchport mode access
switchport access vlan 666
shutdown
exit

Interface range f0/1-16


switchport port-security
switchport port-security maximum 4
switchport port-security mac-address sticky
switchport port-security violation shutdown
exit

spanning-tree portfast default


spanning-tree portfast bpduguard default

************************SW-C2*************************

--------------Configuración Básica---------------
enable
configure terminal
hostname SW-C2
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name swc2.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

---------------Configuración de Vlans-------------

vlan 30
name TI
exit
vlan 40
name Proveeduria
exit
vlan 150
name VOICE
exit
vlan 99
name Administracion
exit
vlan 666
name BLACKHOLE
exit
vlan 999
name NATIVE
exit

-------------Configuración Interfaces---------------

Interface range f0/1-8


switchport mode access
switchport access vlan 30
exit

Interface range f0/9-16


switchport mode access
switchport access vlan 40
exit

inter f0/9
mls qos trust cos
switchport voice vlan 150
exit

interface vlan 99
ip add 172.168.30.4 255.255.255.0
exit
ip default-gateway 172.168.30.5

-----------Configuración de Truncales-------------

inter f0/24
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

inter g0/1
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

------------Configuración de Seguridad------------

Interface range f0/17-23


switchport mode access
switchport access vlan 666
shutdown
exit

int g0/2
switchport mode access
switchport access vlan 666
shutdown
exit

***********************MC-C1***********************

-------------Configuración Básica-----------------

enable
configure terminal
hostname MC-C1
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name mcc1.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

--------------Configuración de Vlans--------------

vlan 10
name Ingenieria
exit
vlan 20
name Contabilidad
exit
vlan 30
name TI
exit
vlan 40
name Proveeduria
exit
vlan 150
name VOICE
exit
vlan 99
name Administracion
exit
vlan 999
name NATIVE
exit

-------------Configuración de Truncales-----------

inter g0/2
switchport mode access
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

inter f0/4
switchport mode access
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

----------Configuración de EtherChanel------------
interface range f0/1-3
shutdown
channel-group 2 mode Desirable
interface range f0/1-3
no shutdown
interface po 2
switchport mode access
switchport mode trunk
switchport trunk native vlan 999
switchport trunk allowed vlan all
no shutdown
exit

------------Configuracion Routing-----------------
ip routing
inter g0/1
no switchport
ip add 192.168.150.2 255.255.255.252
no shutdown
exit

-------------Configuración de HSRP----------------

inter vlan 10
description default gateway SVI para la ip 10.12.10.1/24
ip add 10.12.10.1 255.255.255.0
ip helper-address 10.0.100.9
Standby 10 ip 10.12.10.3
Standby 10 priority 255
Standby 10 preempt
no shutdown
exit

inter vlan 20
description default gateway SVI para la ip 20.22.20.1/24
ip add 20.22.20.1 255.255.255.0
ip helper-address 10.0.100.9
Standby 20 ip 20.22.20.3
Standby 20 priority 255
Standby 20 preempt
no shutdown
exit

inter vlan 30
description default gateway SVI para la ip 30.32.30.1/24
ip add 30.32.30.1 255.255.255.0
ip helper-address 10.0.100.9
Standby 30 ip 30.32.30.3
Standby 30 priority 255
Standby 30 preempt
no shutdown
exit

inter vlan 40
description default gateway SVI para la ip 40.42.40.1/24
ip add 40.42.40.1 255.255.255.0
ip helper-address 10.0.100.9
Standby 40 ip 40.42.40.3
Standby 40 priority 255
Standby 40 preempt
no shutdown
exit

int vlan 99
description default gateway SVI para la ip 172.168.30.1/24
ip add 172.168.30.1 255.255.255.0
Standby 99 ip 172.168.30.5
Standby 99 priority 255
Standby 99 preempt
no shutdown
exit

--------------Configuración OSPF------------------

router ospf 1
router-id 4.4.0.1
network 192.168.150.0 0.0.0.3 area 1
network 10.12.10.0 0.0.0.255 area 1
network 20.22.20.0 0.0.0.255 area 1
network 30.32.30.0 0.0.0.255 area 1
network 40.42.40.0 0.0.0.255 area 1
network 172.168.30.0 0.0.0.255 area 1
exit

------------Configuración de Seguridad------------

int range f0/5-24


shutdown
exit

**********************MC-C2************************
-------------Configuración Básica-----------------
enable
configure terminal
hostname MC-C2
line console 0
password cisco
login
exit
enable password class
service password-encryption
banner motd #--SOLO PERSONAL AUTORIZADO--#
ip domain-name mcc2.com
crypto key generate rsa
1024
username admin secret ccna
line vty 0 15
login local
exit
ip ssh version 2

--------------Configuración de Vlans--------------

vlan 10
name Ingenieria
exit
vlan 20
name Contabilidad
exit
vlan 30
name TI
exit
vlan 40
name Proveeduria
exit
vlan 150
name VOICE
exit
vlan 99
name Administracion
exit
vlan 999
name NATIVE
exit

-------------Configuración de Truncales-----------

inter g0/2
switchport mode access
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

inter f0/4
switchport mode access
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate
switchport trunk native vlan 999
exit

----------Configuración de EtherChanel------------
interface range f0/1-3
shutdown
channel-group 2 mode Desirable
interface range f0/1-3
no shutdown
interface po 2
switchport mode access
switchport mode trunk
switchport trunk native vlan 999
switchport trunk allowed vlan all
no shutdown
exit

------------Configuracion Routing-----------------
ip routing
inter g0/1
no switchport
ip add 172.16.64.2 255.255.255.252
no shutdown
exit

-------------Configuración de HSRP----------------

inter vlan 10
description default gateway SVI para la ip 10.12.10.2/24
ip add 10.12.10.2 255.255.255.0
ip helper-address 10.0.100.9
Standby 10 ip 10.12.10.3
no shutdown
exit

inter vlan 20
description default gateway SVI para la ip 20.22.20.2/24
ip add 20.22.20.2 255.255.255.0
ip helper-address 10.0.100.9
Standby 20 ip 20.22.20.3
no shutdown
exit

inter vlan 30
description default gateway SVI para la ip 30.32.30.2/24
ip add 30.32.30.2 255.255.255.0
ip helper-address 10.0.100.9
Standby 30 ip 30.32.30.3
no shutdown
exit

inter vlan 40
description default gateway SVI para la ip 40.42.40.2/24
ip add 40.42.40.2 255.255.255.0
ip helper-address 10.0.100.9
Standby 40 ip 40.42.40.3
no shutdown
exit

int vlan 99
description default gateway SVI para la ip 172.168.30.2/24
ip add 172.168.30.2 255.255.255.0
Standby 99 ip 172.168.30.5
no shutdown
exit
--------------Configuración OSPF------------------

router ospf 1
router-id 4.4.0.2
network 172.16.64.0 0.0.0.3 area 1
network 10.12.10.0 0.0.0.255 area 1
network 20.22.20.0 0.0.0.255 area 1
network 30.32.30.0 0.0.0.255 area 1
network 40.42.40.0 0.0.0.255 area 1
network 172.168.30.0 0.0.0.255 area 1
exit

------------Configuración de Seguridad------------

int range f0/5-24


shutdown
exit

You might also like