You are on page 1of 10

=============== ISP ===================

enable
conf t
hostname ISP
int gi 0/0/0
ip add 203.0.113.1 255.255.255.0
no shut
exit
int s 0/1/0
ip address 64.0.100.1 255.255.255.252
clock rate 2000000
no shut
exit
ip route 0.0.0.0 0.0.0.0 serial 0/1/0
end
copy running-config startup-config
======================================

=============== HQ1 ===================


enable
conf t
hostname HQ1
int s0/1/0
ip add 203.0.113.2 255.255.255.0
no shut
exit
int gi 0/0/0
ip add 10.10.10.1 255.255.255.240
no shut
end
copy running-config startup-config
======================================

=============== HQ2 ===================


enable
conf t
hostname HQ2
int s0/1/0
description LINK HQ2 to BRANCH
ip add 33.33.33.1 255.255.255.252
clock rate 2000000
no shut
exit
int gi 0/0/0
ip add 10.10.10.2 255.255.255.240
no shut
exit
int gi 0/0/1
no shut
end
copy running-config startup-config
======================================

=============== HQ3 ===================


enable
conf t
hostname HQ3
int gi 0/0/0
ip add 10.10.10.3 255.255.255.240
no shut
exit
int gi 0/0/1
no shut
end
copy running-config startup-config
======================================

=============== BRANCH ===================


enable
conf t
hostname BRANCH
int s0/1/0
description LINK BRANCH to HQ2
ip add 33.33.33.2 255.255.255.252
no shut
exit
int gi 0/0/1
no shut
exit
end
copy running-config startup-config
======================================

Ripv2 y OSPF en Branch

enable
configure terminal
interface Serial0/1/0
ip ospf hello-interval 20
ip ospf dead-interval 80
exit
router ospf 10
auto-cost reference-bandwidth 1000
network 33.33.33.2 0.0.0.3 area 0
passive-interface Gig 0/0/1
exit
router rip
version 2
network 33.33.33.2
no auto-summary
passive-interface serial 0/1/0

end
wr

3. Redistribuir entre protocolos RIPv2 y OSPFv2

================ BRANCH ========================


enable
configure terminal
router ospf 10
redistribute rip subnets
exit
router rip
redistribute ospf 10 metric 4
end
wr

Configurar Router on a Stick (subinterfaces)

================ BRANCH==================
enable
conf t
interface Gig0/0/1
no ip address
no shutdown
exit
interface Gi0/0/1.15
description Vlan15_Alumnos
encapsulation dot1Q 15
ip address 172.31.15.1 255.255.255.0
exit
interface Gi0/0/1.25
description Vlan25_Docentes
encapsulation dot1Q 25
ip address 172.31.25.1 255.255.255.0
exit
interface Gi0/0/1.35
description Vlan35_Invitados
encapsulation dot1Q 35
ip address 172.31.35.1 255.255.255.0
exit
interface Gi0/0/1.45
description Vlan45_Tutores
encapsulation dot1Q 45
ip address 172.31.45.1 255.255.255.0
exit
interface Gi0/0/1.55
description Vlan55_Mng
encapsulation dot1Q 55
ip address 172.31.55.1 255.255.255.248
exit
interface Gi0/0/1.65
description Vlan55_Native
encapsulation dot1Q 65
ip address 172.31.65.1 255.255.255.0
exit
end
wr

================ HQ2==================
enable
conf t
interface serial0/0/1
no ip address
no shutdown
exit
interface Gi0/0/1.15
description Vlan15_WEB
encapsulation dot1Q 15
ip address 192.168.15.1 255.255.255.128
exit
interface Gi0/0/1.55
description Vlan55_MNG
encapsulation dot1Q 55
ip address 192.168.15.1 255.255.255.252
exit
interface Gi0/0/1.65
description Vlan65_NATIVE
encapsulation dot1Q 65
ip address 192.168.65.1 255.255.255.0
exit
end
wr

================ HQ3==================
enable
conf t
interface serial0/0/1
no ip address
no shutdown
exit
interface Gi0/0/1.25
description Vlan25_DNS
encapsulation dot1Q 25
ip address 192.168.25.1 255.255.255.192
exit
interface Gi0/0/1.55
description Vlan55_MNG
encapsulation dot1Q 55
ip address 192.168.55.1 255.255.255.252
exit
interface Gi0/0/1.65
description Vlan65_NATIVE
encapsulation dot1Q 65
ip address 192.168.65.1 255.255.255.0
exit
end
wr

CREAR VLAN EN SWITCHS

======= SWA/SWB/SWC =========


enable
conf t
vlan 15
name ALUMNOS
vlan 25
name DOCENTES
vlan 35
name TUTORES
vlan 55
name MNG
vlan 65
name NATIVE
vlan 75
name NULL
exit

======= SW2 =========


enable
conf t
vlan 15
name WEB
vlan 55
name MNG
vlan 65
name NATIVE
vlan 75
name NULL
exit

======= SW3 =========


enable
conf t
vlan 25
name DNS
vlan 55
name MNG
vlan 65
name NATIVE
vlan 75
name NULL
exit

======= SWA/SWB/SWC =========


enable
configure terminal
int range fa 0/1-5
switchport mode access
switchport access vlan 15
exit
int range fa 0/6-10
switchport mode access
switchport access vlan 25
exit
int range fa 0/11-15
switchport mode access
switchport access vlan 35
exit
int range fa 0/16-20
switchport mode access
switchport access vlan 45
exit
int range Fa0/21-24
switchport mode access
switchport access vlan 75
shutdown
exit
------------------------

======= SW2 =========


enable
configure terminal
int range fa 0/1-5
switchport mode access
switchport access vlan 15
exit
int range Fa0/6-24, Gig0/2
switchport mode access
switchport access vlan 100
shutdown
exit

======= SW3 =========


enable
configure terminal
int range fa 0/1-5
switchport mode access
switchport access vlan 25
exit
int range Fa0/6-24, Gig0/2
switchport mode access
switchport access vlan 100
shutdown
exit

Configurar los puertos troncales

=============== SWA=======================
int range fa 0/1, Gi 0/1-2
switchport mode trunk
switchport trunk native vlan 65
switchport mode trunk allowed vlan 15,25,35,45,55,65
exit
------------------------------------------

=============== SWB=======================
int range fa 0/1, fa 0/6, Gi 0/1
switchport mode trunk
switchport trunk native vlan 65
switchport mode trunk allowed vlan 15,25,35,45,55,65
exit
------------------------------------------

=============== SWC=======================
int range fa 0/11, fa 0/16, Gi 0/2
switchport mode trunk
switchport trunk native vlan 65
switchport trunk allowed vlan 15,25,35,45,55,65
exit
------------------------------------------
=============== SW1=======================
int range fa 0/1-3
switchport mode trunk
switchport trunk native vlan 65
switchport mode trunk allowed vlan 15,25,55,65
exit

=============== SW2=======================
int range fa 0/1, Gi 0/1
switchport mode trunk
switchport trunk native vlan 65
switchport mode trunk allowed vlan 15,55,65
exit

=============== SW3=======================
int range fa 0/1, Gi 0/1
switchport mode trunk
switchport trunk native vlan 65
switchport mode trunk allowed vlan 25,55,65
exit

Seguridad de puerto

======= SWA/SWB/SWC=========
int range fa 0/1-5
switchport port-security
switchport port-security maximum 5
switchport port-security mac-address sticky
switchport port-security violation protect
exit
int range fa 0/6-10
switchport port-security
switchport port-security maximum 4
switchport port-security mac-address sticky
switchport port-security violation restrict
exit
int range fa 0/11-15
switchport port-security
switchport port-security maximum 3
switchport port-security mac-address sticky
switchport port-security violation shutdown
exit
int range fa 0/16-20
switchport port-security
switchport port-security maximum 2
switchport port-security mac-address sticky
switchport port-security violation protect
end
wr

======= SW2=========
int range fa 0/1-5
switchport port-security
switchport port-security maximum 1
switchport port-security mac-address 000B.BEB3.6735
switchport port-security violation shutdown
exit

C:\>ipconfig /all

FastEthernet0 Connection:(default port)

Connection-specific DNS Suffix..:


Physical Address................: 000B.BEB3.6735
Link-local IPv6 Address.........: FE80::20B:BEFF:FEB3:6735
IPv6 Address....................: ::
IPv4 Address....................: 0.0.0.0
Subnet Mask.....................: 0.0.0.0

-----------------------------------------------------
======= SW3=========
int range fa 0/1-5
switchport port-security
switchport port-security maximum 1
switchport port-security mac-address 0001.C9B0.4A0E
switchport port-security violation shutdown
exit
-----------------------------------------------------

C:\>ipconfig /all

FastEthernet0 Connection:(default port)

Connection-specific DNS Suffix..:


Physical Address................: 0001.C9B0.4A0E
Link-local IPv6 Address.........: FE80::201:C9FF:FEB0:4A0E
IPv6 Address....................: ::
IPv4 Address....................: 0.0.0.0
Subnet Mask.....................: 0.0.0.0
Default Gateway.................: ::C:\>ipconfig /all

CONFIGURACIONES BASICAS SWUITCH Y ROUTERS

================= R1/R2 =======================


enable
configure terminal
security passwords min-length 7
enable secret P1CCNA2
line console 0
password Pandem1a
login
logging synchronous
exit
ip ssh version 2
ip domain-name www.cisco.com
line vty 0 3
username carlos5 secret secret2020
username francisco5 secret secret2020
crypto key generate rsa
1024
password Cisco_Academy
login
exit
service password-encryption
no ip domain-lookup
banner motd #SOLO PERSONAL AUTORIZADO#
exit

Configurar Router OSPFv2

================ HQ1========================
enable
configure terminal
interface GigabitEthernet0/0/0
interface Serial0/1/0
ip ospf priority 255
ip ospf hello-interval 20
ip ospf dead-interval 80
exit
enable
configure terminal
router ospf 105
router-id 1.1.1.1
network 10.10.10.0 0.0.0.3 area 0
passive-interface Serial0/1/1
auto-cost reference-bandwidth 1000
default-information originate
exit
ip route 0.0.0.0 0.0.0.0 Serial0/1/0
end
copy running-config startup-config
-------------------------------------

================ HQ2========================
enable
configure terminal
interface GigabitEthernet0/0/0
interface GigabitEthernet0/0/1
ip ospf priority 254
interface Serial0/1/0
ip ospf hello-interval 40
ip ospf dead-interval 160
exit
enable
configure terminal
router ospf 105
router-id 2.2.2.2
network 10.10.10.0 0.0.0.3 area 0
network 192.168.15.1 .0 0.0.0.127 area 0
passive-interface Serial0/1/1
auto-cost reference-bandwidth 1000
default-information originate
exit
ip route 0.0.0.0 0.0.0.0 Serial0/1/0
end
copy running-config startup-config

================ HQ3 ========================


enable
configure terminal
router ospf 105
router-id 3.3.3.3
network 10.10.10.0 0.0.0.3 area 0
passive-interface GigabitEthernet0/0/0
auto-cost reference-bandwidth 1000
end
copy running-config startup-config

================ BRANCH ========================


enable
configure terminal
router ospf 105
router-id 4.4.4.4
network 33.33.33.0 0.0.0.3 area 0
passive-interface GigabitEthernet0/0/0
auto-cost reference-bandwidth 1000
end
copy running-config startup-config

============ HQ1 Ruta recursiva ==========


enable
configure terminal
ip route 10.10.10.0 255.255.255.240 64.0.100.1
end

You might also like