You are on page 1of 5

Configuracion de SW 1

enable
configure terminal
hostname SW01
username ADMIN privilege 15 secret ADMIN
ip domain-name tarea.edu
crypto key generate rsa general-keys modulus 1024
line vty 0 15
login local
line con 0
login local

vlan 200
vlan 300

interface range fa0/1-24


shutdown
description LIBRE

interface fa0/1
description TO-R1
switchport mode trunk
no shutdown

interface fa0/2
description TO-VLAN-200
switchport mode access
switchport access vlan 200
no shutdown

interface fa0/3
description TO-VLAN-300
switchport mode access
switchport access vlan 300

--------------------------------------------------------------

configuracion de SW02

enable
configure terminal
hostname SW02
username ADMIN privilege 15 secret ADMIN
ip domain-name tarea.edu
crypto key generate rsa general-keys modulus 1024
line vty 0 15
login local
line con 0
login local

vlan 400
vlan 500
interface range fa0/1-24
shutdown
description LIBRE

interface fa0/1
description TO-R3
switchport mode trunk

interface fa0/2
description TO-VLAN-400
switchport mode access
switchport access vlan400
no shutdown

interface fa0/3
description TO-LAN-500
switchport mode access
switchport accessm vlan 500
no shutdown

-----------------------------------------------------------

configuracion de R1

enable
configure terminal
hostname R1
username ADMIN privilege 15 secret ADMIN
ip domain-name tarea.edu
crypto key generate rsa general-keys modulus 1024
line vty 0 15
login local
line con 0
login local

interface g0/0
ip address 172.16.0.1 255.255.255.252
description TO-R2
no shutdown

interface g0/1.200
encapsulation dot1Q 200
ip address 10.90.0.1 255.255.255.128
description TO-VLAN-200

interface g0/1.300
encapsulation dot1Q 300
ip address 10.90.0.129 255.255.255.224
description TO-VLAN-300

interface g0/1
no shutdown

router ospf 1
network 10.90.0.0 0.0.0.127 area 0
network 10.90.0.128 0.0.0.31 area 0
network 172.16.0.0 0.0.0.3 area 0
exit

----------------------------------------------------------
configuracion de R2

enable
configure terminal
hostname R2
username ADMIN privilege 15 secret ADMIN
ip domain-name tarea.edu
crypto key generate rsa general-keys modulus 1024
line vty 0 15
login local
line con 0
login local

interface g0/0
ip address 172.16.0.2 255.255.255.252
description TO-R1
no shutdown

interface g0/1
ip address 172.16.0.5 255.255.255.5
description TO-R3
no shutdown

interface g0/2
ip address 204.75.0.1
description TO-R4
no shutdown

router ospf 1
network 172.16.0.0 0.0.0.3 area 0
exit

router eigrp 10
network 172.16.0.4 0.0.0.3
exit

ip route 190.5.100.0 255.255.255.0 204.75.0.2

router ospf 1
redistribute static subnets
redistribute eigrp 10
exit

router eigrp 10
redistribute static metric 1000 200 255 255 250
redistribute ospf 1 metric 1000 200 255 255 250
exit

ip access-list standard INTERNET-VLAN-200


permit 10.90.0.128 0.0.0.127
ip access-list standard INTERNET-VLAN-300
permit 10.80.0.128 0.0.0.31

ip access-list standard INTERNET-VLAN-500


permit 10.80.0.128 0.0.0.127

ip access-list standard INTERNET-VLAN-400


permit 10.80.0.0 0.0.0.127

ip nat inside source list INTERNET-VLAN-200 interface g0/0 overload

ip nat inside source list INTERNET-VLAN-300 interface g0/0 overload

ip nat inside source list INTERNET-VLAN-400 interface g0/1 overload

ip nat inside source list INTERNET-VLAN-500 interface g0/1 overload

------------------------------------------------------------

configuracio de R3

enable
configure terminal
hostname R2
username ADMIN privilege 15 secret ADMIN
ip domain-name tarea.edu
crypto key generate rsa general-keys modulus 1024
line vty 0 15
login local
line con 0
login local

interface g0/0
ip address 172.16.0.6 255.255.255.252
description TO-R1
no shutdown

interface g0/1.400
encapsulation dot1Q 400
ip address 10.80.0.1 255.255.255.128
description TO-VLAN-400

interface g0/1.500
encapsulation dot1Q 500
ip address 10.80.0.129 255.255.255.128
description TO-VLAN-500

interface g0/0
no shutdown

router eigrp 10
network 172.16.0.4 0.0.0.3
network 10.80.0.0 0.0.0.127
network 10.80.0.128 0.0.0.3
exit

-------------------------------------------------------------
configuracion de R4

enable
configure terminal
hostname R4
username ADMIN privilege 15 secret ADMIN
ip domain-name tarea.edu
crypto key generate rsa general-keys modulus 1024
line vty 0 15
login local
line con 0
login local

interface g0/0
ip address 172.16.0.6 255.255.255.252
description TO-R1
no shutdown

interface g0/1
ip address 190.5.100.0 255.255.255.0
description TO-LAN
no shutdown

ip route

You might also like