You are on page 1of 21

PROJECT REPORT

Data Communication Network Lab(CEL-222)

BS(CS) - 4(B)
Project Title: College Department Management System
Group Members
Name Enrollment
1. Nafay Ur Rehman 02-134201-042
2. Anas Inam 02-134201-072
3. Ashar Rashid 02-134201-061

Submitted to:
Sir Mirza Waqas Baig

BAHRIA UNIVERSITY KARACHI CAMPUS


Department of Computer Science

Page no: 1 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
Table of Contents
I. Introduction........................................................................................................................................5
II. Methodology.......................................................................................................................................5
III. Implementation..............................................................................................................................6
IV. Network Requirements...................................................................................................................7
V. Proposed System................................................................................................................................7
VI. Flow Diagram of the system...........................................................................................................7
VII. Screenshots of the module with explanation.................................................................................8
 Design Module................................................................................................................................8
 IT Department.................................................................................................................................9
 Faculty Block...................................................................................................................................9
 Computer Science Block................................................................................................................10
 Engineering Block..........................................................................................................................10
 Head Block.....................................................................................................................................11
 Configuration for authorization for President:.............................................................................12
 Server Block...................................................................................................................................12
 Server Connection.........................................................................................................................13
 Email Server Connection...............................................................................................................13
 Sent Mail to Office Room:.............................................................................................................14
 Received Mail from President.......................................................................................................14
Coding for Switch Configuration...............................................................................................................15
 Switch for Engineering Block:........................................................................................................15
 Switch for Faculty Block:................................................................................................................15
 Switch for President Block:............................................................................................................16
 Switch for IT Block:........................................................................................................................17
 Switch for Computer Science Block:..............................................................................................17
Coding for Router Configuration..............................................................................................................18
 Block Connection Router:..............................................................................................................18
 Access Control list 15 on Printer:...................................................................................................19
VIII. Conclusion.....................................................................................................................................19
IX. References.....................................................................................................................................19

Page no: 2 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
Acknowledgment

“Firstly, we would like to give our great and lovely thanks to Almighty Allah (S.
W) for blessing us with strong and comfortable health as well as courage for the
accomplishment of my project report. We have taken efforts in this project.
However, it would not have been possible without the kind support and help of our
teachers especially “SIR WAQAS” and “MISS NOUREEN”, who taught us to
get the knowledge and skills. I would like to extend my sincere thanks to highly
indebted to Aptech faculty for their guidance and constant supervision as well as
for necessary information regarding the project & also for their support in
completing the project. We also express our gratitude towards our parents for
their kind encouragement which help us in the project. My thanks and
appreciations also go to my Co-students in developing the people who have
willingly helped me out with their abilities.”

Page no: 3 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
Abstract
“College Department Management System is essential for an institution or to a
college or to a university, which utilizes a computer, also which reduces
manpower. The main objective of this study is an important step towards
streamlining this effort is to develop a framework and identify necessary
properties that a secure and trusted online department working system must satisfy
to reduce discovery redundancy. Such a framework will allow us to evaluate as
well as compare the merits of existing and future candidates in the department.
The system should support a multi-user environment. The system should be fully
automated. The system should provide concrete security features like creating
users and assigning privileges to users of the system. The system should be
capable to keep track of all the detailed descriptions of the client and the whole
details of services offered by the client.”

Page no: 4 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
I. Introduction
College Department Management System is being developed to fulfill all the needs and
requirements at the department level. The user will log in to the system with a login id and
password. Users are individuals who interact with the system. All user interaction is performed
through the user's web browser. Department management System software manages complete
department working system. It will have all the basic modules and also it makes have all the
basic modules and also it makes working fully computerized which is very fast and efficient. This
management system helps to maintain enhanced security.

II. Methodology

Very comprehensive requirement


analysis was done, in
order to get a very good understanding
about the problem
domain. During the design phase not
only the theories but

Page no: 5 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
also the functional and nonfunctional
requirements were
kept in mind. Due to that some design
concept were slightly
violated in order to achieve better
outcome with respect to
the functionality. Implementation was
done according to the
design
Very comprehensive requirement
analysis was done, in
order to get a very good understanding
about the problem
domain. During the design phase not
only the theories but
also the functional and nonfunctional
requirements were
kept in mind. Due to that some design
concept were slightly
Page no: 6 Lab Teachers : Sir Mirza
Waqas
Course Teacher: Miss
Noureen Farhan
violated in order to achieve better
outcome with respect to
the functionality. Implementation was
done according to the
design
A very comprehensive requirement analysis was done, in order to get a very good
understanding of the problem domain. During the design phase, not only the theories but also
the functional and non-functional requirements were kept in mind. Due to that, some design
concept was slightly violated to achieve a better outcome with respect to the functionality.
Implementation was done according to the design. Switch port securities were implemented for
the security of specific departments, also access-list was implemented for various restrictions.

Fig 1.1 RIP Network Communication from Engineering HOD to Faculty Research Cell

Page no: 7 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
Fig 1.2 RIP Success Network Communication from Engineering HOD to Faculty Research Cell

Fig 1.2 Routing path of network communication

III. Implementation
The Department management system contains a major involvement of Web Servers, our
network works through various servers which play a vital role in connections, every department
is attached to a respective router named a Block Connection Router. All blocks are connected
via RIP that holds the network IPs of its network. Our system also has a network email facility
that is also controlled through web servers, only the president has access to send mail to only
Faculty Block, and the faculty block receives the mails from the president, although all
department PCs are accessible to every department’s PC.
Page no: 8 Lab Teachers : Sir Mirza
Waqas
Course Teacher: Miss
Noureen Farhan
IV. Network Requirements
 The new system should be able to reduce internet downtime.
 Network will be scalable.
 The system should support remote access.
 Should comprise of data centers with necessary security features and support.

V. Proposed System
The main objective of the proposed network is to update the existing network and also enhance
its capabilities and increase the flexibility of the network which will eventually provide good
security.

The second main objective of our management system is to ensure the stable network
connectivity of the following main departments in the college.

 Engineering Department
 Computer Science Department
 IT Department
 Head Block
 Faculty Block
 Server Room

VI. Flow Diagram of the system

Page no: 9 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
Fig 2.1 Flow chart of the system

VII. Screenshots of the module with explanation

 Design Module
This is our overall system includes all modules.

Page no: 10 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
 IT Department
The department contains network IP (192.168.1.0) Only authorized access allows to enter in a
system.

 Faculty Block
Faculty Block contains Network IP (192.168.3.0) and has Research cell, Enquiry, Exam cell, Office
and printers. The network also only authorized accessible.

Page no: 11 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
 Computer Science Block
Faculty Block contains Network IP (192.168.2.0) and has HOD cabin in their block, that can only
authorized accessible.

 Engineering Block
Engineering Block contains Network IP (128.168.0.0) and has a HOD cabin in their block, that can
only be authorized access.

Page no: 12 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
 Head Block
Head Block contains Network IP (192.168.4.0) and can only be accessible by President itself only.

Page no: 13 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
 Configuration for authorization for President:

 Server Block
Server Block contains Network IP (1.0.0.0) and has an HOD cabin in their block, that can only be
authorized accessible.

Page no: 14 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
 Server Connection
WEB Server connects all PC’s to its server and gave all PC’s access.

 Email Server Connection


Email server connection, connects from Web server and every PC assigned to their specific email
address to communicate, only president PC allows to send mails emails to Faculty Block.

Page no: 15 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
 Sent Mail to Office Room:

 Received Mail from President

Page no: 16 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
Coding for Switch Configuration

 Switch for Engineering Block:


Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#enable secret password
Switch(config)#username DR.Nafay password password
Switch(config)#line con 0
Switch(config-line)#password password
Switch(config-line)#login local
Switch(config-line)#line vty 0 15
Switch(config-line)#password password
Switch(config-line)#login local
Switch(config-line)#exit
Switch(config)#service pas
Switch(config)#service password-encryption
Switch(config)#
Switch(config)#banner motd #
Enter TEXT message. End with the character '#'.

********************
AUTHORIZED ACCESS ONLY
********************
#

Switch(config)#exit
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Switch#copy run start


Destination filename [startup-config]?
Building configuration...
[OK]
Switch#ex

 Switch for Faculty Block:


Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#enable secret password
Switch(config)#username DR.Nafay password password
Switch(config)#line con 0
Switch(config-line)#password password
Switch(config-line)#login local
Switch(config-line)#line vty 0 15
Switch(config-line)#password password
Switch(config-line)#login local
Switch(config-line)#exit
Switch(config)#service pas
Page no: 17 Lab Teachers : Sir Mirza
Waqas
Course Teacher: Miss
Noureen Farhan
Switch(config)#service password-encryption
Switch(config)#
Switch(config)#banner motd #
Enter TEXT message. End with the character '#'.

********************
AUTHORIZED ACCESS ONLY
********************
#

Switch(config)#exit
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Switch#copy run start


Destination filename [startup-config]?
Building configuration...
[OK]
Switch#ex

 Switch for President Block:


Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#enable secret password
Switch(config)#username DR.Nafay password password
Switch(config)#line con 0
Switch(config-line)#password password
Switch(config-line)#login local
Switch(config-line)#line vty 0 15
Switch(config-line)#password password
Switch(config-line)#login local
Switch(config-line)#exit
Switch(config)#service pas
Switch(config)#service password-encryption
Switch(config)#
Switch(config)#banner motd #
Enter TEXT message. End with the character '#'.

********************
AUTHORIZED ACCESS ONLY
********************
#

Switch(config)#exit
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Switch#copy run start


Destination filename [startup-config]?
Building configuration...
[OK]
Switch#ex

Page no: 18 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
 Switch for IT Block:
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#enable secret password
Switch(config)#username DR.Nafay password password
Switch(config)#line con 0
Switch(config-line)#password password
Switch(config-line)#login local
Switch(config-line)#line vty 0 15
Switch(config-line)#password password
Switch(config-line)#login local
Switch(config-line)#exit
Switch(config)#service pas
Switch(config)#service password-encryption
Switch(config)#
Switch(config)#banner motd #
Enter TEXT message. End with the character '#'.

********************
AUTHORIZED ACCESS ONLY
********************
#

Switch(config)#exit
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Switch#copy run start


Destination filename [startup-config]?
Building configuration...
[OK]
Switch#ex

 Switch for Computer Science Block:


CSBlock>en
CSBlock#config t
Enter configuration commands, one per line. End with CNTL/Z.
CSBlock(config)#enable secret password
CSBlock(config)#username DR.Nafay password password
CSBlock(config)#line con 0
CSBlock(config-line)#password password
CSBlock(config-line)#login local
CSBlock(config-line)#line vty 0 15
CSBlock(config-line)#password password
CSBlock(config-line)#login local
CSBlock(config-line)#exit
CSBlock(config)#service pas
CSBlock(config)#service password-encryption
CSBlock(config)#
CSBlock(config)#banner motd #

Page no: 19 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
Enter TEXT message. End with the character '#'.

********************
AUTHORIZED ACCESS ONLY
********************
#

Switch(config)#exit
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Switch#copy run start


Destination filename [startup-config]?
Building configuration...
[OK]
Switch#ex

Coding for Router Configuration

 Block Connection Router:


Block-Connection-Router >en
Block-Connection-Router #config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#enable secret password
Block-Connection-Router(config)#username DR.Nafay password password
Block-Connection-Router(config)#line con 0
Block-Connection-Router (config-line)#password password
Block-Connection-Router config-line)#login local
Block-Connection-Router (config-line)#line vty 0 15
Block-Connection-Router (config-line)#password password
Block-Connection-Router (config-line)#login local
Block-Connection-Router (config-line)#exit
Block-Connection-Router (config)#service pas
Block-Connection-Router (config)#service password-encryption
Block-Connection-Router (config)#
Block-Connection-Router (config)#banner motd #
Enter TEXT message. End with the character '#'.

********************
AUTHORIZED ACCESS ONLY
********************
#

Block-Connection-Router (config)#exit
Block-Connection-Router #
%SYS-5-CONFIG_I: Configured from console by console

Block-Connection-Router #copy run start


Destination filename [startup-config]?
Building configuration...

Page no: 20 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan
[OK]
Block-Connection-Router #ex

 Access Control list 15 on Printer:

Block-Connection-Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Block-Connection-Router(config)#access-list 15 deny host 192.168.1.1
Block-Connection-Router(config)#access-list 15 permit any
Block-Connection-Router(config)#interface serial 0/2/% Bad secrets

Block-Connection-Router(config)#interface serial 2% Bad secrets

/0Block-Connection-Router(config)#interface serial 2/0


Block-Connection-Router(config-if)#ip access-group 15 in
Block-Connection-Router(config-if)#end
Block-Connection-Router#

VIII. Conclusion
Hereby we, the Student of BS(CS) 4th Semester conclude that the project was completely and
slowly developed by us. I also conclude that this project will be helped us gain more knowledge
about the topic that we are indulging ourselves in “cisco packet tracer”. We will be glad to
enhance this project if given chance and help ourselves and society in the near future.
The efficiency of this system can be enhanced with some minor modifications. Future
development can be made in the proposed system by integrating more services.

IX. References

[1]. Krithi P1, Dr. M Ramakrishna2,” student management system – a survey” Computer Science
and Engineering, Vemana Institute of Technology, Bangalore-34 International Research Journal
of Computer Science (IRJCS) Issue 05, Volume 4 (May 2017.
[2]. Srikant Patnaik1, Khushboo Kumari Singh2, Rashmi Ranjan3, Niki Kumari4 “College,
management system”, International research journal of Engineering and Technology (IRJ
Volume:03Issue:05/May-2016.
[3]. Lalit Mohan Joshi M.tech schola BTKIT Dwarahat, Almora, Uttarakhand “A Research Paper
on College Management System” International Journal of Computer Applications (0975 – 8887)
Volume 122 – No.11, July 2015

Page no: 21 Lab Teachers : Sir Mirza


Waqas
Course Teacher: Miss
Noureen Farhan

You might also like