You are on page 1of 5

Configure MGMT switch

show version
show license status

configure terminal
hostname Mgmt_Switch
interface vlan 1501
description Management_network
no shutdown
exit

interface ethernet 1/1/54


description Discovery_port
switchport access vlan 1501
no shutdown
exit

interface mgmt 1/1/1


no shutdown
no ip address dhcp
ip address 172.17.57.10/24
exit

management route 0.0.0.0/0 172.17.57.254


ntp server 172.17.57.50

interface ethernet 1/1/1


description "Node A management port"
switchport mode access
switchport access vlan 1501
no shutdown
exit

interface ethernet 1/1/2


description "Node B management port"
switchport mode access
switchport access vlan 1501
no shutdown
exit

interface port-channel 40
description "Port-channel for management switch uplink"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 1501
exit

interface range ethernet 1/1/25-1/1/26


description "Uplink to core switching"
no shutdown
channel-group 40 mode active
no switchport
flowcontrol receive off
flowcontrol transmit off
exit
end
copy running-configuration startup-configuration
exit

Configure data switches

Dataswitch-01

show version
show license status

configure terminal
hostname Data_Switch_01

interface mgmt 1/1/1


no shutdown
no ip address dhcp
ip address 172.17.57.20/24
exit

management route 0.0.0.0/0 172.17.57.254


ntp server 172.17.57.50
spanning-tree mode rstp
spanning-tree rstp priority 40960
end

copy running-configuration startup-configuration

ssh admin@172.17.57.20

configure terminal
interface vlan 1
description Internal_network
no shutdown
exit

interface vlan 1502


description Storage_network
no shutdown
exit

interface vlan 1503


description NAS_network
no shutdown
exit
end

copy running-configuration startup-configuration

interface range ethernet 1/1/55-1/1/56


description VLTi
no shutdown
no switchport
exit

vlt-domain 1
descovery-interface ethernet 1/1/55-1/1/56
backup destination 172.17.57.30
peer-routing
primary-priority 1
vlt-mac 00:00:00:00:00:01
end

copy running-configuration startup-configuration

interface port-channel 10
description "LACP port-channel for Node A"
vlt-port-channel 10
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 1502,1503
spannig-tree port type edge
exit

interface port-channel 20
description "LACP port-channel for Node B"
vlt-port-channel 20
no shutdown
switchport mode trunk
switchport accesss vlan 1
switchport trunk allowed vlan 1502,1503
spanning-tree port type edge
exit

interface ethernet 1/1/1


no shutdown
no switchport
channel-group 10 mode active
flowcontrol recieve off
flowcontrol trasmit off
exit

interface ethernet 1/1/2


no shutdown
no switchport
channl-group 20 mode active
flowcontrol recieve off
flowcontrol trasmit off
exit
end

copy running-configuration startup-configuration

interface port-channel 30
description "LACP port-channel for core switch uplink"
vlt-port-channel 30
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 1502, 1503
exit

interface range ethernet 1/1/48


description Uplink_port_CS
no shutdown
no switchport
channel-group 30 mode active
flowcontrol recieve off
flowcontrol transmit off
exit
end

copy running-configuration startup-configuration

Configure DataSwitch02

show version
show license status

configure terminal
hostname Data_Switch_02

interface mgmt 1/1/1


no shutdown
no ip address dhcp
ip address 172.17.57.30/24
exit

management route 0.0.0.0/0 172.17.57.254


ntp server 172.17.57.50
spanning-tree mode rstp
spanning-tree rstp priority 45056

copy runnnig-configuration startup configuration

interface vlan 1502


description Storage_network
no shutdown
exit

interface vlan 1503


description NAS_network
no shutdown
exit

interface vlan 1
description interfanl_network
no shutdown
exit

interface range ethernet 1/1/55-1/1/56


description VLTi
no shutdown
no switchport
exit

vlt-domain 1
descovery-interface ethernet 1/1/55-1/1/56
backup destination 172.17.57.20
peer-routing
primary-priority 8192
vlt-mac 00:00:00:00:00:01
end

interface port-channel 10
description "LACP port-channel for Node A"
vlt-port-channel 10
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 1502,1503
spanning-tree port type edge
no shutdown
exit

interface port-channel 20
description "LACP port-channel for Node B"
vlt-port-channel 20
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 1502,1503
spanning-tree port type edge
no shutdown
exit

interface ethernet 1/1/1


no shutdown
no switchport
channel-group 10 mode active
flowcontroll recieve off
flowcontrol transmit off
exit

interface ethernet 1/1/2


no shutdown
no switchport
channel-group 20 mode active
flowcontrol recieve off
flowcontrol transmit off
exit

interface port-channel 30
description "LACP port-channel for core switch uplink"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 1502,1503
exit

interface range ethernet 1/1/53-1/1/54


description Uplink_port_CS
no shudown
no switchport
channel-group 30 mode active
flowcontrol recieve off
flowcontrol transmit off
exit
end

copy run start

You might also like