You are on page 1of 1

+============================================================+

[ AUTO LOGIN WMS REGULER / WMS LITE TARBARU 2023 ]


[ FUNGSI TAMBAHAN ADA AUTO CHANGE MAC ADDRESS ]
[ INFO KONTAK WA 0857-1350-4459 ]
+============================================================+

# Simpan Pada Menu Script Dengan Nama wms


:local jalur "wlan2.4";
:local username "08122121279401.gtka@wms.1208372258.000"
:local password "08122121279401"
:local gwid "WAG2-D3-CBN"
:local wlanid "CBNSDU00068-N/TLK-CI-44405:ISK@Wifi.id";
:local machp "50:3E:AA:09:25:"

:local datahuruf ([/certificate scep-server otp generate minutes-valid=0 as-value]-


>"password");
:log warning $datahuruf
:local kodemac [:pick $datahuruf 0 2]
:local macbaru "$machp$kodemac"
:log warning ("new mac address untuk wms-isk : $macbaru");
/interface wireless set wlan2.4 mac-address=$macbaru;

:delay 30s;
:local ip [:pick [:ip address get [:ip addres find interface=wlan2.4] address] 0
([:len [:ip address get [:ip addres find interface=wlan2.4] address]]-3) ];
:local mac [/interface wireless get [ find default-name=wlan2.4] mac-address];
:tool fetch mode=https http-header-field="Content-Type: application/x-www-form-
urlencoded; charset=UTF-8,User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64)
AppleWebKit/537.36,Referer: https://welcome2.wifi.id" http-method=post http-
data="username=$username&password=$password"
url="https://welcome2.wifi.id/wms/auth/authnew/autologin/quarantine.php\?
ipc=$ip&gw_id=$gwid&mac=$mac&username=$username&password=$password&redirect=&wlan=$
wlanID";

# Simpan Pada Menu Scheduler Dengan Durasi Minimal 1 Menit


:if ([:ping 8.8.8.8 count=5 interface=wlan2.4]=0) do={
:system script run wms-isk;
}

You might also like