You are on page 1of 37

ADVANCED COMPUTER

NETWORKS

PRACTICAL FILE

Submitted By:
Divyansh Verma
03313203120
IT-1
INDEX
S.No. Experiment Date Signature

2
EXPERIMENT 1
Aim: To define a default route between two routers so that all the devices can ping any other devices.

Lab Scenario: Host A (on the left) should be setup with an IP address of 192.168.101.2/24 and a
default gateway of 192.168.101.1 .Host B (on the right) should be setup with an IP address of
192.168.100.2/24 and a default gateway of 192.168.100.1. The Ethernet interface of Router R1 should
use an IP address of 192.168.101.1/24 and Serial interface of Router R1 should use an IP address of
192.168.1.1/24. The Ethernet interface of Router R2 should use an IP address of 192.168.100.1/24
and Serial interface of Router R2 should use an IP address of 192.168.1.2/24.You have a DCE cable
connected to Router R1.the Serial link should have speed of 64K.configure the routers with default
routes so that all the devices can ping any other device.

Router R1 Configuration:-
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z
Router(config)#hostname R1
R1(config)#interface f0/0
R1(config-if)#ip address 192.168.101.1 255.255.255.0
R1(config-if)#no shut
20:09:27 %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
20:09:27 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state
to up
R1(config-if)#interface s0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shut
20:10:45 %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
20:10:45 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R1(config-if)#exit
R1(config)#exit

3
R1#

Router R2 Configuration:-
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z
Router(config)#hostname R2
R2(config)#interface f0/0
R2(config-if)#ip address 192.168.100.1 255.255.255.0
R2(config-if)#no shut
20:14:36 %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
20:14:36 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state
to up
R2(config-if)#interface s0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shut
20:15:10 %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
20:15:10 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R2(config-if)#exit
R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1
R2(config)#exit
R2#
Host A & Host B Configuration:-

Host A Console:-

4
Packets:

5
EXPERIMENT 2

Aim: To configure a dynamic route (using IGRP (autonomous system 100)) between two routers so
that all the devices can ping any other device.

Lab Scenario: Host A (on the left) should be setup with an IP address of 192.168.101.2/24 and a
default gateway of 192.168.101.1 .Host B (on the right) should be setup with an IP address of
192.168.100.2/24 and a default gateway of 192.168.100.1. The Ethernet interface of Router R1 should
use an IP address of 192.168.101.1/24 and Serial interface of Router R1 should use an IP address of
192.168.1.1/24. The Ethernet interface of Router R2 should use an IP address of 192.168.100.1/24
and Serial interface of Router R2 should use an IP address of 192.168.1.2/24.You have a DCE cable
connected to Router R1. The Serial link should have speed of 64K. Configure the routers using IGRP
(autonomous system 100) so that all the devices can ping any other device.

Router R1 Configuration:-
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z
Router(config)#hostname R1
R1(config)#interface f0/0
R1(config-if)#ip address 192.168.101.1 255.255.255.0
R1(config-if)#no shut
10:10:05 %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
10:10:05 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to
up
R1(config-if)#interface s0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shut
10:10:37 %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
10:10:37 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

6
R1(config-if)#exit
R1(config)#router igrp 100
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.101.0
R1(config-router)#exit
R1(config)#
Router R2 Configuration:-
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z
Router(config)#hostname R2
R2(config)#interface f0/0
R2(config-if)#ip address 192.168.100.1 255.255.255.0
R2(config-if)#no shut
10:14:27 %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
10:14:27 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state
to up
R2(config-if)#interface s0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shut
10:16:03 %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
10:16:03 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R2(config-if)#exit
R2(config)#router igrp 100
R2(config-router)#network 192.168.1.0
R2(config-router)#network 192.168.100.0
R2(config-router)#exit
R2(config)#exit
R2#
Host A& Host B Configuration:-

Host A Console:-

7
Packets:-

8
EXPERIMENT 3
AIM:

To configure a dynamic route using EIGRP (autonomous system 10) between 2 routers so that all
the devices can ping any other devices.
Host A should be setup with
IP address : 192.168.101.2/24
Subnet : 255.255.255.0
Default gateway : 192.168.101.1

Host B should be setup with


IP address : 192.168.100.2/24
Subnet : 255.255.255.0
Default gateway : 192.168.100.1

Router R1 should be setup with


Ethernet interface IP address : 192.168.101.1/24
Serial interface IP address : 192.168.1.1/24

Router R2 should be setup with


Ethernet interface IP address : 192.168.100.1/24
Serial interface IP address : 192.168.1.2/24

A DCE cable should be connected to R1. The serial link should have a speed of 64K. Configure the
routers using EIGRP(autonomous system 10) so that all the devices can ping any other device.

Router R1 Configuration
Router>enable

9
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z
Router(config)#hostname R1

R1(config)#interface f0/0
R1(config-if)#ip address 192.168.101.1 255.255.255.0
R1(config-if)#no shutdown
10:28:07 %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
10:28:07 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state
to up
R1(config-if)#exit

R1(config)#interface s0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
10:29:21 %LINK-3-UPDOWN: Interface Serial0/1, changed state to up
10:29:21 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router eigrp 10
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.101.0
R1(config-router)#
R1#

Router R2 Configuration
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z
Router(config)#hostname R2

R2(config)#interface f0/0
R2(config-if)#ip address 192.168.100.1 255.255.255.0
R2(config-if)#no shutdown
10:57:25 %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
10:57:25 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state
to up
R2(config-if)#exit

R2(config)#interface s0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
10:55:53 %LINK-3-UPDOWN: Interface Serial0/1, changed state to up
10:55:53 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
R2(config-if)#exit
10
R2(config)#router eigrp 100
R2(config-router)#network 192.168.1.0
R2(config-router)#network 192.168.100.0
R2(config-router)#
R2#

RESULT:

Dynamic route EIGRP (autonomous system 10) is successfully established.

OUTPUTS:

Connection Diagram

Host A and Host B Configuration:

Pinging Host B from Host A.


11
12
EXPERIMENT 4
AIM:

To Configure a dynamic route using OSPF between two routers so that all the devices can ping any
other devices.
Host A should be setup with
IP address : 192.168.101.2/24
Subnet : 255.255.255.0
Default gateway : 192.168.101.1

Host B should be setup with


IP address : 192.168.100.2/24
Subnet : 255.255.255.0
Default gateway : 192.168.100.1

Router R1 should be setup with


Ethernet interface IP address : 192.168.101.1/24
Serial interface IP address : 192.168.1.1/24

Router R2 should be setup with


Ethernet interface IP address : 192.168.100.1/24
Serial interface IP address : 192.168.1.2/24

A DCE cable should be connected to R1. The serial link should have a speed of 64K. Configure the
routers using OSPF so that all the devices can ping any other device.

Router R1 Configuration
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z
Router(config)#hostname R1

R1(config)#interface f0/0
R1(config-if)#ip address 192.168.101.1 255.255.255.0
R1(config-if)#no shutdown
10:28:07 %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
10:28:07 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state
to up
R1(config-if)#exit

R1(config)#interface s0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0

13
R1(config-if)#no shutdown

14
10:29:21 %LINK-3-UPDOWN: Interface Serial0/1, changed state to up
10:29:21 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router ospf 1
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#network 192.168.101.0 0.0.0.255 area 0
R1(config-router)#
R1#

Router R2 Configuration
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z
Router(config)#hostname R2

R2(config)#interface f0/0
R2(config-if)#ip address 192.168.100.1 255.255.255.0
R2(config-if)#no shutdown
10:57:25 %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
10:57:25 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state
to up
R2(config-if)#exit

R2(config)#interface s0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
10:55:53 %LINK-3-UPDOWN: Interface Serial0/1, changed state to up
10:55:53 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
R2(config-if)#exit
R2(config)#router ospf 1
R2(config-router)#network 192.168.1.0 0.0.0.255 area 0
R2(config-router)#network 192.168.100.0 0.0.0.255 area 0
R2(config-router)#
R2#

RESULT:

Dynamic route using OSPF is successfully established.

15
OUTPUTS:

Connection Diagram

Host A and Host B Configuration:

Pinging Host B from Host A.

16
EXPERIMENT 5
AIM:
To Configure a static NAT
You are interested in testing a NAT configuration.
Host A should be setup with
IP address : 192.168.101.2/24
Subnet : 255.255.255.0
Default gateway : 192.168.101.1

Host B should be setup with


IP address : 192.168.100.2/24
Subnet : 255.255.255.0
Default gateway : 192.168.100.1

Router R1 should be setup with


Ethernet interface IP address : 192.168.101.1/24
Serial interface IP address : 192.168.1.1/24

Router R2 should be setup with


Ethernet interface IP address : 192.168.100.1/24
Serial interface IP address : 192.168.1.2/24

A DCE cable should be connected to R1. The serial link should have a speed of 64K. Configure the
routers with RIP, do not advertise the network off of the ethernet 0 interface of Router1. Setup static
NAT so that HostA appears as the IP address 192.168.1.100.

Router R1 Configuration
Router>ena
Router#conf ter
Enter configuration commands, one per line. End with CNTL/Z
Router(config)#hostname Router1
Router1(config)#int f0/0
Router1(config-if)#ip nat inside
Router1(config-if)#ip address 192.168.101.1 255.255.255.0
Router1(config-if)#no shut
16:57:56 %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
16:57:56 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state
to up

Router1(config-if)#int s0/0
Router1(config-if)#ip nat outside
Router1(config-if)#ip address 192.168.1.1 255.255.255.0
Router1(config-if)#clock rate 64000
17
Router1(config-if)#no shut
16:58:57 %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
16:58:57 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

Router1(config-if)#exit
Router1(config)#ip nat inside source static 192.168.101.2 192.168.1.100
Router1(config)#router rip
Router1(config-router)#network 192.168.1.0
Router1(config-router)#network 192.168.101.0
Router1(config-router)#
Router1#

Router R2 Configuration
Router>ena
Router#conf ter
Enter configuration commands, one per line. End with CNTL/Z
Router(config)#hostname Router2
Router2(config)#int f0/0
Router2(config-if)#ip address 192.168.100.1 255.255.255.0
Router2(config-if)#no shut
16:57:56 %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
16:57:56 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state
to up

Router2(config-if)#int s0/0
Router2(config-if)#ip address 192.168.1.2 255.255.255.0
Router2(config-if)#no shut
16:58:57 %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
16:58:57 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

Router2(config-if)#exit
Router2(config)#router rip
Router2(config-router)#network 192.168.1.0
Router2(config-router)#network 192.168.100.0
Router2(config-router)#
Router2#

Host A:
Ipconfig /IP 192.168.101.2 255.255.255.0
Ipconfig /DG 192.168.101.1

Host B:
Ipconfig /IP 192.168.100.2 255.255.255.0
Ipconfig /DG 192.168.100.1

18
RESULT:

Static NAT is successfully configured.

OUTPUTS:

Connection Diagram

Host A and Host B Configuration:

19
Pinging Host B from Host A.

Router R1 configuration:

20
Router R2 Configuration:

Net Packet Manager

21
EXPERIMENT 6
AIM:
To Configure a Many to One NAT.
You are interested in testing a NAT Pool configuration
Host A should be setup with
IP address : 192.168.101.2/24
Subnet : 255.255.255.0
Default gateway : 192.168.101.1

Host B should be setup with


IP address : 192.168.100.2/24
Subnet : 255.255.255.0
Default gateway : 192.168.100.1

Router R1 should be setup with


Ethernet interface IP address : 192.168.101.1/24
Serial interface IP address : 192.168.1.1/24

Router R2 should be setup with


Ethernet interface IP address : 192.168.100.1/24
Serial interface IP address : 192.168.1.2/24

A DCE cable should be connected to Router1. The serial link should have a speed of 64K.
Configure the routers using RIP do not advertise the network off of the ethernet0 interface of
Router1. Setup NAT so that all host of router1’s ethernet0 interface appears as the router1’s serial
interface. Make sure that multiple hosts can access the outside world

Router R1 Configuration
Router>en
Router#con ter
Router(config)#hostname Router1
Router1(config)#int f0/0
Router1(config-if)#ip nat inside
Router1(config-if)#ip address 192.168.101.1 255.255.255.0
Router1(config-if)#no shutdown
10:28:07 %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
10:28:07 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state
to up
Router1(config-if)#interface s0/0
Router1(config-if)#ip nat outside
Router1(config-if)#ip address 192.168.1.1 255.255.255.0
Router1(config-if)#no shut
10:29:21 %LINK-3-UPDOWN: Interface Serial0/1, changed state to up
10:29:21 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up

22
Router1(config-if)#clock rate 64000
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#access-list 12 permit 192.168.101.0 0.0.0.255
Router1(config)#ip nat inside source list 12 interface serial 0/0 overload
Router1(config)#router rip
Router1(config-router)#network 192.168.1.0
Router1(config-router)#network 192.168.101.0
Router1(config-router)#
Router1#

Router R2 Configuration
Router>en
Router#con ter
Enter configuration commands, one per line. End with CNTL/Z
Router(config)#hostname Router2
Router2(config)#int f0/0
Router2(config-if)#ip address 192.168.100.1 255.255.255.0
Router2(config-if)#no shut
10:57:25 %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
10:57:25 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state
to up
Router2(config-if)#int s0/0
Router2(config-if)#ip address 192.168.1.2 255.255.255.0
Router2(config-if)#no shutdown
10:55:53 %LINK-3-UPDOWN: Interface Serial0/1, changed state to up
10:55:53 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
Router2(config-if)#exit
Router2(config)#router rip
Router2(config-router)#network 192.168.1.0
Router2(config-router)#network 192.168.100.0
Router2(config-router)#
Router2#

Host A:
Ipconfig /IP 192.168.101.2 255.255.255.0
Ipconfig /DG 192.168.101.1

Host B:
Ipconfig /IP 192.168.100.2 255.255.255.0
Ipconfig /DG 192.168.100.1

RESULT:

Many to one NAT is successfully configured.

23
OUTPUTS:

Connection Diagram

Host A and Host B Configuration:

Ping Host B from Host A

24
Net Packet Manager

25
EXPERIMENT 7
AIM:
To Configure a NAT Pool.
You are interested in testing a NAT Pool configuration
Host A should be setup with
IP address : 192.168.101.2/24
Subnet : 255.255.255.0
Default gateway : 192.168.101.1

Host B should be setup with


IP address : 192.168.100.2/24
Subnet : 255.255.255.0
Default gateway : 192.168.100.1

Router R1 should be setup with


Ethernet interface IP address : 192.168.101.1/24
Serial interface IP address : 192.168.1.1/24

Router R2 should be setup with


Ethernet interface IP address : 192.168.100.1/24
Serial interface IP address : 192.168.1.2/24

A DCE cable should be connected to Router1. The serial link should have a speed of 64K.
Configure the routers with RIP, do not advertise the network off the ethernet 0 interface of Router1.
Setup NAT so that all Host of off router1’s ethernet 0 interface can be translated to a pool of the
first 100 available ip address of the subnet off of router 1’s Loopback 0 interface.

Router R1 Configuration
Router>en
Router#conf ter
Router(config)#hostname Router1
Router1(config)#int f0/0
Router1(config-if)#ip nat inside
Router1(config-if)#ip address 192.168.101.1 255.255.255.0
Router1(config-if)#no shut
10:28:07 %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
10:28:07 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state
to up
Router1(config-if)#int s0/0
Router1(config-if)#ip nat outside
Router1(config-if)#ip address 192.168.1.1 255.255.255.0
Router1(config-if)#clock rate 64000
Router1(config-if)#no shut
10:29:21 %LINK-3-UPDOWN: Interface Serial0/1, changed state to up

26
10:29:21 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
Router1(config-if)#exit
Router1(config)#interface loopback 0
Router1(config-if)#ip address 192.168.200.1 255.255.255.0
Router1(config-if)#exit
Router1(config)#ip nat pool goodpool 192.168.200.2 192.168.200.101 netmask 255.255.255.0
Router1(config)#access-list 10 permit 192.168.101.0 0.0.0.255
Router1(config)#ip nat inside source list 10 pool goodpool
Router1(config)#router rip
Router1(config-router)#network 192.168.1.0
Router1(config-router)#network 192.168.101.0
Router1(config-router)#network 192.168.200.0
Router1(config-router)#
Router1#

Router R2 Configuration
Router>ena
Router#con ter
Enter configuration commands, one per line. End with CNTL/Z
Router(config)#hostname Router2
Router2(config)#int f0/0
Router2(config-if)#ip address 192.168.100.1 255.255.255.0
Router2(config-if)#no shut
10:57:25 %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
10:57:25 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state
to up
Router2(config-if)#int s0/0
Router2(config-if)#ip address 192.168.1.2 255.255.255.0
Router2(config-if)#no shut
10:55:53 %LINK-3-UPDOWN: Interface Serial0/1, changed state to up
10:55:53 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
Router2(config-if)#exit
Router2(config)#router rip
Router2(config-router)#network 192.168.1.0
Router2(config-router)#network 192.168.100.0
Router2 (config-router)#
Router2#

Host A:
Ipconfig /IP 192.168.101.2 255.255.255.0
Ipconfig /DG 192.168.101.1
Host B:
Ipconfig /IP 192.168.100.2 255.255.255.0
Ipconfig /DG 192.168.100.1

27
RESULT
NAT pool is successfully configured.

OUTPUTS:

Connection Diagram

Host A and Host B Configuration:

28
Ping Host B from Host A

29
30
Net Packet Manager

31
EXPERIMENT 8
AIM:

To Configure a dynamic route between two routers using RIP (version 1) so that all the devices can
ping any other device. Setup the routers so that they can be managed via telnet, use a password of
“cisco”.
Host A should be setup with
IP address : 192.168.101.2/24
Subnet : 255.255.255.0
Default gateway : 192.168.101.1

Host B should be setup with


IP address : 192.168.100.2/24
Subnet : 255.255.255.0
Default gateway : 192.168.100.1

Router R1 should be setup with


Ethernet interface IP address : 192.168.101.1/24
Serial interface IP address : 192.168.1.1/24
Router R2 should be setup with
Ethernet interface IP address : 192.168.100.1/24
Serial interface IP address : 192.168.1.2/24

A DCE cable should be connected to R1. The serial link should have a speed of 64K. Configure the
routers using RIP so that all the devices can ping any other device. Setup the router so that they can
be managed via telnet, use the password of “cisco”.

Router R1 Configuration
Router>en
Router#con ter
Router(config)#hostname Router1
Router1(config)#int f0/0
Router1(config-if)#ip nat inside
Router1(config-if)#ip address 192.168.101.1 255.255.255.0
Router1(config-if)#no shut
10:28:07 %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
10:28:07 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state
to up
Router1(config-if)#int s0/0
Router1(config-if)#ip nat outside
Router1(config-if)#ip address 192.168.1.1 255.255.255.0
Router1(config-if)#clock rate 64000
Router1(config-if)#no shut
10:29:21 %LINK-3-UPDOWN: Interface Serial0/1, changed state to up
10:29:21 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
32
Router1(config-if)#exit
Router1(config)#router rip
Router1(config-router)#network 192.168.1.0
Router1(config-router)#network 192.168.101.0
Router1(config-router)#exit
Router1(config)#line vty 0 4
Router1(config-line)#password cisco
Router1(config-line)#login
Router1(config-line)#
Router1#

Router R2 Configuration
Router>en
Router#con ter
Enter configuration commands, one per line. End with CNTL/Z
Router(config)#hostname Router2
Router2(config)#int f0/0
Router2(config-if)#ip address 192.168.100.1 255.255.255.0
Router2(config-if)#no shut
10:57:25 %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
10:57:25 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state
to up
Router2(config-if)#int s0/0
Router2(config-if)#ip address 192.168.1.2 255.255.255.0
Router2(config-if)#no shut
10:55:53 %LINK-3-UPDOWN: Interface Serial0/1, changed state to up
10:55:53 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
Router2(config-if)#exit
Router2(config)#router rip
Router2(config-router)#network 192.168.1.0
Router2(config-router)#network 192.168.100.0
Router2(config-router)#
Router2#

RESULT

Dynamic route using RIP is successfully established.

33
OUTPUTS:

Connection Diagram

Host A and Host B Configuration:

34
Remote Login using telnet

Pinging Host B from router R1.

35
Pinging Host B from Host A.

Pinging Host A from Host B.

36
Pinging Host A from Router R2.

Net Packet Manager

37

You might also like