You are on page 1of 5

R1

en
config t
hostname R1

ipv6 unicast-routing

int G0/0
ipv6 add 2001:A:A:14::1/64
ipv6 add FE80::1 link-local
no sh
exit

int G0/2.14
encapsulation dot1q 14
ipv6 add 2001:B:B:14::1/64
ipv6 add FE80::1 link-local
no sh
exit

int G0/2.15
encapsulation dot1q 15
ipv6 add 2001:B:B:15::1/64
ipv6 add FE80::1 link-local
no sh
exit

int G0/2
no sh
exit

OSPFv3 IPv6

ipv6 router ospf 8


router-id 1.1.1.1
passive-interface G0/2
passive-interface G0/2.14
passive-interface G0/2.15
exit

int g0/2.14
ipv6 ospf 8 area 14
exit

int g0/2.15
ipv6 ospf 8 area 14
exit

int g0/0
ipv6 ospf 8 area 14
exit

/////////////////////////////////////////////////7

Sw1
en
config t
hostname Sw1

vlan 14
vlan 15

int range f0/1-6


switchport mode access
switchport access vlan 14
exit

int range f0/7-16


switchport mode access
switchport access vlan 15
exit

int G0/1
switchport mode trunk
exit

//////////////////////////////////////////////////7

R2

en
config t
hostname R2

ipv6 unicast-routing

int G0/1
ipv6 add 2001:A:A:14::2/64
ipv6 add FE80::2 link-local
no sh
exit

int G0/2
ipv6 add 2001:A:B:14::1/64
ipv6 add FE80::2 link-local
no sh
exit

int G0/0
ipv6 add 2001:A:C:14::1/64
ipv6 add FE80::2 link-local
no sh
exit

ipv6 route ::/0 2001:A:B:14::2

OSPFv3 IPv6 aqui me quede

ipv6 router ospf 14


router-id 2.2.2.2
int g0/1
ipv6 ospf 14 area 14
exit

/*
int g0/2
ipv6 ospf 14 area 14
exit
*/

int g0/0
ipv6 ospf 14 area 14
exit

default-information originate
redistribute static

////////////////////////////////////////////////////

ISP

en
config t
hostname ISP

ipv6 unicast-routing

int G0/0
ipv6 add 2001:A:B:14::2/64
ipv6 add FE80::3 link-local
no sh
exit

ipv6 route ::/0 2001:A:B:14::1

/*
OSPFv3 IPv6

ipv6 router ospf 14


router-id 3.3.3.3

int g0/0
ipv6 ospf 14 area 14
exit
*/

/////////////////////////////////////////////////////

M1

en
config t
hostname M1

ipv6 unicast-routing
ip routing

vlan 99
vlan 16
vlan 17

int vlan 99
ipv6 add 2001:A:C:14::2/64
ipv6 add FE80::4 link-local
no sh
exit

int G1/0/1
switchport mode access
switchport access vlan 99
exit

int vlan 16
ipv6 add 2001:B:D:14::1/64
ipv6 add FE80::4 link-local
no sh
exit

int range G1/0/2-3


switchport mode access
switchport access vlan 16
exit

int vlan 17
ipv6 add 2001:B:C:14::1/64
ipv6 add FE80::4 link-local
no sh
exit

int G1/0/4
switchport mode access
switchport access vlan 17
exit

OSPFv3 IPv6

ipv6 router ospf 9


router-id 4.4.4.4

int vlan 99
ipv6 ospf 9 area 14
exit

int vlan 16
ipv6 ospf 9 area 14
exit

int vlan 17
ipv6 ospf 9 area 14
exit

////////////////////////////////////////////

R1
ACL extendida. Bloquear servicio web a la vlan NL

ipv6 access-list NO-DNS


deny udp 2001:B:B:14::/64 host 2001:B:D:14::3 eq 53
permit tcp any any eq 53
permit ipv6 any any
exit
int g0/2.14
ipv6 traffic-filter NO-DNS in
end

////////////////////////////////////////////////

M1

ACL extendida. Bloquear servicio ftp a la vlan NL+3

ipv6 access-list NO-FTP


deny tcp 2001:B:C:14::/64 any eq ftp
permit ipv6 any any
exit
int vlan 17
ipv6 traffic-filter NO-FTP in
end

You might also like