You are on page 1of 43

Outline

 Introduction to Static Routing


 Dynamic Routing Overview
 Routing Protocols Overview

1
Introducing routing

 Routing is the process that a router uses to


forward packets toward the destination
network.
 A router makes decisions based upon the
destination IP address of a packet.
 In order to make the correct decisions,
routers must learn the direction to remote
networks.
2
 When routers use dynamic routing, this
information is learned from other routers.
 When static routing is used, a network
administrator configures information about
remote networks manually.

3
4
Static route operation

 Static route operations can be divided into


these three parts:
 Network administrator configures the route
 Router installs the route in the routing table
 Packets are routed using the static route
 Since a static route is manually configured,
the administrator must configure the static
route on the router using the ip route
command.
5
6
 The administrative distance is an optional parameter
that gives a measure of the reliability of the route.
 A lower value for the administrative distance
indicates the more reliable route.
 The default administrative distance when using
next-hop address is 1, while the default
administrative distance when using the outgoing
interface is 0.
waycross(config)#ip route 172.16.3.0 255.255.255.0
172.16.4.1 130

7
 If the router cannot reach the outgoing
interface that is being used in the route, the
route will not be installed in the routing table.
 This means if that interface is down, the route
will not be placed in the routing table.

8
 Sometimes static routes are used for backup
purposes.
 A static route can be configured on a router that will
only be used when the dynamically learned route
has failed.
 To use a static route in this manner, simply set the
administrative distance higher than that of the
dynamic routing protocol being used.

9
Configuring static routes

 Use the following steps to configure static routes:


1. Determine all desired destination networks, their subnet
masks, and their gateways. A gateway can be either a
local interface or a next hop address that leads to the
desired destination.
2. Enter global configuration mode.
3. Type the ip route command with a destination address
and subnet mask followed by their corresponding
gateway from Step one. Including an administrative
distance is optional.

10
4. Repeat Step three for as many destination
networks as were defined in Step one.
5. Exit global configuration mode.
6. Save the active configuration to NVRAM by
using the copy running-config startup-config
command.

11
Configuring default route
forwarding
 Default routes are used to route packets with
destinations that do not match any of the
other routes in the routing table.
 A default route is actually a special static
route that uses this format:
ip route 0.0.0.0 0.0.0.0 [next-hop-address | outgoing
interface]

12
 Use the following steps to configure default routes:
1. Enter global configuration mode.
2. Type the ip route command with 0.0.0.0 for the
destination network address and 0.0.0.0 for the subnet
mask. The gateway for the default route can be either the
local router interface that connects to the outside
networks or the IP address of the next-hop router.
3. Exit global configuration mode.
4. Save the active configuration to NVRAM by using the
copy running-config startup-config command.

13
Verifying static route
configuration
 Use the following steps to verify static route
configuration:
 In privileged mode enter the command show running-
config to view the active configuration.
 Verify that the static route has been correctly entered.
 Enter the command show ip route.
 Verify that the route that was configured is in the routing
table.

14
Outline
 Introduction to Static Routing
 Dynamic Routing Overview
 Routing Protocols Overview

15
Pros and Cons of Static
Routing
 Static routing is not really a routing protocol. Static
routing is simply the process of manually entering
routes into a device's routing table via a configuration
file that is loaded when the routing device starts up
 Static routing is the simplest form of routing, but it is a
manual process
 Use static routing when you have very few devices to
configure (<5) and when you know the routes will
probably never change.
 Static routing also does not handle failures in external
networks well because any route that is configured
manually must be updated or reconfigured manually to
fix or repair any lost connectivity
Pros and Cons of Dynamic
Routing
 Dynamic routing protocols are supported by software applications
running on the routing device (the router) which dynamically learn
network destinations and how to get to them and also advertise those
destinations to other routers
 A router using dynamic routing will 'learn' the routes to all networks
that are directly connected to the device.
 Next, the router will learn routes from other routers that run the same
routing protocol (RIP, RIP2, EIGRP, OSPF, IS-IS, BGP etc). Each
router will then sort through it's list of routes and select one or more
'best' routes for each network destination the router knows or has
learned.
 Dynamic routing protocols have the ability to adapt to logical network
topology changes, equipment failures or network outages 'on the fly'.
Introduction to routing
protocols
 A routing protocol is the communication used
between routers.
 Examples of routing protocols are:
 Routing Information Protocol (RIP)
 Interior Gateway Routing Protocol (IGRP)
 Enhanced Interior Gateway Routing Protocol
(EIGRP)
 Open Shortest Path First (OSPF)

18
 A routed protocol is used to direct user traffic.
 Examples of routed protocols are:
 Internet Protocol (IP)
 Internetwork Packet Exchange (IPX)

19
20
Autonomous systems
 An autonomous system (AS) is a collection of
networks under a common administration
sharing a common routing strategy.
 To the outside world, an AS is viewed as a
single entity.

21
Purpose of a routing protocol
and autonomous systems

 When all routers in an internetwork are


operating with the same knowledge, the
internetwork is said to have converged.
 Fast convergence is desirable because it
reduces the period of time in which routers
would continue to make incorrect routing
decisions.

22
 Autonomous systems (AS) provide the
division of the global internetwork into smaller
and more manageable networks.
 Each AS has its own set of rules and policies
and an AS number that will uniquely
distinguish it from other autonomous systems
throughout the world.

23
Identifying the classes of routing
protocols
 Most routing algorithms can be classified into one of
two categories:
 distance vector
 link-state
 The distance vector routing approach determines
the direction (vector) and distance to any link in the
internetwork.
 The link-state approach, also called shortest path
first, recreates the exact topology of the entire
internetwork.
24
25
Link-state routing protocol
features

26
Outline
 Introduction to Static Routing
 Dynamic Routing Overview
 Routing Protocols Overview

27
Path determination
 A router determines the path of a packet from
one data link to another, using two basic
functions:
 A path determination function
 A switching function

28
 Path determination occurs at the network layer.
 The path determination function enables a router to
evaluate the paths to a destination and to establish
the preferred handling of a packet.
 The router uses the routing table to determine the
best path and proceeds to forward the packet using
the switching function.

29
 The switching function is the internal process
used by a router to accept a packet on one
interface and forward it to a second interface
on the same router.
 A key responsibility of the switching function
of the router is to encapsulate packets in the
appropriate frame type for the next data link.

30
Routing configuration
 Enabling an IP routing protocol on a router
involves the setting of both global and routing
parameters.
 Global tasks include selecting a routing
protocol, such as RIP, IGRP, EIGRP or OSPF.
 The major task in the routing configuration
mode is to indicate IP network numbers.

31
 The router command starts a routing process.
 The network command is required because it
enables the routing process to determine which
interfaces participate in the sending and receiving of
routing updates.
 An example of a routing configuration is:
GAD(config)#router rip
GAD(config-router)#network 172.16.0.0

32
Routing protocols
 Examples of IP routing protocols include:
 RIP – A distance vector interior routing protocol
 IGRP – Cisco's distance vector interior routing protocol
 OSPF – A link-state interior routing protocol
 EIGRP – Cisco’s advanced distance vector interior routing
protocol
 BGP – A distance vector exterior routing protocol

33
 Routing Information Protocol (RIP) was originally
specified in RFC 1058.
 Its key characteristics include the following:
 It is a distance vector routing protocol.
 Hop count is used as the metric for path selection.
 If the hop count is greater than 15, the packet is discarded.
 Routing updates are broadcast every 30 seconds, by
default.

34
RIP support for default routers
There are two ways to get RIP to propagate a default
route. The preferred method is using the default-
information originate command as follows:
 Router1#configure terminal

Enter configuration commands, one per line. End with


CNTL/Z.
Router1(config)#ip route 0.0.0.0 0.0.0.0 172.25.1.1
Router1(config)#router rip
Router1(config-router)#default-information originate
Router1(config-router)#end
Router1#
In simple situations, you can accomplish the same thing by
just redistributing a static route:
Router1#configure terminal
Enter configuration commands, one per line. End with
CNTL/Z.
Router1(config)#ip route 0.0.0.0 0.0.0.0 172.25.1.1
Router1(config)#access-list 7 permit 0.0.0.0
Router1(config)#router rip
Router1(config-router)#redistribute static
Router1(config-router)#distribute-list 7 out static
Router1(config-router)#end
Router1#
Disscussion
 There are two main advantages to using default
originate instead of simply redistributing static
routes. The first is that you may have other static
routes on your router that you do not want to
distribute, or that you want to distribute with a
different default metric. In this case, if you just
use redistribute static, you will need to filter out
the unwanted routes using route maps, as shown
in Recipe 6.4, or a distribute-list, as we use in
this recipe.
 Interior Gateway Routing Protocol (IGRP) is a
proprietary protocol developed by Cisco.
 Some of the IGRP key design characteristics
emphasize the following:
 It is a distance vector routing protocol.
 Bandwidth, load, delay and reliability are used to create a
composite metric.
 Routing updates are broadcast every 90 seconds, by
default.

38
 Open Shortest Path First (OSPF) is a nonproprietary
link-state routing protocol.
 The key characteristics of OSPF are as follows:
 It is a link-state routing protocol.
 Open standard routing protocol described in RFC 2328.
 Uses the SPF algorithm to calculate the lowest cost to a
destination.
 Routing updates are flooded as topology changes occur.

39
 EIGRP is a Cisco proprietary enhanced distance
vector routing protocol.
 The key characteristics of EIGRP are as follows:
 It is an enhanced distance vector routing protocol.
 Uses load balancing.
 Uses a combination of distance vector and link-state
features.
 Uses Diffused Update Algorithm (DUAL) to calculate the
shortest path.
 Routing updates are broadcast every 90 seconds or as
triggered by topology changes.

40
 Border Gateway Protocol (BGP) is an exterior
routing protocol.
 The key characteristics of BGP are as
follows:
 It is a distance vector exterior routing protocol.
 Used between ISPs or ISPs and clients.
 Used to route Internet traffic between autonomous
systems.

41
Autonomous systems and IGP
versus EGP
 Interior routing protocols are designed for use
in a network whose parts are under the
control of a single organization.
 An exterior routing protocol is designed for
use between two different networks that are
under the control of two different
organizations.

42
Characteristics of BGP.
 It is most popular Exterior Gateway Protocol in
Internet. It has following characteristics:
 "It provides routing among autonomous systems
(EGP).
 "It provides policies to control routes advertised. "It
uses reliable transport (TCP).
 "It gives path of autonomous systems for each
destination. "Currently the EGP is of choice in the
Internet. "The current version is four (BGP-4).
 "It provides facilities for Transit Routing.

You might also like