You are on page 1of 15

Lab 1 - Konfigurasi Dasar iBGP Peering

1. enable router BGP


Router(config)# router bgp [AS NUBER]
2. neighbor configuration
Router(config-router)# neighbor [peer address] remote-as [AS NUMBER]
3. Check the status
Router# Show ip bgp summary
Router# Show ip bgp

Router R1

Router R2

int fa0/0
ip addr 12.12.12.1 255.255.255.0
no shut

int fa0/0
ip addr 12.12.12.2 255.255.255.0
no shut

router bgp 12
neighbor 12.12.12.2 remote-as 12

router bgp 12
neighbor 12.12.12.1 remote-as 12

BGP Workshop - www.id-networkers.com 26 Juli 2009

BGP Network Advertisement


R1 Loopback interface
R1(config)# int lo1
R1(config-if)# ip address 11.11.11.11

255.255.255.255

R1(config)# int lo2


R1(config-if)# ip address 111.111.111.111

255.255.255.0

R2 Loopback interface
R2(config)# int lo1
R2(config-if)# ip address 22.22.22.22

255.255.255.255

R2(config)# int lo2


R2(config-if)# ip address 222.222.222.222

255.255.255.0

1. Network command
R1(config)# router bgp 12
R1(config-router)# network 11.11.11.11 mask 255.255.255.255
R1(config-router)# network 111.111.111.0 mask 255.255.255.0
R1(config-router)# network 12.12.12.0 mask 255.255.255.0
2. Static Redistribution
R2(config)# ip route 222.222.222.0 255.255.255.0 null0
R2(config)# router bgp 12
R2(config-router)# redistribute static
R2(config-router)# network 12.12.12.0 mask 255.255.255.0
3. Dynamic Route Redistribution (RIP, OSPF, EIGRP dll)
R2(config)# router eigrp 12
R2(config-router)# network 22.22.22.22 0.0.0.0
R2(config-router)# no auto-summary
R2(config)# router bgp 12
R2(config-router)# redistribute eigrp 12
Pengecekan :
Router# Show ip bgp summary
Router# Show ip bgp
Router# Show ip route bgp
Router# ping 11.11.11.11
Router# ping 111.111.111.111
Router# ping 22.22.22.22
Router# ping 222.222.222.222
BGP Workshop - www.id-networkers.com 26 Juli 2009

Lab 2 iBGP Peering - Loopback

1. Konfigurasi IP address R1
R1(config)# int fa0/0
R1(config-if)# ip addr 12.12.12.1 255.255.255.0
R1(config)# int fa1/0
R1(config-if)# ip addr 21.21.21.1 255.255.255.0
R1(config)# int lo0
R1(config-if)# ip addr 1.1.1.1 255.255.255.255
2. Konfigurasi IP address R2
R2(config)# int fa0/0
R2(config-if)# ip addr 12.12.12.2 255.255.255.0
R2(config)# int fa1/0
R2(config-if)# ip addr 21.21.21.2 255.255.255.0
R2(config)# int lo0
R2(config-if)# ip addr 2.2.2.2 255.255.255.255
3. static route ke loopback interface
R1(config)# ip route 2.2.2.2 255.255.255.255
R1(config)# ip route 2.2.2.2 255.255.255.255
R2(config)# ip route 1.1.1.1 255.255.255.255
R2(config)# ip route 1.1.1.1 255.255.255.255

12.12.12.2
21.21.21.2
12.12.12.1
21.21.21.1

4. Konfigurasi BGP
R1(config)# router bgp 12
R1(config-router)# neighbor 2.2.2.2 remote-as 12
R1(config-router)# neighbor 2.2.2.2 update-source Loopback0
R1(config-router)# network 1.1.1.1 mask 255.255.255.255
R1(config-router)# network 21.21.21.0 mask 255.255.255.0
R2(config)# router bgp 12
R2(config-router)# neighbor 1.1.1.1 remote-as 12
R2(config-router)# neighbor 1.1.1.1 update-source Loopback0
R1(config-router)# network 2.2.2.2 mask 255.255.255.255
R1(config-router)# network 21.21.21.0 mask 255.255.255.0
Pengecekan :
R1,R2# ping 1.1.1.1
R1,R2r# ping 2.2.2.2
R1,R2# Show ip bgp summary
R1,R2# Show ip bgp
R1,R2# Show ip route bgp
R1,R2# ping 11.11.11.11
R1,R2# ping 111.111.111.111
R1,R2# ping 22.22.22.22
R1,R2# ping 222.222.222.222

BGP Workshop - www.id-networkers.com 26 Juli 2009

Lab 3 eBGP Peering


AS 12

AS 3

1. Konfigurasi IP address
R2(config)# int s0/0
R2(config-if)# ip addr 23.23.23.2 255.255.255.0
R3(config)# int s0/0
R3(config-if)# ip addr 23.23.23.3 255.255.255.0
R3(config)# int loopback0
R3(config-if)# ip addr 33.33.33.33 255.255.255.255
2. Konfigurasi BGP
R2(config)# router bgp 12
R2(config-router)# neighbor 23.23.23.3 remote-as 3
R2(config-router)# network 23.23.23.0 mask 255.255.255.0
R3(config)# router bgp 3
R3(config-router)# neighbor 23.23.23.2 remote-as 12
R3(config-router)# network 33.33.33.33 mask 255.255.255.255
R2(config-router)# network 23.23.23.0 mask 255.255.255.0
Pengecekan :
R2,R3# Show ip bgp summary
R2,R3# Show ip bgp
R2,R3# Show ip route bgp
R2,R3# ping 22.22.22.22
R2,R3# ping 222.222.222.222
R2,R3# ping 33.33.33.33

BGP Workshop - www.id-networkers.com 26 Juli 2009

Lab 4 eBGP Peering Loopback eBGP Multihop


AS 12

AS 3

1. Konfigurasi IP address R2
R2(config)# int s0/0
R2(config-if)# ip addr 23.23.23.2 255.255.255.0
R2(config)# int s0/1
R2(config-if)# ip addr 32.32.32.2 255.255.255.0
R2(config)# int lo0
R2(config-if)# ip addr 2.2.2.2 255.255.255.255
2. Konfigurasi IP address R3
R3(config)# int s0/0
R3(config-if)# ip addr 23.23.23.3 255.255.255.0
R3(config)# int s0/1
R3(config-if)# ip addr 32.32.32.3 255.255.255.0
R3(config)# int lo0
R3(config-if)# ip addr 3.3.3.3 255 .255.255.255
3. static route ke loopback interface
R2(config)# ip route 3.3.3.3 255.255.255.255 32.32.32.3
R2(config)# ip route 3.3.3.3 255.255.255.255 23.23.23.3
R3(config)# ip route 2.2.2.2 255.255.255.255 32.32.32.2
R3(config)# ip route 2.2.2.2 255.255.255.255 23.23.23.2
4. Konfigurasi BGP
R2(config)# router bgp 12
R2(config-router)# neighbor 3.3.3.3 remote-as 3
R2(config-router)# neighbor 3.3.3.3 update-source Loopback0
R2(config-router)# network 32.32.32.0 mask 255.255.255.0
R3(config)# router bgp 3
R3(config-router)# neighbor 2.2.2.2 remote-as 12
R3(config-router)# neighbor 3.3.3.3 update-source Loopback0
R3(config-router)# network 32.32.32.0 mask 255.255.255.0
Pengecekan :
R2,R3# ping 2.2.2.2
R2,R3# ping 3.3.3.3
R2,R3# Show ip bgp summary
R2,R3# Show ip bgp
R2,R3# Show ip route bgp
R2,R3# ping 22.22.22.22
R2,R3# ping 222.222.222.222
R2,R3# ping 33.33.33.33
BGP Workshop - www.id-networkers.com 26 Juli 2009

Lab 5 BGP Next-Hop-Self


AS 12

AS 3

1. Konfigurasi BGP
R2(config)# router bgp 12
R2(config-router)# neighbor 1.1.1.1 next-hop-self
Pengecekan :
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#

Show ip bgp summary


Show ip bgp
Show ip route bgp
ping 1.1.1.1
ping 2.2.2.2
ping 3.3.3.3
ping 11.11.11.11
ping 22.22.22.22
ping 33.33.33.33
ping 111.111.111.111
ping 222.222.222.222

BGP Workshop - www.id-networkers.com 26 Juli 2009

Lab 6 BGP Authentication


AS 12

AS 3

1. Konfigurasi BGP
R1(config)# router bgp 12
R1(config-router)# neighbor 2.2.2.2 password 0 RAHASIA
R2(config)# router bgp 12
R2(config-router)# neighbor 1.1.1.1 password 0 RAHASIA
Pengecekan :
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#
R1,R2,R3#

Show ip bgp summary


Show ip bgp
Show ip route bgp
ping 1.1.1.1
ping 2.2.2.2
ping 3.3.3.3
ping 11.11.11.11
ping 22.22.22.22
ping 33.33.33.33
ping 111.111.111.111
ping 222.222.222.222

BGP Workshop - www.id-networkers.com 26 Juli 2009

Lab 7 BGP Route Reflector


AS 12

AS 3

1. Konfigurasi IP address
R1(config)# int s0/0
R1(config-if)# ip addr 41.41.41.1 255.255.25.0
R4(config)# int s0/0
R4(config-if)# ip addr 41.41.41.4 255.255.255.0
R4(config)# int Lo0
R4(config-if)# ip addr 4.4.4.4 255.255.255.255
2. Konfigurasi BGP
R1(config)# router bgp 12
R1(config-router)# neighbor 41.41.41.4 remote-as 12
R1(config-router)# network 41.41.41.0 mask 255.255.255.0
R4(config)# router bgp 12
R4(config-router)# neighbor 41.41.41.1 remote-as 12
R4(config-router)# network 41.41.41.0 mask 255.255.255.0
R4(config-router)# network 4.4.4.4 mask 255.255.255.255
3. Konfigurasi Route Reflector
R1(config)# router bgp 12
R1(config-router)# neighbor 41.41.41.4 route-reflector-client
R1(config-router)# neighbor 2.2.2.2 route-reflector-client
Pengecekan :
R1,R2,R3,R4#
R1,R2,R3,R4#
R1,R2,R3,R4#
R1,R2,R3,R4#
R1,R2,R3,R4#
R1,R2,R3,R4#
R1,R2,R3,R4#
R1,R2,R3,R4#
R1,R2,R3,R4#
R1,R2,R3,R4#
R1,R2,R3,R4#
R1,R2,R3,R4#

Show ip bgp summary


Show ip bgp
Show ip route bgp
ping 1.1.1.1
ping 2.2.2.2
ping 3.3.3.3
ping 4.4.4.4
ping 11.11.11.11
ping 22.22.22.22
ping 33.33.33.33
ping 111.111.111.111
ping 222.222.222.222

BGP Workshop - www.id-networkers.com 26 Juli 2009

Lab 8 BGP Confederation

AS 12001

AS 12002

AS 12003

AS 12

AS 3

1. Konfigurasi R1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 14.14.14.1 255.255.255.0
!
interface FastEthernet1/0
ip address 12.12.12.1 255.255.255.0
!
router bgp 12001
bgp confederation identifier 12
bgp confederation peers 12002 12003
network 1.1.1.1 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 14.14.14.0 mask 255.255.255.0
neighbor 12.12.12.2 remote-as 12002
neighbor 14.14.14.4 remote-as 12001
2. Konfigurasi R4
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 14.14.14.4 255.255.255.0
!
router bgp 12001
bgp confederation identifier 12
bgp confederation peers 12002 12003
network 4.4.4.4 mask 255.255.255.255
network 14.14.14.0 mask 255.255.255.0
neighbor 14.14.14.1 remote-as 12001

BGP Workshop - www.id-networkers.com 26 Juli 2009

3. Konfigurasi R2
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
ip address 25.25.25.2 255.255.255.0
!
interface FastEthernet1/0
ip address 12.12.12.2 255.255.255.0
!
interface FastEthernet2/0
ip address 23.23.23.2 255.255.255.0
!
router bgp 12002
bgp confederation identifier 12
bgp confederation peers 12001 12003
network 2.2.2.2 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
network 25.25.25.0 mask 255.255.255.0
neighbor 12.12.12.1 remote-as 12001
neighbor 23.23.23.3 remote-as 12003
neighbor 25.25.25.5 remote-as 12002
4. Konfigurasi R5
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Serial0/0
ip address 25.25.25.5 255.255.255.0
!
router bgp 12002
bgp confederation identifier 12
bgp confederation peers 12001 12003
network 5.5.5.5 mask 255.255.255.255
network 25.25.25.0 mask 255.255.255.0
neighbor 25.25.25.2 remote-as 12002

BGP Workshop - www.id-networkers.com 26 Juli 2009

5. Konfigurasi R3
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
ip address 36.36.36.3 255.255.255.0
!
interface FastEthernet1/0
ip address 23.23.23.3 255.255.255.0
!
router bgp 12003
bgp confederation identifier 12
bgp confederation peers 12002 12001
network 3.3.3.3 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
network 36.36.36.0 mask 255.255.255.0
neighbor 23.23.23.2 remote-as 12002
neighbor 36.36.36.6 remote-as 6
6. Konfigurasi R6
interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface Serial0/0
ip address 36.36.36.6 255.255.255.0
!
router bgp 6
network 6.6.6.6 mask 255.255.255.255
network 36.36.36.0 mask 255.255.255.0
neighbor 36.36.36.3 remote-as 12

BGP Workshop - www.id-networkers.com 26 Juli 2009

Lab 9 BGP Attribute (weight)

AS 12

AS 34

1. Jalur Routing ..
R1#sh ip bgp 45.45.45.5
BGP routing table entry for 45.45.45.0/24, version 9
Paths: (2 available, best #2, table Default-IP-Routing-Table)
Advertised to update-groups:
1
34
23.23.23.3 from 12.12.12.2 (2.2.2.2)
Origin IGP, metric 0, localpref 100, valid, internal
34
14.14.14.4 from 14.14.14.4 (4.4.4.4)
Origin IGP, metric 0, localpref 100, valid, external, best
R0#traceroute 45.45.45.5
Type escape sequence to abort.
Tracing the route to 45.45.45.5
1 10.10.10.1 72 msec 80 msec 64 msec
2 14.14.14.4 124 msec 92 msec 128 msec
3 45.45.45.5 156 msec 116 msec *

BGP Workshop - www.id-networkers.com 26 Juli 2009

2. Konfigurasi Weight Attribute


R1(config)#router bgp 100
R1(config-router)#neighbor 12.12.12.2 remote-as 12
R1(config-router)#neighbor 12.12.12.2 route-map WEIGHT in
R1(config)#route-map WEIGHT permit 10
R1(config-route-map)#set weight 100
R1(config-route-map)#do clear ip bgp *
R1#sh ip bgp 45.45.45.5
BGP routing table entry for 45.45.45.0/24, version 15
Paths: (2 available, best #2, table Default-IP-Routing-Table)
Flag: 0x840
Advertised to update-groups:
2
34
14.14.14.4 from 14.14.14.4 (4.4.4.4)
Origin IGP, metric 0, localpref 100, valid, external
34
23.23.23.3 from 12.12.12.2 (2.2.2.2)
Origin IGP, metric 0, localpref 100, weight 100, valid, internal, best
R0#traceroute 45.45.45.5
Type escape sequence to abort.
Tracing the route to 45.45.45.5
1 10.10.10.1
2 12.12.12.2
3 23.23.23.3
4 34.34.34.4
5 45.45.45.5
Router#

36 msec 92 msec 64 msec


104 msec 124 msec 104 msec
224 msec 204 msec 236 msec
256 msec 228 msec 188 msec
344 msec 276 msec *

BGP Workshop - www.id-networkers.com 26 Juli 2009

Lab 10 BGP Attribute (Metric-MED)

AS 12

AS 34

1. Jalur Routing ..
R1#sh ip bgp 45.45.45.5
BGP routing table entry for 45.45.45.0/24, version 29
Paths: (2 available, best #2, table Default-IP-Routing-Table)
Flag: 0x820
Advertised to update-groups:
1
34
23.23.23.3 from 12.12.12.2 (2.2.2.2)
Origin IGP, metric 0, localpref 100, valid, internal
34
14.14.14.4 from 14.14.14.4 (4.4.4.4)
Origin IGP, metric 0, localpref 100, valid, external, best
R0#traceroute 45.45.45.5
Type escape sequence to abort.
Tracing the route to 45.45.45.5
1 10.10.10.1 72 msec 80 msec 64 msec
2 14.14.14.4 124 msec 92 msec 128 msec
3 45.45.45.5 156 msec 116 msec *

BGP Workshop - www.id-networkers.com 26 Juli 2009

2. Konfigurasi MED Attribute


R4(config)#router bgp 12
R4(config-router)#neighbor 12.12.12.2 remote-as 12
R4(config-router)# neighbor 14.14.14.1 route-map MED out
R4(config)#route-map MED permit 10
R4(config-route-map)#set metric 200
R4(config-route-map)#do clear ip bgp *
Router#sh ip bgp 45.45.45.5
BGP routing table entry for 45.45.45.0/24, version 40
Paths: (2 available, best #1, table Default-IP-Routing-Table)
Flag: 0x860
Advertised to update-groups:
2
34
23.23.23.3 from 12.12.12.2 (2.2.2.2)
Origin IGP, metric 0, localpref 100, valid, internal, best
34
14.14.14.4 from 14.14.14.4 (4.4.4.4)
Origin IGP, metric 200, localpref 100, valid, external
R0#traceroute 45.45.45.5
Type escape sequence to abort.
Tracing the route to 45.45.45.5
1
2
3
4
5

10.10.10.1
12.12.12.2
23.23.23.3
34.34.34.4
45.45.45.5

100 msec 76 msec 64 msec


96 msec 108 msec 172 msec
228 msec 196 msec 184 msec
156 msec 264 msec 156 msec
204 msec 168 msec *

BGP Workshop - www.id-networkers.com 26 Juli 2009

You might also like